linux-kselftest.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-07-06 23:17:45 to 2020-07-14 07:05:39 UTC [more...]

[RFC PATCH 00/15] PKS: Add Protection Keys Supervisor (PKS) support
 2020-07-14  7:02 UTC  (13+ messages)
` [RFC PATCH 01/15] x86/pkeys: Create pkeys_internal.h
` [RFC PATCH 04/15] x86/pks: Preserve the PKRS MSR on context switch
` [RFC PATCH 05/15] x86/pks: Add PKS kernel API
` [RFC PATCH 06/15] x86/pks: Add a debugfs file for allocated PKS keys
` [RFC PATCH 07/15] Documentation/pkeys: Update documentation for kernel pkeys
` [RFC PATCH 09/15] fs/dax: Remove unused size parameter
` [RFC PATCH 10/15] drivers/dax: Expand lock scope to cover the use of addresses
` [RFC PATCH 11/15] memremap: Add zone device access protection
` [RFC PATCH 12/15] kmap: Add stray write protection for device pages
` [RFC PATCH 13/15] dax: Stray write protection for dax_direct_access()
` [RFC PATCH 14/15] nvdimm/pmem: Stray write protection for pmem->virt_addr
` [RFC PATCH 15/15] [dax|pmem]: Enable stray write protection

[PATCH 0/3] readfile(2): a new syscall to make open/read/close faster
 2020-07-14  6:51 UTC  (3+ messages)

[PATCH 0/4] Paravirtualized Control Register pinning
 2020-07-14  5:39 UTC  (14+ messages)
` [PATCH 2/4] KVM: x86: Introduce paravirt feature CR0/CR4 pinning

[PATCH v2 0/8] selftests/harness: Switch to TAP output
 2020-07-14  0:50 UTC  (5+ messages)
` [PATCH v2 6/8] selftests/harness: Refactor XFAIL into SKIP

[PATCH v3 0/2] Syscall user redirection
 2020-07-14  0:22 UTC  (5+ messages)
` [PATCH v3 1/2] kernel: Implement selective syscall userspace redirection
` [PATCH v3 2/2] selftests: Add kselftest for syscall user dispatch

[PATCH] selftests: Replace HTTP links with HTTPS ones
 2020-07-13 19:57 UTC 

[PATCH] rcutorture: Replace HTTP links with HTTPS ones
 2020-07-13 19:37 UTC 

[PATCH v2 0/5] mm/migrate: avoid device private invalidations
 2020-07-13 17:21 UTC  (6+ messages)
` [PATCH v2 1/5] nouveau: fix storing invalid ptes
` [PATCH v2 2/5] mm/migrate: add a direction parameter to migrate_vma
` [PATCH v2 3/5] mm/notifier: add migration invalidation type
` [PATCH v2 4/5] nouveau/svm: use the new migration invalidation
` [PATCH v2 5/5] mm/hmm/test: "

[PATCH] selftests/livepatch: Use "comm" instead of "diff" for dmesg
 2020-07-13 12:51 UTC  (3+ messages)

[PATCH] selftests/livepatch: adopt to newer sysctl error format
 2020-07-13  8:52 UTC  (4+ messages)

[PATCH for-next/seccomp v2 0/2] selftests/seccomp: SKIP tests requiring root
 2020-07-11 16:05 UTC  (6+ messages)
` [PATCH for-next/seccomp v2 1/2] selftests/seccomp: Add SKIPs for failed unshare()
` [PATCH for-next/seccomp v2 2/2] selftests/seccomp: Set NNP for TSYNC ESRCH flag test

[PATCH bpf] selftests/bpf: Fix cgroup sockopt verifier test
 2020-07-10 23:34 UTC  (3+ messages)

[GIT PULL] Kselftest fixes update for Linux 5.8-rc5
 2020-07-10 22:10 UTC  (2+ messages)

[PATCH 0/5] mm/migrate: avoid device private invalidations
 2020-07-10 20:17 UTC  (7+ messages)
` [PATCH 2/5] mm/migrate: add a direction parameter to migrate_vma
` [PATCH 3/5] mm/notifier: add migration invalidation type

[PATCH v3 0/5] mm/hmm/nouveau: add PMD system memory mapping
 2020-07-10 20:13 UTC  (5+ messages)
` [PATCH v3 3/5] nouveau: fix mapping 2MB sysmem pages
  ` [Nouveau] "

[PATCH v2 0/2] mm/migrate: optimize migrate_vma_setup() for holes
 2020-07-10 19:48 UTC  (3+ messages)
` [PATCH v2 1/2] "
` [PATCH v2 2/2] mm/migrate: add migrate-shared test for migrate_vma_*()

[PATCH 0/2] mm/migrate: optimize migrate_vma_setup() for holes
 2020-07-10 16:19 UTC  (5+ messages)
` [PATCH 1/2] "
` [PATCH 2/2] mm/migrate: add migrate-shared test for migrate_vma_*()

[PATCH for-next/seccomp 0/3] Check ENOSYS under tracing
 2020-07-10 16:11 UTC  (3+ messages)

[PATCH v19 00/12] Landlock LSM
 2020-07-10 12:57 UTC  (27+ messages)
` [PATCH v19 01/12] landlock: Add object management
` [PATCH v19 02/12] landlock: Add ruleset and domain management
` [PATCH v19 03/12] landlock: Set up the security framework and manage credentials
` [PATCH v19 04/12] landlock: Add ptrace restrictions
` [PATCH v19 05/12] LSM: Infrastructure management of the superblock
` [PATCH v19 06/12] fs,security: Add sb_delete hook
` [PATCH v19 07/12] landlock: Support filesystem access-control
` [PATCH v19 08/12] landlock: Add syscall implementation
` [PATCH v19 09/12] arch: Wire up landlock() syscall
` [PATCH v19 10/12] selftests/landlock: Add initial tests
` [PATCH v19 11/12] samples/landlock: Add a sandbox manager example
` [PATCH v19 12/12] landlock: Add user and kernel documentation

[PATCH v7 0/9] Add seccomp notifier ioctl that enables adding fds
 2020-07-10 11:28 UTC  (14+ messages)
` [PATCH v7 1/9] net/compat: Add missing sock updates for SCM_RIGHTS
` [PATCH v7 2/9] pidfd: Add missing sock updates for pidfd_getfd()
` [PATCH v7 3/9] net/scm: Regularize compat handling of scm_detach_fds()
` [PATCH v7 4/9] fs: Move __scm_install_fd() to __receive_fd()
` [PATCH v7 5/9] fs: Add receive_fd() wrapper for __receive_fd()
` [PATCH v7 6/9] pidfd: Replace open-coded receive_fd()
` [PATCH v7 7/9] fs: Expand __receive_fd() to accept existing fd
` [PATCH v7 8/9] seccomp: Introduce addfd ioctl to seccomp user notifier
` [PATCH v7 9/9] selftests/seccomp: Test SECCOMP_IOCTL_NOTIF_ADDFD

[PATCH bpf] selftests: bpf: fix detach from sockmap tests
 2020-07-09 21:43 UTC  (3+ messages)

[PATCH] kunit: capture stderr on all make subprocess calls
 2020-07-09 21:27 UTC  (2+ messages)

[PATCH v6 0/7] Add seccomp notifier ioctl that enables adding fds
 2020-07-09 13:08 UTC  (23+ messages)
` [PATCH v6 1/7] net/scm: Regularize compat handling of scm_detach_fds()
` [PATCH v6 2/7] fs: Move __scm_install_fd() to __receive_fd()
` [PATCH v6 3/7] fs: Add receive_fd() wrapper for __receive_fd()
` [PATCH v6 4/7] pidfd: Replace open-coded partial receive_fd()
` [PATCH v6 5/7] fs: Expand __receive_fd() to accept existing fd
` [PATCH v6 6/7] seccomp: Introduce addfd ioctl to seccomp user notifier

[PATCH] Replace HTTP links with HTTPS ones: KMOD KERNEL MODULE LOADER - USERMODE HELPER
 2020-07-08 15:20 UTC  (3+ messages)

[PATCH v2 1/2] kbuild: introduce ccflags-remove-y and asflags-remove-y
 2020-07-08  9:23 UTC  (7+ messages)
` [PATCH v2 2/2] kbuild: trace functions in subdirectories of lib/

[PATCH] selftests: kmod: Add module address visibility test
 2020-07-08  6:44 UTC  (2+ messages)

[PATCH v10 0/9] firmware: add request_partial_firmware_into_buf
 2020-07-08  4:51 UTC  (27+ messages)
` [PATCH v10 1/9] fs: move kernel_read_file* to its own include file
` [PATCH v10 2/9] fs: introduce kernel_pread_file* support
` [PATCH v10 3/9] firmware: add request_partial_firmware_into_buf
` [PATCH v10 4/9] test_firmware: add partial read support for request_firmware_into_buf
` [PATCH v10 5/9] firmware: test partial file reads of request_partial_firmware_into_buf
` [PATCH v10 6/9] bcm-vk: add bcm_vk UAPI
` [PATCH v10 8/9] MAINTAINERS: bcm-vk: add maintainer for Broadcom VK Driver
` [PATCH v10 9/9] ima: add FIRMWARE_PARTIAL_READ support
  ` [PATCH v10 7/9] misc: bcm-vk: add Broadcom VK driver

[PATCH v5 00/12] kunit: create a centralized executor to dispatch all KUnit tests
 2020-07-08  4:38 UTC  (7+ messages)
` [PATCH v5 01/12] vmlinux.lds.h: add linker section for KUnit test suites
` [PATCH v5 08/12] init: main: add KUnit to kernel init

[PATCH 0/2] KUnit-Kmemleak Integration
 2020-07-07 19:34 UTC  (7+ messages)
` [PATCH 2/2] kunit: kmemleak integration

[PATCH 0/2] Selftest for cpuidle latency measurement
 2020-07-07 15:53 UTC  (5+ messages)
` [PATCH 1/2] cpuidle: Trace IPI based and timer based wakeup latency from idle states
` [PATCH 2/2] selftest/cpuidle: Add support for cpuidle latency measurement

[PATCH v4 0/2] selftests: pidfd: prefer ksft_test_result_skip to ksft_exit_*
 2020-07-07 15:39 UTC  (3+ messages)
` [PATCH v4 1/2] selftests: pidfd: do not use ksft_exit_skip after ksft_set_plan
` [PATCH v4 2/2] selftests: pidfd: skip test if unshare fails with EPERM

[PATCH 5.4 19/65] selftests: tpm: Use /bin/sh instead of /bin/bash
 2020-07-07 15:16 UTC 

[PATCH 5.7 041/112] Revert "tpm: selftest: cleanup after unseal with wrong auth/policy test"
 2020-07-07 15:16 UTC  (2+ messages)
` [PATCH 5.7 042/112] selftests: tpm: Use /bin/sh instead of /bin/bash

[PATCH v3 0/2] selftests: pidfd: prefer ksft_test_result_skip to ksft_exit_*
 2020-07-07 15:24 UTC  (6+ messages)
` [PATCH v3 1/2] selftests: pidfd: do not use ksft_exit_skip after ksft_set_plan
` [PATCH v3 2/2] selftests: pidfd: skip test if unshare fails with EPERM

[PATCH v2 0/6] kselftest: fix TAP output for skipped test and ksft_set_plan misuse
 2020-07-07  9:49 UTC  (6+ messages)
` [PATCH v2 4/6] selftests: pidfd: do not use ksft_exit_skip after ksft_set_plan

[PATCH] Documentation: kunit: Remove references to --defconfig
 2020-07-07  6:38 UTC  (2+ messages)

[PATCH v35 22/24] selftests/x86: Add a selftest for SGX
 2020-07-07  3:37 UTC 

[PATCH v34 22/24] selftests/x86: Add a selftest for SGX
 2020-07-07  3:02 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).