linux-kselftest.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2021-06-14 21:22:01 to 2021-06-21 23:35:57 UTC [more...]

[PATCH v12 0/7] KVM statistics data fd-based binary interface
 2021-06-21 23:35 UTC  (15+ messages)
` [PATCH v12 1/7] KVM: stats: Separate generic stats from architecture specific ones
` [PATCH v12 2/7] KVM: stats: Add fd-based API to read binary stats data
` [PATCH v12 3/7] KVM: stats: Support binary stats retrieval for a VM
` [PATCH v12 4/7] KVM: stats: Support binary stats retrieval for a VCPU
` [PATCH v12 5/7] KVM: stats: Add documentation for binary statistics interface
` [PATCH v12 6/7] KVM: selftests: Add selftest for KVM statistics data binary interface
` [PATCH v12 7/7] KVM: stats: Remove code duplication for binary and debugfs stats

[PATCH v4 0/1] lib: Convert UUID runtime test to KUnit
 2021-06-21 21:56 UTC  (4+ messages)
` [PATCH v4 1/1] "

[PATCH] selftests/sgx: remove checks for file execute permissions
 2021-06-21 21:18 UTC  (3+ messages)

[PATCH net 1/2] selftests: tls: clean up uninitialized warnings
 2021-06-21 19:20 UTC  (5+ messages)
` [PATCH net 2/2] selftests: tls: fix chacha+bidir tests

[PATCH v2 0/6] cgroup/cpuset: Add new cpuset partition type & empty effecitve cpus
 2021-06-21 18:49 UTC  (7+ messages)
` [PATCH v2 1/6] cgroup/cpuset: Miscellaneous code cleanup
` [PATCH v2 2/6] cgroup/cpuset: Clarify the use of invalid partition root
` [PATCH v2 3/6] cgroup/cpuset: Add a new isolated cpus.partition type
` [PATCH v2 4/6] cgroup/cpuset: Allow non-top parent partition root to distribute out all CPUs
` [PATCH v2 5/6] cgroup/cpuset: Update description of cpuset.cpus.partition in cgroup-v2.rst
` [PATCH v2 6/6] kselftest/cgroup: Add cpuset v2 partition root state test

[PATCH AUTOSEL 4.19 13/16] KVM: selftests: Fix kvm_check_cap() assertion
 2021-06-21 17:54 UTC 

[PATCH AUTOSEL 5.4 21/26] KVM: selftests: Fix kvm_check_cap() assertion
 2021-06-21 17:53 UTC 

[PATCH AUTOSEL 5.10 28/35] KVM: selftests: Fix kvm_check_cap() assertion
 2021-06-21 17:52 UTC 

[PATCH AUTOSEL 5.12 24/39] bpf, selftests: Adjust few selftest outcomes wrt unreachable code
 2021-06-21 17:51 UTC  (2+ messages)
` [PATCH AUTOSEL 5.12 31/39] KVM: selftests: Fix kvm_check_cap() assertion

[PATCH v5 bpf-next 0/3] libbpf: BTF dumper support for typed data
 2021-06-19  8:56 UTC  (4+ messages)
` [PATCH v5 bpf-next 1/3] "
` [PATCH v5 bpf-next 2/3] selftests/bpf: add ASSERT_STRNEQ() variant for test_progs
` [PATCH v5 bpf-next 3/3] selftests/bpf: add dump type data tests to btf dump tests

[net-next, v3, 00/10] ptp: support virtual clocks and timestamping
 2021-06-19  4:06 UTC  (20+ messages)
` [net-next, v3, 01/10] ptp: add ptp virtual clock driver framework
` [net-next, v3, 02/10] ptp: support ptp physical/virtual clocks conversion
` [net-next, v3, 03/10] ptp: track available ptp vclocks information
` [net-next, v3, 04/10] ptp: add kernel API ptp_get_vclocks_index()
` [net-next, v3, 05/10] ethtool: add a new command for getting PHC virtual clocks
` [net-next, v3, 06/10] ptp: add kernel API ptp_convert_timestamp()
` [net-next, v3, 07/10] net: sock: extend SO_TIMESTAMPING for PHC binding
` [net-next, v3, 08/10] net: socket: support hardware timestamp conversion to PHC bound
` [net-next, v3, 09/10] selftests/net: timestamping: support binding PHC
` [net-next, v3, 10/10] MAINTAINERS: add entry for PTP virtual clock driver

[PATCH] selftests/lkdtm: Use /bin/sh not $SHELL
 2021-06-19  3:02 UTC  (3+ messages)

[PATCH v2] selftests/lkdtm: Use /bin/sh not $SHELL
 2021-06-19  2:58 UTC 

[PATCH v1 1/1] tools: Rename bitmap_alloc() to bitmap_zalloc()
 2021-06-18 22:31 UTC  (5+ messages)

[PATCH] selftests/tls: don't change cipher type in bidirectional test
 2021-06-18 22:04 UTC  (3+ messages)

[net-next v1 0/2] seg6: add support for SRv6 End.DT46 Behavior
 2021-06-18 18:40 UTC  (4+ messages)
` [net-next v1 1/2] "
` [net-next v1 2/2] selftests: seg6: add selftest "

[PATCH v11 0/7] KVM statistics data fd-based binary interface
 2021-06-18 17:57 UTC  (24+ messages)
` [PATCH v11 1/7] KVM: stats: Separate generic stats from architecture specific ones
` [PATCH v11 2/7] KVM: stats: Add fd-based API to read binary stats data
` [PATCH v11 3/7] KVM: stats: Support binary stats retrieval for a VM
` [PATCH v11 4/7] KVM: stats: Support binary stats retrieval for a VCPU
` [PATCH v11 5/7] KVM: stats: Add documentation for binary statistics interface
` [PATCH v11 6/7] KVM: selftests: Add selftest for KVM statistics data binary interface
` [PATCH v11 7/7] KVM: stats: Remove code duplication for binary and debugfs stats

[PATCH v8 1/5] selftests/sgx: Rename 'eenter' and 'sgx_call_vdso'
 2021-06-18  9:07 UTC  (12+ messages)
` [PATCH v8 3/5] selftests/sgx: Dump enclave memory map
` [PATCH v8 5/5] selftests/sgx: Refine the test enclave to have storage

[PATCH] powerpc/selftests: Use gettid() instead of getppid() for null_syscall
 2021-06-18  3:51 UTC  (2+ messages)

Hangs during tls multi_chunk_sendfile selftest
 2021-06-17 23:03 UTC  (3+ messages)

[PATCH v10 0/5] KVM statistics data fd-based binary interface
 2021-06-17 22:15 UTC  (29+ messages)
` [PATCH v10 1/5] KVM: stats: Separate generic stats from architecture specific ones
` [PATCH v10 2/5] KVM: stats: Add fd-based API to read binary stats data
` [PATCH v10 3/5] KVM: stats: Add documentation for binary statistics interface
` [PATCH v10 4/5] KVM: selftests: Add selftest for KVM statistics data binary interface
` [PATCH v10 5/5] KVM: stats: Remove code duplication for binary and debugfs stats

[PATCH 0/5] cgroup/cpuset: Enable cpuset partition with no load balancing
 2021-06-17 20:45 UTC  (10+ messages)
` [PATCH 1/5] cgroup/cpuset: Don't call validate_change() for some flag changes
` [PATCH 2/5] cgroup/cpuset: Add new cpus.partition type with no load balancing
` [PATCH 3/5] cgroup/cpuset: Allow non-top parent partition root to distribute out all CPUs

[PATCH v2 00/29] docs: avoid using ReST :doc:`foo` tag
 2021-06-17 19:34 UTC  (4+ messages)
` [PATCH v2 02/29] docs: dev-tools: kunit: don't use a table for docs name
` [PATCH v2 10/29] docs: dev-tools: kunit: avoid using ReST :doc:`foo` markup

[PATCH] KVM: selftests: Fix kvm_check_cap() assertion
 2021-06-17 17:07 UTC  (2+ messages)

[PATCH] kunit: tool: Assert version requirement
 2021-06-17  7:46 UTC  (4+ messages)
    ` [PATCH v2] kunit: tool: Assert the "

[PATCH v9 0/5] KVM statistics data fd-based binary interface
 2021-06-16 21:35 UTC  (22+ messages)
` [PATCH v9 1/5] KVM: stats: Separate generic stats from architecture specific ones
` [PATCH v9 2/5] KVM: stats: Add fd-based API to read binary stats data
` [PATCH v9 3/5] KVM: stats: Add documentation for statistics data binary interface
` [PATCH v9 4/5] KVM: selftests: Add selftest for KVM "
` [PATCH v9 5/5] KVM: stats: Remove code duplication for binary and debugfs stats

[PATCHv8] exec: Fix dead-lock in de_thread with ptrace_attach
 2021-06-16 21:31 UTC  (6+ messages)
  ` [PATCH v9] "

[PATCH v2] kunit: tool: internal refactor of parser input handling
 2021-06-16 20:59 UTC  (2+ messages)

[PATCH v2 1/3] kunit: arch/um/configs: Enable KUNIT_ALL_TESTS by default
 2021-06-16 20:41 UTC  (5+ messages)
` [PATCH v2 2/3] kunit: Move default config from arch/um -> tools/testing/kunit
` [PATCH v2 3/3] kunit: Remove the unused all_tests.config

[PATCH] selftests: net: veth: make test compatible with dash
 2021-06-16 20:00 UTC  (2+ messages)

[PATCH] selftests: net: use bash to run udpgro_fwd test case
 2021-06-16 20:00 UTC  (2+ messages)

[PATCH v2 01/10] kunit: Do not typecheck binary assertions
 2021-06-16 14:08 UTC  (19+ messages)
` [PATCH v2 03/10] Documentation: kunit: Clean up some string casts in examples
` [PATCH v2 04/10] device property: Remove some casts in property-entry-test
` [PATCH v2 05/10] iio: Remove a cast in iio-test-format which is no longer required
` [PATCH v2 06/10] mmc: sdhci-of-aspeed: Remove some unnecessary casts from KUnit tests
` [PATCH v2 07/10] thunderbolt: test: Remove sone casts which are no longer required
` [PATCH v2 08/10] kernel/sysctl-test: Remove some casts which are no-longer required
` [PATCH v2 09/10] apparmor: test: "
` [PATCH v2 10/10] lib/cmdline_kunit: Remove a cast "

[PATCH 00/34] docs: avoid using ReST :doc:`foo` tag
 2021-06-16  6:13 UTC  (5+ messages)
` [PATCH 14/34] docs: dev-tools: kunit: avoid using ReST :doc:`foo` markup

[PATCH] kunit: Add gnu_printf specifiers
 2021-06-15 21:01 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).