linux-kselftest.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2021-12-08 03:54:45 to 2021-12-10 18:54:27 UTC [more...]

[PATCH v4 0/3] kselftest: alsa: Add basic mixer selftest
 2021-12-10 18:54 UTC  (3+ messages)
` [PATCH v4 1/3] kselftest: alsa: Add simplistic test for ALSA mixer controls kselftest
` [PATCH v4 2/3] kselftest: alsa: optimization for SNDRV_CTL_ELEM_ACCESS_VOLATILE

[PATCH kvm-next] selftests/kvm: remove unneeded variable
 2021-12-10 18:47 UTC  (2+ messages)

[PATCH v7 00/37] arm64/sme: Initial support for the Scalable Matrix Extension
 2021-12-10 18:41 UTC  (38+ messages)
` [PATCH v7 01/37] arm64/sve: Make sysctl interface for SVE reusable by SME
` [PATCH v7 02/37] arm64/sve: Generalise vector length configuration prctl() for SME
` [PATCH v7 03/37] arm64/sve: Minor clarification of ABI documentation
` [PATCH v7 04/37] kselftest/arm64: Parameterise ptrace vector length information
` [PATCH v7 05/37] kselftest/arm64: Allow signal tests to trigger from a function
` [PATCH v7 06/37] kselftest/arm64: Add a test program to exercise the syscall ABI
` [PATCH v7 07/37] arm64: cpufeature: Always specify and use a field width for capabilities
` [PATCH v7 08/37] tools/nolibc: Implement gettid()
` [PATCH v7 09/37] arm64/sme: Provide ABI documentation for SME
` [PATCH v7 10/37] arm64/sme: System register and exception syndrome definitions
` [PATCH v7 11/37] arm64/sme: Define macros for manually encoding SME instructions
` [PATCH v7 12/37] arm64/sme: Early CPU setup for SME
` [PATCH v7 13/37] arm64/sme: Basic enumeration support
` [PATCH v7 14/37] arm64/sme: Identify supported SME vector lengths at boot
` [PATCH v7 15/37] arm64/sme: Implement sysctl to set the default vector length
` [PATCH v7 16/37] arm64/sme: Implement vector length configuration prctl()s
` [PATCH v7 17/37] arm64/sme: Implement support for TPIDR2
` [PATCH v7 18/37] arm64/sme: Implement SVCR context switching
` [PATCH v7 19/37] arm64/sme: Implement streaming SVE "
` [PATCH v7 20/37] arm64/sme: Implement ZA "
` [PATCH v7 21/37] arm64/sme: Implement traps and syscall handling for SME
` [PATCH v7 22/37] arm64/sme: Implement streaming SVE signal handling
` [PATCH v7 23/37] arm64/sme: Implement ZA "
` [PATCH v7 24/37] arm64/sme: Implement ptrace support for streaming mode SVE registers
` [PATCH v7 25/37] arm64/sme: Add ptrace support for ZA
` [PATCH v7 26/37] arm64/sme: Disable streaming mode and ZA when flushing CPU state
` [PATCH v7 27/37] arm64/sme: Save and restore streaming mode over EFI runtime calls
` [PATCH v7 28/37] arm64/sme: Provide Kconfig for SME
` [PATCH v7 29/37] kselftest/arm64: sme: Add streaming SME support to vlset
` [PATCH v7 30/37] kselftest/arm64: Add tests for TPIDR2
` [PATCH v7 31/37] kselftest/arm64: Extend vector configuration API tests to cover SME
` [PATCH v7 32/37] kselftest/arm64: sme: Provide streaming mode SVE stress test
` [PATCH v7 33/37] kselftest/arm64: Add stress test for SME ZA context switching
` [PATCH v7 34/37] kselftest/arm64: signal: Add SME signal handling tests
` [PATCH v7 35/37] kselftest/arm64: Add streaming SVE to SVE ptrace tests
` [PATCH v7 36/37] kselftest/arm64: Add coverage for the ZA ptrace interface
` [PATCH v7 37/37] kselftest/arm64: Add SME support to syscall ABI test

[PATCH v2 0/7] Documentation: KUnit: Rework KUnit documentation
 2021-12-10 17:16 UTC  (17+ messages)
` [PATCH v2 1/7] Documentation: KUnit: Rewrite main page
` [PATCH v2 3/7] Documentation: KUnit: Added KUnit Architecture
` [PATCH v2 4/7] Documentation: kunit: Reorganize documentation related to running tests
` [PATCH v2 5/7] Documentation: KUnit: Rework writing page to focus on writing tests
` [PATCH v2 6/7] Documentation: KUnit: Restyle Test Style and Nomenclature page

[PATCH] selftests: mptcp: remove duplicate include in mptcp_inq.c
 2021-12-10 18:00 UTC  (7+ messages)

[PATCH 00/12] selftests: Remove ARRAY_SIZE duplicate defines
 2021-12-10 17:33 UTC  (13+ messages)
` [PATCH 01/12] tools: fix ARRAY_SIZE defines in tools and selftests hdrs
` [PATCH 02/12] selftests/arm64: remove ARRAY_SIZE define from vec-syscfg.c
` [PATCH 03/12] selftests/cgroup: remove ARRAY_SIZE define from cgroup_util.h
` [PATCH 04/12] selftests/core: remove ARRAY_SIZE define from close_range_test.c
` [PATCH 05/12] selftests/ir: remove ARRAY_SIZE define from ir_loopback.c
` [PATCH 06/12] selftests/landlock: remove ARRAY_SIZE define from common.h
` [PATCH 07/12] selftests/net: remove ARRAY_SIZE define from individual tests
` [PATCH 08/12] selftests/rseq: "
` [PATCH 09/12] selftests/seccomp: remove ARRAY_SIZE define from seccomp_benchmark
` [PATCH 10/12] selftests/sparc64: remove ARRAY_SIZE define from adi-test
` [PATCH 11/12] selftests/timens: remove ARRAY_SIZE define from individual tests
` [PATCH 12/12] selftests/vm: "

[PATCH] selftests/bpf: remove ARRAY_SIZE defines from tests
 2021-12-10 17:34 UTC 

[PATCH v3 0/7] Documentation: KUnit: Rework KUnit documentation
 2021-12-10 17:06 UTC  (9+ messages)
` [PATCH v3 1/7] Documentation: KUnit: Rewrite main page
` [PATCH v3 2/7] Documentation: KUnit: Rewrite getting started
` [PATCH v3 3/7] Documentation: KUnit: Added KUnit Architecture
` [PATCH v3 4/7] Documentation: kunit: Reorganize documentation related to running tests
` [PATCH v3 5/7] Documentation: KUnit: Rework writing page to focus on writing tests
` [PATCH v3 6/7] Documentation: KUnit: Restyle Test Style and Nomenclature page
` [PATCH v3 7/7] Documentation: KUnit: Restyled Frequently Asked Questions

[RFC PATCH 00/10] KVM: selftests: Add support for test-selectable ucall implementations
 2021-12-10 16:46 UTC  (11+ messages)
` [PATCH RFC 01/10] kvm: selftests: move base kvm_util.h declarations to kvm_util_base.h
` [PATCH RFC 02/10] kvm: selftests: move ucall declarations into ucall_common.h
` [PATCH RFC 03/10] kvm: selftests: introduce ucall_ops for test/arch-specific ucall implementations
` [PATCH RFC 04/10] kvm: arm64: selftests: use ucall_ops to define default ucall implementation
` [PATCH RFC 05/10] kvm: s390: "
` [PATCH RFC 06/10] kvm: selftests: add ucall interfaces based around shared memory
` [PATCH RFC 07/10] kvm: selftests: add ucall_shared ops for PIO
` [PATCH RFC 08/10] kvm: selftests: introduce ucall implementation based on halt instructions
` [PATCH RFC 09/10] kvm: selftests: add GUEST_SHARED_* macros for shared ucall implementations
` [PATCH RFC 10/10] kvm: selftests: add ucall_test to test various ucall functionality

[RFC PATCH v5 0/2] Introduce XSAVE feature self-test
 2021-12-10 16:48 UTC  (5+ messages)
` [RFC PATCH v5 1/2] selftests/x86: add xsave test during and after signal handling

[PATCH v5 net-next 0/4] Add ethtool interface for RClocks
 2021-12-10 16:16 UTC  (6+ messages)
` [PATCH v5 net-next 1/4] ice: add support detecting features based on netlist
` [PATCH v5 net-next 2/4] ethtool: Add ability to configure recovered clock for SyncE feature
` [PATCH v5 net-next 3/4] ice: add support for monitoring SyncE DPLL state
` [PATCH v5 net-next 4/4] ice: add support for recovered clocks

[PATCH v6 00/37] arm64/sme: Initial support for the Scalable Matrix Extension
 2021-12-10 13:59 UTC  (15+ messages)
` [PATCH v6 05/37] kselftest/arm64: Allow signal tests to trigger from a function
` [PATCH v6 06/37] kselftest/arm64: Add a test program to exercise the syscall ABI
` [PATCH v6 13/37] arm64/sme: Basic enumeration support

[PATCH v2 0/2] livepatch: Allow user to specify functions to search for on a stack
 2021-12-10 12:44 UTC  (3+ messages)
` [PATCH v2 1/2] "
` [PATCH v2 2/2] selftests/livepatch: Test of the API for specifying "

[PATCHv2] selftests: icmp_redirect: pass xfail=0 to log_test()
 2021-12-10  7:25 UTC 

[PATCH] selftests: icmp_redirect: pass xfail=0 to log_test() for non-xfail cases
 2021-12-10  7:16 UTC  (3+ messages)

[PATCH v3] selftests: net: Correct ping6 expected rc from 2 to 1
 2021-12-10  3:20 UTC  (2+ messages)

[PATCH v3 0/3] kselftest: alsa: Add basic mixer selftest
 2021-12-10  3:10 UTC  (9+ messages)
` [PATCH v3 1/3] kselftest: alsa: Add simplistic test for ALSA mixer controls kselftest
` [PATCH v3 2/3] kselftest: alsa: optimization for SNDRV_CTL_ELEM_ACCESS_VOLATILE
` [PATCH v3 3/3] kselftest: alsa: Use private alsa-lib configuration in mixer test

[V2 0/6] Auxiliary bus driver support for Intel PCIe VSEC/DVSEC
 2021-12-09 16:54 UTC  (20+ messages)
` [V2 2/6] driver core: auxiliary bus: Add driver data helpers
` [V2 4/6] platform/x86: Add Intel Software Defined Silicon driver

[PATCH v9 0/7] cgroup/cpuset: Add new cpuset partition type & empty effecitve cpus
 2021-12-09 15:39 UTC  (2+ messages)

[PATCH v1 1/1] kunit: Replace kernel.h with the necessary inclusions
 2021-12-09 12:26 UTC  (2+ messages)

[PATCH v2] selftests: net: Correct ping6 expected rc from 2 to 1
 2021-12-09  1:58 UTC 

[PATCH v9 0/6] test_sysfs: add new selftest for sysfs
 2021-12-09  1:48 UTC  (4+ messages)
` [PATCH v9 3/6] selftests: add tests_sysfs module

[PATCH] selftests: net: Correct ping6 expected rc from 2 to 1
 2021-12-09  1:23 UTC  (2+ messages)

[PATCH v13 0/7] gpio-sim: configfs-based GPIO simulator
 2021-12-09  0:54 UTC  (2+ messages)

[PATCH v2] kselftest: alsa: Add simplistic test for ALSA mixer controls kselftest
 2021-12-08 21:14 UTC  (11+ messages)

[PATCH] kselftest: alsa: Use private alsa-lib configuration in mixer test
 2021-12-08 21:08 UTC  (6+ messages)

[PATCH RESEND v3 0/5] test_hash.c: refactor into KUnit
 2021-12-08 20:58 UTC  (7+ messages)
` [PATCH RESEND v3 1/5] hash.h: remove unused define directive
` [PATCH RESEND v3 2/5] test_hash.c: split test_int_hash into arch-specific functions
` [PATCH RESEND v3 3/5] test_hash.c: split test_hash_init
` [PATCH RESEND v3 4/5] lib/Kconfig.debug: properly split hash test kernel entries
` [PATCH RESEND v3 5/5] test_hash.c: refactor into kunit

[PATCH 00/11] mm/damon: Trivial fixups and improvements
 2021-12-08 16:48 UTC  (6+ messages)
` [PATCH 02/11] mm/damon/dbgfs: Remove an unnecessary error message

[RFC PATCH v2] Documentation: dev-tools: Add KTAP specification
 2021-12-08 16:17 UTC  (3+ messages)

[PATCH] KVM: x86: selftests: svm_int_ctl_test: fix intercept calculation
 2021-12-08 14:04 UTC  (2+ messages)

[PATCH v3 00/18] tcp: Initial support for RFC5925 auth option
 2021-12-08 11:37 UTC  (19+ messages)
` [PATCH v3 01/18] tcp: authopt: Initial support and key management
` [PATCH v3 02/18] docs: Add user documentation for tcp_authopt
` [PATCH v3 03/18] tcp: authopt: Add crypto initialization
` [PATCH v3 04/18] tcp: md5: Refactor tcp_sig_hash_skb_data for AO
` [PATCH v3 05/18] tcp: authopt: Compute packet signatures
` [PATCH v3 06/18] tcp: authopt: Hook into tcp core
` [PATCH v3 07/18] tcp: authopt: Disable via sysctl by default
` [PATCH v3 08/18] tcp: authopt: Implement Sequence Number Extension
` [PATCH v3 09/18] tcp: ipv6: Add AO signing for tcp_v6_send_response
` [PATCH v3 10/18] tcp: authopt: Add support for signing skb-less replies
` [PATCH v3 11/18] tcp: ipv4: Add AO signing for "
` [PATCH v3 12/18] tcp: authopt: Add key selection controls
` [PATCH v3 13/18] tcp: authopt: Add initial l3index support
` [PATCH v3 14/18] tcp: authopt: Add NOSEND/NORECV flags
` [PATCH v3 15/18] tcp: authopt: Add prefixlen support
` [PATCH v3 16/18] selftests: nettest: Rename md5_prefix to key_addr_prefix
` [PATCH v3 17/18] selftests: nettest: Initial tcp_authopt support
` [PATCH v3 18/18] selftests: net/fcnal: "

[PATCH v2] selftests: net: Correct case name
 2021-12-08  4:07 UTC  (5+ messages)

selftests/net/fcnal-test.sh: ipv6_ping test failed
 2021-12-08  3:54 UTC  (5+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).