On Tue 2019-07-30 00:21:14, Akinobu Mita wrote: > 2019年7月29日(月) 2:30 Jacek Anaszewski : > > > > Hi Akinobu, > > > > On 7/28/19 4:00 PM, Akinobu Mita wrote: > > > The umem driver defines LED_* macros for MEMCTRLCMD_LEDCTRL register > > > values. The LED_OFF and LED_ON macros conflict with the LED subsystem's > > > LED_OFF and LED_ON enums. > > > > > > This renames these LED_* macros to LEDCTRL_* in umem driver. > > [...] > > > > > > diff --git a/drivers/block/umem.h b/drivers/block/umem.h > > > index 5838497..8563fdc 100644 > > > --- a/drivers/block/umem.h > > > +++ b/drivers/block/umem.h > > > @@ -32,16 +32,16 @@ > > > #define MEM_2_GB 0xe0 > > > > > > #define MEMCTRLCMD_LEDCTRL 0x08 > > > -#define LED_REMOVE 2 > > > -#define LED_FAULT 4 > > > -#define LED_POWER 6 > > > -#define LED_FLIP 255 > > > -#define LED_OFF 0x00 > > > -#define LED_ON 0x01 > > > -#define LED_FLASH_3_5 0x02 > > > -#define LED_FLASH_7_0 0x03 > > > -#define LED_POWER_ON 0x00 > > > -#define LED_POWER_OFF 0x01 > > > +#define LEDCTRL_REMOVE 2 > > > > This way the namespacing prefix still begins with "LED", > > which can lead to further conflicts in the future. > > How about renaming 'LED_ON' to 'MEMCTRLCMD_LEDCTRL_ON', and 'LED_OFF' to > 'MEMCTRLCMD_LEDCTRL_OFF' ? I'd say that "MEMCTRL_LED_ON" woudl e enough, but... :-). Pavel -- (english) http://www.livejournal.com/~pavelmachek (cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html