linux-lvm.redhat.com archive mirror
 help / color / mirror / Atom feed
From: Christoph Pleger <christoph.pleger@cs.uni-dortmund.de>
To: linux-lvm@redhat.com
Subject: [linux-lvm] dmsetup says "Device does not exist", though it exists
Date: Tue, 13 Aug 2019 09:11:58 +0200	[thread overview]
Message-ID: <843935217a8de82c4cf47f02953489c6@cs.uni-dortmund.de> (raw)

Hello,

I have a volume group with 20 logical volumes. Only the last one of 
these volumes has a strange problem with dmsetup, shown by these 
commands and output on the command line:

root@host:/home/linux# /sbin/dmsetup info -c -o name --noheadings 
/dev/vg/lv20
Device does not exist.
Command failed

root@host:/home/linux# lvdisplay -c /dev/vg/lv20
   /dev/vg/lv20:vg:3:1:-1:0:4194304:512:-1:0:-1:253:19

root@host:/home/linux# mount /dev/vg/lv20 /mnt
root@host:/home/linux# ls /mnt
lost+found data1 data2

That is, dmsetup says "Device does not exist" about a logical volume, 
though the volume exists and is operating normally. What is the possible 
problem here?

Regards
   Christoph

             reply	other threads:[~2019-08-13  7:12 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-08-13  7:11 Christoph Pleger [this message]
2019-08-13 13:54 ` [linux-lvm] dmsetup says "Device does not exist", though it exists Zdenek Kabelac
2019-08-13 21:25   ` Bernd Eckenfels
2019-08-14 11:09     ` Zdenek Kabelac
2019-08-14  7:22   ` Christoph Pleger
2019-08-14 11:07     ` Zdenek Kabelac
2019-08-14 12:49       ` Christoph Pleger
2019-08-14 13:06       ` Christoph Pleger

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=843935217a8de82c4cf47f02953489c6@cs.uni-dortmund.de \
    --to=christoph.pleger@cs.uni-dortmund.de \
    --cc=linux-lvm@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).