Hi Niklas, On Mon, Jan 14, 2019 at 03:55:33PM +0100, Niklas Söderlund wrote: [snip] > > + /* Register link to HDMI for TXA only. */ > > + if (is_txb(tx) || !is_hdmi_enabled(state)) > > Small nit, I would s/is_txb(tx)/!is_txa(tx)/ here as to me it becomes > easier to read. With or without this change, > > Reviewed-by: Niklas Söderlund > Would you want me to resend for this or can this series be collected? Thanks j > > + return 0; > > + > > + return adv748x_csi2_register_link(tx, sd->v4l2_dev, &state->hdmi.sd, > > + ADV748X_HDMI_SOURCE, true); > > } > > > > static const struct v4l2_subdev_internal_ops adv748x_csi2_internal_ops = { > > -- > > 2.20.1 > > > > -- > Regards, > Niklas Söderlund