linux-media.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Marco Felsch <m.felsch@pengutronix.de>
To: mchehab@kernel.org, sakari.ailus@linux.intel.com,
	hans.verkuil@cisco.com, jacopo+renesas@jmondi.org,
	robh+dt@kernel.org, laurent.pinchart@ideasonboard.com
Cc: devicetree@vger.kernel.org, kernel@pengutronix.de,
	linux-media@vger.kernel.org
Subject: Re: [PATCH v10 07/14] media: tvp5150: fix set_selection rectangle handling
Date: Fri, 27 Sep 2019 14:13:34 +0200	[thread overview]
Message-ID: <20190927121334.xjt4pneuohppy44n@pengutronix.de> (raw)
In-Reply-To: <20190830101646.6530-8-m.felsch@pengutronix.de>

Hi Hans,

since you review contained many checkpatch issues I wanna ask if it okay
to keep this line as it before I will send a v11. Please check my inline
comment.

On 19-08-30 12:16, Marco Felsch wrote:
> Currently a local copy of sel->r is made and adapted to the hardware
> constraints. After the adaption the value is applied to the hardware but
> the driver forgot to reflect the adapted value to the user space.
> 
> Drop the local copy and work directly on the requested rectangle
> instead to fix this.
> 
> Signed-off-by: Marco Felsch <m.felsch@pengutronix.de>
> ---
> 
> v10:
> - new patch
> 
>  drivers/media/i2c/tvp5150.c | 32 ++++++++++++++++----------------
>  1 file changed, 16 insertions(+), 16 deletions(-)
> 
> diff --git a/drivers/media/i2c/tvp5150.c b/drivers/media/i2c/tvp5150.c
> index 477a929d4f89..c1542a89e8c8 100644
> --- a/drivers/media/i2c/tvp5150.c
> +++ b/drivers/media/i2c/tvp5150.c
> @@ -1024,7 +1024,7 @@ static int tvp5150_set_selection(struct v4l2_subdev *sd,
>  				 struct v4l2_subdev_selection *sel)
>  {
>  	struct tvp5150 *decoder = to_tvp5150(sd);
> -	struct v4l2_rect rect = sel->r;
> +	struct v4l2_rect *rect = &sel->r;
>  	v4l2_std_id std;
>  	int hmax;
>  
> @@ -1033,11 +1033,11 @@ static int tvp5150_set_selection(struct v4l2_subdev *sd,
>  		return -EINVAL;
>  
>  	dev_dbg_lvl(sd->dev, 1, debug, "%s left=%d, top=%d, width=%d, height=%d\n",
> -		__func__, rect.left, rect.top, rect.width, rect.height);
> +		__func__, rect->left, rect->top, rect->width, rect->height);
>  
>  	/* tvp5150 has some special limits */
> -	rect.left = clamp(rect.left, 0, TVP5150_MAX_CROP_LEFT);
> -	rect.top = clamp(rect.top, 0, TVP5150_MAX_CROP_TOP);
> +	rect->left = clamp(rect->left, 0, TVP5150_MAX_CROP_LEFT);
> +	rect->top = clamp(rect->top, 0, TVP5150_MAX_CROP_TOP);
>  
>  	/* Calculate height based on current standard */
>  	if (decoder->norm == V4L2_STD_ALL)
> @@ -1055,26 +1055,26 @@ static int tvp5150_set_selection(struct v4l2_subdev *sd,
>  	 *  - width = 2 due to UYVY colorspace
>  	 *  - height, image = no special alignment
>  	 */
> -	v4l_bound_align_image(&rect.width,
> -			      TVP5150_H_MAX - TVP5150_MAX_CROP_LEFT - rect.left,
> -			      TVP5150_H_MAX - rect.left, 1, &rect.height,
> -			      hmax - TVP5150_MAX_CROP_TOP - rect.top,
> -			      hmax - rect.top, 0, 0);
> +	v4l_bound_align_image(&rect->width,
> +			      TVP5150_H_MAX - TVP5150_MAX_CROP_LEFT - rect->left,

Now checkpatch complains about this line because it is 81 characters
long. Is it okay to keep this as single line for readability?

Regards,
  Marco


> +			      TVP5150_H_MAX - rect->left, 1, &rect->height,
> +			      hmax - TVP5150_MAX_CROP_TOP - rect->top,
> +			      hmax - rect->top, 0, 0);
>  
> -	regmap_write(decoder->regmap, TVP5150_VERT_BLANKING_START, rect.top);
> +	regmap_write(decoder->regmap, TVP5150_VERT_BLANKING_START, rect->top);
>  	regmap_write(decoder->regmap, TVP5150_VERT_BLANKING_STOP,
> -		     rect.top + rect.height - hmax);
> +		     rect->top + rect->height - hmax);
>  	regmap_write(decoder->regmap, TVP5150_ACT_VD_CROP_ST_MSB,
> -		     rect.left >> TVP5150_CROP_SHIFT);
> +		     rect->left >> TVP5150_CROP_SHIFT);
>  	regmap_write(decoder->regmap, TVP5150_ACT_VD_CROP_ST_LSB,
> -		     rect.left | (1 << TVP5150_CROP_SHIFT));
> +		     rect->left | (1 << TVP5150_CROP_SHIFT));
>  	regmap_write(decoder->regmap, TVP5150_ACT_VD_CROP_STP_MSB,
> -		     (rect.left + rect.width - TVP5150_MAX_CROP_LEFT) >>
> +		     (rect->left + rect->width - TVP5150_MAX_CROP_LEFT) >>
>  		     TVP5150_CROP_SHIFT);
>  	regmap_write(decoder->regmap, TVP5150_ACT_VD_CROP_STP_LSB,
> -		     rect.left + rect.width - TVP5150_MAX_CROP_LEFT);
> +		     rect->left + rect->width - TVP5150_MAX_CROP_LEFT);
>  
> -	decoder->rect = rect;
> +	decoder->rect = *rect;
>  
>  	return 0;
>  }
> -- 
> 2.20.1
> 
> 

-- 
Pengutronix e.K.                           |                             |
Industrial Linux Solutions                 | http://www.pengutronix.de/  |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

  reply	other threads:[~2019-09-27 12:13 UTC|newest]

Thread overview: 43+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-08-30 10:16 [PATCH v10 00/14] TVP5150 features and fixes Marco Felsch
2019-08-30 10:16 ` [PATCH v10 01/14] dt-bindings: connector: analog: add sdtv standards property Marco Felsch
2019-09-27  9:09   ` Hans Verkuil
2019-09-27 10:01     ` Marco Felsch
2019-08-30 10:16 ` [PATCH v10 02/14] media: v4l2-fwnode: add v4l2_fwnode_connector Marco Felsch
2019-08-30 10:16 ` [PATCH v10 03/14] media: v4l2-fwnode: add initial connector parsing support Marco Felsch
2019-10-02  7:03   ` Sakari Ailus
2019-10-02  8:07     ` Marco Felsch
2019-10-22 10:17       ` Marco Felsch
2019-10-23 10:57       ` Sakari Ailus
2019-10-23 12:21         ` Marco Felsch
2019-10-24 12:02           ` Sakari Ailus
2019-11-08  8:58             ` Marco Felsch
2019-11-15 23:06               ` Sakari Ailus
2019-11-19 11:15                 ` Marco Felsch
2019-11-27  8:26                   ` Marco Felsch
2019-11-27 12:24                     ` Sakari Ailus
2019-12-10  9:50                       ` Marco Felsch
2020-01-07 11:56                         ` Marco Felsch
2020-01-07 13:49                         ` Sakari Ailus
2020-01-07 14:00                           ` Marco Felsch
2020-01-07 14:03                             ` Sakari Ailus
2019-11-27 12:21                   ` Sakari Ailus
2019-08-30 10:16 ` [PATCH v10 04/14] partial revert of "[media] tvp5150: add HW input connectors support" Marco Felsch
2019-08-30 10:16 ` [PATCH v10 05/14] media: tvp5150: add input source selection of_graph support Marco Felsch
2019-09-27  8:54   ` Hans Verkuil
2019-09-27 12:09     ` Marco Felsch
2019-08-30 10:16 ` [PATCH v10 06/14] media: dt-bindings: tvp5150: Add input port connectors DT bindings Marco Felsch
2019-08-30 10:16 ` [PATCH v10 07/14] media: tvp5150: fix set_selection rectangle handling Marco Felsch
2019-09-27 12:13   ` Marco Felsch [this message]
2019-09-27 12:14     ` Hans Verkuil
2019-08-30 10:16 ` [PATCH v10 08/14] media: tvp5150: add FORMAT_TRY support for get/set selection handlers Marco Felsch
2019-09-27  9:01   ` Hans Verkuil
2019-09-27 10:57     ` Marco Felsch
2019-09-27 11:05       ` Hans Verkuil
2019-08-30 10:16 ` [PATCH v10 09/14] media: tvp5150: initialize subdev before parsing device tree Marco Felsch
2019-08-30 10:16 ` [PATCH v10 10/14] media: tvp5150: add s_power callback Marco Felsch
2019-08-30 10:16 ` [PATCH v10 11/14] media: dt-bindings: tvp5150: cleanup bindings stlye Marco Felsch
2019-08-30 10:16 ` [PATCH v10 12/14] media: dt-bindings: tvp5150: add optional sdtv standards documentation Marco Felsch
2019-08-30 10:16 ` [PATCH v10 13/14] media: tvp5150: add support to limit sdtv standards Marco Felsch
2019-09-27  8:52   ` Hans Verkuil
2019-09-27 12:09     ` Marco Felsch
2019-08-30 10:16 ` [PATCH v10 14/14] media: tvp5150: make debug output more readable Marco Felsch

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190927121334.xjt4pneuohppy44n@pengutronix.de \
    --to=m.felsch@pengutronix.de \
    --cc=devicetree@vger.kernel.org \
    --cc=hans.verkuil@cisco.com \
    --cc=jacopo+renesas@jmondi.org \
    --cc=kernel@pengutronix.de \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=linux-media@vger.kernel.org \
    --cc=mchehab@kernel.org \
    --cc=robh+dt@kernel.org \
    --cc=sakari.ailus@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).