linux-media.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Dan Carpenter <dan.carpenter@oracle.com>
To: Juan Antonio Aldea-Armenteros <juant.aldea@gmail.com>
Cc: Mauro Carvalho Chehab <mchehab@kernel.org>,
	Sakari Ailus <sakari.ailus@linux.intel.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org,
	linux-media@vger.kernel.org
Subject: Re: [PATCH] media: atomisp-mt9m114: replace fixed function names
Date: Mon, 27 Jul 2020 16:20:43 +0300	[thread overview]
Message-ID: <20200727132042.GE1913@kadam> (raw)
In-Reply-To: <20200725081108.272643-1-juant.aldea@gmail.com>

On Sat, Jul 25, 2020 at 10:11:08AM +0200, Juan Antonio Aldea-Armenteros wrote:
> There are a couple of debug messages using hardcoded function names
> instead of the preferred __func__ magic constant.
> 
> Replace them:
> 
> WARNING: Prefer using '"%s...", __func__' to using 'misensor_rmw_reg', this function's name, in a string
> 215: FILE: ./media/atomisp/i2c/atomisp-mt9m114.c:215:
> +       v4l2_err(client, "misensor_rmw_reg error exit, read failed\n");
> 
> WARNING: Prefer using '"%s...", __func__' to using 'misensor_rmw_reg', this function's name, in a string
> 236: FILE: ./media/atomisp/i2c/atomisp-mt9m114.c:236:
> +       v4l2_err(client, "misensor_rmw_reg error exit, write failed\n");
> 
> Signed-off-by: Juan Antonio Aldea-Armenteros <juant.aldea@gmail.com>
> ---
>  drivers/staging/media/atomisp/i2c/atomisp-mt9m114.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/staging/media/atomisp/i2c/atomisp-mt9m114.c b/drivers/staging/media/atomisp/i2c/atomisp-mt9m114.c
> index 0d60918a9b19..54c24bc2061d 100644
> --- a/drivers/staging/media/atomisp/i2c/atomisp-mt9m114.c
> +++ b/drivers/staging/media/atomisp/i2c/atomisp-mt9m114.c
> @@ -212,7 +212,7 @@ misensor_rmw_reg(struct i2c_client *client, u16 data_length, u16 reg,
>  
>  	err = mt9m114_read_reg(client, data_length, reg, &val);
>  	if (err) {
> -		v4l2_err(client, "misensor_rmw_reg error exit, read failed\n");
> +		v4l2_err(client, "%s exit, read failed\n", __func__);

Did you intend to delete the word "error"?

regards,
dan carpenter



  reply	other threads:[~2020-07-27 13:21 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-25  8:11 [PATCH] media: atomisp-mt9m114: replace fixed function names Juan Antonio Aldea-Armenteros
2020-07-27 13:20 ` Dan Carpenter [this message]
2020-07-28 14:32   ` Juan Antonio Aldea-Armenteros

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200727132042.GE1913@kadam \
    --to=dan.carpenter@oracle.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=juant.aldea@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=mchehab@kernel.org \
    --cc=sakari.ailus@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).