linux-mips.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Jonathan Cameron <Jonathan.Cameron@Huawei.com>
To: Christophe Branchereau <cbranchereau@gmail.com>
Cc: <paul@crapouillou.net>, <jic23@kernel.org>, <lars@metafoo.de>,
	<linux-mips@vger.kernel.org>, <linux-iio@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>, <robh+dt@kernel.org>,
	<devicetree@vger.kernel.org>, <linux@roeck-us.net>,
	<contact@artur-rojek.eu>
Subject: Re: [PATCH V2 4/5] iio/adc: ingenic: add JZ4760B support to the sadc driver
Date: Fri, 23 Jul 2021 17:15:58 +0100	[thread overview]
Message-ID: <20210723171558.00005383@Huawei.com> (raw)
In-Reply-To: <20210723085813.1523934-5-cbranchereau@gmail.com>

On Fri, 23 Jul 2021 10:58:12 +0200
Christophe Branchereau <cbranchereau@gmail.com> wrote:

> The JZ4760B variant differs slightly from the JZ4760: it has a bit called 
> VBAT_SEL in the CFG register.
> 
> In order to correctly sample the battery voltage on existing handhelds 
> using this SOC, the bit must be cleared.
> 
> We leave the possibility to set the bit, by adding the 
> "ingenic,use-internal-divider" property to a devicetree.
> 
> Signed-off-by: Christophe Branchereau <cbranchereau@gmail.com>

One minor formatting comment inline.  If that is all that comes up in
review I can just change it whilst applying.

Jonathan

> ---
>  drivers/iio/adc/ingenic-adc.c | 8 ++++++++
>  1 file changed, 8 insertions(+)
> 
> diff --git a/drivers/iio/adc/ingenic-adc.c b/drivers/iio/adc/ingenic-adc.c
> index 6b9af0530590..09937c05d2af 100644
> --- a/drivers/iio/adc/ingenic-adc.c
> +++ b/drivers/iio/adc/ingenic-adc.c
> @@ -37,6 +37,7 @@
>  #define JZ_ADC_REG_CFG_SAMPLE_NUM(n)	((n) << 10)
>  #define JZ_ADC_REG_CFG_PULL_UP(n)	((n) << 16)
>  #define JZ_ADC_REG_CFG_CMD_SEL		BIT(22)
> +#define JZ_ADC_REG_CFG_VBAT_SEL		BIT(30)
>  #define JZ_ADC_REG_CFG_TOUCH_OPS_MASK	(BIT(31) | GENMASK(23, 10))
>  #define JZ_ADC_REG_ADCLK_CLKDIV_LSB	0
>  #define JZ4725B_ADC_REG_ADCLK_CLKDIV10US_LSB	16
> @@ -879,6 +880,12 @@ static int ingenic_adc_probe(struct platform_device *pdev)
>  	/* Put hardware in a known passive state. */
>  	writeb(0x00, adc->base + JZ_ADC_REG_ENABLE);
>  	writeb(0xff, adc->base + JZ_ADC_REG_CTRL);
> +
> +	if (device_property_present(dev, "ingenic,use-internal-divider")) /* JZ4760B specific */
> +		ingenic_adc_set_config(adc, JZ_ADC_REG_CFG_VBAT_SEL, JZ_ADC_REG_CFG_VBAT_SEL);
Please break this line and move the comment on the one above.

Whilst we have relaxed the kernel style to allow longer lines, it's nice
to still keep them to the 80 char limit when it doesn't really hurt readability.
Here I don't think it would make much difference.

> +	else
> +		ingenic_adc_set_config(adc, JZ_ADC_REG_CFG_VBAT_SEL, 0);
> +
>  	usleep_range(2000, 3000); /* Must wait at least 2ms. */
>  	clk_disable(adc->clk);
>  
> @@ -906,6 +913,7 @@ static const struct of_device_id ingenic_adc_of_match[] = {
>  	{ .compatible = "ingenic,jz4725b-adc", .data = &jz4725b_adc_soc_data, },
>  	{ .compatible = "ingenic,jz4740-adc", .data = &jz4740_adc_soc_data, },
>  	{ .compatible = "ingenic,jz4760-adc", .data = &jz4760_adc_soc_data, },
> +	{ .compatible = "ingenic,jz4760b-adc", .data = &jz4760_adc_soc_data, },
>  	{ .compatible = "ingenic,jz4770-adc", .data = &jz4770_adc_soc_data, },
>  	{ },
>  };


  reply	other threads:[~2021-07-23 16:16 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-21 10:53 [PATCH] Ingenic: iio/adc: add JZ4760(B) support to the citral23
2021-07-21 10:53 ` [PATCH 1/6] iio/adc: ingenic: rename has_aux2 to has_aux_md citral23
2021-07-21 17:46   ` Paul Cercueil
2021-07-21 10:53 ` [PATCH 2/6] dt-bindings: iio/adc: add an INGENIC_ADC_AUX0 entry citral23
2021-07-21 17:46   ` Paul Cercueil
2021-07-21 10:53 ` [PATCH 3/6] iio/adc: ingenic: add JZ4760 support to the sadc driver citral23
2021-07-21 18:15   ` Paul Cercueil
2021-07-22  5:09     ` Christophe Branchereau
2021-07-22  5:23       ` Guenter Roeck
2021-07-23  8:58         ` [PATCH V2 0/5] iio/adc: ingenic: add support for the JZ4760(B) Socs to the ingenic " Christophe Branchereau
2021-07-23  8:58           ` [PATCH V2 1/5] iio/adc: ingenic: rename has_aux2 to has_aux_md Christophe Branchereau
2021-07-23  8:58           ` [PATCH V2 2/5] dt-bindings: iio/adc: add an INGENIC_ADC_AUX0 entry Christophe Branchereau
2021-07-23  8:58           ` [PATCH V2 3/5] iio/adc: ingenic: add JZ4760 support to the sadc driver Christophe Branchereau
2021-07-23  8:58           ` [PATCH V2 4/5] iio/adc: ingenic: add JZ4760B " Christophe Branchereau
2021-07-23 16:15             ` Jonathan Cameron [this message]
2021-07-23  8:58           ` [PATCH V2 5/5] dt-bindings: iio/adc: ingenic: add the JZ4760(B) socs to the sadc Documentation Christophe Branchereau
2021-07-23 16:16             ` Jonathan Cameron
2021-07-24  7:33               ` Christophe Branchereau
2021-07-24 15:23                 ` Jonathan Cameron
2021-07-23 16:03           ` [PATCH V2 0/5] iio/adc: ingenic: add support for the JZ4760(B) Socs to the ingenic sadc driver Jonathan Cameron
2021-07-23 16:13     ` [PATCH 3/6] iio/adc: ingenic: add JZ4760 support to the " Jonathan Cameron
2021-07-21 10:53 ` [PATCH 4/6] iio/adc: ingenic: add JZ4760B " citral23
2021-07-21 18:24   ` Paul Cercueil
2021-07-21 10:53 ` [PATCH 5/6] iio/adc: ingenic: modify citral23
2021-07-21 18:28   ` Paul Cercueil
2021-07-21 10:53 ` [PATCH 6/6] dt-bindings: iio/adc: ingenic: add the JZ4760(B) socs to the sadc Documentation citral23
2021-07-21 19:17   ` Paul Cercueil
2021-07-23 16:10     ` Jonathan Cameron
2021-07-22  2:09   ` Rob Herring

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210723171558.00005383@Huawei.com \
    --to=jonathan.cameron@huawei.com \
    --cc=cbranchereau@gmail.com \
    --cc=contact@artur-rojek.eu \
    --cc=devicetree@vger.kernel.org \
    --cc=jic23@kernel.org \
    --cc=lars@metafoo.de \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mips@vger.kernel.org \
    --cc=linux@roeck-us.net \
    --cc=paul@crapouillou.net \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).