linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: Alex Shi <alex.shi@linux.alibaba.com>
To: akpm@linux-foundation.org, mgorman@techsingularity.net,
	tj@kernel.org, hughd@google.com, khlebnikov@yandex-team.ru,
	daniel.m.jordan@oracle.com, yang.shi@linux.alibaba.com,
	willy@infradead.org, hannes@cmpxchg.org, lkp@intel.com,
	linux-mm@kvack.org, linux-kernel@vger.kernel.org,
	cgroups@vger.kernel.org, shakeelb@google.com,
	iamjoonsoo.kim@lge.com, richard.weiyang@gmail.com
Subject: [PATCH v12 01/16] mm/vmscan: remove unnecessary lruvec adding
Date: Thu, 11 Jun 2020 14:16:34 +0800	[thread overview]
Message-ID: <1591856209-166869-2-git-send-email-alex.shi@linux.alibaba.com> (raw)
In-Reply-To: <1591856209-166869-1-git-send-email-alex.shi@linux.alibaba.com>

We don't have to add a freeable page into lru and then remove from it.
This change saves a couple of actions and makes the moving more clear.

The SetPageLRU needs to be kept here for list intergrity.
Otherwise:
 #0 mave_pages_to_lru              #1 release_pages
                                   if (put_page_testzero())
 if !put_page_testzero
                                     !PageLRU //skip lru_lock
                                       list_add(&page->lru,)
   list_add(&page->lru,) //corrupt

[akpm@linux-foundation.org: coding style fixes]
Signed-off-by: Alex Shi <alex.shi@linux.alibaba.com>
Cc: Andrew Morton <akpm@linux-foundation.org>
Cc: Johannes Weiner <hannes@cmpxchg.org>
Cc: Tejun Heo <tj@kernel.org>
Cc: Matthew Wilcox <willy@infradead.org>
Cc: Hugh Dickins <hughd@google.com>
Cc: linux-mm@kvack.org
Cc: linux-kernel@vger.kernel.org
---
 mm/vmscan.c | 32 +++++++++++++++++++++-----------
 1 file changed, 21 insertions(+), 11 deletions(-)

diff --git a/mm/vmscan.c b/mm/vmscan.c
index b6d84326bdf2..81228334f7d6 100644
--- a/mm/vmscan.c
+++ b/mm/vmscan.c
@@ -1855,26 +1855,29 @@ static unsigned noinline_for_stack move_pages_to_lru(struct lruvec *lruvec,
 	while (!list_empty(list)) {
 		page = lru_to_page(list);
 		VM_BUG_ON_PAGE(PageLRU(page), page);
+		list_del(&page->lru);
 		if (unlikely(!page_evictable(page))) {
-			list_del(&page->lru);
 			spin_unlock_irq(&pgdat->lru_lock);
 			putback_lru_page(page);
 			spin_lock_irq(&pgdat->lru_lock);
 			continue;
 		}
-		lruvec = mem_cgroup_page_lruvec(page, pgdat);
 
+		/*
+		 * The SetPageLRU needs to be kept here for list intergrity.
+		 * Otherwise:
+		 *   #0 mave_pages_to_lru             #1 release_pages
+		 *				      if (put_page_testzero())
+		 *   if !put_page_testzero
+		 *				        !PageLRU //skip lru_lock
+		 *                                        list_add(&page->lru,)
+		 *     list_add(&page->lru,) //corrupt
+		 */
 		SetPageLRU(page);
-		lru = page_lru(page);
-
-		nr_pages = hpage_nr_pages(page);
-		update_lru_size(lruvec, lru, page_zonenum(page), nr_pages);
-		list_move(&page->lru, &lruvec->lists[lru]);
 
-		if (put_page_testzero(page)) {
+		if (unlikely(put_page_testzero(page))) {
 			__ClearPageLRU(page);
 			__ClearPageActive(page);
-			del_page_from_lru_list(page, lruvec, lru);
 
 			if (unlikely(PageCompound(page))) {
 				spin_unlock_irq(&pgdat->lru_lock);
@@ -1882,9 +1885,16 @@ static unsigned noinline_for_stack move_pages_to_lru(struct lruvec *lruvec,
 				spin_lock_irq(&pgdat->lru_lock);
 			} else
 				list_add(&page->lru, &pages_to_free);
-		} else {
-			nr_moved += nr_pages;
+			continue;
 		}
+
+		lruvec = mem_cgroup_page_lruvec(page, pgdat);
+		lru = page_lru(page);
+		nr_pages = hpage_nr_pages(page);
+
+		update_lru_size(lruvec, lru, page_zonenum(page), nr_pages);
+		list_add(&page->lru, &lruvec->lists[lru]);
+		nr_moved += nr_pages;
 	}
 
 	/*
-- 
1.8.3.1



  reply	other threads:[~2020-06-11  6:17 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-11  6:16 [PATCH v12 00/16] per memcg lru lock Alex Shi
2020-06-11  6:16 ` Alex Shi [this message]
2020-06-11  6:16 ` [PATCH v12 02/16] mm/page_idle: no unlikely double check for idle page counting Alex Shi
2020-06-11  6:16 ` [PATCH v12 03/16] mm/compaction: correct the comments of compact_defer_shift Alex Shi
2020-06-11  6:16 ` [PATCH v12 04/16] mm/compaction: rename compact_deferred as compact_should_defer Alex Shi
2020-06-11  6:16 ` [PATCH v12 05/16] mm/thp: move lru_add_page_tail func to huge_memory.c Alex Shi
2020-06-11  6:16 ` [PATCH v12 06/16] mm/thp: clean up lru_add_page_tail Alex Shi
2020-06-11  6:16 ` [PATCH v12 07/16] mm/thp: narrow lru locking Alex Shi
2020-06-11  6:16 ` [PATCH v12 08/16] mm/memcg: add debug checking in lock_page_memcg Alex Shi
2020-06-11  6:16 ` [PATCH v12 09/16] mm/lru: introduce TestClearPageLRU Alex Shi
2020-06-11  6:16 ` [PATCH v12 10/16] mm/compaction: do page isolation first in compaction Alex Shi
2020-06-12 10:26   ` Alex Shi
2020-06-11  6:16 ` [PATCH v12 11/16] mm/mlock: reorder isolation sequence during munlock Alex Shi
2020-06-11  6:16 ` [PATCH v12 12/16] mm/lru: replace pgdat lru_lock with lruvec lock Alex Shi
2020-06-12 10:28   ` Alex Shi
2020-06-11  6:16 ` [PATCH v12 13/16] mm/lru: introduce the relock_page_lruvec function Alex Shi
2020-06-11  6:16 ` [PATCH v12 14/16] mm/vmscan: use relock for move_pages_to_lru Alex Shi
2020-06-11  6:16 ` [PATCH v12 15/16] mm/pgdat: remove pgdat lru_lock Alex Shi
2020-06-11  6:16 ` [PATCH v12 16/16] mm/lru: revise the comments of lru_lock Alex Shi
2020-06-11 22:26 ` [PATCH v12 00/16] per memcg lru lock Hugh Dickins
2020-06-12  3:09   ` Alex Shi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1591856209-166869-2-git-send-email-alex.shi@linux.alibaba.com \
    --to=alex.shi@linux.alibaba.com \
    --cc=akpm@linux-foundation.org \
    --cc=cgroups@vger.kernel.org \
    --cc=daniel.m.jordan@oracle.com \
    --cc=hannes@cmpxchg.org \
    --cc=hughd@google.com \
    --cc=iamjoonsoo.kim@lge.com \
    --cc=khlebnikov@yandex-team.ru \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=lkp@intel.com \
    --cc=mgorman@techsingularity.net \
    --cc=richard.weiyang@gmail.com \
    --cc=shakeelb@google.com \
    --cc=tj@kernel.org \
    --cc=willy@infradead.org \
    --cc=yang.shi@linux.alibaba.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).