linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: Nicholas Piggin <npiggin@gmail.com>
To: Andrew Morton <akpm@linux-foundation.org>,
	Arnd Bergmann <arnd@arndb.de>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Christophe Leroy <christophe.leroy@csgroup.eu>,
	Helge Deller <deller@gmx.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"James E.J. Bottomley" <James.Bottomley@HansenPartnership.com>,
	Kees Cook <keescook@chromium.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Paul Mackerras <paulus@samba.org>
Cc: linux-arch@vger.kernel.org, linux-ia64@vger.kernel.org,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	linux-parisc@vger.kernel.org, linuxppc-dev@lists.ozlabs.org
Subject: Re: [PATCH v3 07/12] asm-generic: Define 'func_desc_t' to commonly describe function descriptors
Date: Mon, 18 Oct 2021 16:29:57 +1000	[thread overview]
Message-ID: <1634538449.eah9b31bbz.astroid@bobo.none> (raw)
In-Reply-To: <a33107c5b82580862510cc20af0d61e33a2b841d.1634457599.git.christophe.leroy@csgroup.eu>

Excerpts from Christophe Leroy's message of October 17, 2021 10:38 pm:
> We have three architectures using function descriptors, each with its
> own type and name.
> 
> Add a common typedef that can be used in generic code.
> 
> Also add a stub typedef for architecture without function descriptors,
> to avoid a forest of #ifdefs.
> 
> It replaces the similar 'func_desc_t' previously defined in
> arch/powerpc/kernel/module_64.c
> 
> Reviewed-by: Kees Cook <keescook@chromium.org>
> Acked-by: Arnd Bergmann <arnd@arndb.de>
> Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu>
> ---

[...]

> diff --git a/include/asm-generic/sections.h b/include/asm-generic/sections.h
> index a918388d9bf6..33b51efe3a24 100644
> --- a/include/asm-generic/sections.h
> +++ b/include/asm-generic/sections.h
> @@ -63,6 +63,9 @@ extern __visible const void __nosave_begin, __nosave_end;
>  #else
>  #define dereference_function_descriptor(p) ((void *)(p))
>  #define dereference_kernel_function_descriptor(p) ((void *)(p))
> +typedef struct {
> +	unsigned long addr;
> +} func_desc_t;
>  #endif
>  

I think that deserves a comment. If it's just to allow ifdef to be 
avoided, I guess that's okay with a comment. Would be nice if you could 
cause it to generate a link time error if it was ever used like
undefined functions, but I guess you can't. It's not a necessity though.

Thanks,
Nick


  reply	other threads:[~2021-10-18  6:30 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-10-17 12:38 [PATCH v3 00/12] Fix LKDTM for PPC64/IA64/PARISC Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 01/12] powerpc: Move and rename func_descr_t Christophe Leroy
2021-10-18  5:58   ` Nicholas Piggin
2022-02-11  0:51   ` Kees Cook
2021-10-17 12:38 ` [PATCH v3 02/12] powerpc: Use 'struct func_desc' instead of 'struct ppc64_opd_entry' Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 03/12] powerpc: Remove " Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 04/12] powerpc: Prepare func_desc_t for refactorisation Christophe Leroy
2021-10-18  6:27   ` Nicholas Piggin
2021-10-18  7:08     ` Christophe Leroy
2022-02-11  0:54   ` Kees Cook
2022-02-11  7:39     ` Segher Boessenkool
2022-02-14 10:30     ` Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 05/12] ia64: Rename 'ip' to 'addr' in 'struct fdesc' Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 06/12] asm-generic: Define CONFIG_HAVE_FUNCTION_DESCRIPTORS Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 07/12] asm-generic: Define 'func_desc_t' to commonly describe function descriptors Christophe Leroy
2021-10-18  6:29   ` Nicholas Piggin [this message]
2021-10-18  7:07     ` Christophe Leroy
2021-10-18  9:16       ` Nicholas Piggin
2021-10-17 12:38 ` [PATCH v3 08/12] asm-generic: Refactor dereference_[kernel]_function_descriptor() Christophe Leroy
2022-02-10 10:30   ` Michael Ellerman
2022-02-11  0:56     ` Kees Cook
2022-02-14 10:32       ` Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 09/12] lkdtm: Force do_nothing() out of line Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 10/12] lkdtm: Really write into kernel text in WRITE_KERN Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 11/12] lkdtm: Fix execute_[user]_location() Christophe Leroy
2021-12-17 11:49   ` Christophe Leroy
2022-01-19 19:28     ` Christophe Leroy
2022-01-19 22:00       ` Kees Cook
2022-02-11  1:01   ` Kees Cook
2021-10-17 12:38 ` [PATCH v3 12/12] lkdtm: Add a test for function descriptors protection Christophe Leroy
2022-02-11  1:09   ` Kees Cook
2022-02-14 10:34     ` Christophe Leroy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1634538449.eah9b31bbz.astroid@bobo.none \
    --to=npiggin@gmail.com \
    --cc=James.Bottomley@HansenPartnership.com \
    --cc=akpm@linux-foundation.org \
    --cc=arnd@arndb.de \
    --cc=benh@kernel.crashing.org \
    --cc=christophe.leroy@csgroup.eu \
    --cc=deller@gmx.de \
    --cc=gregkh@linuxfoundation.org \
    --cc=keescook@chromium.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-ia64@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-parisc@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mpe@ellerman.id.au \
    --cc=paulus@samba.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).