linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: Vladimir Davydov <vdavydov.dev@gmail.com>
To: Kirill Tkhai <ktkhai@virtuozzo.com>
Cc: akpm@linux-foundation.org, shakeelb@google.com,
	viro@zeniv.linux.org.uk, hannes@cmpxchg.org, mhocko@kernel.org,
	tglx@linutronix.de, pombredanne@nexb.com,
	stummala@codeaurora.org, gregkh@linuxfoundation.org,
	sfr@canb.auug.org.au, guro@fb.com, mka@chromium.org,
	penguin-kernel@I-love.SAKURA.ne.jp, chris@chris-wilson.co.uk,
	longman@redhat.com, minchan@kernel.org, ying.huang@intel.com,
	mgorman@techsingularity.net, jbacik@fb.com, linux@roeck-us.net,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	willy@infradead.org, lirongqing@baidu.com,
	aryabinin@virtuozzo.com
Subject: Re: [PATCH v6 05/17] mm: Assign memcg-aware shrinkers bitmap to memcg
Date: Mon, 21 May 2018 21:40:41 +0300	[thread overview]
Message-ID: <20180521184041.5p2zyhzu45eeihmi@esperanza> (raw)
In-Reply-To: <7a5c644d-625e-a01e-a9a7-304eea13d225@virtuozzo.com>

On Mon, May 21, 2018 at 01:16:40PM +0300, Kirill Tkhai wrote:
> >> +static int memcg_expand_one_shrinker_map(struct mem_cgroup *memcg,
> >> +					 int size, int old_size)
> > 
> > Nit: No point in passing old_size here. You can instead use
> > memcg_shrinker_map_size directly.
> 
> This is made for the readability. All the actions with global variable
> is made in the same function -- memcg_expand_shrinker_maps(), all
> the actions with local variables are also in the same -- memcg_expand_one_shrinker_map().
> Accessing memcg_shrinker_map_size in memcg_expand_one_shrinker_map()
> looks not intuitive and breaks modularity. 

I guess it depends on how you look at it. Anyway, it's nitpicking so I
won't mind if you leave it as is.

> >> +static int memcg_alloc_shrinker_maps(struct mem_cgroup *memcg)
> >> +{
> >> +	struct memcg_shrinker_map *map;
> >> +	int nid, size, ret = 0;
> >> +
> >> +	if (mem_cgroup_is_root(memcg))
> >> +		return 0;
> >> +
> >> +	mutex_lock(&memcg_shrinker_map_mutex);
> >> +	size = memcg_shrinker_map_size;
> >> +	for_each_node(nid) {
> >> +		map = kvzalloc(sizeof(*map) + size, GFP_KERNEL);
> >> +		if (!map) {
> > 
> >> +			memcg_free_shrinker_maps(memcg);
> > 
> > Nit: Please don't call this function under the mutex as it isn't
> > necessary. Set 'ret', break the loop, then check 'ret' after releasing
> > the mutex, and call memcg_free_shrinker_maps() if it's not 0.
> 
> No, it must be called under the mutex. See the race with memcg_expand_one_shrinker_map().
> NULL maps are not expanded, and this is the indicator we use to differ memcg, which is
> not completely online. If the allocations in memcg_alloc_shrinker_maps() fail at nid == 1,
> then freeing of nid == 0 can race with expanding.

Ah, I see, you're right.

> >> diff --git a/mm/vmscan.c b/mm/vmscan.c
> >> index 3de12a9bdf85..f09ea20d7270 100644
> >> --- a/mm/vmscan.c
> >> +++ b/mm/vmscan.c
> >> @@ -171,6 +171,7 @@ static DECLARE_RWSEM(shrinker_rwsem);
> >>  
> >>  #ifdef CONFIG_MEMCG_KMEM
> >>  static DEFINE_IDR(shrinker_idr);
> > 
> >> +static int memcg_shrinker_nr_max;
> > 
> > Nit: Please rename it to shrinker_id_max and make it store max shrinker
> > id, not the max number shrinkers that have ever been allocated. This
> > will make it easier to understand IMO.
> >
> > Also, this variable doesn't belong to this patch as you don't really
> > need it to expaned mem cgroup maps. Let's please move it to patch 3
> > (the one that introduces shrinker_idr).
> > 
> >>  
> >>  static int prealloc_memcg_shrinker(struct shrinker *shrinker)
> >>  {
> >> @@ -181,6 +182,15 @@ static int prealloc_memcg_shrinker(struct shrinker *shrinker)
> >>  	ret = id = idr_alloc(&shrinker_idr, shrinker, 0, 0, GFP_KERNEL);
> >>  	if (ret < 0)
> >>  		goto unlock;
> > 
> >> +
> >> +	if (id >= memcg_shrinker_nr_max) {
> >> +		if (memcg_expand_shrinker_maps(id + 1)) {
> >> +			idr_remove(&shrinker_idr, id);
> >> +			goto unlock;
> >> +		}
> >> +		memcg_shrinker_nr_max = id + 1;
> >> +	}
> >> +
> > 
> > Then we'll have here:
> > 
> > 	if (memcg_expaned_shrinker_maps(id)) {
> > 		idr_remove(shrinker_idr, id);
> > 		goto unlock;
> > 	}
> > 
> > and from patch 3:
> > 
> > 	shrinker_id_max = MAX(shrinker_id_max, id);
> 
> So, shrinker_id_max contains "the max number shrinkers that have ever been allocated" minus 1.
> The only difference to existing logic is "minus 1", which will be needed to reflect in
> shrink_slab_memcg()->for_each_set_bit()...
> 
> To have "minus 1" instead of "not to have minus 1" looks a little subjective.

OK, leave 'nr' then, but please consider my other comments:

 - rename memcg_shrinker_nr_max to shrinker_nr_max so that the variable
   name is consistent with shrinker_idr

 - move shrinker_nr_max to patch 3 as you don't need it for expanding
   memcg shrinker maps

 - don't use shrinker_nr_max to check whether we need to expand memcg
   maps - simply call memcg_expand_shrinker_maps() and let it decide -
   this will neatly isolate all the logic related to memcg shrinker map
   allocation in memcontrol.c

  reply	other threads:[~2018-05-21 18:40 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-05-18  8:41 [PATCH v6 00/17] Improve shrink_slab() scalability (old complexity was O(n^2), new is O(n)) Kirill Tkhai
2018-05-18  8:41 ` [PATCH v6 01/17] list_lru: Combine code under the same define Kirill Tkhai
2018-05-18  8:41 ` [PATCH v6 02/17] mm: Introduce CONFIG_MEMCG_KMEM as combination of CONFIG_MEMCG && !CONFIG_SLOB Kirill Tkhai
2018-05-18  8:42 ` [PATCH v6 03/17] mm: Assign id to every memcg-aware shrinker Kirill Tkhai
2018-05-20  7:08   ` Vladimir Davydov
2018-05-18  8:42 ` [PATCH v6 04/17] memcg: Move up for_each_mem_cgroup{, _tree} defines Kirill Tkhai
2018-05-18  8:42 ` [PATCH v6 05/17] mm: Assign memcg-aware shrinkers bitmap to memcg Kirill Tkhai
2018-05-20  7:27   ` Vladimir Davydov
2018-05-21 10:16     ` Kirill Tkhai
2018-05-21 18:40       ` Vladimir Davydov [this message]
2018-05-18  8:42 ` [PATCH v6 06/17] mm: Refactoring in workingset_init() Kirill Tkhai
2018-05-18  8:42 ` [PATCH v6 07/17] fs: Refactoring in alloc_super() Kirill Tkhai
2018-05-18  8:43 ` [PATCH v6 08/17] fs: Propagate shrinker::id to list_lru Kirill Tkhai
2018-05-18  8:43 ` [PATCH v6 09/17] list_lru: Add memcg argument to list_lru_from_kmem() Kirill Tkhai
2018-05-18  8:43 ` [PATCH v6 10/17] list_lru: Pass dst_memcg argument to memcg_drain_list_lru_node() Kirill Tkhai
2018-05-18  8:43 ` [PATCH v6 11/17] list_lru: Pass lru " Kirill Tkhai
2018-05-18  8:43 ` [PATCH v6 12/17] mm: Set bit in memcg shrinker bitmap on first list_lru item apearance Kirill Tkhai
2018-05-20  7:55   ` Vladimir Davydov
2018-05-21  9:31     ` Kirill Tkhai
2018-05-21 18:16       ` Vladimir Davydov
2018-05-18  8:43 ` [PATCH v6 13/17] mm: Export mem_cgroup_is_root() Kirill Tkhai
2018-05-20  7:57   ` Vladimir Davydov
2018-05-18  8:44 ` [PATCH v6 14/17] mm: Iterate only over charged shrinkers during memcg shrink_slab() Kirill Tkhai
2018-05-20  8:00   ` Vladimir Davydov
2018-05-21  9:17     ` Kirill Tkhai
2018-05-21 17:56       ` Vladimir Davydov
2018-05-18  8:44 ` [PATCH v6 15/17] mm: Generalize shrink_slab() calls in shrink_node() Kirill Tkhai
2018-05-20  8:08   ` Vladimir Davydov
2018-05-21  9:19     ` Kirill Tkhai
2018-05-18  8:44 ` [PATCH v6 16/17] mm: Add SHRINK_EMPTY shrinker methods return value Kirill Tkhai
2018-05-18  8:44 ` [PATCH v6 17/17] mm: Clear shrinker bit if there are no objects related to memcg Kirill Tkhai

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180521184041.5p2zyhzu45eeihmi@esperanza \
    --to=vdavydov.dev@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=aryabinin@virtuozzo.com \
    --cc=chris@chris-wilson.co.uk \
    --cc=gregkh@linuxfoundation.org \
    --cc=guro@fb.com \
    --cc=hannes@cmpxchg.org \
    --cc=jbacik@fb.com \
    --cc=ktkhai@virtuozzo.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux@roeck-us.net \
    --cc=lirongqing@baidu.com \
    --cc=longman@redhat.com \
    --cc=mgorman@techsingularity.net \
    --cc=mhocko@kernel.org \
    --cc=minchan@kernel.org \
    --cc=mka@chromium.org \
    --cc=penguin-kernel@I-love.SAKURA.ne.jp \
    --cc=pombredanne@nexb.com \
    --cc=sfr@canb.auug.org.au \
    --cc=shakeelb@google.com \
    --cc=stummala@codeaurora.org \
    --cc=tglx@linutronix.de \
    --cc=viro@zeniv.linux.org.uk \
    --cc=willy@infradead.org \
    --cc=ying.huang@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).