linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: Peter Xu <peterx@redhat.com>
To: Matthew Wilcox <willy@infradead.org>
Cc: Linus Torvalds <torvalds@linux-foundation.org>,
	Linux-MM <linux-mm@kvack.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	David Hildenbrand <david@redhat.com>,
	Hugh Dickins <hughd@google.com>, Maya Gokhale <gokhale2@llnl.gov>,
	Jerome Glisse <jglisse@redhat.com>,
	Pavel Emelyanov <xemul@virtuozzo.com>,
	Johannes Weiner <hannes@cmpxchg.org>,
	Martin Cracauer <cracauer@cons.org>,
	Marty McFadden <mcfadden8@llnl.gov>, Shaohua Li <shli@fb.com>,
	Andrea Arcangeli <aarcange@redhat.com>,
	Mike Kravetz <mike.kravetz@oracle.com>,
	Denis Plotnikov <dplotnikov@virtuozzo.com>,
	Mike Rapoport <rppt@linux.vnet.ibm.com>,
	Mel Gorman <mgorman@suse.de>,
	"Kirill A . Shutemov" <kirill@shutemov.name>,
	"Dr . David Alan Gilbert" <dgilbert@redhat.com>
Subject: Re: [PATCH v4 05/10] mm: Return faster for non-fatal signals in user mode faults
Date: Tue, 24 Sep 2019 11:19:08 +0800	[thread overview]
Message-ID: <20190924031908.GF28074@xz-x1> (raw)
In-Reply-To: <20190924025447.GE1855@bombadil.infradead.org>

On Mon, Sep 23, 2019 at 07:54:47PM -0700, Matthew Wilcox wrote:
> On Tue, Sep 24, 2019 at 10:47:21AM +0800, Peter Xu wrote:
> > On Mon, Sep 23, 2019 at 11:03:49AM -0700, Linus Torvalds wrote:
> > > On Sun, Sep 22, 2019 at 9:26 PM Peter Xu <peterx@redhat.com> wrote:
> > > >
> > > > This patch is a preparation of removing that special path by allowing
> > > > the page fault to return even faster if we were interrupted by a
> > > > non-fatal signal during a user-mode page fault handling routine.
> > > 
> > > So I really wish saome other vm person would also review these things,
> > > but looking over this series once more, this is the patch I probably
> > > like the least.
> > > 
> > > And the reason I like it the least is that I have a hard time
> > > explaining to myself what the code does and why, and why it's so full
> > > of this pattern:
> > > 
> > > > -       if ((fault & VM_FAULT_RETRY) && fatal_signal_pending(current))
> > > > +       if ((fault & VM_FAULT_RETRY) &&
> > > > +           fault_should_check_signal(user_mode(regs)))
> > > >                 return;
> > > 
> > > which isn't all that pretty.
> > > 
> > > Why isn't this just
> > > 
> > >   static bool fault_signal_pending(unsigned int fault_flags, struct
> > > pt_regs *regs)
> > >   {
> > >         return (fault_flags & VM_FAULT_RETRY) &&
> > >                 (fatal_signal_pending(current) ||
> > >                  (user_mode(regs) && signal_pending(current)));
> > >   }
> > > 
> > > and then most of the users would be something like
> > > 
> > >         if (fault_signal_pending(fault, regs))
> > >                 return;
> > > 
> > > and the exceptions could do their own thing.
> > > 
> > > Now the code is prettier and more understandable, I feel.
> > > 
> > > And if something doesn't follow this pattern, maybe it either _should_
> > > follow that pattern or it should just not use the helper but explain
> > > why it has an unusual pattern.
> 
> > +++ b/arch/alpha/mm/fault.c
> > @@ -150,7 +150,7 @@ do_page_fault(unsigned long address, unsigned long mmcsr,
> >  	   the fault.  */
> >  	fault = handle_mm_fault(vma, address, flags);
> >  
> > -	if ((fault & VM_FAULT_RETRY) && fatal_signal_pending(current))
> > +	if (fault_signal_pending(fault, regs))
> >  		return;
> >  
> >  	if (unlikely(fault & VM_FAULT_ERROR)) {
> 
> > +++ b/arch/arm/mm/fault.c
> > @@ -301,6 +301,11 @@ do_page_fault(unsigned long addr, unsigned int fsr, struct pt_regs *regs)
> >  		return 0;
> >  	}
> >  
> > +	/* Fast path to handle user mode signals */
> > +	if ((fault & VM_FAULT_RETRY) && user_mode(regs) &&
> > +	    signal_pending(current))
> > +		return 0;
> 
> But _why_ are they different?  This is a good opportunity to make more
> code the same between architectures.

(Thanks for joining the discussion)

I'd like to do these - my only worry is that I can't really test them
well simply because I don't have all the hardwares.  For now the
changes are mostly straightforward so I'm relatively confident (not to
mention the code needs proper reviews too, and of course I would
appreciate much if anyone wants to smoke test it).  If I change it in
a drastic way, I won't be that confident without some tests at least
on multiple archs (not to mention that even smoke testing across major
archs will be a huge amount of work...).  So IMHO those might be more
suitable as follow-up for per-arch developers if we can at least reach
a consensus on the whole idea of this patchset.

Thanks,

-- 
Peter Xu


  reply	other threads:[~2019-09-24  3:19 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-09-23  4:25 [PATCH v4 00/10] mm: Page fault enhancements Peter Xu
2019-09-23  4:25 ` [PATCH v4 01/10] mm/gup: Rename "nonblocking" to "locked" where proper Peter Xu
2019-09-23  4:25 ` [PATCH v4 02/10] mm/gup: Fix __get_user_pages() on fault retry of hugetlb Peter Xu
2019-09-23  4:25 ` [PATCH v4 03/10] mm: Introduce FAULT_FLAG_DEFAULT Peter Xu
2019-09-23  4:25 ` [PATCH v4 04/10] mm: Introduce FAULT_FLAG_INTERRUPTIBLE Peter Xu
2019-09-23  4:25 ` [PATCH v4 05/10] mm: Return faster for non-fatal signals in user mode faults Peter Xu
2019-09-23 18:03   ` Linus Torvalds
2019-09-24  2:47     ` Peter Xu
2019-09-24  2:54       ` Matthew Wilcox
2019-09-24  3:19         ` Peter Xu [this message]
2019-09-24 15:45           ` Matthew Wilcox
2019-09-25  3:46             ` Peter Xu
2019-09-26  8:58             ` Peter Xu
2019-10-08 22:43   ` Palmer Dabbelt
2019-10-09  7:41     ` Peter Xu
2019-09-23  4:25 ` [PATCH v4 06/10] userfaultfd: Don't retake mmap_sem to emulate NOPAGE Peter Xu
2019-09-23  4:25 ` [PATCH v4 07/10] mm: Allow VM_FAULT_RETRY for multiple times Peter Xu
2019-09-23  4:25 ` [PATCH v4 08/10] mm/gup: " Peter Xu
2019-09-23  4:25 ` [PATCH v4 09/10] mm/gup: Allow to react to fatal signals Peter Xu
2019-09-23  4:25 ` [PATCH v4 10/10] mm/userfaultfd: Honor FAULT_FLAG_KILLABLE in fault path Peter Xu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190924031908.GF28074@xz-x1 \
    --to=peterx@redhat.com \
    --cc=aarcange@redhat.com \
    --cc=cracauer@cons.org \
    --cc=david@redhat.com \
    --cc=dgilbert@redhat.com \
    --cc=dplotnikov@virtuozzo.com \
    --cc=gokhale2@llnl.gov \
    --cc=hannes@cmpxchg.org \
    --cc=hughd@google.com \
    --cc=jglisse@redhat.com \
    --cc=kirill@shutemov.name \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mcfadden8@llnl.gov \
    --cc=mgorman@suse.de \
    --cc=mike.kravetz@oracle.com \
    --cc=rppt@linux.vnet.ibm.com \
    --cc=shli@fb.com \
    --cc=torvalds@linux-foundation.org \
    --cc=willy@infradead.org \
    --cc=xemul@virtuozzo.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).