linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/3] Rename variables in mmu_notifier.c
@ 2020-01-16 16:39 Jason Gunthorpe
  2020-01-16 16:39 ` [PATCH 1/3] mm/mmu_notifier: Rename struct mmu_notifier_mm to mmu_notifier_subscriptions Jason Gunthorpe
                   ` (3 more replies)
  0 siblings, 4 replies; 5+ messages in thread
From: Jason Gunthorpe @ 2020-01-16 16:39 UTC (permalink / raw)
  To: linux-mm, Daniel Vetter, Jerome Glisse, Ralph Campbell
  Cc: linux-rdma, Jason Gunthorpe

From: Jason Gunthorpe <jgg@mellanox.com>

Linus has observed that the variable names here do not make a lot of sense,
revise them as discussed so the file has better readability.

The new names are:

  struct mmu_notifier_mm -> struct mmu_notifier_subscriptions
  mmu_notifier_mm or mmn_mm -> subscriptions
   The per mm_struct memory that holds all the notifier subscription list
   heads and interval tree

  mn -> subscription (of type struct mmu_notifier)
   A list based subscription to notifications

  mni -> interval_sub (of type struct mmu_interval_notifier)
   A VA interval based subscription to notifications

I had originaly thought to also change the struct names, and while they are
not ideal, it seems that the resulting tree wide churn is probably not
worthwhile considering the size.

This is intended to have no functional change.

Jason Gunthorpe (3):
  mm/mmu_notifier: Rename struct mmu_notifier_mm to
    mmu_notifier_subscriptions
  mm/mmu_notifiers: Use 'subscription' as the variable name for
    mmu_notifier
  mm/mmu_notifiers: Use 'interval_sub' as the variable for
    mmu_interval_notifier

 Documentation/vm/hmm.rst     |  20 +-
 include/linux/mm_types.h     |   2 +-
 include/linux/mmu_notifier.h |  86 ++---
 kernel/fork.c                |   4 +-
 mm/debug.c                   |   4 +-
 mm/mmu_notifier.c            | 585 +++++++++++++++++++----------------
 6 files changed, 375 insertions(+), 326 deletions(-)

-- 
2.24.1



^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2020-01-27 20:52 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-01-16 16:39 [PATCH 0/3] Rename variables in mmu_notifier.c Jason Gunthorpe
2020-01-16 16:39 ` [PATCH 1/3] mm/mmu_notifier: Rename struct mmu_notifier_mm to mmu_notifier_subscriptions Jason Gunthorpe
2020-01-16 16:39 ` [PATCH 2/3] mm/mmu_notifiers: Use 'subscription' as the variable name for mmu_notifier Jason Gunthorpe
2020-01-16 16:39 ` [PATCH 3/3] mm/mmu_notifiers: Use 'interval_sub' as the variable for mmu_interval_notifier Jason Gunthorpe
2020-01-27 20:52 ` [PATCH 0/3] Rename variables in mmu_notifier.c Jason Gunthorpe

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).