linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: Mike Rapoport <rppt@kernel.org>
To: Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>
Cc: Ingo Molnar <mingo@kernel.org>,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	Andi Kleen <ak@linux.intel.com>,
	Masami Hiramatsu <mhiramat@kernel.org>,
	Peter Zijlstra <peterz@infradead.org>,
	"Naveen N. Rao" <naveen.n.rao@linux.ibm.com>,
	Anil S Keshavamurthy <anil.s.keshavamurthy@intel.com>,
	"David S. Miller" <davem@davemloft.net>,
	Jessica Yu <jeyu@kernel.org>, Ard Biesheuvel <ardb@kernel.org>
Subject: Re: [PATCH v5 5/6] kprobes: Use text_alloc() and text_free()
Date: Wed, 19 Aug 2020 09:47:18 +0300	[thread overview]
Message-ID: <20200819064718.GR752365@kernel.org> (raw)
In-Reply-To: <20200818163033.GF137138@linux.intel.com>

On Tue, Aug 18, 2020 at 07:30:33PM +0300, Jarkko Sakkinen wrote:
> On Tue, Aug 18, 2020 at 02:51:41PM +0300, Mike Rapoport wrote:
> > On Tue, Aug 18, 2020 at 08:30:29AM +0300, Jarkko Sakkinen wrote:
> > > On Sun, Jul 26, 2020 at 11:14:08AM +0300, Mike Rapoport wrote:
> > > > > 
> > > > > I'm not still sure that I fully understand this feedback as I don't see
> > > > > any inherent and obvious difference to the v4. In that version fallbacks
> > > > > are to module_alloc() and module_memfree() and text_alloc() and
> > > > > text_memfree() can be overridden by arch.
> > > > 
> > > > The major difference between your v4 and my suggestion is that I'm not
> > > > trying to impose a single ARCH_HAS_TEXT_ALLOC as an alternative to
> > > > MODULES but rather to use per subsystem config option, e.g.
> > > > HAVE_KPROBES_TEXT_ALLOC.
> > > > 
> > > > Another thing, which might be worth doing regardless of the outcome of
> > > > this discussion is to rename alloc_insn_pages() to text_alloc_kprobes()
> > > > because the former is way too generic and does not emphasize that the 
> > > > instruction page is actually used by kprobes only.
> > > 
> > > What if we in kernel/kprobes.c just:
> > > 
> > > #ifndef CONFIG_ARCH_HAS_TEXT_ALLOC
> > 
> > I don't think that CONFIG_ARCH_HAS_TEXT_ALLOC will work for all
> > architectures.
> > 
> > If an architecture has different restrictions for allocation of text
> > for, say, modules, kprobes, bfp, it won't be able to use a single
> > ARCH_HAS_TEXT_ALLOC. Which means that this architecture is stuck with
> > dependency of kprobes on MODULES until the next rework.
> 
> I was thinking to name it as CONFIG_HAS_KPROBES_ALLOC_PAGE, alogn the
> lines described below, so it is merely a glitch in my example.
 
IMHO, it would be better to emphasize that this is text page. I liked
Mark's idea [1] to have text_alloc_<subsys>() naming for the allocation
functions. The Kconfig options then would become
HAVE_TEXT_ALLOC_<SUBSYS>.

[1] https://lore.kernel.org/linux-riscv/20200714133314.GA67386@C02TD0UTHF1T.local/


> > > void __weak *alloc_insn_page(void)
> > > {
> > > 	return module_alloc(PAGE_SIZE);
> > > }
> > > 
> > > void __weak free_insn_page(void *page)
> > > {
> > > 	module_memfree(page);
> > > }
> > > #endif
> > > 
> > > In Kconfig (as in v5):
> > > 
> > > config KPROBES
> > > 	bool "Kprobes"
> > > 	depends on MODULES || ARCH_HAS_TEXT_ALLOC
> > > 
> > > I checked architectures that override alloc_insn_page(). With the
> > > exception of x86, they do not call module_alloc().
> > > 
> > > If no rename was done, then with this approach a more consistent.
> > > config flag name would be CONFIG_ARCH_HAS_ALLOC_INSN_PAGE.
> > > 
> > > I'd call the function just as kprobes_alloc_page(). Then the
> > > config flag would become CONFIG_HAS_KPROBES_ALLOC_PAGE.
> > > 
> > > > -- 
> > > > Sincerely yours,
> > > > Mike.
> > > 
> > > Thanks for the feedback!
> > > 
> > > /Jarkko
> > 
> 
> > -- 
> > Sincerely yours,
> > Mike.
> 
> BR,
> /Jarkko

-- 
Sincerely yours,
Mike.


  reply	other threads:[~2020-08-19  6:47 UTC|newest]

Thread overview: 45+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-24  5:05 [PATCH v5 0/6] arch/x86: kprobes: Remove MODULES dependency Jarkko Sakkinen
2020-07-24  5:05 ` [PATCH v5 1/6] kprobes: Remove dependency to the module_mutex Jarkko Sakkinen
2020-07-24  9:13   ` Ingo Molnar
2020-07-25  2:36     ` Jarkko Sakkinen
2020-07-24  9:17   ` Ingo Molnar
2020-07-25  3:01     ` Jarkko Sakkinen
2020-07-25 10:21       ` Ingo Molnar
2020-07-28  7:34         ` Masami Hiramatsu
2020-08-17 21:22           ` Jarkko Sakkinen
2020-07-24 10:22   ` Mike Rapoport
2020-07-25  2:42     ` Jarkko Sakkinen
2020-07-24 14:46   ` Masami Hiramatsu
2020-07-25  2:48     ` Jarkko Sakkinen
2020-07-24  5:05 ` [PATCH v5 2/6] vmalloc: Add text_alloc() and text_free() Jarkko Sakkinen
2020-07-24 10:22   ` Mike Rapoport
2020-07-25  2:20     ` Jarkko Sakkinen
2020-07-24  5:05 ` [PATCH v5 3/6] arch/x86: Implement " Jarkko Sakkinen
2020-07-24  9:22   ` Ingo Molnar
2020-07-25  2:03     ` Jarkko Sakkinen
2020-07-24  5:05 ` [PATCH v5 4/6] arch/x86: kprobes: Use " Jarkko Sakkinen
2020-07-24  5:05 ` [PATCH v5 5/6] " Jarkko Sakkinen
2020-07-24  9:27   ` Ingo Molnar
2020-07-24 12:16     ` Ard Biesheuvel
2020-07-25  3:19       ` [PATCH v5 5/6] kprobes: Use text_alloc() and text_free()] Jarkko Sakkinen
2020-07-25  3:16     ` [PATCH v5 5/6] kprobes: Use text_alloc() and text_free() Jarkko Sakkinen
2020-07-26  8:14       ` Mike Rapoport
2020-07-26 16:06         ` Ard Biesheuvel
2020-07-28  8:17           ` Masami Hiramatsu
2020-07-28 10:56             ` Ard Biesheuvel
2020-07-28 13:35               ` Masami Hiramatsu
2020-07-28 17:51                 ` Ard Biesheuvel
2020-07-29  1:50                   ` Masami Hiramatsu
2020-07-29  6:13                     ` Ard Biesheuvel
2020-07-30  1:09                       ` Masami Hiramatsu
2020-08-18  5:30         ` Jarkko Sakkinen
2020-08-18 11:51           ` Mike Rapoport
2020-08-18 16:30             ` Jarkko Sakkinen
2020-08-19  6:47               ` Mike Rapoport [this message]
2020-08-19 21:07                 ` Jarkko Sakkinen
2020-07-24 10:27   ` Mike Rapoport
2020-07-24 14:57     ` Masami Hiramatsu
2020-07-24 23:38     ` Jarkko Sakkinen
2020-07-24  5:05 ` [PATCH v5 6/6] kprobes: Remove CONFIG_MODULES dependency Jarkko Sakkinen
2020-07-24  7:01 ` [PATCH v5 0/6] arch/x86: kprobes: Remove MODULES dependency Jarkko Sakkinen
2020-07-24 10:26 ` Mike Rapoport

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200819064718.GR752365@kernel.org \
    --to=rppt@kernel.org \
    --cc=ak@linux.intel.com \
    --cc=anil.s.keshavamurthy@intel.com \
    --cc=ardb@kernel.org \
    --cc=davem@davemloft.net \
    --cc=jarkko.sakkinen@linux.intel.com \
    --cc=jeyu@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mhiramat@kernel.org \
    --cc=mingo@kernel.org \
    --cc=naveen.n.rao@linux.ibm.com \
    --cc=peterz@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).