linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: Johannes Weiner <hannes@cmpxchg.org>
To: Matthew Wilcox <willy@infradead.org>
Cc: linux-mm@kvack.org, Andrew Morton <akpm@linux-foundation.org>,
	Hugh Dickins <hughd@google.com>,
	William Kucharski <william.kucharski@oracle.com>,
	Jani Nikula <jani.nikula@linux.intel.com>,
	Alexey Dobriyan <adobriyan@gmail.com>,
	Chris Wilson <chris@chris-wilson.co.uk>,
	Matthew Auld <matthew.auld@intel.com>,
	Huang Ying <ying.huang@intel.com>,
	intel-gfx@lists.freedesktop.org, cgroups@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/8] mm: Use find_get_swap_page in memcontrol
Date: Wed, 26 Aug 2020 12:26:47 -0400	[thread overview]
Message-ID: <20200826162647.GA995045@cmpxchg.org> (raw)
In-Reply-To: <20200826145414.GS17456@casper.infradead.org>

On Wed, Aug 26, 2020 at 03:54:14PM +0100, Matthew Wilcox wrote:
> On Wed, Aug 26, 2020 at 10:20:02AM -0400, Johannes Weiner wrote:
> > On Wed, Aug 19, 2020 at 07:48:44PM +0100, Matthew Wilcox (Oracle) wrote:
> > > +	return find_get_swap_page(vma->vm_file->f_mapping,
> > > +			linear_page_index(vma, addr));
> > 
> > The refactor makes sense to me, but the name is confusing. We're not
> > looking for a swap page, we're primarily looking for a file page in
> > the page cache mapping that's handed in. Only in the special case
> > where it's a shmem mapping and there is a swap entry do we consult the
> > auxiliary swap cache.
> > 
> > How about find_get_page_or_swapcache()? find_get_page_shmemswap()?
> > Maybe you have a better idea. It's a fairly specialized operation that
> > isn't widely used, so a longer name isn't a bad thing IMO.
> 
> Yeah, I had trouble with the naming here too.
> 
> get_page_even_from_swap()
> find_get_shmem_page()
> 
> or maybe refactor the whole thing:
> 
> 	struct page *page = find_get_entry(mapping, index);
> 	page = find_swap_page(mapping, page);
> 
> struct page *find_swap_page(struct address_space *mapping, struct page *page)
> {
> 	swp_entry_t swp;
> 	struct swap_info_struct *si;
> 
> 	if (!xa_is_value(page))
> 		return page;
> 	if (!shmem_mapping(mapping))
> 		return NULL;
> 
> 	...
> }

Yeah, I like the idea of two lookups if we can't find a good name for
the operation that combines them. I'd just bubble the control flow
that links them up to the callsite - that still seems plenty compact
for two callsites, and keeps all the shmem magic in shmem code:

	page = find_get_entry(mapping, index);
	if (xa_is_value(page))
		if (shmem_mapping(mapping))
			page = lookup_shmem_swap_cache(page);
		else
			page = NULL;

So close to making radix_to_swp_entry() & co. private to shmem.c, too
- if it weren't for force_shm_swapin_readahead(). Ah well.


  reply	other threads:[~2020-08-26 16:28 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-08-19 18:48 [PATCH 0/8] Return head pages from find_get_entry and find_lock_entry Matthew Wilcox (Oracle)
2020-08-19 18:48 ` [PATCH 1/8] mm: Factor find_get_swap_page out of mincore_page Matthew Wilcox (Oracle)
2020-08-19 19:21   ` Matthew Wilcox
2020-08-19 18:48 ` [PATCH 2/8] mm: Use find_get_swap_page in memcontrol Matthew Wilcox (Oracle)
2020-08-26 14:20   ` Johannes Weiner
2020-08-26 14:54     ` Matthew Wilcox
2020-08-26 16:26       ` Johannes Weiner [this message]
2020-08-27 12:59     ` Matthew Wilcox
2020-08-27 14:22       ` Johannes Weiner
2020-08-19 18:48 ` [PATCH 3/8] mm: Optimise madvise WILLNEED Matthew Wilcox (Oracle)
2020-08-26 14:23   ` Johannes Weiner
2020-08-19 18:48 ` [PATCH 4/8] proc: Optimise smaps for shmem entries Matthew Wilcox (Oracle)
2020-08-26 14:24   ` Johannes Weiner
2020-08-19 18:48 ` [PATCH 5/8] i915: Use find_lock_page instead of find_lock_entry Matthew Wilcox (Oracle)
2020-08-26 14:27   ` Johannes Weiner
2020-08-19 18:48 ` [PATCH 6/8] mm: Convert find_get_entry to return the head page Matthew Wilcox (Oracle)
2020-08-26 15:09   ` Johannes Weiner
2020-08-26 15:48     ` Matthew Wilcox
2020-08-19 18:48 ` [PATCH 7/8] mm: Return head page from find_lock_entry Matthew Wilcox (Oracle)
2020-08-19 18:48 ` [PATCH 8/8] mm: Hoist find_subpage call further up in pagecache_get_page Matthew Wilcox (Oracle)
2020-08-21 17:37 ` [PATCH 0/8] Return head pages from find_get_entry and find_lock_entry William Kucharski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200826162647.GA995045@cmpxchg.org \
    --to=hannes@cmpxchg.org \
    --cc=adobriyan@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=cgroups@vger.kernel.org \
    --cc=chris@chris-wilson.co.uk \
    --cc=hughd@google.com \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=jani.nikula@linux.intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=matthew.auld@intel.com \
    --cc=william.kucharski@oracle.com \
    --cc=willy@infradead.org \
    --cc=ying.huang@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).