linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v4 0/4] mm/gup: page unpining improvements
@ 2021-02-12 13:08 Joao Martins
  2021-02-12 13:08 ` [PATCH v4 1/4] mm/gup: add compound page list iterator Joao Martins
                   ` (4 more replies)
  0 siblings, 5 replies; 9+ messages in thread
From: Joao Martins @ 2021-02-12 13:08 UTC (permalink / raw)
  To: linux-mm
  Cc: linux-kernel, linux-rdma, Andrew Morton, Jason Gunthorpe,
	Doug Ledford, John Hubbard, Matthew Wilcox, Joao Martins

Hey,

This series improves page unpinning, with an eye on improving MR
deregistration for big swaths of memory (which is bound by the page
unpining), particularly:

 1) Decrement the head page by @ntails and thus reducing a lot the number of
atomic operations per compound page. This is done by comparing individual
tail pages heads, and counting number of consecutive tails on which they 
match heads and based on that update head page refcount. Should have a
visible improvement in all page (un)pinners which use compound pages

 2) Introducing a new API for unpinning page ranges (to avoid the trick in the
previous item and be based on math), and use that in RDMA ib_mem_release
(used for mr deregistration).

Performance improvements: unpin_user_pages() for hugetlbfs and THP improves ~3x
(through gup_test) and RDMA MR dereg improves ~4.5x with the new API.
See patches 2 and 4 for those.

These patches used to be in this RFC:

https://lore.kernel.org/linux-mm/20201208172901.17384-1-joao.m.martins@oracle.com/,
"[PATCH RFC 0/9] mm, sparse-vmemmap: Introduce compound pagemaps"

But were moved separately at the suggestion of Jason, given it's applicable
to page unpinning in general. Thanks Jason and John for all the comments.

These patches apply on top of linux-next tag next-20210202.

Suggestions, comments, welcomed as usual.

	Joao

Changelog since,

v3 -> v4:
 * Add the Reviewed-by/Acked-by by Jason on all patches.
 * Add the Reviewed-by by John on the third patch.
 * Fix the wrong mention to get_user_pages()  in
 unpin_user_page_range_dirty_lock()  docs (third patch).

v2 -> v3:
 * Handle compound_order = 1 as well and move subtraction to min_t()
   on patch 3.
 * Remove stale paragraph on patch 3 commit description (John)
 * Rename range_next to compound_range_next() (John)
 * Add John's Reviewed-by on patch 1 (John)
 * Clean and rework compound_next() on patch 1 (John)

v1 -> v2:
 * Prefix macro arguments with __ to avoid collisions with other defines (John)
 * Remove count_tails() and have the logic for the two iterators split into
   range_next() and compound_next() (John)
 * Remove the @range boolean from the iterator helpers (John)
 * Add docs on unpin_user_page_range_dirty_lock() on patch 3 (John)
 * Use unsigned for @i on patch 4 (John)
 * Fix subject line of patch 4 (John)
 * Add John's Reviewed-by on the second patch
 * Fix incorrect use of @nmap and use @sg_nents instead (Jason)

RFC -> v1:
 * Introduce a head/ntails iterator and change unpin_*_pages() to use that,
   inspired by folio iterators (Jason)
 * Introduce an alternative unpin_user_page_range_dirty_lock() to unpin based
   on a consecutive page range without having to walk page arrays (Jason)
 * Use unsigned for number of tails (Jason)


Joao Martins (4):
  mm/gup: add compound page list iterator
  mm/gup: decrement head page once for group of subpages
  mm/gup: add a range variant of unpin_user_pages_dirty_lock()
  RDMA/umem: batch page unpin in __ib_umem_release()

 drivers/infiniband/core/umem.c |  12 ++--
 include/linux/mm.h             |   2 +
 mm/gup.c                       | 117 ++++++++++++++++++++++++++++-----
 3 files changed, 107 insertions(+), 24 deletions(-)

-- 
2.17.1



^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2021-02-22  7:53 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-02-12 13:08 [PATCH v4 0/4] mm/gup: page unpining improvements Joao Martins
2021-02-12 13:08 ` [PATCH v4 1/4] mm/gup: add compound page list iterator Joao Martins
2021-02-12 13:08 ` [PATCH v4 2/4] mm/gup: decrement head page once for group of subpages Joao Martins
2021-02-12 13:08 ` [PATCH v4 3/4] mm/gup: add a range variant of unpin_user_pages_dirty_lock() Joao Martins
2021-02-12 13:08 ` [PATCH v4 4/4] RDMA/umem: batch page unpin in __ib_umem_release() Joao Martins
2021-02-18  7:24 ` [PATCH v4 0/4] mm/gup: page unpining improvements Christoph Hellwig
2021-02-18 15:33   ` Joao Martins
2021-02-18 16:01     ` Joao Martins
2021-02-22  7:52     ` Christoph Hellwig

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).