linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: David Hildenbrand <david@redhat.com>
To: Pingfan Liu <kernelfans@gmail.com>, linux-mm@kvack.org
Cc: Dan Williams <dan.j.williams@intel.com>,
	Michal Hocko <mhocko@kernel.org>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	Leonardo Bras <leonardo@linux.ibm.com>,
	Nathan Fontenot <nfont@linux.vnet.ibm.com>,
	Nathan Lynch <nathanl@linux.ibm.com>
Subject: Re: [PATCHv2] mm/sparse: rename pfn_present() as pfn_in_present_section()
Date: Mon, 17 Feb 2020 11:01:07 +0100	[thread overview]
Message-ID: <2acc2c48-4b91-d796-0038-00b4cca7600a@redhat.com> (raw)
In-Reply-To: <1581919110-29575-1-git-send-email-kernelfans@gmail.com>

On 17.02.20 06:58, Pingfan Liu wrote:
> After introducing mem sub section concept, pfn_present() loses its literal
> meaning, and will not be necessary a truth on partial populated mem section.
> 
> Since all of the callers use it to judge an absent section, it is better to
> rename pfn_present() as pfn_in_present_section().
> 
> Signed-off-by: Pingfan Liu <kernelfans@gmail.com>
> Cc: Dan Williams <dan.j.williams@intel.com>
> Cc: Michal Hocko <mhocko@kernel.org>
> Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>
> Cc: Paul Mackerras <paulus@samba.org>
> Cc: Michael Ellerman <mpe@ellerman.id.au>
> Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
> Cc: "Rafael J. Wysocki" <rafael@kernel.org>
> Cc: Andrew Morton <akpm@linux-foundation.org>
> Cc: David Hildenbrand <david@redhat.com>
> Cc: Leonardo Bras <leonardo@linux.ibm.com>
> Cc: Nathan Fontenot <nfont@linux.vnet.ibm.com>
> Cc: Nathan Lynch <nathanl@linux.ibm.com>
> To: linux-mm@kvack.org
> ---
> v1 -> v2: adopt David's suggestion, rename it as pfn_in_present_section()
>  arch/powerpc/platforms/pseries/hotplug-memory.c | 2 +-
>  drivers/base/node.c                             | 2 +-
>  include/linux/mmzone.h                          | 4 ++--
>  mm/page_ext.c                                   | 2 +-
>  mm/shuffle.c                                    | 2 +-
>  5 files changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/arch/powerpc/platforms/pseries/hotplug-memory.c b/arch/powerpc/platforms/pseries/hotplug-memory.c
> index a4d40a3..f3ed1ba 100644
> --- a/arch/powerpc/platforms/pseries/hotplug-memory.c
> +++ b/arch/powerpc/platforms/pseries/hotplug-memory.c
> @@ -360,7 +360,7 @@ static bool lmb_is_removable(struct drmem_lmb *lmb)
>  
>  	for (i = 0; i < scns_per_block; i++) {
>  		pfn = PFN_DOWN(phys_addr);
> -		if (!pfn_present(pfn)) {
> +		if (!pfn_in_present_section(pfn)) {
>  			phys_addr += MIN_MEMORY_BLOCK_SIZE;
>  			continue;
>  		}
> diff --git a/drivers/base/node.c b/drivers/base/node.c
> index 98a31ba..10d7e81 100644
> --- a/drivers/base/node.c
> +++ b/drivers/base/node.c
> @@ -772,7 +772,7 @@ static int register_mem_sect_under_node(struct memory_block *mem_blk,
>  		 * memory block could have several absent sections from start.
>  		 * skip pfn range from absent section
>  		 */
> -		if (!pfn_present(pfn)) {
> +		if (!pfn_in_present_section(pfn)) {
>  			pfn = round_down(pfn + PAGES_PER_SECTION,
>  					 PAGES_PER_SECTION) - 1;
>  			continue;
> diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
> index 462f687..f6ceebdb 100644
> --- a/include/linux/mmzone.h
> +++ b/include/linux/mmzone.h
> @@ -1372,7 +1372,7 @@ static inline int pfn_valid(unsigned long pfn)
>  }
>  #endif
>  
> -static inline int pfn_present(unsigned long pfn)
> +static inline int pfn_in_present_section(unsigned long pfn)
>  {
>  	if (pfn_to_section_nr(pfn) >= NR_MEM_SECTIONS)
>  		return 0;
> @@ -1409,7 +1409,7 @@ void sparse_init(void);
>  #else
>  #define sparse_init()	do {} while (0)
>  #define sparse_index_init(_sec, _nid)  do {} while (0)
> -#define pfn_present pfn_valid
> +#define pfn_in_present_section pfn_valid
>  #define subsection_map_init(_pfn, _nr_pages) do {} while (0)
>  #endif /* CONFIG_SPARSEMEM */
>  
> diff --git a/mm/page_ext.c b/mm/page_ext.c
> index 4ade843..08ded03 100644
> --- a/mm/page_ext.c
> +++ b/mm/page_ext.c
> @@ -304,7 +304,7 @@ static int __meminit online_page_ext(unsigned long start_pfn,
>  	}
>  
>  	for (pfn = start; !fail && pfn < end; pfn += PAGES_PER_SECTION) {
> -		if (!pfn_present(pfn))
> +		if (!pfn_in_present_section(pfn))
>  			continue;

This check should be gone in -next already.


Reviewed-by: David Hildenbrand <david@redhat.com>


-- 
Thanks,

David / dhildenb



  reply	other threads:[~2020-02-17 10:01 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-02-15  6:17 [PATCH] mm/sparse: rename pfn_present() as pfn_to_section_present() Pingfan Liu
2020-02-15 12:59 ` David Hildenbrand
2020-02-17  3:22   ` Pingfan Liu
2020-02-17  5:58     ` [PATCHv2] mm/sparse: rename pfn_present() as pfn_in_present_section() Pingfan Liu
2020-02-17 10:01       ` David Hildenbrand [this message]
2020-02-18 11:34       ` Michael Ellerman

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2acc2c48-4b91-d796-0038-00b4cca7600a@redhat.com \
    --to=david@redhat.com \
    --cc=akpm@linux-foundation.org \
    --cc=benh@kernel.crashing.org \
    --cc=dan.j.williams@intel.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=kernelfans@gmail.com \
    --cc=leonardo@linux.ibm.com \
    --cc=linux-mm@kvack.org \
    --cc=mhocko@kernel.org \
    --cc=mpe@ellerman.id.au \
    --cc=nathanl@linux.ibm.com \
    --cc=nfont@linux.vnet.ibm.com \
    --cc=paulus@samba.org \
    --cc=rafael@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).