linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: Waiman Long <longman@redhat.com>
To: Shakeel Butt <shakeelb@google.com>
Cc: Johannes Weiner <hannes@cmpxchg.org>,
	Michal Hocko <mhocko@kernel.org>,
	Vladimir Davydov <vdavydov.dev@gmail.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Tejun Heo <tj@kernel.org>, LKML <linux-kernel@vger.kernel.org>,
	Cgroups <cgroups@vger.kernel.org>, Linux MM <linux-mm@kvack.org>,
	Chris Down <chris@chrisdown.name>, Roman Gushchin <guro@fb.com>,
	Yafang Shao <laoar.shao@gmail.com>
Subject: Re: [PATCH 2/3] mm/memcg: Simplify mem_cgroup_get_max()
Date: Sun, 13 Sep 2020 20:49:01 -0400	[thread overview]
Message-ID: <73bab001-b819-1e6d-e130-c52ae2206f19@redhat.com> (raw)
In-Reply-To: <CALvZod6GARMuO8YzMp-1FZaasSZJ8t2b9dUu5tXUcDeuHxA6KA@mail.gmail.com>

On 8/20/20 5:25 PM, Shakeel Butt wrote:
> On Thu, Aug 20, 2020 at 1:29 PM Waiman Long <longman@redhat.com> wrote:
>> On 8/20/20 1:35 PM, Johannes Weiner wrote:
>>> On Thu, Aug 20, 2020 at 09:03:49AM -0400, Waiman Long wrote:
>>>> The mem_cgroup_get_max() function used to get memory+swap max from
>>>> both the v1 memsw and v2 memory+swap page counters & return the maximum
>>>> of these 2 values. This is redundant and it is more efficient to just
>>>> get either the v1 or the v2 values depending on which one is currently
>>>> in use.
>>>>
>>>> Signed-off-by: Waiman Long <longman@redhat.com>
>>>> ---
>>>>    mm/memcontrol.c | 14 +++++---------
>>>>    1 file changed, 5 insertions(+), 9 deletions(-)
>>>>
>>>> diff --git a/mm/memcontrol.c b/mm/memcontrol.c
>>>> index 26b7a48d3afb..d219dca5239f 100644
>>>> --- a/mm/memcontrol.c
>>>> +++ b/mm/memcontrol.c
>>>> @@ -1633,17 +1633,13 @@ void mem_cgroup_print_oom_meminfo(struct mem_cgroup *memcg)
>>>>     */
>>>>    unsigned long mem_cgroup_get_max(struct mem_cgroup *memcg)
>>>>    {
>>>> -    unsigned long max;
>>>> +    unsigned long max = READ_ONCE(memcg->memory.max);
>>>>
>>>> -    max = READ_ONCE(memcg->memory.max);
>>>>       if (mem_cgroup_swappiness(memcg)) {
>>>> -            unsigned long memsw_max;
>>>> -            unsigned long swap_max;
>>>> -
>>>> -            memsw_max = memcg->memsw.max;
>>>> -            swap_max = READ_ONCE(memcg->swap.max);
>>>> -            swap_max = min(swap_max, (unsigned long)total_swap_pages);
>>>> -            max = min(max + swap_max, memsw_max);
>>>> +            if (cgroup_subsys_on_dfl(memory_cgrp_subsys))
>>>> +                    max += READ_ONCE(memcg->swap.max);
>>>> +            else
>>>> +                    max = memcg->memsw.max;
>>> I agree with the premise of the patch, but v1 and v2 have sufficiently
>>> different logic, and the way v1 overrides max from the innermost
>>> branch again also doesn't help in understanding what's going on.
>>>
>>> Can you please split out the v1 and v2 code?
>>>
>>>        if (cgroup_subsys_on_dfl(memory_cgrp_subsys)) {
>>>                max = READ_ONCE(memcg->memory.max);
>>>                if (mem_cgroup_swappiness(memcg))
>>>                        max += READ_ONCE(memcg->swap.max);
>>>        } else {
>>>                if (mem_cgroup_swappiness(memcg))
>>>                        max = memcg->memsw.max;
>>>                else
>>>                        max = READ_ONCE(memcg->memory.max);
>>>        }
>>>
>>> It's slightly repetitive, but IMO much more readable.
>>>
>> Sure. That makes it even better.
>>
> Can you please also add in the commit message why it is ok to drop
> total_swap_pages comparison from mem_cgroup_get_max()?
>
My bad. I accidentally skipped the total_swap_pages check. Will add it 
back in v2.

Cheers,
Longman



  reply	other threads:[~2020-09-14  0:49 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-08-20 13:03 [PATCH 0/3] mm/memcg: Miscellaneous cleanups and streamlining Waiman Long
2020-08-20 13:03 ` [PATCH 1/3] mm/memcg: Clean up obsolete enum charge_type Waiman Long
2020-08-20 17:27   ` Johannes Weiner
2020-08-20 21:16   ` Shakeel Butt
2020-08-20 13:03 ` [PATCH 2/3] mm/memcg: Simplify mem_cgroup_get_max() Waiman Long
2020-08-20 17:35   ` Johannes Weiner
2020-08-20 20:29     ` Waiman Long
2020-08-20 21:25       ` Shakeel Butt
2020-09-14  0:49         ` Waiman Long [this message]
2020-08-20 13:03 ` [PATCH 3/3] mm/memcg: Unify swap and memsw page counters Waiman Long
2020-08-20 15:46   ` Shakeel Butt
2020-08-24 16:02     ` Waiman Long

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=73bab001-b819-1e6d-e130-c52ae2206f19@redhat.com \
    --to=longman@redhat.com \
    --cc=akpm@linux-foundation.org \
    --cc=cgroups@vger.kernel.org \
    --cc=chris@chrisdown.name \
    --cc=guro@fb.com \
    --cc=hannes@cmpxchg.org \
    --cc=laoar.shao@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mhocko@kernel.org \
    --cc=shakeelb@google.com \
    --cc=tj@kernel.org \
    --cc=vdavydov.dev@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).