linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: Kirill Tkhai <ktkhai@virtuozzo.com>
To: Yang Shi <shy828301@gmail.com>,
	guro@fb.com, shakeelb@google.com, david@fromorbit.com,
	hannes@cmpxchg.org, mhocko@suse.com, akpm@linux-foundation.org
Cc: linux-mm@kvack.org, linux-fsdevel@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [v3 PATCH 04/11] mm: vmscan: remove memcg_shrinker_map_size
Date: Wed, 6 Jan 2021 13:15:13 +0300	[thread overview]
Message-ID: <955422c5-0703-e9fb-f309-6ed6b5fc0e0a@virtuozzo.com> (raw)
In-Reply-To: <20210105225817.1036378-5-shy828301@gmail.com>

On 06.01.2021 01:58, Yang Shi wrote:
> Both memcg_shrinker_map_size and shrinker_nr_max is maintained, but actually the
> map size can be calculated via shrinker_nr_max, so it seems unnecessary to keep both.
> Remove memcg_shrinker_map_size since shrinker_nr_max is also used by iterating the
> bit map.
> 
> Signed-off-by: Yang Shi <shy828301@gmail.com>
> ---
>  mm/vmscan.c | 12 ++++--------
>  1 file changed, 4 insertions(+), 8 deletions(-)
> 
> diff --git a/mm/vmscan.c b/mm/vmscan.c
> index ddb9f972f856..8da765a85569 100644
> --- a/mm/vmscan.c
> +++ b/mm/vmscan.c
> @@ -185,8 +185,7 @@ static LIST_HEAD(shrinker_list);
>  static DECLARE_RWSEM(shrinker_rwsem);
>  
>  #ifdef CONFIG_MEMCG
> -
> -static int memcg_shrinker_map_size;
> +static int shrinker_nr_max;
>  
>  static void memcg_free_shrinker_map_rcu(struct rcu_head *head)
>  {
> @@ -248,7 +247,7 @@ int memcg_alloc_shrinker_maps(struct mem_cgroup *memcg)
>  		return 0;
>  
>  	down_read(&shrinker_rwsem);
> -	size = memcg_shrinker_map_size;
> +	size = DIV_ROUND_UP(shrinker_nr_max, BITS_PER_LONG) * sizeof(unsigned long);
>  	for_each_node(nid) {
>  		map = kvzalloc(sizeof(*map) + size, GFP_KERNEL);
>  		if (!map) {
> @@ -269,7 +268,7 @@ static int memcg_expand_shrinker_maps(int new_id)
>  	struct mem_cgroup *memcg;
>  
>  	size = DIV_ROUND_UP(new_id + 1, BITS_PER_LONG) * sizeof(unsigned long);
> -	old_size = memcg_shrinker_map_size;
> +	old_size = DIV_ROUND_UP(shrinker_nr_max, BITS_PER_LONG) * sizeof(unsigned long);
>  	if (size <= old_size)
>  		return 0;

These bunch of DIV_ROUND_UP() looks too complex. Since now all the shrinker maps allocation
logic in the only file, can't we simplify this to look better? I mean something like below
to merge in your patch:

diff --git a/mm/vmscan.c b/mm/vmscan.c
index b951c289ef3a..27b6371a1656 100644
--- a/mm/vmscan.c
+++ b/mm/vmscan.c
@@ -247,7 +247,7 @@ int memcg_alloc_shrinker_maps(struct mem_cgroup *memcg)
 		return 0;
 
 	down_read(&shrinker_rwsem);
-	size = DIV_ROUND_UP(shrinker_nr_max, BITS_PER_LONG) * sizeof(unsigned long);
+	size = shrinker_nr_max / BITS_PER_BYTE;
 	for_each_node(nid) {
 		map = kvzalloc(sizeof(*map) + size, GFP_KERNEL);
 		if (!map) {
@@ -264,13 +264,11 @@ int memcg_alloc_shrinker_maps(struct mem_cgroup *memcg)
 
 static int memcg_expand_shrinker_maps(int new_id)
 {
-	int size, old_size, ret = 0;
+	int size, old_size, new_nr_max, ret = 0;
 	struct mem_cgroup *memcg;
 
 	size = DIV_ROUND_UP(new_id + 1, BITS_PER_LONG) * sizeof(unsigned long);
-	old_size = DIV_ROUND_UP(shrinker_nr_max, BITS_PER_LONG) * sizeof(unsigned long);
-	if (size <= old_size)
-		return 0;
+	new_nr_max = size * BITS_PER_BYTE;
 
 	if (!root_mem_cgroup)
 		goto out;
@@ -287,6 +285,9 @@ static int memcg_expand_shrinker_maps(int new_id)
 	} while ((memcg = mem_cgroup_iter(NULL, memcg, NULL)) != NULL);
 
 out:
+	if (ret == 0)
+		shrinker_nr_max = new_nr_max;
+
 	return ret;
 }
 
@@ -334,8 +335,6 @@ static int prealloc_memcg_shrinker(struct shrinker *shrinker)
 			idr_remove(&shrinker_idr, id);
 			goto unlock;
 		}
-
-		shrinker_nr_max = id + 1;
 	}
 	shrinker->id = id;
 	ret = 0;


  reply	other threads:[~2021-01-06 10:16 UTC|newest]

Thread overview: 43+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-01-05 22:58 [RFC v3 PATCH 0/11] Make shrinker's nr_deferred memcg aware Yang Shi
2021-01-05 22:58 ` [v3 PATCH 01/11] mm: vmscan: use nid from shrink_control for tracepoint Yang Shi
2021-01-05 22:58 ` [v3 PATCH 02/11] mm: vmscan: consolidate shrinker_maps handling code Yang Shi
2021-01-07  0:13   ` Roman Gushchin
2021-01-07 17:29     ` Yang Shi
2021-01-11 19:00     ` Yang Shi
2021-01-11 19:37       ` Roman Gushchin
2021-01-11 19:43         ` Yang Shi
2021-01-05 22:58 ` [v3 PATCH 03/11] mm: vmscan: use shrinker_rwsem to protect shrinker_maps allocation Yang Shi
2021-01-06  9:54   ` Kirill Tkhai
2021-01-11 17:08     ` Yang Shi
2021-01-11 17:33       ` Kirill Tkhai
2021-01-11 18:57         ` Yang Shi
2021-01-11 21:33           ` Kirill Tkhai
2021-01-12 21:23             ` Yang Shi
2021-01-13 18:16               ` Yang Shi
2021-01-05 22:58 ` [v3 PATCH 04/11] mm: vmscan: remove memcg_shrinker_map_size Yang Shi
2021-01-06 10:15   ` Kirill Tkhai [this message]
2021-01-11 17:44     ` Yang Shi
2021-01-13 23:48     ` Yang Shi
2021-01-05 22:58 ` [v3 PATCH 05/11] mm: vmscan: use a new flag to indicate shrinker is registered Yang Shi
2021-01-06 10:21   ` Kirill Tkhai
2021-01-11 18:17     ` Yang Shi
2021-01-11 21:37       ` Kirill Tkhai
2021-01-12 20:58         ` Yang Shi
2021-01-05 22:58 ` [v3 PATCH 06/11] mm: memcontrol: rename shrinker_map to shrinker_info Yang Shi
2021-01-06 11:38   ` Kirill Tkhai
2021-01-11 18:19     ` Yang Shi
2021-01-05 22:58 ` [v3 PATCH 07/11] mm: vmscan: add per memcg shrinker nr_deferred Yang Shi
2021-01-06 11:06   ` Kirill Tkhai
2021-01-11 18:24     ` Yang Shi
2021-01-13 23:30     ` Yang Shi
2021-01-05 22:58 ` [v3 PATCH 08/11] mm: vmscan: use per memcg nr_deferred of shrinker Yang Shi
2021-01-07  0:17   ` Roman Gushchin
2021-01-07 17:34     ` Yang Shi
2021-01-05 22:58 ` [v3 PATCH 09/11] mm: vmscan: don't need allocate shrinker->nr_deferred for memcg aware shrinkers Yang Shi
2021-01-06 11:15   ` Kirill Tkhai
2021-01-11 18:40     ` Yang Shi
2021-01-11 21:57       ` Kirill Tkhai
2021-01-05 22:58 ` [v3 PATCH 10/11] mm: memcontrol: reparent nr_deferred when memcg offline Yang Shi
2021-01-06 11:34   ` Kirill Tkhai
2021-01-11 18:43     ` Yang Shi
2021-01-05 22:58 ` [v3 PATCH 11/11] mm: vmscan: shrink deferred objects proportional to priority Yang Shi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=955422c5-0703-e9fb-f309-6ed6b5fc0e0a@virtuozzo.com \
    --to=ktkhai@virtuozzo.com \
    --cc=akpm@linux-foundation.org \
    --cc=david@fromorbit.com \
    --cc=guro@fb.com \
    --cc=hannes@cmpxchg.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mhocko@suse.com \
    --cc=shakeelb@google.com \
    --cc=shy828301@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).