linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
 messages from 2017-05-15 12:12:31 to 2017-05-17 15:51:16 UTC [more...]

[PATCH v3 0/4] Zeroing hash tables in allocator
 2017-05-17 15:51 UTC  (4+ messages)
` [PATCH v3 4/4] mm: Adaptive hash table scaling

[PATCH] Correct spelling and grammar for notification text
 2017-05-17 15:35 UTC  (2+ messages)

[RFC 0/6] cpuset/mempolicies related fixes and cleanups
 2017-05-17 15:27 UTC  (16+ messages)
` [RFC 1/6] mm, page_alloc: fix more premature OOM due to race with cpuset update

[PATCH] mm,oom: fix oom invocation issues
 2017-05-17 15:26 UTC 

[PATCH v2 0/6] cpuset/mempolicies related fixes and cleanups
 2017-05-17 15:19 UTC  (9+ messages)
` [PATCH v2 1/6] mm, page_alloc: fix more premature OOM due to race with cpuset update
` [PATCH v2 2/6] mm, mempolicy: stop adjusting current->il_next in mpol_rebind_nodemask()
` [PATCH v2 3/6] mm, page_alloc: pass preferred nid instead of zonelist to allocator
` [PATCH v2 4/6] mm, mempolicy: simplify rebinding mempolicies when updating cpusets
` [PATCH v2 5/6] mm, cpuset: always use seqlock when changing task's nodemask
` [PATCH v2 6/6] mm, mempolicy: don't check cpuset seqlock where it doesn't matter

[PATCH 0/6] refine and rename slub sysfs
 2017-05-17 14:57 UTC  (9+ messages)
` [PATCH 1/6] mm/slub: add total_objects_partial sysfs
` [PATCH 2/6] mm/slub: not include cpu_partial data in cpu_slabs sysfs
` [PATCH 3/6] mm/slub: add cpu_slabs_[total_]objects sysfs
` [PATCH 4/6] mm/slub: rename ALL slabs sysfs
` [PATCH 5/6] mm/slub: rename partial_slabs sysfs
` [PATCH 6/6] mm/slub: rename cpu_partial_slab sysfs

[Qustion] vmalloc area overlap with another allocated vmalloc area
 2017-05-17 14:23 UTC  (4+ messages)

[RFC summary] Enable Coherent Device Memory
 2017-05-17 13:54 UTC  (12+ messages)

[PATCH] mm: clarify why we want kmalloc before falling backto vmallock
 2017-05-17 13:02 UTC  (2+ messages)

[PATCH 1/2] drm: replace drm_[cm]alloc* by kvmalloc alternatives
 2017-05-17 12:23 UTC  (8+ messages)
` [PATCH 2/2] drm: drop drm_[cm]alloc* helpers
  ` [PATCH 2/2 -v2] "

[PATCH v1 00/11] mm/kasan: support per-page shadow memory to reduce memory consumption
 2017-05-17 12:17 UTC  (20+ messages)
` [PATCH v1 01/11] mm/kasan: rename XXX_is_zero to XXX_is_nonzero
` [PATCH v1 02/11] mm/kasan: don't fetch the next shadow value speculartively
` [PATCH v1 03/11] mm/kasan: handle unaligned end address in zero_pte_populate
` [PATCH v1 04/11] mm/kasan: extend kasan_populate_zero_shadow()
` [PATCH v1 05/11] mm/kasan: introduce per-page shadow memory infrastructure
` [PATCH v1 06/11] mm/kasan: mark/unmark the target range that is for original shadow memory
` [PATCH v1 07/11] x86/kasan: use per-page "
` [PATCH v1 08/11] mm/kasan: support on-demand shadow allocation/mapping
` [PATCH v1 09/11] x86/kasan: support on-demand shadow mapping
` [PATCH v1 10/11] mm/kasan: support dynamic shadow memory free
` [PATCH v1 11/11] mm/kasan: change the order of shadow memory check
` [PATCH(RE-RESEND) v1 01/11] mm/kasan: rename _is_zero to _is_nonzero

[PATCH] drm: use kvmalloc_array for drm_malloc*
 2017-05-17  8:09 UTC  (11+ messages)

[PATCH v7 0/7] Introduce ZONE_CMA
 2017-05-17  7:44 UTC  (12+ messages)

[PATCH v5 00/32] x86: Secure Memory Encryption (AMD)
 2017-05-17  7:05 UTC  (22+ messages)
` [PATCH v5 06/32] x86/mm: Add Secure Memory Encryption (SME) support
` [PATCH v5 14/32] efi: Add an EFI table address match function
` [PATCH v5 17/32] x86/mm: Add support to access boot related data in the clear
` [PATCH v5 18/32] x86, mpparse: Use memremap to map the mpf and mpc data
` [PATCH v5 19/32] x86/mm: Add support to access persistent memory in the clear
` [PATCH v5 22/32] x86, swiotlb: DMA support for memory encryption
` [PATCH v5 23/32] swiotlb: Add warnings for use of bounce buffers with SME
` [PATCH v5 26/32] x86, drm, fbdev: Do not specify encrypted memory for video mappings

[patch V2 15/17] mm/vmscan: Adjust system_state checks
 2017-05-17  6:56 UTC  (2+ messages)

[Question] softlock up in handle_mm_fault
 2017-05-17  6:45 UTC 

[PATCH v3 1/2] mm/hugetlb: Cleanup ARCH_HAS_GIGANTIC_PAGE
 2017-05-17  4:28 UTC  (2+ messages)
` [PATCH v3 2/2] powerpc/mm/hugetlb: Add support for 1G huge pages

[PATCH v4] arm64: fix the overlap between the kernel image and vmalloc address
 2017-05-17  3:17 UTC  (4+ messages)

[PATCH] mm/vmscan: fix unsequenced modification and access warning
 2017-05-17  3:01 UTC  (5+ messages)
` [Patch v2] "

Low memory killer problem
 2017-05-17  2:47 UTC  (8+ messages)

8 Gigabytes and constantly swapping
 2017-05-17  1:27 UTC  (3+ messages)

[v3 0/9] parallelized "struct page" zeroing
 2017-05-16 23:50 UTC  (5+ messages)

[PATCH] mm: per-cgroup memory reclaim stats
 2017-05-16 22:03 UTC  (6+ messages)

[PATCH 0/4] thp: fix few MADV_DONTNEED races
 2017-05-16 20:29 UTC  (5+ messages)
` [PATCH 2/4] thp: fix MADV_DONTNEED vs. numa balancing race

[PATCH RFC] hugetlbfs 'noautofill' mount option
 2017-05-16 16:51 UTC  (10+ messages)

[PATCH] Patch for remapping pages around the fault page
 2017-05-16 16:16 UTC 

[PATCH v2 1/2] mm/hugetlb: Cleanup ARCH_HAS_GIGANTIC_PAGE
 2017-05-16 15:29 UTC  (5+ messages)
` [PATCH v2 2/2] powerpc/mm/hugetlb: Add support for 1G huge pages

[PATCH v6 00/15] lockdep: Implement crossrelease feature
 2017-05-16 14:18 UTC  (7+ messages)
` [PATCH v6 05/15] "

[PATCH v3] arm64: fix the overlap between the kernel image and vmalloc address
 2017-05-16 14:06 UTC  (3+ messages)

[patch 2/2] MM: allow per-cpu vmstat_threshold and vmstat_worker configuration
 2017-05-16 13:37 UTC  (12+ messages)

[RFC PATCH 0/5] userfaultfd: non-cooperative: syncronous events
 2017-05-16 10:36 UTC  (6+ messages)
` [RFC PATCH 1/5] userfaultfd: introduce userfault_init_waitqueue helper
` [RFC PATCH 2/5] userfaultfd: introduce userfaultfd_should_wait helper
` [RFC PATCH 3/5] userfaultfd: non-cooperative: generalize wake key structure
` [RFC PATCH 4/5] userfaultfd: non-cooperative: use fault_pending_wqh for all events
` [RFC PATCH 5/5] userfaultfd: non-cooperative: allow synchronous EVENT_REMOVE

[PATCH] userfaultfd: drop dead code
 2017-05-16 10:35 UTC 

[PATCH] exit: don't include unused userfaultfd_k.h
 2017-05-16 10:35 UTC 

[PATCH V2] mm/madvise: Enable (soft|hard) offline of HugeTLB pages at PGD level
 2017-05-16 10:05 UTC  (2+ messages)
` [PATCH V3] "

[PATCH 06/17] mm/shmem: expose driver overridable huge option
 2017-05-16 10:02 UTC  (3+ messages)
` [PATCH 07/17] drm/i915: request THP for shmem backed objects

[PATCH v2 0/9] HugeTLB migration support for PPC64
 2017-05-16  9:23 UTC  (10+ messages)
` [PATCH v2 1/9] mm/hugetlb/migration: Use set_huge_pte_at instead of set_pte_at
` [PATCH v2 2/9] mm/follow_page_mask: Split follow_page_mask to smaller functions
` [PATCH v2 3/9] mm/hugetlb: export hugetlb_entry_migration helper
` [PATCH v2 4/9] mm/follow_page_mask: Add support for hugetlb pgd entries
` [PATCH v2 5/9] mm/hugetlb: Move default definition of hugepd_t earlier in the header
` [PATCH v2 6/9] mm/follow_page_mask: Add support for hugepage directory entry
` [PATCH v2 7/9] powerpc/hugetlb: Add follow_huge_pd implementation for ppc64
` [PATCH v2 8/9] powerpc/mm/hugetlb: Remove follow_huge_addr for powerpc
` [PATCH v2 9/9] powerpc/hugetlb: Enable hugetlb migration for ppc64

[RFC PATCH 0/4 v2] mm: give __GFP_REPEAT a better semantic
 2017-05-16  9:10 UTC  (2+ messages)

[v3 0/9] parallelized "struct page" zeroing
 2017-05-16  8:36 UTC  (11+ messages)
` [v3 9/9] s390: teach platforms not to zero struct pages memory

[patch 3/3] MM: allow per-cpu vmstat_worker configuration
 2017-05-16  1:31 UTC  (2+ messages)
` [lkp-robot] [MM] 3e38a07a66: ltp.proc01.fail

[PATCH(RESEND) v1 01/11] mm/kasan: rename XXX_is_zero to XXX_is_nonzero
 2017-05-16  1:23 UTC 

[PATCHv5, REBASED 0/9] x86: 5-level paging enabling for v4.12, Part 4
 2017-05-15 19:48 UTC  (12+ messages)
` [PATCHv5, REBASED 3/9] x86/boot/64: Rename init_level4_pgt and early_level4_pgt
` [PATCHv5, REBASED 5/9] x86/mm: Add sync_global_pgds() for configuration with 5-level paging
` [PATCHv5, REBASED 6/9] x86/mm: Make kernel_physical_mapping_init() support "
` [PATCHv5, REBASED 7/9] x86/mm: Add support for 5-level paging for KASLR
` [PATCHv5, REBASED 8/9] x86: Enable 5-level paging support
` [PATCHv5, REBASED 9/9] x86/mm: Allow to have userspace mappings above 47-bits

[PATCH v4 00/27] fs: introduce new writeback error reporting and convert existing API as a wrapper around it
 2017-05-15 17:58 UTC  (4+ messages)
` [PATCH v4 15/27] fs: retrofit old error reporting API onto new infrastructure

[xfstests PATCH v2 0/3] xfstest for updated writeback error handling
 2017-05-15 17:42 UTC  (3+ messages)
` [xfstests PATCH v2 2/3] ext4: allow ext4 to use $SCRATCH_LOGDEV

[RFC] [PATCH 0/1] ksm: fix use after free with merge_across_nodes = 0
 2017-05-15 16:14 UTC  (3+ messages)
` [PATCH 1/1] "

[RFC 0/4] RFC - Coherent Device Memory (Not for inclusion)
 2017-05-15 15:53 UTC  (11+ messages)

[patch 15/18] mm/vmscan: Adjust system_state checks
 2017-05-15 14:54 UTC  (2+ messages)

[RFC PATCH v2 00/17] cgroup: Major changes to cgroup v2 core
 2017-05-15 13:34 UTC  (18+ messages)
` [RFC PATCH v2 01/17] cgroup: reorganize cgroup.procs / task write path
` [RFC PATCH v2 02/17] cgroup: add @flags to css_task_iter_start() and implement CSS_TASK_ITER_PROCS
` [RFC PATCH v2 03/17] cgroup: introduce cgroup->proc_cgrp and threaded css_set handling
` [RFC PATCH v2 04/17] cgroup: implement CSS_TASK_ITER_THREADED
` [RFC PATCH v2 05/17] cgroup: implement cgroup v2 thread support
` [RFC PATCH v2 06/17] cgroup: Fix reference counting bug in cgroup_procs_write()
` [RFC PATCH v2 07/17] cgroup: Prevent kill_css() from being called more than once
` [RFC PATCH v2 08/17] cgroup: Move debug cgroup to its own file
` [RFC PATCH v2 09/17] cgroup: Keep accurate count of tasks in each css_set
` [RFC PATCH v2 10/17] cgroup: Make debug cgroup support v2 and thread mode
` [RFC PATCH v2 11/17] cgroup: Implement new thread mode semantics
` [RFC PATCH v2 12/17] cgroup: Remove cgroup v2 no internal process constraint
` [RFC PATCH v2 13/17] cgroup: Allow fine-grained controllers control in cgroup v2
` [RFC PATCH v2 14/17] cgroup: Enable printing of v2 controllers' cgroup hierarchy
` [RFC PATCH v2 15/17] sched: Misc preps for cgroup unified hierarchy interface
` [RFC PATCH v2 16/17] sched: Implement interface for cgroup unified hierarchy
` [RFC PATCH v2 17/17] sched: Make cpu/cpuacct threaded controllers

mm: page allocation failures in swap_duplicate -> add_swap_count_continuation
 2017-05-15 12:57 UTC  (5+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).