linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-04-07 01:38:58 to 2020-04-07 10:01:20 UTC [more...]

[RFC v6 0/7] Implement Data Access Monitoring-based Memory Operation Schemes
 2020-04-07  9:59 UTC 

[PATCH] mm/gup: fix null pointer dereference detected by coverity
 2020-04-07  9:51 UTC 

[PATCH v3] mm, memcg: fix error return value of mem_cgroup_css_alloc()
 2020-04-07  9:31 UTC  (7+ messages)

[PATCH 2/2] MM: Discard NR_UNSTABLE_NFS, use NR_WRITEBACK instead
 2020-04-07  9:19 UTC  (3+ messages)

BUG: unable to handle kernel paging request in kernel_get_mempolicy
 2020-04-07  8:27 UTC  (7+ messages)

[kernel-hardening] [PATCH 09/38] usercopy: Mark kmalloc caches as usercopy caches
 2020-04-07  8:00 UTC  (13+ messages)

[PATCHv2 7/8] thp: Change CoW semantics for anon-THP
 2020-04-07  7:57 UTC  (2+ messages)
` [thp] db001b7115: vm-scalability.median 8.9% improvement

incoming
 2020-04-07  7:50 UTC  (168+ messages)
` [patch 001/166] mm, memcg: bypass high reclaim iteration for cgroup hierarchy root
` [patch 002/166] mm: don't prepare anon_vma if vma has VM_WIPEONFORK
` [patch 003/166] Revert "mm/rmap.c: reuse mergeable anon_vma as parent when fork"
` [patch 004/166] mm: set vm_next and vm_prev to NULL in vm_area_dup()
` [patch 005/166] mm/vma: add missing VMA flag readable name for VM_SYNC
` [patch 006/166] mm/vma: make vma_is_accessible() available for general use
` [patch 007/166] mm/vma: replace all remaining open encodings with is_vm_hugetlb_page()
` [patch 008/166] mm/vma: replace all remaining open encodings with vma_is_anonymous()
` [patch 009/166] mm/vma: append unlikely() while testing VMA access permissions
` [patch 010/166] mm/vmalloc: fix a typo in comment
` [patch 011/166] mm: make it clear that gfp reclaim modifiers are valid only for sleepable allocations
` [patch 012/166] mm/migrate.c: no need to check for i > start in do_pages_move()
` [patch 013/166] mm/migrate.c: wrap do_move_pages_to_node() and store_status()
` [patch 014/166] mm/migrate.c: check pagelist in move_pages_and_store_status()
` [patch 015/166] mm/migrate.c: unify "not queued for migration" handling in do_pages_move()
` [patch 016/166] mm/migrate.c: migrate PG_readahead flag
` [patch 017/166] mm, shmem: add vmstat for hugepage fallback
` [patch 018/166] mm, thp: track fallbacks due to failed memcg charges separately
` [patch 019/166] include/linux/pagemap.h: optimise find_subpage for !THP
` [patch 020/166] mm: remove CONFIG_TRANSPARENT_HUGE_PAGECACHE
` [patch 021/166] mm/ksm.c: update get_user_pages() argument in comment
` [patch 022/166] mm: code cleanup for MADV_FREE
` [patch 023/166] mm: adjust shuffle code to allow for future coalescing
` [patch 024/166] mm: use zone and order instead of free area in free_list manipulators
` [patch 025/166] mm: add function __putback_isolated_page
` [patch 026/166] mm: introduce Reported pages
` [patch 027/166] virtio-balloon: pull page poisoning config out of free page hinting
` [patch 028/166] virtio-balloon: add support for providing free page reports to host
` [patch 029/166] mm/page_reporting: rotate reported pages to the tail of the list
` [patch 030/166] mm/page_reporting: add budget limit on how many pages can be reported per pass
` [patch 031/166] mm/page_reporting: add free page reporting documentation
` [patch 032/166] virtio-balloon: switch back to OOM handler for VIRTIO_BALLOON_F_DEFLATE_ON_OOM
` [patch 033/166] userfaultfd: wp: add helper for writeprotect check
` [patch 034/166] userfaultfd: wp: hook userfault handler to write protection fault
` [patch 035/166] userfaultfd: wp: add WP pagetable tracking to x86
` [patch 036/166] userfaultfd: wp: userfaultfd_pte/huge_pmd_wp() helpers
` [patch 037/166] userfaultfd: wp: add UFFDIO_COPY_MODE_WP
` [patch 038/166] mm: merge parameters for change_protection()
` [patch 039/166] userfaultfd: wp: apply _PAGE_UFFD_WP bit
` [patch 040/166] userfaultfd: wp: drop _PAGE_UFFD_WP properly when fork
` [patch 041/166] userfaultfd: wp: add pmd_swp_*uffd_wp() helpers
` [patch 042/166] userfaultfd: wp: support swap and page migration
` [patch 043/166] khugepaged: skip collapse if uffd-wp detected
` [patch 044/166] userfaultfd: wp: support write protection for userfault vma range
` [patch 045/166] userfaultfd: wp: add the writeprotect API to userfaultfd ioctl
` [patch 046/166] userfaultfd: wp: enabled write protection in userfaultfd API
` [patch 047/166] userfaultfd: wp: don't wake up when doing write protect
` [patch 048/166] userfaultfd: wp: UFFDIO_REGISTER_MODE_WP documentation update
` [patch 049/166] userfaultfd: wp: declare _UFFDIO_WRITEPROTECT conditionally
` [patch 050/166] userfaultfd: selftests: refactor statistics
` [patch 051/166] userfaultfd: selftests: add write-protect test
` [patch 052/166] drivers/base/memory.c: drop section_count
` [patch 053/166] drivers/base/memory.c: drop pages_correctly_probed()
` [patch 054/166] mm/page_ext.c: drop pfn_present() check when onlining
` [patch 055/166] mm/memory_hotplug.c: only respect mem= parameter during boot stage
` [patch 056/166] mm/memory_hotplug.c: simplify calculation of number of pages in __remove_pages()
` [patch 057/166] mm/memory_hotplug.c: cleanup __add_pages()
` [patch 058/166] mm/sparse.c: introduce new function fill_subsection_map()
` [patch 059/166] mm/sparse.c: introduce a new function clear_subsection_map()
` [patch 060/166] mm/sparse.c: only use subsection map in VMEMMAP case
` [patch 061/166] mm/sparse.c: add note about only VMEMMAP supporting sub-section hotplug
` [patch 062/166] mm/sparse.c: move subsection_map related functions together
` [patch 063/166] drivers/base/memory: rename MMOP_ONLINE_KEEP to MMOP_ONLINE
` [patch 064/166] drivers/base/memory: map MMOP_OFFLINE to 0
` [patch 065/166] drivers/base/memory: store mapping between MMOP_* and string in an array
` [patch 066/166] powernv/memtrace: always online added memory blocks
` [patch 067/166] hv_balloon: don't check for memhp_auto_online manually
` [patch 068/166] mm/memory_hotplug: unexport memhp_auto_online
` [patch 069/166] mm/memory_hotplug: convert memhp_auto_online to store an online_type
` [patch 070/166] mm/memory_hotplug: allow to specify a default online_type
` [patch 071/166] mm/memory_hotplug.c: use __pfn_to_section() instead of open-coding
` [patch 072/166] mm/shmem.c: distribute switch variables for initialization
` [patch 073/166] mm/shmem.c: clean code by removing unnecessary assignment
` [patch 074/166] mm: huge tmpfs: try to split_huge_page() when punching hole
` [patch 075/166] mm: prevent a warning when casting void* -> enum
` [patch 076/166] mm/zswap: allow setting default status, compressor and allocator in Kconfig
` [patch 077/166] mm/compaction: add missing annotation for compact_lock_irqsave
` [patch 078/166] mm/hugetlb: add missing annotation for gather_surplus_pages()
` [patch 079/166] mm/mempolicy: add missing annotation for queue_pages_pmd()
` [patch 080/166] mm/slub: add missing annotation for get_map()
` [patch 081/166] mm/slub: add missing annotation for put_map()
` [patch 082/166] mm/zsmalloc: add missing annotation for migrate_read_lock()
` [patch 083/166] mm/zsmalloc: add missing annotation for migrate_read_unlock()
` [patch 084/166] mm/zsmalloc: add missing annotation for pin_tag()
` [patch 085/166] mm/zsmalloc: add missing annotation for unpin_tag()
` [patch 086/166] mm: fix ambiguous comments for better code readability
` [patch 087/166] mm/mm_init.c: clean code. Use BUILD_BUG_ON when comparing compile time constant
` [patch 088/166] mm: use fallthrough;
` [patch 089/166] include/linux/swapops.h: correct guards for non_swap_entry()
` [patch 090/166] include/linux/memremap.h: remove stale comments
` [patch 091/166] mm/dmapool.c: micro-optimisation remove unnecessary branch
` [patch 092/166] mm: remove dummy struct bootmem_data/bootmem_data_t
` [patch 093/166] fs/proc/inode.c: annotate close_pdeo() for sparse
` [patch 094/166] proc: faster open/read/close with "permanent" files
` [patch 095/166] proc: speed up /proc/*/statm
` [patch 096/166] proc: inline vma_stop into m_stop
` [patch 097/166] proc: remove m_cache_vma
` [patch 098/166] proc: use ppos instead of m->version
` [patch 099/166] seq_file: remove m->version
` [patch 100/166] proc: inline m_next_vma into m_next
` [patch 101/166] asm-generic: fix unistd_32.h generation format
` [patch 102/166] kernel/extable.c: use address-of operator on section symbols
` [patch 103/166] sparc,x86: vdso: remove meaningless undefining CONFIG_OPTIMIZE_INLINING
` [patch 104/166] compiler: remove CONFIG_OPTIMIZE_INLINING entirely
` [patch 105/166] compiler.h: fix error in BUILD_BUG_ON() reporting
` [patch 106/166] MAINTAINERS: list the section entries in the preferred order
` [patch 107/166] bitops: always inline sign extension helpers
` [patch 108/166] lib/test_lockup: test module to generate lockups
` [patch 109/166] lib/test_lockup.c: fix spelling mistake "iteraions" -> "iterations"
` [patch 110/166] lib/test_lockup.c: add parameters for locking generic vfs locks
` [patch 111/166] lib/bch.c: replace zero-length array with flexible-array member
` [patch 112/166] lib/ts_bm.c: "
` [patch 113/166] lib/ts_fsm.c: "
` [patch 114/166] lib/ts_kmp.c: "
` [patch 115/166] lib/scatterlist: fix sg_copy_buffer() kerneldoc
` [patch 116/166] lib: test_stackinit.c: XFAIL switch variable init tests
` [patch 117/166] lib/stackdepot.c: check depot_index before accessing the stack slab
` [patch 118/166] lib/stackdepot.c: build with -fno-builtin
` [patch 119/166] kasan: stackdepot: move filter_irq_stacks() to stackdepot.c
` [patch 120/166] percpu_counter: fix a data race at vm_committed_as
` [patch 121/166] lib/test_bitmap.c: make use of EXP2_IN_BITS
` [patch 122/166] lib/rbtree: fix coding style of assignments
` [patch 123/166] lib/test_kmod.c: remove a NULL test
` [patch 124/166] linux/bits.h: add compile time sanity check of GENMASK inputs
` [patch 125/166] lib/list: prevent compiler reloads inside 'safe' list iteration
` [patch 126/166] lib/dynamic_debug.c: use address-of operator on section symbols
` [patch 127/166] checkpatch: remove email address comment from email address comparisons
` [patch 128/166] checkpatch: check SPDX tags in YAML files
` [patch 129/166] checkpatch: support "base-commit:" format
` [patch 130/166] checkpatch: prefer fallthrough; over fallthrough comments
` [patch 131/166] checkpatch: fix minor typo and mixed space+tab in indentation
` [patch 132/166] checkpatch: fix multiple const * types
` [patch 133/166] checkpatch: add command-line option for TAB size
` [patch 134/166] checkpatch: improve Gerrit Change-Id: test
` [patch 135/166] checkpatch: check proper licensing of Devicetree bindings
` [patch 136/166] checkpatch: avoid warning about uninitialized_var()
` [patch 137/166] kselftest: introduce new epoll test case
` [patch 138/166] fs/epoll: make nesting accounting safe for -rt kernel
` [patch 139/166] fs/binfmt_elf.c: delete "loc" variable
` [patch 140/166] fs/binfmt_elf.c: allocate less for static executable
` [patch 141/166] fs/binfmt_elf.c: don't free interpreter's ELF pheaders on common path
` [patch 142/166] samples/hw_breakpoint: drop HW_BREAKPOINT_R when reporting writes
` [patch 143/166] samples/hw_breakpoint: drop use of kallsyms_lookup_name()
` [patch 144/166] kallsyms: unexport kallsyms_lookup_name() and kallsyms_on_each_symbol()
` [patch 145/166] reiserfs: clean up several indentation issues
` [patch 146/166] kernel/kmod.c: fix a typo "assuems" -> "assumes"
` [patch 147/166] gcov: gcc_4_7: replace zero-length array with flexible-array member
` [patch 148/166] gcov: gcc_3_4: "
` [patch 149/166] kernel/gcov/fs.c: "
` [patch 150/166] init/Kconfig: clean up ANON_INODES and old IO schedulers options
` [patch 151/166] kcov: cleanup debug messages
` [patch 152/166] kcov: fix potential use-after-free in kcov_remote_start
` [patch 153/166] kcov: move t->kcov assignments into kcov_start/stop
` [patch 154/166] kcov: move t->kcov_sequence assignment
` [patch 155/166] kcov: use t->kcov_mode as enabled indicator
` [patch 156/166] kcov: collect coverage from interrupts
` [patch 157/166] usb: core: kcov: collect coverage from usb complete callback
` [patch 158/166] ubsan: add trap instrumentation option
` [patch 159/166] ubsan: split "bounds" checker from other options
` [patch 160/166] drivers/misc/lkdtm/bugs.c: add arithmetic overflow and array bounds checks
` [patch 161/166] ubsan: check panic_on_warn
` [patch 162/166] kasan: unset panic_on_warn before calling panic()
` [patch 163/166] ubsan: include bug type in report header
` [patch 164/166] lib/Kconfig.debug: fix a typo "capabilitiy" -> "capability"
` [patch 165/166] ipc/mqueue.c: fix a brace coding style issue
` [patch 166/166] ipc/shm.c: make compat_ksys_shmctl() static

[PATCH/RFC] MM: fix writeback for NFS
 2020-04-07  7:33 UTC  (9+ messages)
` Writeback fixes "
  ` [PATCH 1/2] MM: replace PF_LESS_THROTTLE with PF_LOCAL_THROTTLE
    ` [PATCH 2/2] Deprecate NR_UNSTABLE_NFS, use NR_WRITEBACK
        ` [PATCH 2/2 - v2] MM: Discard NR_UNSTABLE_NFS, use NR_WRITEBACK instead

[PATCH 0/2] mm: few refinements to gfp flags documentation
 2020-04-07  7:24 UTC  (11+ messages)
` [PATCH 1/2] mm: clarify __GFP_MEMALLOC usage
` [PATCH 2/2] mm: make it clear that gfp reclaim modifiers are valid only for sleepable allocations

Where should I send patch related to mmtests?
 2020-04-07  7:04 UTC  (2+ messages)

[PATCH v4 0/2] mm: using CMA for 1 GB hugepages allocation
 2020-04-07  7:03 UTC  (3+ messages)
` [PATCH v4 2/2] mm: hugetlb: optionally allocate gigantic hugepages using cma

[PATCH v2] mm, memcg: fix error return value of mem_cgroup_css_alloc()
 2020-04-07  6:44 UTC  (3+ messages)

[PATCH v2] mm: Add kvfree_sensitive() for freeing sensitive data objects
 2020-04-07  6:41 UTC  (4+ messages)

BUG: unable to handle kernel paging request in kernel_get_mempolicy
 2020-04-07  5:26 UTC  (2+ messages)

improve use_mm / unuse_mm
 2020-04-07  3:08 UTC  (3+ messages)
` [PATCH 2/6] i915/gvt/kvm: a NULL ->mm does not mean a thread is a kthread

[PATCH] mm/page_alloc: make pcpu_drain_mutex and pcpu_drain static
 2020-04-07  2:39 UTC 

[PATCH v5 00/10] workingset protection/detection on the anonymous LRU list
 2020-04-07  2:21 UTC  (3+ messages)
` [PATCH v5 05/10] mm/swap: charge the page when adding to the swap cache

[PATCH 1/3] rcu/tree: use more permissive parameters when attaching a head
 2020-04-07  2:11 UTC  (3+ messages)

[PATCH 1/1] rcu/tree: add emergency pool for headless case
 2020-04-07  1:47 UTC  (8+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).