linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-04-07 03:08:18 to 2020-04-08 09:01:18 UTC [more...]

[RFC PATCH v5 0/8] arm64: tlb: add support for TTL feature
 2020-04-08  9:00 UTC  (9+ messages)
` [RFC PATCH v5 4/8] mm: tlb: Pass struct mmu_gather to flush_pmd_tlb_range

[PATCH] stacktrace: cleanup inconsistent variable type
 2020-04-08  8:49 UTC 

general protection fault in kernel_get_mempolicy
 2020-04-08  7:43 UTC 

[PATCH V2 0/3] mm/debug: Add more arch page table helper tests
 2020-04-08  7:11 UTC  (5+ messages)

[PATCH -next] mm: page_alloc: fix kernel-doc warning
 2020-04-08  4:29 UTC 

[PATCH v1 0/2] mm/memory_hotplug: remove is_mem_section_removable()
 2020-04-08  2:48 UTC  (8+ messages)
` [PATCH v1 1/2] powerpc/pseries/hotplug-memory: stop checking is_mem_section_removable()
` [PATCH v1 2/2] mm/memory_hotplug: remove is_mem_section_removable()

improve use_mm / unuse_mm
 2020-04-08  1:44 UTC  (5+ messages)
` [PATCH 2/6] i915/gvt/kvm: a NULL ->mm does not mean a thread is a kthread
` [PATCH 3/6] i915/gvt: remove unused xen bits

[PATCH 0/2] mm: Two small fixes for recent syzbot reports
 2020-04-08  1:40 UTC  (3+ messages)
` [PATCH 1/2] mm/mempolicy: Allow lookup_node() to handle fatal signal
` [PATCH 2/2] mm/gup: Mark lock taken only after a successful retake

WARNING: bad unlock balance in __get_user_pages_remote
 2020-04-08  1:37 UTC  (4+ messages)

BUG: unable to handle kernel paging request in get_pfnblock_flags_mask
 2020-04-08  1:25 UTC  (4+ messages)

[PATCH v3] mm: Add kvfree_sensitive() for freeing sensitive data objects
 2020-04-08  0:35 UTC  (12+ messages)

[PATCH] mm, slab_common: Fix a typo in comment "eariler"->"earlier"
 2020-04-08  0:22 UTC  (2+ messages)

[PATCH v2] mm: Add kvfree_sensitive() for freeing sensitive data objects
 2020-04-07 23:50 UTC  (13+ messages)

[RFC PATCH v9 00/27] Control-flow Enforcement: Shadow Stack
 2020-04-07 22:21 UTC  (5+ messages)
` [RFC PATCH v9 14/27] mm: Handle Shadow Stack page fault

incoming
 2020-04-07 20:06 UTC  (99+ messages)
` [patch 080/166] mm/slub: add missing annotation for get_map()
` [patch 081/166] mm/slub: add missing annotation for put_map()
` [patch 082/166] mm/zsmalloc: add missing annotation for migrate_read_lock()
` [patch 083/166] mm/zsmalloc: add missing annotation for migrate_read_unlock()
` [patch 084/166] mm/zsmalloc: add missing annotation for pin_tag()
` [patch 085/166] mm/zsmalloc: add missing annotation for unpin_tag()
` [patch 086/166] mm: fix ambiguous comments for better code readability
` [patch 087/166] mm/mm_init.c: clean code. Use BUILD_BUG_ON when comparing compile time constant
` [patch 088/166] mm: use fallthrough;
` [patch 089/166] include/linux/swapops.h: correct guards for non_swap_entry()
` [patch 090/166] include/linux/memremap.h: remove stale comments
` [patch 091/166] mm/dmapool.c: micro-optimisation remove unnecessary branch
` [patch 092/166] mm: remove dummy struct bootmem_data/bootmem_data_t
` [patch 093/166] fs/proc/inode.c: annotate close_pdeo() for sparse
` [patch 094/166] proc: faster open/read/close with "permanent" files
` [patch 095/166] proc: speed up /proc/*/statm
` [patch 096/166] proc: inline vma_stop into m_stop
` [patch 097/166] proc: remove m_cache_vma
` [patch 098/166] proc: use ppos instead of m->version
` [patch 099/166] seq_file: remove m->version
` [patch 100/166] proc: inline m_next_vma into m_next
` [patch 101/166] asm-generic: fix unistd_32.h generation format
` [patch 102/166] kernel/extable.c: use address-of operator on section symbols
` [patch 103/166] sparc,x86: vdso: remove meaningless undefining CONFIG_OPTIMIZE_INLINING
` [patch 104/166] compiler: remove CONFIG_OPTIMIZE_INLINING entirely
` [patch 105/166] compiler.h: fix error in BUILD_BUG_ON() reporting
` [patch 106/166] MAINTAINERS: list the section entries in the preferred order
` [patch 107/166] bitops: always inline sign extension helpers
` [patch 108/166] lib/test_lockup: test module to generate lockups
` [patch 109/166] lib/test_lockup.c: fix spelling mistake "iteraions" -> "iterations"
` [patch 110/166] lib/test_lockup.c: add parameters for locking generic vfs locks
` [patch 111/166] lib/bch.c: replace zero-length array with flexible-array member
` [patch 112/166] lib/ts_bm.c: "
` [patch 113/166] lib/ts_fsm.c: "
` [patch 114/166] lib/ts_kmp.c: "
` [patch 115/166] lib/scatterlist: fix sg_copy_buffer() kerneldoc
` [patch 116/166] lib: test_stackinit.c: XFAIL switch variable init tests
` [patch 117/166] lib/stackdepot.c: check depot_index before accessing the stack slab
` [patch 118/166] lib/stackdepot.c: build with -fno-builtin
` [patch 119/166] kasan: stackdepot: move filter_irq_stacks() to stackdepot.c
` [patch 120/166] percpu_counter: fix a data race at vm_committed_as
` [patch 121/166] lib/test_bitmap.c: make use of EXP2_IN_BITS
` [patch 122/166] lib/rbtree: fix coding style of assignments
` [patch 123/166] lib/test_kmod.c: remove a NULL test
` [patch 124/166] linux/bits.h: add compile time sanity check of GENMASK inputs
` [patch 125/166] lib/list: prevent compiler reloads inside 'safe' list iteration
` [patch 126/166] lib/dynamic_debug.c: use address-of operator on section symbols
` [patch 127/166] checkpatch: remove email address comment from email address comparisons
` [patch 128/166] checkpatch: check SPDX tags in YAML files
` [patch 129/166] checkpatch: support "base-commit:" format
` [patch 130/166] checkpatch: prefer fallthrough; over fallthrough comments
` [patch 131/166] checkpatch: fix minor typo and mixed space+tab in indentation
` [patch 132/166] checkpatch: fix multiple const * types
` [patch 133/166] checkpatch: add command-line option for TAB size
` [patch 134/166] checkpatch: improve Gerrit Change-Id: test
` [patch 135/166] checkpatch: check proper licensing of Devicetree bindings
` [patch 136/166] checkpatch: avoid warning about uninitialized_var()
` [patch 137/166] kselftest: introduce new epoll test case
` [patch 138/166] fs/epoll: make nesting accounting safe for -rt kernel
` [patch 139/166] fs/binfmt_elf.c: delete "loc" variable
` [patch 140/166] fs/binfmt_elf.c: allocate less for static executable
` [patch 141/166] fs/binfmt_elf.c: don't free interpreter's ELF pheaders on common path
` [patch 142/166] samples/hw_breakpoint: drop HW_BREAKPOINT_R when reporting writes
` [patch 143/166] samples/hw_breakpoint: drop use of kallsyms_lookup_name()
` [patch 144/166] kallsyms: unexport kallsyms_lookup_name() and kallsyms_on_each_symbol()
` [patch 145/166] reiserfs: clean up several indentation issues
` [patch 146/166] kernel/kmod.c: fix a typo "assuems" -> "assumes"
` [patch 147/166] gcov: gcc_4_7: replace zero-length array with flexible-array member
` [patch 148/166] gcov: gcc_3_4: "
` [patch 149/166] kernel/gcov/fs.c: "
` [patch 150/166] init/Kconfig: clean up ANON_INODES and old IO schedulers options
` [patch 151/166] kcov: cleanup debug messages
` [patch 152/166] kcov: fix potential use-after-free in kcov_remote_start
` [patch 153/166] kcov: move t->kcov assignments into kcov_start/stop
` [patch 154/166] kcov: move t->kcov_sequence assignment
` [patch 155/166] kcov: use t->kcov_mode as enabled indicator
` [patch 156/166] kcov: collect coverage from interrupts
` [patch 157/166] usb: core: kcov: collect coverage from usb complete callback
` [patch 158/166] ubsan: add trap instrumentation option
` [patch 159/166] ubsan: split "bounds" checker from other options
` [patch 160/166] drivers/misc/lkdtm/bugs.c: add arithmetic overflow and array bounds checks
` [patch 161/166] ubsan: check panic_on_warn
` [patch 162/166] kasan: unset panic_on_warn before calling panic()
` [patch 163/166] ubsan: include bug type in report header
` [patch 164/166] lib/Kconfig.debug: fix a typo "capabilitiy" -> "capability"
` [patch 165/166] ipc/mqueue.c: fix a brace coding style issue
` [patch 166/166] ipc/shm.c: make compat_ksys_shmctl() static

[PATCH v2] mm: Add kvfree_sensitive() for freeing sensitive data objects
 2020-04-07 20:02 UTC  (2+ messages)

Bad rss-counter state from drm/ttm, drm/vmwgfx: Support huge TTM pagefaults
 2020-04-07 19:57 UTC  (6+ messages)

[RFC] Renaming page_offset() to page_pos()
 2020-04-07 19:09 UTC  (2+ messages)

[PATCH v5 0/2] mm: using CMA for 1 GB hugepages allocation
 2020-04-07 18:42 UTC  (5+ messages)
` [PATCH v5 1/2] mm: cma: NUMA node interface
` [PATCH v5 2/2] mm: hugetlb: optionally allocate gigantic hugepages using cma

[PATCH] mm/gup: fix null pointer dereference detected by coverity
 2020-04-07 18:19 UTC  (2+ messages)

[PATCH v3] mm, memcg: fix error return value of mem_cgroup_css_alloc()
 2020-04-07 18:10 UTC  (9+ messages)

mmotm 2020-04-05-16-45 uploaded
 2020-04-07 18:00 UTC  (3+ messages)
` mmotm 2020-04-05-16-45 uploaded (objtool warning)

[linux-next:pending-fixes] BUILD SUCCESS 594736fe2462d632506cde58148b7fe3656c16db
 2020-04-07 16:41 UTC 

[PATCH v4 0/2] mm: using CMA for 1 GB hugepages allocation
 2020-04-07 16:23 UTC  (7+ messages)
` [PATCH v4 2/2] mm: hugetlb: optionally allocate gigantic hugepages using cma

[PATCH/RFC] MM: fix writeback for NFS
 2020-04-07 16:10 UTC  (12+ messages)
` Writeback fixes "
  ` [PATCH 1/2] MM: replace PF_LESS_THROTTLE with PF_LOCAL_THROTTLE
    ` [PATCH 2/2] Deprecate NR_UNSTABLE_NFS, use NR_WRITEBACK
        ` [PATCH 2/2 - v2] MM: Discard NR_UNSTABLE_NFS, use NR_WRITEBACK instead
  ` Writeback fixes for NFS - V2

BUG: unable to handle kernel paging request in kernel_get_mempolicy
 2020-04-07 15:59 UTC  (8+ messages)

[Patch v5 0/4] cleanup on do_pages_move()
 2020-04-07 12:45 UTC  (2+ messages)

[PATCH 2/2] MM: Discard NR_UNSTABLE_NFS, use NR_WRITEBACK instead
 2020-04-07 11:33 UTC  (5+ messages)

[kernel-hardening] [PATCH 09/38] usercopy: Mark kmalloc caches as usercopy caches
 2020-04-07 11:05 UTC  (14+ messages)

[RFC v6 0/7] Implement Data Access Monitoring-based Memory Operation Schemes
 2020-04-07 10:00 UTC  (8+ messages)
` [RFC v6 1/7] mm/madvise: Export do_madvise() to external GPL modules
` [RFC v6 2/7] mm/damon: Account age of target regions
` [RFC v6 3/7] mm/damon: Implement data access monitoring-based operation schemes
` [RFC v6 4/7] mm/damon/schemes: Implement a debugfs interface
` [RFC v6 5/7] mm/damon-test: Add kunit test case for regions age accounting
` [RFC v6 6/7] mm/damon/selftests: Add 'schemes' debugfs tests
` [RFC v6 7/7] damon/tools: Support more human friendly 'schemes' control

[PATCHv2 7/8] thp: Change CoW semantics for anon-THP
 2020-04-07  7:57 UTC  (2+ messages)
` [thp] db001b7115: vm-scalability.median 8.9% improvement

[PATCH 0/2] mm: few refinements to gfp flags documentation
 2020-04-07  7:24 UTC  (8+ messages)
` [PATCH 1/2] mm: clarify __GFP_MEMALLOC usage

Where should I send patch related to mmtests?
 2020-04-07  7:04 UTC  (2+ messages)

[PATCH v2] mm, memcg: fix error return value of mem_cgroup_css_alloc()
 2020-04-07  6:44 UTC  (3+ messages)

BUG: unable to handle kernel paging request in kernel_get_mempolicy
 2020-04-07  5:26 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).