linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-06-03 08:22:29 to 2020-06-04 00:55:02 UTC [more...]

incoming
 2020-06-04  0:54 UTC  (133+ messages)
` [patch 001/131] mm/slub: fix a memory leak in sysfs_slab_add()
` [patch 002/131] mm/memcg: optimize memory.numa_stat like memory.stat
` [patch 003/131] mm/gup: move __get_user_pages_fast() down a few lines in gup.c
` [patch 004/131] mm/gup: refactor and de-duplicate gup_fast() code
` [patch 005/131] mm/gup: introduce pin_user_pages_fast_only()
` [patch 006/131] drm/i915: convert get_user_pages() --> pin_user_pages()
` [patch 007/131] mm/gup: might_lock_read(mmap_sem) in get_user_pages_fast()
` [patch 008/131] kasan: stop tests being eliminated as dead code with FORTIFY_SOURCE
` [patch 009/131] string.h: fix incompatibility between FORTIFY_SOURCE and KASAN
` [patch 010/131] mm: clarify __GFP_MEMALLOC usage
` [patch 011/131] mm: memblock: replace dereferences of memblock_region.nid with API calls
` [patch 012/131] mm: make early_pfn_to_nid() and related defintions close to each other
` [patch 013/131] mm: remove CONFIG_HAVE_MEMBLOCK_NODE_MAP option
` [patch 014/131] mm: free_area_init: use maximal zone PFNs rather than zone sizes
` [patch 015/131] mm: use free_area_init() instead of free_area_init_nodes()
` [patch 016/131] alpha: simplify detection of memory zone boundaries
` [patch 017/131] arm: "
` [patch 018/131] arm64: simplify detection of memory zone boundaries for UMA configs
` [patch 019/131] csky: simplify detection of memory zone boundaries
` [patch 020/131] m68k: mm: "
` [patch 021/131] parisc: "
` [patch 022/131] sparc32: "
` [patch 023/131] unicore32: "
` [patch 024/131] xtensa: "
` [patch 025/131] mm: memmap_init: iterate over memblock regions rather that check each PFN
` [patch 026/131] mm: remove early_pfn_in_nid() and CONFIG_NODES_SPAN_OTHER_NODES
` [patch 027/131] mm: free_area_init: allow defining max_zone_pfn in descending order
` [patch 028/131] mm: rename free_area_init_node() to free_area_init_memoryless_node()
` [patch 029/131] mm: clean up free_area_init_node() and its helpers
` [patch 030/131] mm: simplify find_min_pfn_with_active_regions()
` [patch 031/131] docs/vm: update memory-models documentation
` [patch 032/131] mm/page_alloc.c: bad_[reason|flags] is not necessary when PageHWPoison
` [patch 033/131] mm/page_alloc.c: bad_flags is not necessary for bad_page()
` [patch 034/131] mm/page_alloc.c: rename free_pages_check_bad() to check_free_page_bad()
` [patch 035/131] mm/page_alloc.c: rename free_pages_check() to check_free_page()
` [patch 036/131] mm/page_alloc.c: extract check_[new|free]_page_bad() common part to page_bad_reason()
` [patch 037/131] mm,page_alloc,cma: conditionally prefer cma pageblocks for movable allocations
` [patch 038/131] mm/page_alloc.c: remove unused free_bootmem_with_active_regions
` [patch 039/131] mm/page_alloc.c: only tune sysctl_lowmem_reserve_ratio value once when changing it
` [patch 040/131] mm/page_alloc.c: clear out zone->lowmem_reserve[] if the zone is empty
` [patch 041/131] mm/vmstat.c: do not show lowmem reserve protection information of empty zone
` [patch 042/131] mm/page_alloc: use ac->high_zoneidx for classzone_idx
` [patch 043/131] mm/page_alloc: integrate classzone_idx and high_zoneidx
` [patch 044/131] mm/page_alloc.c: use NODE_MASK_NONE in build_zonelists()
` [patch 045/131] mm: rename gfpflags_to_migratetype to gfp_migratetype for same convention
` [patch 046/131] mm/page_alloc.c: reset numa stats for boot pagesets
` [patch 047/131] mm, page_alloc: reset the zone->watermark_boost early
` [patch 048/131] mm/page_alloc: restrict and formalize compound_page_dtors[]
` [patch 049/131] mm/pagealloc.c: call touch_nmi_watchdog() on max order boundaries in deferred init
` [patch 050/131] mm: initialize deferred pages with interrupts enabled
` [patch 051/131] mm: call cond_resched() from deferred_init_memmap()
` [patch 052/131] padata: remove exit routine
` [patch 053/131] padata: initialize earlier
` [patch 054/131] padata: allocate work structures for parallel jobs from a pool
` [patch 055/131] padata: add basic support for multithreaded jobs
` [patch 056/131] mm: don't track number of pages during deferred initialization
` [patch 057/131] mm: parallelize deferred_init_memmap()
` [patch 058/131] mm: make deferred init's max threads arch-specific
` [patch 059/131] padata: document multithreaded jobs
` [patch 060/131] mm/page_alloc.c: add missing newline
` [patch 061/131] khugepaged: add self test
` [patch 062/131] khugepaged: do not stop collapse if less than half PTEs are referenced
` [patch 063/131] khugepaged: drain all LRU caches before scanning pages
` [patch 064/131] khugepaged: drain LRU add pagevec after swapin
` [patch 065/131] khugepaged: allow to collapse a page shared across fork
` [patch 066/131] khugepaged: allow to collapse PTE-mapped compound pages
` [patch 067/131] thp: change CoW semantics for anon-THP
` [patch 068/131] khugepaged: introduce 'max_ptes_shared' tunable
` [patch 069/131] hugetlbfs: add arch_hugetlb_valid_size
` [patch 070/131] hugetlbfs: move hugepagesz= parsing to arch independent code
` [patch 071/131] hugetlbfs: remove hugetlb_add_hstate() warning for existing hstate
` [patch 072/131] hugetlbfs: clean up command line processing
` [patch 073/131] hugetlbfs: fix changes to "
` [patch 074/131] mm/hugetlb: avoid unnecessary check on pud and pmd entry in huge_pte_offset
` [patch 075/131] arm64/mm: drop __HAVE_ARCH_HUGE_PTEP_GET
` [patch 076/131] mm/hugetlb: define a generic fallback for is_hugepage_only_range()
` [patch 077/131] mm/hugetlb: define a generic fallback for arch_clear_hugepage_flags()
` [patch 078/131] mm: simplify calling a compound page destructor
` [patch 079/131] mm/vmscan.c: use update_lru_size() in update_lru_sizes()
` [patch 080/131] mm/vmscan: count layzfree pages and fix nr_isolated_* mismatch
` [patch 081/131] mm/vmscan.c: change prototype for shrink_page_list
` [patch 082/131] mm/vmscan: update the comment of should_continue_reclaim()
` [patch 083/131] mm: fix NUMA node file count error in replace_page_cache()
` [patch 084/131] mm: memcontrol: fix stat-corrupting race in charge moving
` [patch 085/131] mm: memcontrol: drop @compound parameter from memcg charging API
` [patch 086/131] mm: shmem: remove rare optimization when swapin races with hole punching
` [patch 087/131] mm: memcontrol: move out cgroup swaprate throttling
` [patch 088/131] mm: memcontrol: convert page cache to a new mem_cgroup_charge() API
` [patch 089/131] mm: memcontrol: prepare uncharging for removal of private page type counters
` [patch 090/131] mm: memcontrol: prepare move_account "
` [patch 091/131] mm: memcontrol: prepare cgroup vmstat infrastructure for native anon counters
` [patch 092/131] mm: memcontrol: switch to native NR_FILE_PAGES and NR_SHMEM counters
` [patch 093/131] mm: memcontrol: switch to native NR_ANON_MAPPED counter
` [patch 094/131] mm: memcontrol: switch to native NR_ANON_THPS counter
` [patch 095/131] mm: memcontrol: convert anon and file-thp to new mem_cgroup_charge() API
` [patch 096/131] mm: memcontrol: drop unused try/commit/cancel charge API
` [patch 097/131] mm: memcontrol: prepare swap controller setup for integration
` [patch 098/131] mm: memcontrol: make swap tracking an integral part of memory control
` [patch 099/131] mm: memcontrol: charge swapin pages on instantiation
` [patch 100/131] mm: memcontrol: document the new swap control behavior
` [patch 101/131] mm: memcontrol: delete unused lrucare handling
` [patch 102/131] mm: memcontrol: update page->mem_cgroup stability rules
` [patch 103/131] mm: fix LRU balancing effect of new transparent huge pages
` [patch 104/131] mm: keep separate anon and file statistics on page reclaim activity
` [patch 105/131] mm: allow swappiness that prefers reclaiming anon over the file workingset
` [patch 106/131] mm: fold and remove lru_cache_add_anon() and lru_cache_add_file()
` [patch 107/131] mm: workingset: let cache workingset challenge anon
` [patch 108/131] mm: remove use-once cache bias from LRU balancing
` [patch 109/131] mm: vmscan: drop unnecessary div0 avoidance rounding in get_scan_count()
` [patch 110/131] mm: base LRU balancing on an explicit cost model
` [patch 111/131] mm: deactivations shouldn't bias the LRU balance
` [patch 112/131] mm: only count actual rotations as LRU reclaim cost
` [patch 113/131] mm: balance LRU lists based on relative thrashing
` [patch 114/131] mm: vmscan: determine anon/file pressure balance at the reclaim root
` [patch 115/131] mm: vmscan: reclaim writepage is IO cost
` [patch 116/131] mm: vmscan: limit the range of LRU type balancing
` [patch 117/131] mm: swap: fix vmstats for huge pages
` [patch 118/131] mm: swap: memcg: fix memcg stats "
` [patch 119/131] tools/vm/page_owner_sort.c: filter out unneeded line
` [patch 120/131] mm, mempolicy: fix up gup usage in lookup_node
` [patch 121/131] include/linux/memblock.h: fix minor typo and unclear comment
` [patch 122/131] sparc32: register memory occupied by kernel as memblock.memory
` [patch 123/131] hugetlbfs: get unmapped area below TASK_UNMAPPED_BASE for hugetlbfs
` [patch 124/131] mm: thp: don't need to drain lru cache when splitting and mlocking THP
` [patch 125/131] powerpc/mm: drop platform defined pmd_mknotpresent()
` [patch 126/131] mm/thp: rename pmd_mknotpresent() as pmd_mkinvalid()
` [patch 127/131] drivers/base/memory.c: cache memory blocks in xarray to accelerate lookup
` [patch 128/131] mm: add DEBUG_WX support
` [patch 129/131] riscv: support DEBUG_WX
` [patch 130/131] x86: mm: use ARCH_HAS_DEBUG_WX instead of arch defined
` [patch 131/131] arm64: "
` mmotm 2020-06-03-17-54 uploaded

[PATCH 00/10] Remove uninitialized_var() macro
 2020-06-04  0:50 UTC  (14+ messages)
` [PATCH 01/10] x86/mm/numa: Remove uninitialized_var() usage
` [PATCH 02/10] drbd: "
` [PATCH 03/10] b43: "
` [PATCH 04/10] rtlwifi: rtl8192cu: "
` [PATCH 05/10] ide: "
` [PATCH 06/10] clk: st: "
` [PATCH 07/10] spi: davinci: "
` [PATCH 08/10] checkpatch: Remove awareness of uninitialized_var() macro
` [PATCH 09/10] treewide: Remove uninitialized_var() usage
` [PATCH 10/10] compiler: Remove uninitialized_var() macro

[PATCH] mm/slub: fix a memory leak in sysfs_slab_add()
 2020-06-04  0:23 UTC  (14+ messages)
` kobject_init_and_add is easy to misuse

[PATCH 06/12] xen-blkfront: add callbacks for PM suspend and hibernation]
 2020-06-03 23:33 UTC 

[PATCH 00/12] Fix PM hibernation in Xen guests
 2020-06-03 22:40 UTC  (4+ messages)
` [PATCH 04/12] x86/xen: add system core suspend and resume callbacks

[PATCH] mm,thp: stop leaking unreleased file pages
 2020-06-03 22:19 UTC  (5+ messages)

[PATCH] mm: thp: Add new kernel parameters transparent_hugepage_defrag/khugepaged_defrag
 2020-06-03 22:09 UTC  (4+ messages)

[PATCH v14 13/15] mm/damon-test: Add a kunit test for recording setup
 2020-06-03 21:07 UTC  (3+ messages)
`  "

[linux-next:master] BUILD REGRESSION 48f99181fc118d82dc8bf6c7221ad1c654cb8bc2
 2020-06-03 20:24 UTC 

[PATCH] x86/mm: Fix boot with some memory above MAXMEM
 2020-06-03 19:18 UTC  (7+ messages)

[PATCH v4 00/14] mm: remove __ARCH_HAS_5LEVEL_HACK
 2020-06-03 19:05 UTC  (3+ messages)
` [PATCH v4 08/14] powerpc: add support for folded p4d page tables

[PATCH] vmalloc: Convert to XArray
 2020-06-03 17:35 UTC  (2+ messages)

[PATCH 0/2] mm: fix the names of general cma and hugetlb cma
 2020-06-03 17:28 UTC  (7+ messages)
` [PATCH 1/2] mm: cma: fix the name of CMA areas
` [PATCH 2/2] mm: hugetlb: fix the name of hugetlb CMA

[PATCH] mm/memblock: export max_pfn for kernel modules
 2020-06-03 17:06 UTC  (3+ messages)

[PATCH] mm/vmstat: Add events for PMD based THP migration without split
 2020-06-03 16:08 UTC  (13+ messages)

[RFC v2 0/9] DAMON: Support Access Monitoring of Any Address Space Including Physical Memory
 2020-06-03 16:09 UTC  (11+ messages)
` [RFC v2 1/9] mm/damon: Use vm-independent address range concept
` [RFC v2 2/9] mm/damon: Clean up code using 'struct damon_addr_range'
` [RFC v2 3/9] mm/damon: Make monitoring target regions init/update configurable
` [RFC v2 4/9] mm/damon/debugfs: Allow users to set initial monitoring target regions
` [RFC v2 5/9] Docs/damon: Document 'initial_regions' feature
` [RFC v2 6/9] mm/damon: Make access check primitive configurable
` [RFC v2 7/9] mm/damon: Implement callbacks for physical memory monitoring
` [RFC v2 8/9] mm/damon/debugfs: Support "
` [RFC v2 9/9] Docs/damon: Document physical memory monitoring support

[PATCH] mm/page_alloc: Skip setting nodemask when we are in interrupt
 2020-06-03 15:51 UTC 

[PATCH v4 0/4] make vm_committed_as_batch aware of vm overcommit policy
 2020-06-03 14:28 UTC  (6+ messages)
` [PATCH v4 2/4] mm/util.c: make vm_memory_committed() more accurate
` [PATCH v4 4/4] mm: adjust vm_committed_as_batch according to vm overcommit policy

[RFC PATCH] mm: swap: remove lru drain waiters
 2020-06-03 13:39 UTC  (4+ messages)

[PATCH v4 3/4] mm/util.c: remove the VM_WARN_ONCE for vm_committed_as underflow check
 2020-06-03 13:36 UTC  (2+ messages)

[RFC 00/16] KVM protected memory extension
 2020-06-03 11:14 UTC  (8+ messages)
` [RFC 02/16] x86/kvm: Introduce KVM memory protection feature

[PATCH v14 04/15] mm/damon: Adaptively adjust regions
 2020-06-03  8:21 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).