linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-06-04 11:34:25 to 2020-06-04 23:53:00 UTC [more...]

incoming
 2020-06-04 23:52 UTC  (127+ messages)
` [patch 001/127] kcov: cleanup debug messages
` [patch 002/127] kcov: fix potential use-after-free in kcov_remote_start
` [patch 003/127] kcov: move t->kcov assignments into kcov_start/stop
` [patch 004/127] kcov: move t->kcov_sequence assignment
` [patch 005/127] kcov: use t->kcov_mode as enabled indicator
` [patch 006/127] kcov: collect coverage from interrupts
` [patch 007/127] usb: core: kcov: collect coverage from usb complete callback
` [patch 008/127] mm/util.c: remove the VM_WARN_ONCE for vm_committed_as underflow check
` [patch 009/127] h8300: remove usage of __ARCH_USE_5LEVEL_HACK
` [patch 010/127] arm: add support for folded p4d page tables
` [patch 011/127] arm64: "
` [patch 012/127] hexagon: remove __ARCH_USE_5LEVEL_HACK
` [patch 013/127] ia64: add support for folded p4d page tables
` [patch 014/127] nios2: "
` [patch 015/127] openrisc: "
` [patch 016/127] powerpc: "
` [patch 017/127] sh: fault: modernize printing of kernel messages
` [patch 018/127] sh: drop __pXd_offset() macros that duplicate pXd_index() ones
` [patch 019/127] sh: add support for folded p4d page tables
` [patch 020/127] unicore32: remove __ARCH_USE_5LEVEL_HACK
` [patch 021/127] asm-generic: remove pgtable-nop4d-hack.h
` [patch 022/127] mm: remove __ARCH_HAS_5LEVEL_HACK and include/asm-generic/5level-fixup.h
` [patch 023/127] x86/mm: define mm_p4d_folded()
` [patch 024/127] mm/debug: add tests validating architecture page table helpers
` [patch 025/127] mm/vmalloc: fix a typo in comment
` [patch 026/127] arch/kmap: remove BUG_ON()
` [patch 027/127] arch/xtensa: move kmap build bug out of the way
` [patch 028/127] arch/kmap: remove redundant arch specific kmaps
` [patch 029/127] arch/kunmap: remove duplicate kunmap implementations
` [patch 030/127] {x86,powerpc,microblaze}/kmap: move preempt disable
` [patch 031/127] arch/kmap_atomic: consolidate duplicate code
` [patch 032/127] arch/kunmap_atomic: "
` [patch 033/127] arch/kmap: ensure kmap_prot visibility
` [patch 034/127] arch/kmap: don't hard code kmap_prot values
` [patch 035/127] arch/kmap: define kmap_atomic_prot() for all arch's
` [patch 036/127] drm: remove drm specific kmap_atomic code
` [patch 037/127] kmap: remove kmap_atomic_to_page()
` [patch 038/127] parisc/kmap: remove duplicate kmap code
` [patch 039/127] sparc: remove unnecessary includes
` [patch 040/127] kmap: consolidate kmap_prot definitions
` [patch 041/127] mm: add kvfree_sensitive() for freeing sensitive data objects
` [patch 042/127] mm/memory_hotplug: refrain from adding memory into an impossible node
` [patch 043/127] powerpc/pseries/hotplug-memory: stop checking is_mem_section_removable()
` [patch 044/127] mm/memory_hotplug: remove is_mem_section_removable()
` [patch 045/127] mm/memory_hotplug: set node_start_pfn of hotadded pgdat to 0
` [patch 046/127] mm/memory_hotplug: handle memblocks only with CONFIG_ARCH_KEEP_MEMBLOCK
` [patch 047/127] mm/memory_hotplug: introduce add_memory_driver_managed()
` [patch 048/127] kexec_file: don't place kexec images on IORESOURCE_MEM_DRIVER_MANAGED
` [patch 049/127] device-dax: add memory via add_memory_driver_managed()
` [patch 050/127] mm/memory_hotplug: disable the functionality for 32b
` [patch 051/127] mm: replace zero-length array with flexible-array member
` [patch 052/127] mm/memory_hotplug: fix a typo in comment "recoreded"->"recorded"
` [patch 053/127] mm: ksm: fix a typo in comment "alreaady"->"already"
` [patch 054/127] mm: mmap: fix a typo in comment "compatbility"->"compatibility"
` [patch 055/127] mm/hugetlb: fix a typos in comments
` [patch 056/127] mm/vmsan: fix some typos in comment
` [patch 057/127] mm/compaction: fix a typo in comment "pessemistic"->"pessimistic"
` [patch 058/127] mm/memblock: fix a typo in comment "implict"->"implicit"
` [patch 059/127] mm/list_lru: fix a typo in comment "numbesr"->"numbers"
` [patch 060/127] mm/filemap: fix a typo in comment "unneccssary"->"unnecessary"
` [patch 061/127] mm/frontswap: fix some typos in frontswap.c
` [patch 062/127] mm, memcg: fix some typos in memcontrol.c
` [patch 063/127] mm: fix a typo in comment "strucure"->"structure"
` [patch 064/127] mm/slub: fix a typo in comment "disambiguiation"->"disambiguation"
` [patch 065/127] mm/sparse: fix a typo in comment "convienence"->"convenience"
` [patch 066/127] mm/page-writeback: fix a typo in comment "effictive"->"effective"
` [patch 067/127] mm/memory: fix a typo in comment "attampt"->"attempt"
` [patch 068/127] mm: use false for bool variable
` [patch 069/127] include/linux/mm.h: return true in cpupid_pid_unset()
` [patch 070/127] zcomp: Use ARRAY_SIZE() for backends list
` [patch 071/127] proc: rename "catch" function argument
` [patch 072/127] user.c: make uidhash_table static
` [patch 073/127] get_maintainer: add email addresses from .yaml files
` [patch 074/127] get_maintainer: fix unexpected behavior for path/to//file (double slashes)
` [patch 075/127] lib/math: avoid trailing newline hidden in pr_fmt()
` [patch 076/127] lib: Add might_fault() to strncpy_from_user
` [patch 077/127] lib/test_lockup.c: make test_inode static
` [patch 078/127] lib/zlib: remove outdated and incorrect pre-increment optimization
` [patch 079/127] lib/percpu-refcount.c: use a more common logging style
` [patch 080/127] lib/flex_proportions.c: cleanup __fprop_inc_percpu_max
` [patch 081/127] lib: make a test module with set/clear bit
` [patch 082/127] include/linux/bitops.h: avoid clang shift-count-overflow warnings
` [patch 083/127] checkpatch: additional MAINTAINER section entry ordering checks
` [patch 084/127] checkpatch: look for c99 comments in ctx_locate_comment
` [patch 085/127] checkpatch: disallow --git and --file/--fix
` [patch 086/127] checkpatch: use patch subject when reading from stdin
` [patch 087/127] fs/binfmt_elf: remove redundant elf_map ifndef
` [patch 088/127] elfnote: mark all .note sections SHF_ALLOC
` [patch 089/127] init: allow distribution configuration of default init
` [patch 090/127] fat: don't allow to mount if the FAT length == 0
` [patch 091/127] fat: improve the readahead for FAT entries
` [patch 092/127] fs/seq_file.c: seq_read: Update pr_info_ratelimited
` [patch 093/127] include/linux/seq_file.h: introduce DEFINE_SEQ_ATTRIBUTE() helper macro
` [patch 094/127] mm/vmstat.c: convert to use DEFINE_SEQ_ATTRIBUTE macro
` [patch 095/127] kernel/kprobes.c: "
` [patch 096/127] exec: simplify the copy_strings_kernel calling convention
` [patch 097/127] exec: open code copy_string_kernel
` [patch 098/127] rapidio: avoid data race between file operation callbacks and mport_cdev_add()
` [patch 099/127] rapidio: convert get_user_pages() --> pin_user_pages()
` [patch 100/127] kernel/relay.c: handle alloc_percpu returning NULL in relay_open
` [patch 101/127] kernel/relay.c: fix read_pos error when multiple readers
` [patch 102/127] selftests/x86/pkeys: move selftests to arch-neutral directory
` [patch 103/127] selftests/vm/pkeys: rename all references to pkru to a generic name
` [patch 104/127] selftests/vm/pkeys: move generic definitions to header file
` [patch 105/127] selftests/vm/pkeys: move some definitions to arch-specific header
` [patch 106/127] selftests/vm/pkeys: make gcc check arguments of sigsafe_printf()
` [patch 107/127] selftests: vm: pkeys: Use sane types for pkey register
` [patch 108/127] selftests: vm: pkeys: add helpers for pkey bits
` [patch 109/127] selftests/vm/pkeys: fix pkey_disable_clear()
` [patch 110/127] selftests/vm/pkeys: fix assertion in pkey_disable_set/clear()
` [patch 111/127] selftests/vm/pkeys: fix alloc_random_pkey() to make it really random
` [patch 112/127] selftests: vm: pkeys: use the correct huge page size
` [patch 113/127] selftests/vm/pkeys: introduce generic pkey abstractions
` [patch 114/127] selftests/vm/pkeys: introduce powerpc support
` [patch 115/127] selftests/vm/pkeys: fix number of reserved powerpc pkeys
` [patch 116/127] selftests/vm/pkeys: fix assertion in test_pkey_alloc_exhaust()
` [patch 117/127] selftests/vm/pkeys: improve checks to determine pkey support
` [patch 118/127] selftests/vm/pkeys: associate key on a mapped page and detect access violation
` [patch 119/127] selftests/vm/pkeys: associate key on a mapped page and detect write violation
` [patch 120/127] selftests/vm/pkeys: detect write violation on a mapped access-denied-key page
` [patch 121/127] selftests/vm/pkeys: introduce a sub-page allocator
` [patch 122/127] selftests/vm/pkeys: test correct behaviour of pkey-0
` [patch 123/127] selftests/vm/pkeys: override access right definitions on powerpc
` [patch 124/127] selftests: vm: pkeys: use the correct page size "
` [patch 125/127] selftests: vm: pkeys: fix multilib builds for x86
` [patch 126/127] tools/testing/selftests/vm: remove duplicate headers

[RFC 00/16] KVM protected memory extension
 2020-06-04 23:29 UTC  (8+ messages)

[PATCH 00/12] Fix PM hibernation in Xen guests
 2020-06-04 23:03 UTC  (7+ messages)
` [PATCH 03/12] x86/xen: Introduce new function to map HYPERVISOR_shared_info on Resume
` [PATCH 09/12] x86/xen: save and restore steal clock

[hnaz-linux-mm:master 298/544] arch/mips/include/asm/barrier.h:(.text.cps_kexec_nonboot_cpu+0x88): undefined reference to `cps_pm_enter_state'
 2020-06-04 22:55 UTC 

[PATCH 01/10] x86/mm/numa: Remove uninitialized_var() usage
 2020-06-04 22:39 UTC  (8+ messages)

[PATCH] x86/mm: use max memory block size with unaligned memory end
 2020-06-04 22:27 UTC  (9+ messages)

[PATCH] mm, page_alloc: skip ->waternark_boost for atomic order-0 allocations
 2020-06-04 21:43 UTC  (2+ messages)

[PATCH 00/10] Remove uninitialized_var() macro
 2020-06-04 20:58 UTC  (24+ messages)
` [PATCH 02/10] drbd: Remove uninitialized_var() usage
` [PATCH 03/10] b43: "
` [PATCH 04/10] rtlwifi: rtl8192cu: "
` [PATCH 05/10] ide: "
` [PATCH 07/10] spi: davinci: "
` [PATCH 09/10] treewide: "

[PATCH] mm: Fix pud_alloc_track()
 2020-06-04 20:36 UTC  (5+ messages)

[PATCH 1/1] psi: eliminate kthread_worker from psi trigger scheduling mechanism
 2020-06-04 19:20 UTC  (3+ messages)

slub freelist issue / BUG: unable to handle page fault for address: 000000003ffe0018
 2020-06-04 18:46 UTC  (6+ messages)

[linux-next:master] BUILD REGRESSION d4899e5542c15062cc55cac0ca99025bb64edc61
 2020-06-04 18:10 UTC 

[PATCH V2] mm/vmstat: Add events for THP migration without split
 2020-06-04 16:49 UTC  (5+ messages)

Re: [RFC v2 7/9] mm/damon: Implement callbacks for physical memory monitoring
 2020-06-04 16:01 UTC  (6+ messages)
`  "

[PATCH mm v6 0/4] memcg: Slow down swap allocation as the available space gets depleted
 2020-06-04 15:57 UTC  (3+ messages)
` [PATCH mm v6 4/4] mm: automatically penalize tasks with high swap use

[PATCH 00/14] mm: balance LRU lists based on relative thrashing v2
 2020-06-04 15:05 UTC  (13+ messages)
` [PATCH 05/14] mm: workingset: let cache workingset challenge anon

[RFC PATCH 0/8] dax: Add a dax-rmap tree to support reflink
 2020-06-04 14:51 UTC  (6+ messages)
  ` 回复: "

[PATCH] mm/memory_hotplug: fix default_zone_for_pfn() to include highmem zone range
 2020-06-04 14:49 UTC  (2+ messages)

[PATCH] mm/vmalloc: fix a typo in comment
 2020-06-04 18:52 UTC  (2+ messages)

[linux-next:pending-fixes] BUILD SUCCESS 4ce9138f1bd4aa7b70d042445b6ac98c39e569ed
 2020-06-04 13:21 UTC 

[PATCH v3 0/3] selftests: powerpc: Fixes and execute-disable test for pkeys
 2020-06-04 12:56 UTC  (4+ messages)
` [PATCH v3 1/3] selftests: powerpc: Fix pkey access right updates
` [PATCH v3 2/3] selftests: powerpc: Move Hash MMU check to utilities
` [PATCH v3 3/3] selftests: powerpc: Add test for execute-disabled pkeys


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).