linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-10-12 20:45:06 to 2020-10-13 23:52:08 UTC [more...]

incoming
 2020-10-13 23:52 UTC  (69+ messages)
` [patch 001/181] compiler-clang: add build check for clang 10.0.1
` [patch 002/181] Revert "kbuild: disable clang's default use of -fmerge-all-constants"
` [patch 003/181] Revert "arm64: bti: Require clang >= 10.0.1 for in-kernel BTI support"
` [patch 004/181] Revert "arm64: vdso: Fix compilation with clang older than 8"
` [patch 005/181] Partially revert "ARM: 8905/1: Emit __gnu_mcount_nc when using Clang 10.0.0 or newer"
` [patch 006/181] kasan: remove mentions of unsupported Clang versions
` [patch 007/181] compiler-gcc: improve version error
` [patch 008/181] compiler.h: avoid escaped section names
` [patch 009/181] export.h: fix section name for CONFIG_TRIM_UNUSED_KSYMS for Clang
` [patch 010/181] kbuild: doc: describe proper script invocation
` [patch 011/181] scripts/spelling.txt: increase error-prone spell checking
` [patch 012/181] scripts/spelling.txt: add "arbitrary" typo
` [patch 013/181] scripts/decodecode: add the capability to supply the program counter
` [patch 014/181] ntfs: add check for mft record size in superblock
` [patch 015/181] ocfs2: delete repeated words in comments
` [patch 016/181] ocfs2: fix potential soft lockup during fstrim
` [patch 017/181] fs/xattr.c: fix kernel-doc warnings for setxattr & removexattr
` [patch 018/181] fs_parse: mark fs_param_bad_value() as static
` [patch 019/181] mm/slab.c: clean code by removing redundant if condition
` [patch 020/181] include/linux/slab.h: fix a typo error in comment
` [patch 021/181] mm/slub.c: branch optimization in free slowpath
` [patch 022/181] mm/slub: fix missing ALLOC_SLOWPATH stat when bulk alloc
` [patch 023/181] mm/slub: make add_full() condition more explicit
` [patch 024/181] mm/kmemleak: rely on rcu for task stack scanning
` [patch 025/181] mm,kmemleak-test.c: move kmemleak-test.c to samples dir
` [patch 026/181] x86/numa: cleanup configuration dependent command-line options
` [patch 027/181] x86/numa: add 'nohmat' option
` [patch 028/181] efi/fake_mem: arrange for a resource entry per efi_fake_mem instance
` [patch 029/181] ACPI: HMAT: refactor hmat_register_target_device to hmem_register_device
` [patch 030/181] resource: report parent to walk_iomem_res_desc() callback
` [patch 031/181] mm/memory_hotplug: introduce default phys_to_target_node() implementation
` [patch 032/181] ACPI: HMAT: attach a device for each soft-reserved range
` [patch 033/181] device-dax: drop the dax_region.pfn_flags attribute
` [patch 034/181] device-dax: move instance creation parameters to 'struct dev_dax_data'
` [patch 035/181] device-dax: make pgmap optional for instance creation
` [patch 036/181] device-dax/kmem: introduce dax_kmem_range()
` [patch 037/181] device-dax/kmem: move resource name tracking to drvdata
` [patch 038/181] device-dax/kmem: replace release_resource() with release_mem_region()
` [patch 039/181] device-dax: add an allocation interface for device-dax instances
` [patch 040/181] device-dax: introduce 'struct dev_dax' typed-driver operations
` [patch 041/181] device-dax: introduce 'seed' devices
` [patch 042/181] drivers/base: make device_find_child_by_name() compatible with sysfs inputs
` [patch 043/181] device-dax: add resize support
` [patch 044/181] mm/memremap_pages: convert to 'struct range'
` [patch 045/181] mm/memremap_pages: support multiple ranges per invocation
` [patch 046/181] device-dax: add dis-contiguous resource support
` [patch 047/181] device-dax: introduce 'mapping' devices
` [patch 048/181] device-dax: make align a per-device property
` [patch 049/181] device-dax: add an 'align' attribute
` [patch 050/181] dax/hmem: introduce dax_hmem.region_idle parameter
` [patch 051/181] device-dax: add a range mapping allocation attribute
` [patch 052/181] mm/debug.c: do not dereference i_ino blindly
` [patch 053/181] mm, dump_page: rename head_mapcount() --> head_compound_mapcount()
` [patch 054/181] mm: factor find_get_incore_page out of mincore_page
` [patch 055/181] mm: use find_get_incore_page in memcontrol
` [patch 056/181] mm: optimise madvise WILLNEED
` [patch 057/181] proc: optimise smaps for shmem entries
` [patch 058/181] i915: use find_lock_page instead of find_lock_entry
` [patch 059/181] mm: convert find_get_entry to return the head page
` [patch 060/181] mm/shmem: return head page from find_lock_entry
` [patch 061/181] mm: add find_lock_head
` [patch 062/181] mm/filemap: fix filemap_map_pages for THP
` [patch 063/181] mm, fadvise: improve the expensive remote LRU cache draining after FADV_DONTNEED
` [patch 064/181] mm/gup_benchmark: update the documentation in Kconfig
` [patch 065/181] mm/gup_benchmark: use pin_user_pages for FOLL_LONGTERM flag
` [patch 066/181] mm/gup: don't permit users to call get_user_pages with FOLL_LONGTERM
` [patch 067/181] mm/gup: protect unpin_user_pages() against npages==-ERRNO
` [patch 068/181] swap: rename SWP_FS to SWAP_FS_OPS to avoid ambiguity

[RFC PATCH 0/3] hugetlbfs: introduce hinode_rwsem for pmd sharing synchronization
 2020-10-13 23:11 UTC  (4+ messages)
` [RFC PATCH 1/3] hugetlbfs: revert use of i_mmap_rwsem for pmd sharing and more sync
` [RFC PATCH 2/3] hugetlbfs: introduce hinode_rwsem for pmd sharing synchronization
` [RFC PATCH 3/3] huegtlbfs: handle page fault/truncate races

[linux-next:master] BUILD REGRESSION f2fb1afc57304f9dd68c20a08270e287470af2eb
 2020-10-13 22:27 UTC 

[linux-next:master 9016/14891] drivers/virt/nitro_enclaves/ne_misc_dev.c:1511:14: sparse: sparse: incorrect type in assignment (different base types)
 2020-10-13 21:18 UTC 

[PATCH v4 00/13] mm/debug_vm_pgtable fixes
 2020-10-13 20:58 UTC  (2+ messages)

[PATCH RFC PKS/PMEM 00/58] PMEM: Introduce stray write protection for PMEM
 2020-10-13 20:52 UTC  (12+ messages)
` [PATCH RFC PKS/PMEM 24/58] fs/freevxfs: Utilize new kmap_thread()
` [PATCH RFC PKS/PMEM 33/58] fs/cramfs: "

[PATCH 0/4] Some more lock_page work
 2020-10-13 20:03 UTC  (2+ messages)

[PATCH RFC V3 0/9] PKS: Add Protection Keys Supervisor (PKS) support RFC v3
 2020-10-13 19:44 UTC  (18+ messages)
` [PATCH RFC V3 1/9] x86/pkeys: Create pkeys_common.h
` [PATCH RFC V3 2/9] x86/fpu: Refactor arch_set_user_pkey_access() for PKS support
` [PATCH RFC V3 3/9] x86/pks: Enable Protection Keys Supervisor (PKS)
` [PATCH RFC V3 4/9] x86/pks: Preserve the PKRS MSR on context switch
` [PATCH RFC V3 5/9] x86/pks: Add PKS kernel API
` [PATCH RFC V3 7/9] x86/entry: Preserve PKRS MSR across exceptions
` [PATCH RFC V3 8/9] x86/fault: Report the PKRS state on fault
` [PATCH RFC V3 9/9] x86/pks: Add PKS test code

[PATCH v3 0/2] Add tracepoints around mmap_lock acquisition
 2020-10-13 19:42 UTC  (5+ messages)
` [PATCH v3 1/2] tracing: support "bool" type in synthetic trace events
` [PATCH v3 2/2] mmap_lock: add tracepoints around lock acquisition

[PATCH] mm: memcontrol: Remove unused mod_memcg_obj_state()
 2020-10-13 19:28 UTC  (3+ messages)

[PATCH v2 0/3] Actually fix freelist pointer vs redzoning
 2020-10-13 16:44 UTC  (5+ messages)
` [PATCH v2 1/3] mm/slub: Clarify verification reporting
` [PATCH v2 3/3] mm/slub: Actually fix freelist pointer vs redzoning

[PATCH] mm: proc: add Sock to /proc/meminfo
 2020-10-13 15:28 UTC  (17+ messages)
  ` [External] "

[PATCH v5 0/4] HWpoison: further fixes and cleanups
 2020-10-13 14:44 UTC  (5+ messages)
` [PATCH v5 1/4] mm,hwpoison: drain pcplists before bailing out for non-buddy zero-refcount page
` [PATCH v5 2/4] mm,hwpoison: take free pages off the buddy freelists
` [PATCH v5 3/4] mm,hwpoison: take free pages off the buddy freelists for hugetlb
` [PATCH v5 4/4] mm,hwpoison: drop unneeded pcplist draining

[PATCH 00/11] Remove assumptions of THP size
 2020-10-13 13:52 UTC  (3+ messages)
` [PATCH 03/11] mm/page_owner: Change split_page_owner to take a count

[PATCH 0/3] Wait for I/O without holding a page reference
 2020-10-13 13:32 UTC  (7+ messages)
` [PATCH 1/3] mm: Pass a sleep state to put_and_wait_on_page_locked
` [PATCH 2/3] mm: Don't hold a page reference while waiting for unlock
` [PATCH 2/3] mm/filemap: "
` [PATCH 3/3] mm: Inline __wait_on_page_locked_async into caller

Performance regressions in "boot_time" tests in Linux 5.8 Kernel
 2020-10-13 13:17 UTC  (5+ messages)

[linux-next:master 14484/14891] WARNING: modpost: vmlinux.o(.text.unlikely+0x2830): Section mismatch in reference from the function pmax_setup_memory_region() to the function .meminit.text:memblock_add()
 2020-10-13 13:07 UTC 

[PATCH v6 23/80] docs: get rid of :c:type explicit declarations for structs
 2020-10-13 12:02 UTC  (4+ messages)
` [PATCH v6 55/80] memblock: get rid of a :c:type leftover
` [PATCH v6 78/80] mm/doc: fix a literal block markup

[PATCH] mm, oom: enable rate-limiting controls for oom dumps
 2020-10-13 11:56 UTC  (11+ messages)

[PATCH v2] mm, oom: enable rate-limiting controls for oom dumps
 2020-10-13 11:18 UTC  (2+ messages)

[linux-next:pending-fixes] BUILD SUCCESS f4dd85cd788b42bad73ffd0ae6d3f954fb746ed6
 2020-10-13 10:49 UTC 

[PATCH 1/2] mm/mprotect: Call arch_validate_prot under mmap_lock and with length
 2020-10-13  9:16 UTC  (7+ messages)

[linux-next:master 620/14813] drivers/gpu/drm/mgag200/mgag200_drv.c:232:9: error: implicit declaration of function 'vmalloc'; did you mean
 2020-10-13  4:18 UTC 

[PATCH 00/13] mm: clean up some lru related pieces
 2020-10-13  2:30 UTC  (5+ messages)

[Question Resend] About z3fold page migration
 2020-10-13  1:46 UTC 

[PATCH 0/6] mremap: move_vma() fixes
 2020-10-13  1:34 UTC  (7+ messages)
` [PATCH 1/6] mm/mremap: Account memory on do_munmap() failure
` [PATCH 2/6] mm/mremap: For MREMAP_DONTUNMAP check security_vm_enough_memory_mm()
` [PATCH 3/6] mremap: Don't allow MREMAP_DONTUNMAP on special_mappings and aio
` [PATCH 4/6] vm_ops: Rename .split() callback to .may_split()
` [PATCH 5/6] mremap: Check if it's possible to split original vma
` [PATCH 6/6] mm: Forbid splitting special mappings

[PATCH FIX v0] mm: memcg/slab: Uncharge during kmem_cache_free_bulk()
 2020-10-13  0:40 UTC  (4+ messages)

[PATCH] mm: memcg/slab: fix slab statistics in !SMP configuration
 2020-10-13  0:31 UTC  (6+ messages)
    ` [kbuild-all] "

[PATCH RFC PKS/PMEM 22/58] fs/f2fs: Utilize new kmap_thread()
 2020-10-12 23:31 UTC  (11+ messages)

[linux-next:master] BUILD REGRESSION 148fdf990dee4efd23c1114811b205de9c966680
 2020-10-12 23:19 UTC 

[RFC][PATCH 0/9] [v4][RESEND] Migrate Pages in lieu of discard
 2020-10-12 21:30 UTC  (2+ messages)

[PATCH v2] mm/hmm: make device private reference counts zero based
 2020-10-12 21:14 UTC  (2+ messages)

[hnaz-linux-mm:master 412/421] drivers/pci/switch/switchtec.c:1075:33: sparse: sparse: incorrect type in argument 1 (different address spaces)
 2020-10-12 21:13 UTC 

[PATCH v14 00/26] Control-flow Enforcement: Shadow Stack
 2020-10-12 20:48 UTC  (4+ messages)
` [PATCH v14 03/26] x86/fpu/xstate: Introduce CET MSR XSAVES supervisor states

[PATCH v5 00/40] kasan: add hardware tag-based mode for arm64
 2020-10-12 20:44 UTC  (38+ messages)
` [PATCH v5 04/40] arm64: kasan: Add arch layer for memory tagging helpers
` [PATCH v5 05/40] arm64: mte: Add in-kernel tag fault handler
` [PATCH v5 06/40] arm64: kasan: Enable in-kernel MTE
` [PATCH v5 07/40] arm64: mte: Convert gcr_user into an exclude mask
` [PATCH v5 08/40] arm64: mte: Switch GCR_EL1 in kernel entry and exit
` [PATCH v5 09/40] arm64: kasan: Align allocations for HW_TAGS
` [PATCH v5 10/40] kasan: drop unnecessary GPL text from comment headers
` [PATCH v5 11/40] kasan: KASAN_VMALLOC depends on KASAN_GENERIC
` [PATCH v5 12/40] kasan: group vmalloc code
` [PATCH v5 13/40] kasan: shadow declarations only for software modes
` [PATCH v5 14/40] kasan: rename (un)poison_shadow to (un)poison_memory
` [PATCH v5 15/40] kasan: rename KASAN_SHADOW_* to KASAN_GRANULE_*
` [PATCH v5 16/40] kasan: only build init.c for software modes
` [PATCH v5 17/40] kasan: split out shadow.c from common.c
` [PATCH v5 18/40] kasan: define KASAN_GRANULE_PAGE
` [PATCH v5 19/40] kasan: rename report and tags files
` [PATCH v5 20/40] kasan: don't duplicate config dependencies
` [PATCH v5 21/40] kasan: hide invalid free check implementation
` [PATCH v5 22/40] kasan: decode stack frame only with KASAN_STACK_ENABLE
` [PATCH v5 23/40] kasan, arm64: only init shadow for software modes
` [PATCH v5 24/40] kasan, arm64: only use kasan_depth "
` [PATCH v5 25/40] kasan: rename addr_has_shadow to addr_has_metadata
` [PATCH v5 26/40] kasan: rename print_shadow_for_address to print_memory_metadata
` [PATCH v5 27/40] kasan: kasan_non_canonical_hook only for software modes
` [PATCH v5 28/40] kasan: rename SHADOW layout macros to META
` [PATCH v5 29/40] kasan: separate metadata_fetch_row for each mode
` [PATCH v5 30/40] kasan, arm64: don't allow SW_TAGS with ARM64_MTE
` [PATCH v5 31/40] kasan: introduce CONFIG_KASAN_HW_TAGS
` [PATCH v5 32/40] kasan: define KASAN_GRANULE_SIZE for HW_TAGS
` [PATCH v5 33/40] kasan, x86, s390: update undef CONFIG_KASAN
` [PATCH v5 34/40] kasan, arm64: expand CONFIG_KASAN checks
` [PATCH v5 35/40] kasan, arm64: implement HW_TAGS runtime
` [PATCH v5 36/40] kasan, arm64: print report from tag fault handler
` [PATCH v5 37/40] kasan, mm: reset tags when accessing metadata
` [PATCH v5 38/40] kasan, arm64: enable CONFIG_KASAN_HW_TAGS
` [PATCH v5 39/40] kasan: add documentation for hardware tag-based mode
` [PATCH v5 40/40] kselftest/arm64: Check GCR_EL1 after context switch


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).