linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-10-13 13:52:34 to 2020-10-13 23:57:05 UTC [more...]

[PATCH RFC V3 0/9] PKS: Add Protection Keys Supervisor (PKS) support RFC v3
 2020-10-13 23:56 UTC  (19+ messages)
` [PATCH RFC V3 1/9] x86/pkeys: Create pkeys_common.h
` [PATCH RFC V3 2/9] x86/fpu: Refactor arch_set_user_pkey_access() for PKS support
` [PATCH RFC V3 3/9] x86/pks: Enable Protection Keys Supervisor (PKS)
` [PATCH RFC V3 4/9] x86/pks: Preserve the PKRS MSR on context switch
` [PATCH RFC V3 5/9] x86/pks: Add PKS kernel API
` [PATCH RFC V3 7/9] x86/entry: Preserve PKRS MSR across exceptions
` [PATCH RFC V3 8/9] x86/fault: Report the PKRS state on fault
` [PATCH RFC V3 9/9] x86/pks: Add PKS test code

incoming
 2020-10-13 23:56 UTC  (156+ messages)
` [patch 001/181] compiler-clang: add build check for clang 10.0.1
` [patch 002/181] Revert "kbuild: disable clang's default use of -fmerge-all-constants"
` [patch 003/181] Revert "arm64: bti: Require clang >= 10.0.1 for in-kernel BTI support"
` [patch 004/181] Revert "arm64: vdso: Fix compilation with clang older than 8"
` [patch 005/181] Partially revert "ARM: 8905/1: Emit __gnu_mcount_nc when using Clang 10.0.0 or newer"
` [patch 006/181] kasan: remove mentions of unsupported Clang versions
` [patch 007/181] compiler-gcc: improve version error
` [patch 008/181] compiler.h: avoid escaped section names
` [patch 009/181] export.h: fix section name for CONFIG_TRIM_UNUSED_KSYMS for Clang
` [patch 010/181] kbuild: doc: describe proper script invocation
` [patch 011/181] scripts/spelling.txt: increase error-prone spell checking
` [patch 012/181] scripts/spelling.txt: add "arbitrary" typo
` [patch 013/181] scripts/decodecode: add the capability to supply the program counter
` [patch 014/181] ntfs: add check for mft record size in superblock
` [patch 015/181] ocfs2: delete repeated words in comments
` [patch 016/181] ocfs2: fix potential soft lockup during fstrim
` [patch 017/181] fs/xattr.c: fix kernel-doc warnings for setxattr & removexattr
` [patch 018/181] fs_parse: mark fs_param_bad_value() as static
` [patch 019/181] mm/slab.c: clean code by removing redundant if condition
` [patch 020/181] include/linux/slab.h: fix a typo error in comment
` [patch 021/181] mm/slub.c: branch optimization in free slowpath
` [patch 022/181] mm/slub: fix missing ALLOC_SLOWPATH stat when bulk alloc
` [patch 023/181] mm/slub: make add_full() condition more explicit
` [patch 024/181] mm/kmemleak: rely on rcu for task stack scanning
` [patch 025/181] mm,kmemleak-test.c: move kmemleak-test.c to samples dir
` [patch 026/181] x86/numa: cleanup configuration dependent command-line options
` [patch 027/181] x86/numa: add 'nohmat' option
` [patch 028/181] efi/fake_mem: arrange for a resource entry per efi_fake_mem instance
` [patch 029/181] ACPI: HMAT: refactor hmat_register_target_device to hmem_register_device
` [patch 030/181] resource: report parent to walk_iomem_res_desc() callback
` [patch 031/181] mm/memory_hotplug: introduce default phys_to_target_node() implementation
` [patch 032/181] ACPI: HMAT: attach a device for each soft-reserved range
` [patch 033/181] device-dax: drop the dax_region.pfn_flags attribute
` [patch 034/181] device-dax: move instance creation parameters to 'struct dev_dax_data'
` [patch 035/181] device-dax: make pgmap optional for instance creation
` [patch 036/181] device-dax/kmem: introduce dax_kmem_range()
` [patch 037/181] device-dax/kmem: move resource name tracking to drvdata
` [patch 038/181] device-dax/kmem: replace release_resource() with release_mem_region()
` [patch 039/181] device-dax: add an allocation interface for device-dax instances
` [patch 040/181] device-dax: introduce 'struct dev_dax' typed-driver operations
` [patch 041/181] device-dax: introduce 'seed' devices
` [patch 042/181] drivers/base: make device_find_child_by_name() compatible with sysfs inputs
` [patch 043/181] device-dax: add resize support
` [patch 044/181] mm/memremap_pages: convert to 'struct range'
` [patch 045/181] mm/memremap_pages: support multiple ranges per invocation
` [patch 046/181] device-dax: add dis-contiguous resource support
` [patch 047/181] device-dax: introduce 'mapping' devices
` [patch 048/181] device-dax: make align a per-device property
` [patch 049/181] device-dax: add an 'align' attribute
` [patch 050/181] dax/hmem: introduce dax_hmem.region_idle parameter
` [patch 051/181] device-dax: add a range mapping allocation attribute
` [patch 052/181] mm/debug.c: do not dereference i_ino blindly
` [patch 053/181] mm, dump_page: rename head_mapcount() --> head_compound_mapcount()
` [patch 054/181] mm: factor find_get_incore_page out of mincore_page
` [patch 055/181] mm: use find_get_incore_page in memcontrol
` [patch 056/181] mm: optimise madvise WILLNEED
` [patch 057/181] proc: optimise smaps for shmem entries
` [patch 058/181] i915: use find_lock_page instead of find_lock_entry
` [patch 059/181] mm: convert find_get_entry to return the head page
` [patch 060/181] mm/shmem: return head page from find_lock_entry
` [patch 061/181] mm: add find_lock_head
` [patch 062/181] mm/filemap: fix filemap_map_pages for THP
` [patch 063/181] mm, fadvise: improve the expensive remote LRU cache draining after FADV_DONTNEED
` [patch 064/181] mm/gup_benchmark: update the documentation in Kconfig
` [patch 065/181] mm/gup_benchmark: use pin_user_pages for FOLL_LONGTERM flag
` [patch 066/181] mm/gup: don't permit users to call get_user_pages with FOLL_LONGTERM
` [patch 067/181] mm/gup: protect unpin_user_pages() against npages==-ERRNO
` [patch 068/181] swap: rename SWP_FS to SWAP_FS_OPS to avoid ambiguity
` [patch 069/181] mm: remove activate_page() from unuse_pte()
` [patch 070/181] mm: remove superfluous __ClearPageActive()
` [patch 071/181] mm/swap.c: fix confusing comment in release_pages()
` [patch 072/181] mm/swap_slots.c: remove always zero and unused return value of enable_swap_slots_cache()
` [patch 073/181] mm/page_io.c: remove useless out label in __swap_writepage()
` [patch 074/181] mm/swap.c: fix incomplete comment in lru_cache_add_inactive_or_unevictable()
` [patch 075/181] mm/swapfile.c: remove unnecessary goto out in _swap_info_get()
` [patch 076/181] mm/swapfile.c: fix potential memory leak in sys_swapon
` [patch 077/181] mm/memremap.c: convert devmap static branch to {inc,dec}
` [patch 078/181] mm: memcontrol: use flex_array_size() helper in memcpy()
` [patch 079/181] mm: memcontrol: use the preferred form for passing the size of a structure type
` [patch 080/181] mm: memcg/slab: fix racy access to page->mem_cgroup in mem_cgroup_from_obj()
` [patch 081/181] mm: memcontrol: correct the comment of mem_cgroup_iter()
` [patch 082/181] mm/memcg: clean up obsolete enum charge_type
` [patch 083/181] mm/memcg: simplify mem_cgroup_get_max()
` [patch 084/181] mm/memcg: unify swap and memsw page counters
` [patch 085/181] mm: memcontrol: add the missing numa_stat interface for cgroup v2
` [patch 086/181] mm/page_counter: correct the obsolete func name in the comment of page_counter_try_charge()
` [patch 087/181] mm: memcontrol: reword obsolete comment of mem_cgroup_unmark_under_oom()
` [patch 088/181] mm: memcg/slab: uncharge during kmem_cache_free_bulk()
` [patch 089/181] mm/memcg: fix device private memcg accounting
` [patch 090/181] selftests/vm: fix false build success on the second and later attempts
` [patch 091/181] selftests/vm: fix incorrect gcc invocation in some cases
` [patch 092/181] mm: account PMD tables like PTE tables
` [patch 093/181] mm/memory.c: fix typo in __do_fault() comment
` [patch 094/181] mm/memory.c: replace vmf->vma with variable vma
` [patch 095/181] mm/mmap: rename __vma_unlink_common() to __vma_unlink()
` [patch 096/181] mm/mmap: leverage vma_rb_erase_ignore() to implement vma_rb_erase()
` [patch 097/181] mmap locking API: add mmap_lock_is_contended()
` [patch 098/181] mm: smaps*: extend smap_gather_stats to support specified beginning
` [patch 099/181] mm: proc: smaps_rollup: do not stall write attempts on mmap_lock
` [patch 100/181] mm: move PageDoubleMap bit
` [patch 101/181] mm: simplify PageDoubleMap with PF_SECOND policy
` [patch 102/181] mm/mmap: leave adjust_next as virtual address instead of page frame number
` [patch 103/181] mm/memory.c: fix spello of "function"
` [patch 104/181] mm/mmap: not necessary to check mapping separately
` [patch 105/181] mm/mmap: check on file instead of the rb_root_cached of its address_space
` [patch 106/181] mm: use helper function mapping_allow_writable()
` [patch 107/181] mm/mmap.c: use helper function allow_write_access() in __remove_shared_vm_struct()
` [patch 108/181] mm/mmap.c: replace do_brk with do_brk_flags in comment of insert_vm_struct()
` [patch 109/181] mm: remove src/dst mm parameter in copy_page_range()
` [patch 110/181] include/linux/huge_mm.h: remove mincore_huge_pmd declaration
` [patch 111/181] tools/testing/selftests/vm/hmm-tests.c: use the new SKIP() macro
` [patch 112/181] lib/test_hmm.c: remove unused dmirror_zero_page
` [patch 113/181] mm/dmapool.c: replace open-coded list_for_each_entry_safe()
` [patch 114/181] mm/dmapool.c: replace hard coded function name with __func__
` [patch 115/181] mm/memory-failure: do pgoff calculation before for_each_process()
` [patch 116/181] mm/memory-failure.c: remove unused macro `writeback'
` [patch 117/181] mm/vmalloc.c: update the comment in __vmalloc_area_node()
` [patch 118/181] mm/vmalloc.c: fix the comment of find_vm_area
` [patch 119/181] docs/vm: fix 'mm_count' vs 'mm_users' counter confusion
` [patch 120/181] kasan/kunit: add KUnit Struct to Current Task
` [patch 121/181] KUnit: KASAN Integration
` [patch 122/181] KASAN: port KASAN Tests to KUnit
` [patch 123/181] KASAN: Testing Documentation
` [patch 124/181] mm: kasan: do not panic if both panic_on_warn and kasan_multishot set
` [patch 125/181] mm/page_alloc: tweak comments in has_unmovable_pages()
` [patch 127/181] mm/page_isolation: drop WARN_ON_ONCE() in set_migratetype_isolate()
` [patch 128/181] mm/page_isolation: cleanup set_migratetype_isolate()
` [patch 129/181] virtio-mem: don't special-case ZONE_MOVABLE
` [patch 130/181] mm: document semantics of ZONE_MOVABLE
` [patch 131/181] mm, isolation: avoid checking unmovable pages across pageblock boundary
` [patch 132/181] mm/page_alloc.c: clean code by removing unnecessary initialization
` [patch 133/181] mm/page_alloc.c: micro-optimization remove unnecessary branch
` [patch 134/181] mm/page_alloc.c: fix early params garbage value accesses
` [patch 135/181] mm/page_alloc.c: clean code by merging two functions
` [patch 136/181] mm/page_alloc.c: __perform_reclaim should return 'unsigned long'
` [patch 137/181] mmzone: clean code by removing unused macro parameter
` [patch 138/181] mm: move call to compound_head() in release_pages()
` [patch 139/181] mm/page_alloc.c: fix freeing non-compound pages
` [patch 140/181] include/linux/gfp.h: clarify usage of GFP_ATOMIC in !preemptible contexts
` [patch 141/181] mm/hugetlb.c: make is_hugetlb_entry_hwpoisoned return bool
` [patch 142/181] mm/hugetlb.c: remove the unnecessary non_swap_entry()
` [patch 143/181] doc/vm: fix typo in the hugetlb admin documentation
` [patch 144/181] mm/hugetlb: not necessary to coalesce regions recursively
` [patch 145/181] mm/hugetlb: remove VM_BUG_ON(!nrg) in get_file_region_entry_from_cache()
` [patch 146/181] mm/hugetlb: use list_splice to merge two list at once
` [patch 147/181] mm/hugetlb: count file_region to be added when regions_needed != NULL
` [patch 148/181] mm/hugetlb: a page from buddy is not on any list
` [patch 149/181] mm/hugetlb: narrow the hugetlb_lock protection area during preparing huge page
` [patch 150/181] mm/hugetlb: take the free hpage during the iteration directly
` [patch 151/181] hugetlb: add lockdep check for i_mmap_rwsem held in huge_pmd_share
` [patch 152/181] mm/vmscan: fix infinite loop in drop_slab_node
` [patch 153/181] mm/vmscan: fix comments for isolate_lru_page()
` [patch 154/181] mm/z3fold.c: use xx_zalloc instead xx_alloc and memset
` [patch 155/181] mm/zbud: remove redundant initialization
` [patch 156/181] mm/compaction.c: micro-optimization remove unnecessary branch

[RFC PATCH 0/3] hugetlbfs: introduce hinode_rwsem for pmd sharing synchronization
 2020-10-13 23:11 UTC  (4+ messages)
` [RFC PATCH 1/3] hugetlbfs: revert use of i_mmap_rwsem for pmd sharing and more sync
` [RFC PATCH 2/3] hugetlbfs: introduce hinode_rwsem for pmd sharing synchronization
` [RFC PATCH 3/3] huegtlbfs: handle page fault/truncate races

[linux-next:master] BUILD REGRESSION f2fb1afc57304f9dd68c20a08270e287470af2eb
 2020-10-13 22:27 UTC 

[linux-next:master 9016/14891] drivers/virt/nitro_enclaves/ne_misc_dev.c:1511:14: sparse: sparse: incorrect type in assignment (different base types)
 2020-10-13 21:18 UTC 

[PATCH v4 00/13] mm/debug_vm_pgtable fixes
 2020-10-13 20:58 UTC  (2+ messages)

[PATCH RFC PKS/PMEM 00/58] PMEM: Introduce stray write protection for PMEM
 2020-10-13 20:52 UTC  (12+ messages)
` [PATCH RFC PKS/PMEM 24/58] fs/freevxfs: Utilize new kmap_thread()
` [PATCH RFC PKS/PMEM 33/58] fs/cramfs: "

[PATCH 0/4] Some more lock_page work
 2020-10-13 20:03 UTC  (2+ messages)

[PATCH v3 0/2] Add tracepoints around mmap_lock acquisition
 2020-10-13 19:42 UTC  (5+ messages)
` [PATCH v3 1/2] tracing: support "bool" type in synthetic trace events
` [PATCH v3 2/2] mmap_lock: add tracepoints around lock acquisition

[PATCH] mm: memcontrol: Remove unused mod_memcg_obj_state()
 2020-10-13 19:28 UTC  (3+ messages)

[PATCH v2 0/3] Actually fix freelist pointer vs redzoning
 2020-10-13 16:44 UTC  (5+ messages)
` [PATCH v2 1/3] mm/slub: Clarify verification reporting
` [PATCH v2 3/3] mm/slub: Actually fix freelist pointer vs redzoning

[PATCH] mm: proc: add Sock to /proc/meminfo
 2020-10-13 15:28 UTC  (12+ messages)
  ` [External] "

[PATCH v5 0/4] HWpoison: further fixes and cleanups
 2020-10-13 14:44 UTC  (5+ messages)
` [PATCH v5 1/4] mm,hwpoison: drain pcplists before bailing out for non-buddy zero-refcount page
` [PATCH v5 2/4] mm,hwpoison: take free pages off the buddy freelists
` [PATCH v5 3/4] mm,hwpoison: take free pages off the buddy freelists for hugetlb
` [PATCH v5 4/4] mm,hwpoison: drop unneeded pcplist draining

[PATCH 00/11] Remove assumptions of THP size
 2020-10-13 13:52 UTC  (3+ messages)
` [PATCH 03/11] mm/page_owner: Change split_page_owner to take a count


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).