linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-10-15 14:06:45 to 2020-10-16 03:03:51 UTC [more...]

incoming
 2020-10-16  3:03 UTC  (2+ messages)

[patch 001/156] device-dax/kmem: fix resource release
 2020-10-16  2:50 UTC  (156+ messages)
` [patch 002/156] powerpc/mm: add DEBUG_VM WARN for pmd_clear
` [patch 003/156] powerpc/mm: move setting pte specific flags to pfn_pte
` [patch 004/156] mm/debug_vm_pgtable/ppc64: avoid setting top bits in radom value
` [patch 005/156] mm/debug_vm_pgtables/hugevmap: use the arch helper to identify huge vmap support
` [patch 006/156] mm/debug_vm_pgtable/savedwrite: enable savedwrite test with CONFIG_NUMA_BALANCING
` [patch 007/156] mm/debug_vm_pgtable/THP: mark the pte entry huge before using set_pmd/pud_at
` [patch 008/156] mm/debug_vm_pgtable/set_pte/pmd/pud: don't use set_*_at to update an existing pte entry
` [patch 009/156] mm/debug_vm_pgtable/locks: move non page table modifying test together
` [patch 010/156] mm/debug_vm_pgtable/locks: take correct page table lock
` [patch 011/156] mm/debug_vm_pgtable/thp: use page table depost/withdraw with THP
` [patch 012/156] mm/debug_vm_pgtable/pmd_clear: don't use pmd/pud_clear on pte entries
` [patch 013/156] mm/debug_vm_pgtable/hugetlb: disable hugetlb test on ppc64
` [patch 014/156] mm/debug_vm_pgtable: avoid none pte in pte_clear_test
` [patch 015/156] mm/debug_vm_pgtable: avoid doing memory allocation with pgtable_t mapped
` [patch 016/156] XArray: add xa_get_order
` [patch 017/156] XArray: add xas_split
` [patch 018/156] mm/filemap: fix storing to a THP shadow entry
` [patch 019/156] mm/filemap: fix page cache removal for arbitrary sized THPs
` [patch 020/156] mm/memory: remove page fault assumption of compound page size
` [patch 021/156] mm/page_owner: change split_page_owner to take a count
` [patch 022/156] mm/huge_memory: fix total_mapcount assumption of page size
` [patch 023/156] mm/huge_memory: fix split "
` [patch 024/156] mm/huge_memory: fix page_trans_huge_mapcount assumption of THP size
` [patch 025/156] mm/huge_memory: fix can_split_huge_page "
` [patch 026/156] mm/rmap: fix assumptions "
` [patch 027/156] mm/truncate: fix truncation for pages of arbitrary size
` [patch 028/156] mm/page-writeback: support tail pages in wait_for_stable_page
` [patch 029/156] mm/vmscan: allow arbitrary sized pages to be paged out
` [patch 030/156] fs: add a filesystem flag for THPs
` [patch 031/156] fs: do not update nr_thps for mappings which support THPs
` [patch 032/156] mm: fix a race during THP splitting
` [patch 033/156] mm/readahead: add DEFINE_READAHEAD
` [patch 034/156] mm/readahead: make page_cache_ra_unbounded take a readahead_control
` [patch 035/156] mm/readahead: make do_page_cache_ra "
` [patch 036/156] mm/readahead: make ondemand_readahead "
` [patch 037/156] mm/readahead: pass readahead_control to force_page_cache_ra
` [patch 038/156] mm/readahead: add page_cache_sync_ra and page_cache_async_ra
` [patch 039/156] mm/filemap: fold ra_submit into do_sync_mmap_readahead
` [patch 040/156] mm/readahead: pass a file_ra_state into force_page_cache_ra
` [patch 041/156] mm,hwpoison: cleanup unused PageHuge() check
` [patch 042/156] mm, hwpoison: remove recalculating hpage
` [patch 043/156] mm,hwpoison-inject: don't pin for hwpoison_filter
` [patch 044/156] mm,hwpoison: unexport get_hwpoison_page and make it static
` [patch 045/156] mm,hwpoison: refactor madvise_inject_error
` [patch 046/156] mm,hwpoison: kill put_hwpoison_page
` [patch 047/156] mm,hwpoison: unify THP handling for hard and soft offline
` [patch 048/156] mm,hwpoison: rework soft offline for free pages
` [patch 049/156] mm,hwpoison: rework soft offline for in-use pages
` [patch 050/156] mm,hwpoison: refactor soft_offline_huge_page and __soft_offline_page
` [patch 051/156] mm,hwpoison: return 0 if the page is already poisoned in soft-offline
` [patch 052/156] mm,hwpoison: introduce MF_MSG_UNSPLIT_THP
` [patch 053/156] mm,hwpoison: double-check page count in __get_any_page()
` [patch 054/156] mm,hwpoison: try to narrow window race for free pages
` [patch 055/156] mm/page_poison.c: replace bool variable with static key
` [patch 056/156] mm/vmstat.c: use helper macro abs()
` [patch 057/156] mm/util.c: update the kerneldoc for kstrdup_const()
` [patch 058/156] mm/mmu_notifier: fix mmget() assert in __mmu_interval_notifier_insert
` [patch 059/156] mm/memory_hotplug: inline __offline_pages() into offline_pages()
` [patch 060/156] mm/memory_hotplug: enforce section granularity when onlining/offlining
` [patch 061/156] mm/memory_hotplug: simplify page offlining
` [patch 062/156] mm/page_alloc: simplify __offline_isolated_pages()
` [patch 063/156] mm/memory_hotplug: drop nr_isolate_pageblock in offline_pages()
` [patch 064/156] mm/page_isolation: simplify return value of start_isolate_page_range()
` [patch 065/156] mm/memory_hotplug: simplify page onlining
` [patch 066/156] mm/page_alloc: drop stale pageblock comment in memmap_init_zone*()
` [patch 067/156] mm: pass migratetype into memmap_init_zone() and move_pfn_range_to_zone()
` [patch 068/156] mm/memory_hotplug: mark pageblocks MIGRATE_ISOLATE while onlining memory
` [patch 069/156] kernel/resource: make release_mem_region_adjustable() never fail
` [patch 070/156] kernel/resource: move and rename IORESOURCE_MEM_DRIVER_MANAGED
` [patch 071/156] mm/memory_hotplug: guard more declarations by CONFIG_MEMORY_HOTPLUG
` [patch 072/156] mm/memory_hotplug: prepare passing flags to add_memory() and friends
` [patch 073/156] mm/memory_hotplug: MEMHP_MERGE_RESOURCE to specify merging of System RAM resources
` [patch 074/156] virtio-mem: try to merge system ram resources
` [patch 075/156] xen/balloon: "
` [patch 076/156] hv_balloon: "
` [patch 077/156] kernel/resource: make iomem_resource implicit in release_mem_region_adjustable()
` [patch 078/156] mm: don't panic when links can't be created in sysfs
` [patch 079/156] mm/page_alloc: convert "report" flag of __free_one_page() to a proper flag
` [patch 080/156] mm/page_alloc: place pages to tail in __putback_isolated_page()
` [patch 081/156] mm/page_alloc: move pages to tail in move_to_free_list()
` [patch 082/156] mm/page_alloc: place pages to tail in __free_pages_core()
` [patch 083/156] mm/memory_hotplug: update comment regarding zone shuffling
` [patch 084/156] zram: failing to decompress is WARN_ON worthy
` [patch 085/156] mm/slab.h: remove duplicate include
` [patch 086/156] mm/page_reporting.c: drop stale list head check in page_reporting_cycle
` [patch 087/156] mm/highmem.c: clean up endif comments
` [patch 088/156] mm: use self-explanatory macros rather than "2"
` [patch 089/156] mm: fix some broken comments
` [patch 090/156] mm: fix some comments formatting
` [patch 091/156] mm/workingset.c: fix some doc warnings
` [patch 092/156] mm: use helper function put_write_access()
` [patch 093/156] include/linux/mmzone.h: remove unused early_pfn_valid()
` [patch 094/156] mm: rename page_order() to buddy_order()
` [patch 095/156] fs: configfs: delete repeated words in comments
` [patch 096/156] kernel.h: split out min()/max() et al. helpers
` [patch 097/156] kernel/sys.c: replace do_brk with do_brk_flags in comment of prctl_set_mm_map()
` [patch 098/156] kernel/: fix repeated words in comments
` [patch 099/156] kernel: acct.c: fix some kernel-doc nits
` [patch 100/156] get_maintainer: add test for file in VCS
` [patch 101/156] get_maintainer: exclude MAINTAINERS file(s) from --git-fallback
` [patch 102/156] MAINTAINERS: jarkko.sakkinen@linux.intel.com -> jarkko@kernel.org
` [patch 103/156] lib: bitmap: delete duplicated words
` [patch 104/156] lib: libcrc32c: "
` [patch 105/156] lib: decompress_bunzip2: "
` [patch 106/156] lib: dynamic_queue_limits: delete duplicated words + fix typo
` [patch 107/156] lib: earlycpio: delete duplicated words
` [patch 108/156] lib: radix-tree: "
` [patch 109/156] lib: syscall: "
` [patch 110/156] lib: test_sysctl: "
` [patch 111/156] lib/mpi/mpi-bit.c: fix spello of "functions"
` [patch 112/156] lib/idr.c: document calling context for IDA APIs mustn't use locks
` [patch 113/156] lib/idr.c: document that ida_simple_{get,remove}() are deprecated
` [patch 114/156] lib/scatterlist.c: avoid a double memset
` [patch 115/156] lib/percpu_counter.c: use helper macro abs()
` [patch 116/156] include/linux/list.h: add a macro to test if entry is pointing to the head
` [patch 117/156] lib/test_hmm.c: fix an error code in dmirror_allocate_chunk()
` [patch 118/156] lib/crc32.c: fix trivial typo in preprocessor condition
` [patch 119/156] bitops: simplify get_count_order_long()
` [patch 120/156] bitops: use the same mechanism for get_count_order[_long]
` [patch 121/156] checkpatch: add --kconfig-prefix
` [patch 122/156] checkpatch: move repeated word test
` [patch 123/156] checkpatch: add test for comma use that should be semicolon
` [patch 124/156] const_structs.checkpatch: add phy_ops
` [patch 125/156] checkpatch: warn if trace_printk and friends are called
` [patch 126/156] const_structs.checkpatch: add pinctrl_ops and pinmux_ops
` [patch 127/156] checkpatch: warn on self-assignments
` [patch 128/156] checkpatch: allow not using -f with files that are in git
` [patch 129/156] checkpatch: extend author Signed-off-by check for split From: header
` [patch 130/156] checkpatch: emit a warning on embedded filenames
` [patch 131/156] checkpatch: fix multi-statement macro checks for while blocks
` [patch 132/156] checkpatch: fix false positive on empty block comment lines
` [patch 133/156] checkpatch: add new warnings to author signoff checks
` [patch 134/156] fs/binfmt_elf: use PT_LOAD p_align values for suitable start address
` [patch 135/156] tools/testing/selftests: add self-test for verifying load alignment
` [patch 136/156] binfmt_elf_fdpic: stop using dump_emit() on user pointers on !MMU
` [patch 137/156] coredump: let dump_emit() bail out on short writes
` [patch 138/156] coredump: refactor page range dumping into common helper
` [patch 139/156] coredump: rework elf/elf_fdpic vma_dump_size() "
` [patch 140/156] binfmt_elf, binfmt_elf_fdpic: use a VMA list snapshot
` [patch 141/156] mm/gup: take mmap_lock in get_dump_page()
` [patch 142/156] mm: remove the now-unnecessary mmget_still_valid() hack
` [patch 143/156] ramfs: fix nommu mmap with gaps in the page cache
` [patch 144/156] autofs: harden ioctl table
` [patch 145/156] nilfs2: fix some kernel-doc warnings for nilfs2
` [patch 146/156] rapidio: fix error handling path
` [patch 147/156] rapidio: fix the missed put_device() for rio_mport_add_riodev
` [patch 148/156] panic: dump registers on panic_on_warn
` [patch 149/156] kernel/relay.c: drop unneeded initialization
` [patch 150/156] scripts/gdb/proc: add struct mount & struct super_block addr in lx-mounts command
` [patch 151/156] scripts/gdb/tasks: add headers and improve spacing format
` [patch 152/156] sched.h: drop in_ubsan field when UBSAN is in trap mode
` [patch 153/156] ubsan: introduce CONFIG_UBSAN_LOCAL_BOUNDS for Clang
` [patch 154/156] ROMFS: support inode blocks calculation
` [patch 155/156] lib, include/linux: add usercopy failure capability
` [patch 156/156] lib, uaccess: add failure injection to usercopy functions

[RFC PATCH 0/6] mm and ptrace: Track dumpability until task is freed
 2020-10-16  2:40 UTC  (7+ messages)
` [RFC PATCH 1/6] ptrace: Keep mm around after exit_mm() for __ptrace_may_access()
` [RFC PATCH 2/6] refcount: Move refcount_t definition into linux/types.h
` [RFC PATCH 3/6] mm: Add refcount for preserving mm_struct without pgd
` [RFC PATCH 4/6] mm, oom: Use mm_ref()/mm_unref() and avoid mmdrop_async()
` [RFC PATCH 5/6] ptrace: Use mm_ref() for ->exit_mm
` [RFC PATCH 6/6] mm: remove now-unused mmdrop_async()

[PATCH v1 00/29] virtio-mem: Big Block Mode (BBM)
 2020-10-16  2:16 UTC  (15+ messages)
` [PATCH v1 01/29] virtio-mem: determine nid only once using memory_add_physaddr_to_nid()
` [PATCH v1 02/29] virtio-mem: simplify calculation in virtio_mem_mb_state_prepare_next_mb()
` [PATCH v1 05/29] virtio-mem: generalize check for added memory
` [PATCH v1 06/29] virtio-mem: generalize virtio_mem_owned_mb()
` [PATCH v1 08/29] virtio-mem: drop last_mb_id
` [PATCH v1 11/29] virtio-mem: use "unsigned long" for nr_pages when fake onlining/offlining

[PATCH] zsmalloc: Rework the list_add code in insert_zspage()
 2020-10-16  0:27 UTC  (3+ messages)

cgroup and FALLOC_FL_PUNCH_HOLE: WARNING: CPU: 13 PID: 2438 at mm/page_counter.c:57 page_counter_uncharge+0x4b/0x5
 2020-10-15 23:14 UTC  (6+ messages)

[RFC PATCH 0/3] hugetlbfs: introduce hinode_rwsem for pmd sharing synchronization
 2020-10-15 23:05 UTC  (3+ messages)
` [RFC PATCH 2/3] "

[PATCH v3 0/3] Actually fix freelist pointer vs redzoning
 2020-10-15 22:03 UTC  (4+ messages)

[PATCH 5/8] x86/clear_page: add clear_page_uncached()
 2020-10-15 21:40 UTC  (9+ messages)

[PATCH 0/4] Some more lock_page work
 2020-10-15 21:21 UTC  (10+ messages)
    ` Possible deadlock in fuse write path (Was: Re: [PATCH 0/4] Some more lock_page work..)

[PATCH v4 0/5] Speed up mremap on large regions
 2020-10-15 20:40 UTC  (2+ messages)

[linux-next:master] BUILD REGRESSION 03d992bd2de6c7f2c9bbd4260ff104c0926ce3ff
 2020-10-15 20:26 UTC 

[RFC]: userspace memory reaping
 2020-10-15 19:32 UTC  (8+ messages)

[PATCH v2 00/16] Allow readpage to return a locked page
 2020-10-15 19:03 UTC  (9+ messages)
` [PATCH v2 01/16] mm: Add AOP_UPDATED_PAGE return value
` [PATCH v2 16/16] iomap: Make readpage synchronous

[PATCH 0/2] vfs: move the clone/dedupe/remap helpers to a single file
 2020-10-15 16:46 UTC  (7+ messages)
` [PATCH 1/2] vfs: move generic_remap_checks out of mm
` [PATCH 3/2] vfs: move the generic write and copy checks "

[PATCH v2 00/17] follow_pfn and other iomap races
 2020-10-15 15:29 UTC  (8+ messages)
` [PATCH v2 14/17] resource: Move devmem revoke code to resource framework

[PATCH v21 10/18] mm/damon: Implement a debugfs-based user space interface
 2020-10-15 15:22 UTC  (2+ messages)

[PATCH 1/2] mm/mprotect: Call arch_validate_prot under mmap_lock and with length
 2020-10-15 14:53 UTC  (10+ messages)

[PATCH v6 00/11] Introduces new functions for tracking lockless pagetable walks
 2020-10-15 14:46 UTC  (4+ messages)
` [PATCH v6 02/11] mm/gup: Use functions to track lockless pgtbl walks on gup_pgd_range

[PATCH RFC 0/8] kasan: hardware tag-based mode for production use on arm64
 2020-10-15 14:41 UTC  (2+ messages)

[PATCH v3 00/10] KFENCE: A low-overhead sampling-based memory safety error detector
 2020-10-15 14:15 UTC  (12+ messages)
` [PATCH v3 03/10] arm64, kfence: enable KFENCE for ARM64


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).