linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-12-16 04:44:43 to 2020-12-17 10:42:43 UTC [more...]

[PATCH v9 00/11] Free some vmemmap pages of HugeTLB page
 2020-12-17 10:42 UTC  (36+ messages)
` [PATCH v9 03/11] mm/hugetlb: Free the vmemmap pages associated with each "
    ` [External] "
` [PATCH v9 04/11] mm/hugetlb: Defer freeing of HugeTLB pages
    ` [External] "
` [PATCH v9 05/11] mm/hugetlb: Allocate the vmemmap pages associated with each HugeTLB page
    ` [External] "
` [PATCH v9 06/11] mm/hugetlb: Set the PageHWPoison to the raw error page
    ` [External] "
` [PATCH v9 08/11] mm/hugetlb: Add a kernel parameter hugetlb_free_vmemmap
    ` [External] "
` [PATCH v9 09/11] mm/hugetlb: Introduce nr_free_vmemmap_pages in the struct hstate
    ` [External] "
` [PATCH v9 10/11] mm/hugetlb: Gather discrete indexes of tail page
    ` [External] "
` [PATCH v9 11/11] mm/hugetlb: Optimize the code with the help of the compiler
    ` [External] "

[PATCH 0/1] kasan: fix memory leak of kasan quarantine
 2020-12-17 10:28 UTC  (3+ messages)
` [PATCH 1/1] "

[PATCH v2] mm/mmap: Don't unlock VMAs in remap_file_pages()
 2020-12-17 10:05 UTC  (5+ messages)

incoming
 2020-12-17  9:21 UTC  (66+ messages)
` [patch 18/95] lib/list_kunit: follow new file name convention for KUnit tests
` [patch 28/95] string.h: add FORTIFY coverage for strscpy()
` [patch 33/95] bitops: introduce the for_each_set_clump macro
` [patch 43/95] checkpatch: add a fixer for missing newline at eof
` [patch 44/95] checkpatch: update __attribute__((section("name"))) quote removal
` [patch 45/95] checkpatch: add fix option for GERRIT_CHANGE_ID
` [patch 46/95] checkpatch: add __alias and __weak to suggested __attribute__ conversions
` [patch 47/95] checkpatch: improve email parsing
` [patch 48/95] checkpatch: fix spelling errors and remove repeated word
` [patch 49/95] checkpatch: avoid COMMIT_LOG_LONG_LINE warning for signature tags
` [patch 50/95] checkpatch: fix unescaped left brace
` [patch 51/95] checkpatch: add fix option for ASSIGNMENT_CONTINUATIONS
` [patch 52/95] checkpatch: add fix option for LOGICAL_CONTINUATIONS
` [patch 53/95] checkpatch: add fix and improve warning msg for non-standard signature
` [patch 54/95] checkpatch: add warning for unnecessary use of %h[xudi] and %hh[xudi]
` [patch 55/95] checkpatch: add warning for lines starting with a '#' in commit log
` [patch 56/95] checkpatch: fix TYPO_SPELLING check for words with apostrophe
` [patch 57/95] checkpatch: add printk_once and printk_ratelimit to prefer pr_<level> warning
` [patch 58/95] fs/nilfs2: remove some unused macros to tame gcc
` [patch 59/95] kdump: append uts_namespace.name offset to VMCOREINFO
` [patch 60/95] rapidio: remove unused rio_get_asm() and rio_get_device()
` [patch 61/95] gcov: remove support for GCC < 4.9
` [patch 62/95] gcov: fix kernel-doc markup issue
` [patch 63/95] bfs: don't use WARNING: string when it's just info
` [patch 64/95] relay: remove unused buf_mapped and buf_unmapped callbacks
` [patch 65/95] relay: require non-NULL callbacks in relay_open()
` [patch 66/95] relay: make create_buf_file and remove_buf_file callbacks mandatory
` [patch 67/95] relay: allow the use of const callback structs
` [patch 68/95] drm/i915: make relay callbacks const
` [patch 69/95] ath10k: "
` [patch 70/95] ath11k: "
` [patch 71/95] ath9k: "
` [patch 72/95] blktrace: "
` [patch 73/95] kernel/resource.c: fix kernel-doc markups
` [patch 74/95] ubsan: remove redundant -Wno-maybe-uninitialized
` [patch 75/95] ubsan: move cc-option tests into Kconfig
` [patch 76/95] ubsan: disable object-size sanitizer under GCC
` [patch 77/95] ubsan: disable UBSAN_TRAP for all*config
` [patch 78/95] ubsan: enable for all*config builds
` [patch 79/95] ubsan: remove UBSAN_MISC in favor of individual options
` [patch 80/95] ubsan: expand tests and reporting
` [patch 81/95] kcov: don't instrument with UBSAN
` [patch 82/95] lib/ubsan.c: mark type_check_kinds with static keyword
` [patch 83/95] reboot: refactor and comment the cpu selection code
` [patch 84/95] reboot: allow to specify reboot mode via sysfs
` [patch 85/95] reboot: remove cf9_safe from allowed types and rename cf9_force
` [patch 86/95] reboot: allow to override reboot type if quirks are found
` [patch 87/95] reboot: hide from sysfs not applicable settings
` [patch 88/95] fault-injection: handle EI_ETYPE_TRUE
` [patch 89/95] lib/lzo/lzo1x_compress.c: make lzogeneric1x_1_compress() static
` [patch 90/95] apparmor: remove duplicate macro list_entry_is_head()
` [patch 91/95] mm: unexport follow_pte_pmd
` [patch 92/95] mm: simplify follow_pte{,pmd}
` [patch 93/95] mm: fix some spelling mistakes in comments
` [patch 94/95] mmap locking API: don't check locking if the mm isn't live yet
` [patch 95/95] mm/gup: assert that the mmap lock is held in __get_user_pages()

[PATCH 00/25] Page folios
 2020-12-17  9:15 UTC  (29+ messages)
` [PATCH 01/25] mm: Introduce struct folio
` [PATCH 02/25] mm: Add put_folio
` [PATCH 03/25] mm: Add get_folio
` [PATCH 04/25] mm: Create FolioFlags
` [PATCH 05/25] mm: Add unlock_folio
` [PATCH 06/25] mm: Add lock_folio
` [PATCH 07/25] mm: Add lock_folio_killable
` [PATCH 08/25] mm: Add __alloc_folio_node and alloc_folio
` [PATCH 09/25] mm: Convert __page_cache_alloc to return a folio
` [PATCH 10/25] mm/filemap: Convert end_page_writeback to use "
` [PATCH 11/25] mm: Convert mapping_get_entry to return "
` [PATCH 12/25] mm: Add mark_folio_accessed
` [PATCH 13/25] mm: Add filemap_get_folio and find_get_folio
` [PATCH 14/25] mm/filemap: Add folio_add_to_page_cache
` [PATCH 15/25] mm/swap: Convert rotate_reclaimable_page to folio
` [PATCH 16/25] mm: Add folio_mapping
` [PATCH 17/25] mm: Rename THP_SUPPORT to MULTI_PAGE_FOLIOS
` [PATCH 18/25] btrfs: Use readahead_batch_length
` [PATCH 19/25] fs: Change page refcount rules for readahead
` [PATCH 20/25] fs: Change readpage to take a folio
` [PATCH 21/25] mm: Convert wait_on_page_bit to wait_on_folio_bit
` [PATCH 22/25] mm: Add wait_on_folio_locked & wait_on_folio_locked_killable
` [PATCH 23/25] mm: Add flush_dcache_folio
` [PATCH 24/25] mm: Add read_cache_folio and read_mapping_folio
` [PATCH 25/25] fs: Convert vfs_dedupe_file_range_compare to folios

[PATCH 1/3] mm/memcg: revise the using condition of lock_page_lruvec function series
 2020-12-17  6:28 UTC  (3+ messages)
` [PATCH 2/3] mm/memcg: remove rcu locking for "
` [PATCH 3/3] mm/compaction: remove rcu_read_lock during page compaction

[linux-next:master 12593/13311] mm/kfence/core.c:250:13: sparse: sparse: context imbalance in 'kfence_guarded_alloc' - wrong count at exit
 2020-12-17  5:58 UTC  (2+ messages)

[PATCH v13 0/4] xfs: avoid transaction reservation recursion
 2020-12-17  4:46 UTC  (8+ messages)
` [PATCH v13 1/4] mm: Add become_kswapd and restore_kswapd
` [PATCH v13 2/4] xfs: use memalloc_nofs_{save,restore} in xfs transaction
` [PATCH v13 3/4] xfs: refactor the usage around xfs_trans_context_{set,clear}
` [PATCH v13 4/4] xfs: use current->journal_info to avoid transaction reservation recursion

[PATCH v5 0/7] Convert all THP vmstat counters to pages
 2020-12-17  3:43 UTC  (8+ messages)
` [PATCH v5 1/7] mm: memcontrol: fix NR_ANON_THPS accounting in charge moving
` [PATCH v5 2/7] mm: memcontrol: convert NR_ANON_THPS account to pages
` [PATCH v5 3/7] mm: memcontrol: convert NR_FILE_THPS "
` [PATCH v5 4/7] mm: memcontrol: convert NR_SHMEM_THPS "
` [PATCH v5 5/7] mm: memcontrol: convert NR_SHMEM_PMDMAPPED "
` [PATCH v5 6/7] mm: memcontrol: convert NR_FILE_PMDMAPPED "
` [PATCH v5 7/7] mm: memcontrol: make the slab calculation consistent

[PATCH] mm/filemap: Fix warning: no previous prototype
 2020-12-17  2:23 UTC  (2+ messages)

Do we still need skip swapcache logic in do_swap_page() for SWP_SYNCHRONOUS_IO?
 2020-12-17  1:57 UTC 

[PATCH V3 05/10] x86/entry: Pass irqentry_state_t by reference
 2020-12-17  0:38 UTC  (6+ messages)
` [PATCH V3.1] entry: "

[GIT PULL] memblock: debug enhancements
 2020-12-16 23:10 UTC  (2+ messages)

[RFC v2 PATCH 0/9] Make shrinker's nr_deferred memcg aware
 2020-12-16 21:56 UTC  (9+ messages)
` [v2 PATCH 2/9] mm: memcontrol: use shrinker_rwsem to protect shrinker_maps allocation

[RFC PATCH v3 0/9] fsdax: introduce fs query to support reflink
 2020-12-16 21:26 UTC  (6+ messages)
` [RFC PATCH v3 4/9] mm, fsdax: Refactor memory-failure handler for dax mapping
` [RFC PATCH v3 8/9] md: Implement ->corrupted_range()

[linux-next:master 13004/13311] drivers/gpio/gpio-hisi.c:257:28: warning: variable 'clr' set but not used
 2020-12-16 20:55 UTC  (2+ messages)

[PATCH RFC 0/8] dcache: increase poison resistance
 2020-12-16 18:46 UTC  (7+ messages)

[PATCH 0/2] Create 'old' ptes for faultaround mappings on arm64 with hardware access flag
 2020-12-16 18:41 UTC  (10+ messages)
` [PATCH 1/2] mm: Allow architectures to request 'old' entries when prefaulting

mmotm 2020-12-16-10-40 uploaded
 2020-12-16 18:41 UTC 

Question about admin_reserve_kbytes in GUESS mode
 2020-12-16 16:37 UTC  (3+ messages)

[PATCH] mm: cma: allocate cma areas bottom-up
 2020-12-16 15:07 UTC  (5+ messages)

[linux-next:master 6404/13375] drivers/i3c/master/mipi-i3c-hci/core.c:780:34: warning: unused variable 'i3c_hci_of_match'
 2020-12-16 14:44 UTC  (5+ messages)

[PATCH v7] mm: Optional full ASLR for mmap(), mremap(), vdso, stack and heap
 2020-12-16 12:32 UTC 

[patch 012/200] mm: slab: clarify krealloc()'s behavior with __GFP_ZERO
 2020-12-16 11:23 UTC  (5+ messages)

[linux-next:pending-fixes] BUILD SUCCESS 077e992aebce48374837748fb608d714c61211d1
 2020-12-16 11:18 UTC 

[linux-next:master 12693/13311] drivers/ntb/hw/idt/ntb_hw_idt.c:1041:27: warning: stack frame size of 1056 bytes in function 'idt_scan_mws'
 2020-12-16 11:02 UTC 

[RFC v10 00/13] DAMON: Support Physical Memory Address Space and Page-granularity Idleness Monitoring
 2020-12-16  9:42 UTC  (14+ messages)
` [RFC v10 01/13] damon/dbgfs: Allow users to set initial monitoring target regions
` [RFC v10 02/13] tools/damon: Support init target regions specification
` [RFC v10 03/13] damon/dbgfs-test: Add a unit test case for 'init_regions'
` [RFC v10 04/13] selftests/damon/_chk_record: Do not check number of gaps
` [RFC v10 05/13] Docs/admin-guide/mm/damon: Document 'init_regions' feature
` [RFC v10 06/13] mm/damon/vaddr: Separate commonly usable functions
` [RFC v10 07/13] mm/damon: Implement primitives for physical address space monitoring
` [RFC v10 08/13] damon/dbgfs: Support physical memory monitoring
` [RFC v10 09/13] tools/damon/record: "
` [RFC v10 10/13] tools/damon/record: Support NUMA specific recording
` [RFC v10 11/13] Docs/DAMON: Document physical memory monitoring support
` [RFC v10 12/13] mm/damon/paddr: Separate commonly usable functions
` [RFC v10 13/13] mm/damon: Implement primitives for page granularity idleness monitoring

[RFC v15.1 0/8] Implement Data Access Monitoring-based Memory Operation Schemes
 2020-12-16  8:44 UTC  (9+ messages)
` [RFC v15.1 1/8] mm/damon/core: Account age of target regions
` [RFC v15.1 2/8] mm/damon/core: Implement DAMON-based Operation Schemes (DAMOS)
` [RFC v15.1 3/8] mm/damon/vaddr: Support DAMON-based Operation Schemes
` [RFC v15.1 4/8] mm/damon/dbgfs: "
` [RFC v15.1 5/8] mm/damon/schemes: Implement statistics feature
` [RFC v15.1 6/8] selftests/damon: Add 'schemes' debugfs tests
` [RFC v15.1 7/8] tools/damon: Support more human friendly 'schemes' control
` [RFC v15.1 8/8] Docs/admin-guide/mm/damon: Document DAMON-based Operation Schemes

[linux-next:master 6390/13311] drivers/i3c/master/mipi-i3c-hci/core.c:780:34: warning: unused variable 'i3c_hci_of_match'
 2020-12-16  8:04 UTC 

[PATCH] mm/memcontrol: remove the unnecessary rcu_read_[un]lock
 2020-12-16  7:35 UTC  (2+ messages)

[PATCH] mm, tracing: record slab name for kmem_cache_free()
 2020-12-16  7:28 UTC 

[linux-next:master 9830/13311] drivers/block/rnbd/rnbd-clt.c:1397:42: warning: size argument in 'strlcpy' call appears to be size of the source; expected the size of the destination
 2020-12-16  6:29 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).