linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-12-17 13:08:19 to 2020-12-18 22:18:20 UTC [more...]

[patch 01/12] zlib: export S390 symbols for zlib modules
 2020-12-18 22:18 UTC  (5+ messages)

incoming
 2020-12-18 22:05 UTC  (79+ messages)
` [patch 01/78] mm/memcg: bail early from swap accounting if memcg disabled
` [patch 02/78] mm/memcg: warning on !memcg after readahead page charged
` [patch 03/78] mm/memcg: remove unused definitions
` [patch 04/78] mm, kvm: account kvm_vcpu_mmap to kmemcg
` [patch 05/78] mm/memcontrol:rewrite mem_cgroup_page_lruvec()
` [patch 06/78] epoll: check for events when removing a timed out thread from the wait queue
` [patch 07/78] epoll: simplify signal handling
` [patch 08/78] epoll: pull fatal signal checks into ep_send_events()
` [patch 09/78] epoll: move eavail next to the list_empty_careful check
` [patch 10/78] epoll: simplify and optimize busy loop logic
` [patch 11/78] epoll: pull all code between fetch_events and send_event into the loop
` [patch 12/78] epoll: replace gotos with a proper loop
` [patch 13/78] epoll: eliminate unnecessary lock for zero timeout
` [patch 14/78] kasan: drop unnecessary GPL text from comment headers
` [patch 15/78] kasan: KASAN_VMALLOC depends on KASAN_GENERIC
` [patch 16/78] kasan: group vmalloc code
` [patch 17/78] kasan: shadow declarations only for software modes
` [patch 18/78] kasan: rename (un)poison_shadow to (un)poison_range
` [patch 19/78] kasan: rename KASAN_SHADOW_* to KASAN_GRANULE_*
` [patch 20/78] kasan: only build init.c for software modes
` [patch 21/78] kasan: split out shadow.c from common.c
` [patch 22/78] kasan: define KASAN_MEMORY_PER_SHADOW_PAGE
` [patch 23/78] kasan: rename report and tags files
` [patch 24/78] kasan: don't duplicate config dependencies
` [patch 25/78] kasan: hide invalid free check implementation
` [patch 26/78] kasan: decode stack frame only with KASAN_STACK_ENABLE
` [patch 27/78] kasan, arm64: only init shadow for software modes
` [patch 28/78] kasan, arm64: only use kasan_depth "
` [patch 29/78] kasan, arm64: move initialization message
` [patch 30/78] kasan, arm64: rename kasan_init_tags and mark as __init
` [patch 31/78] kasan: rename addr_has_shadow to addr_has_metadata
` [patch 32/78] kasan: rename print_shadow_for_address to print_memory_metadata
` [patch 33/78] kasan: rename SHADOW layout macros to META
` [patch 34/78] kasan: separate metadata_fetch_row for each mode
` [patch 35/78] kasan: introduce CONFIG_KASAN_HW_TAGS
` [patch 36/78] arm64: enable armv8.5-a asm-arch option
` [patch 37/78] arm64: mte: add in-kernel MTE helpers
` [patch 38/78] arm64: mte: reset the page tag in page->flags
` [patch 39/78] arm64: mte: add in-kernel tag fault handler
` [patch 40/78] arm64: kasan: allow enabling in-kernel MTE
` [patch 41/78] arm64: mte: convert gcr_user into an exclude mask
` [patch 42/78] arm64: mte: switch GCR_EL1 in kernel entry and exit
` [patch 43/78] kasan, mm: untag page address in free_reserved_area
` [patch 44/78] arm64: kasan: align allocations for HW_TAGS
` [patch 45/78] arm64: kasan: add arch layer for memory tagging helpers
` [patch 46/78] kasan: define KASAN_GRANULE_SIZE for HW_TAGS
` [patch 47/78] kasan, x86, s390: update undef CONFIG_KASAN
` [patch 48/78] kasan, arm64: expand CONFIG_KASAN checks
` [patch 49/78] kasan, arm64: implement HW_TAGS runtime
` [patch 50/78] kasan, arm64: print report from tag fault handler
` [patch 51/78] kasan, mm: reset tags when accessing metadata
` [patch 52/78] kasan, arm64: enable CONFIG_KASAN_HW_TAGS
` [patch 53/78] kasan: add documentation for hardware tag-based mode
` [patch 54/78] kselftest/arm64: check GCR_EL1 after context switch
` [patch 55/78] kasan: simplify quarantine_put call site
` [patch 56/78] kasan: rename get_alloc/free_info
` [patch 57/78] kasan: introduce set_alloc_info
` [patch 58/78] kasan, arm64: unpoison stack only with CONFIG_KASAN_STACK
` [patch 59/78] kasan: allow VMAP_STACK for HW_TAGS mode
` [patch 60/78] kasan: remove __kasan_unpoison_stack
` [patch 61/78] kasan: inline kasan_reset_tag for tag-based modes
` [patch 62/78] kasan: inline random_tag for HW_TAGS
` [patch 63/78] kasan: open-code kasan_unpoison_slab
` [patch 64/78] kasan: inline (un)poison_range and check_invalid_free
` [patch 65/78] kasan: add and integrate kasan boot parameters
` [patch 66/78] kasan, mm: check kasan_enabled in annotations
` [patch 67/78] kasan, mm: rename kasan_poison_kfree
` [patch 68/78] kasan: don't round_up too much
` [patch 69/78] kasan: simplify assign_tag and set_tag calls
` [patch 70/78] kasan: clarify comment in __kasan_kfree_large
` [patch 71/78] kasan: sanitize objects when metadata doesn't fit
` [patch 72/78] kasan, mm: allow cache merging with no metadata
` [patch 73/78] kasan: update documentation
` [patch 74/78] mm/Kconfig: fix spelling mistake "whats" -> "what's"
` [patch 75/78] epoll: convert internal api to timespec64
` [patch 76/78] epoll: add syscall epoll_pwait2
` [patch 77/78] epoll: wire up "
` [patch 78/78] selftests/filesystems: expand epoll with epoll_pwait2

kernelci/staging-next bisection: sleep.login on rk3288-rock2-square #2286-staging
 2020-12-18 21:59 UTC  (3+ messages)

[PATCH V3 00/10] PKS: Add Protection Keys Supervisor (PKS) support V3
 2020-12-18 21:58 UTC  (21+ messages)
` [PATCH V3 04/10] x86/pks: Preserve the PKRS MSR on context switch
  ` [NEEDS-REVIEW] "
` [PATCH V3 06/10] x86/entry: Preserve PKRS MSR across exceptions
` [PATCH V3 10/10] x86/pks: Add PKS test code

[PULL] drm-next, part 2 + fixes
 2020-12-18 20:54 UTC  (2+ messages)

[linux-next:master] BUILD REGRESSION 0d52778b8710eb11cb616761a02aee0a7fd60425
 2020-12-18 20:53 UTC 

[RFC PATCH] mm: generalise COW SMC TLB flushing race comment
 2020-12-18 18:58 UTC  (2+ messages)

[PATCH 1/2] mm: Allow architectures to request 'old' entries when prefaulting
 2020-12-18 18:56 UTC  (13+ messages)

[PATCH] mm: reduced code declaration
 2020-12-18 18:02 UTC  (2+ messages)

[PATCH] mm/filemap: Fix warning: no previous prototype
 2020-12-18 17:57 UTC  (4+ messages)

[PATCH] mm/vmscan: DRY cleanup for do_try_to_free_pages()
 2020-12-18 17:41 UTC  (7+ messages)

[PATCH] add pin memory method for checkout add restore
 2020-12-18 16:59 UTC  (2+ messages)

[PATCH v10 00/11] Free some vmemmap pages of HugeTLB page
 2020-12-18 15:41 UTC  (8+ messages)
` [PATCH v10 02/11] mm/hugetlb: Introduce a new config HUGETLB_PAGE_FREE_VMEMMAP
` [PATCH v10 10/11] mm/hugetlb: Gather discrete indexes of tail page
    ` [External] "
  ` [External] Re: [PATCH v10 00/11] Free some vmemmap pages of HugeTLB page

[PATCH RFC 0/9] mm, sparse-vmemmap: Introduce compound pagemaps
 2020-12-18 14:25 UTC  (7+ messages)
` [PATCH RFC 7/9] mm/gup: Decrement head page once for group of subpages

[PATCH v4 00/10] prohibit pinning pages in ZONE_MOVABLE
 2020-12-18 14:19 UTC  (28+ messages)
` [PATCH v4 01/10] mm/gup: don't pin migrated cma pages in movable zone
` [PATCH v4 02/10] mm cma: rename PF_MEMALLOC_NOCMA to PF_MEMALLOC_PIN
` [PATCH v4 03/10] mm: apply per-task gfp constraints in fast path
` [PATCH v4 04/10] mm: honor PF_MEMALLOC_PIN for all movable pages
` [PATCH v4 05/10] mm/gup: migrate pinned pages out of movable zone
` [PATCH v4 06/10] memory-hotplug.rst: add a note about ZONE_MOVABLE and page pinning
` [PATCH v4 07/10] mm/gup: change index type to long as it counts pages
` [PATCH v4 08/10] mm/gup: limit number of gup migration failures, honor failures
` [PATCH v4 09/10] selftests/vm: test flag is broken
` [PATCH v4 10/10] selftests/vm: test faulting in kernel, and verify pinnable pages

[PATCH] mm: Remove arch_remap() and mm-arch-hooks.h
 2020-12-18 14:07 UTC 

[linux-next:master 12593/13311] mm/kfence/core.c:250:13: sparse: sparse: context imbalance in 'kfence_guarded_alloc' - wrong count at exit
 2020-12-18 12:20 UTC  (4+ messages)
  ` [kbuild-all] "

[linux-next:pending-fixes] BUILD SUCCESS c41c506b38eb3f2c03ee4d97af570ea4835d89a9
 2020-12-18 11:07 UTC 

[PATCH -V6 RESEND 0/3] numa balancing: Migrate on fault among multiple bound nodes
 2020-12-18 10:21 UTC  (5+ messages)
` [PATCH -V6 RESEND 2/3] NOT kernel/man-pages: man2/set_mempolicy.2: Add mode flag MPOL_F_NUMA_BALANCING

5.10.1: UBSAN: shift-out-of-bounds in ./include/linux/log2.h:57:1
 2020-12-18 10:20 UTC  (2+ messages)

[RFC PATCH v3 0/9] fsdax: introduce fs query to support reflink
 2020-12-18  9:13 UTC  (16+ messages)
` [RFC PATCH v3 4/9] mm, fsdax: Refactor memory-failure handler for dax mapping
` [RFC PATCH v3 8/9] md: Implement ->corrupted_range()
` [RFC PATCH v3 9/9] xfs: Implement ->corrupted_range() for XFS

[RFC v2 PATCH 0/9] Make shrinker's nr_deferred memcg aware
 2020-12-18  1:09 UTC  (6+ messages)
` [v2 PATCH 7/9] mm: vmscan: don't need allocate shrinker->nr_deferred for memcg aware shrinkers

[linux-next:master] BUILD REGRESSION 90cc8cf2d1ab87d708ebc311ac104ccbbefad9fc
 2020-12-18  0:59 UTC 

[PATCH v13 0/4] xfs: avoid transaction reservation recursion
 2020-12-18  0:14 UTC  (7+ messages)
` [PATCH v13 3/4] xfs: refactor the usage around xfs_trans_context_{set,clear}
` [PATCH v13 4/4] xfs: use current->journal_info to avoid transaction reservation recursion

WARNING: modpost: vmlinux.o(.text+0x1b72a48): Section mismatch in reference from the function arch_atomic64_or() to the variable .init.data:numa_nodes_parsed
 2020-12-17 22:26 UTC 

Do we still need skip swapcache logic in do_swap_page() for SWP_SYNCHRONOUS_IO?
 2020-12-17 21:02 UTC  (2+ messages)

[PATCH v2 1/2] mm: cma: allocate cma areas bottom-up
 2020-12-17 20:12 UTC  (2+ messages)
` [PATCH v2 2/2] memblock: do not start bottom-up allocations with kernel_end

[PATCH 00/25] Page folios
 2020-12-17 19:36 UTC  (9+ messages)
` [PATCH 18/25] btrfs: Use readahead_batch_length

[PATCH v4 0/5] Speed up mremap on large regions
 2020-12-17 18:15 UTC  (4+ messages)
` [PATCH v4 3/5] mm: Speedup mremap on 1GB or larger regions

[PATCH V2 0/3] mm/hotplug: Pre-validate the address range with platform
 2020-12-17 17:31 UTC  (5+ messages)
` [PATCH V2 1/3] mm/hotplug: Prevalidate the address range being added "
` [PATCH V2 2/3] arm64/mm: Define arch_get_mappable_range()
` [PATCH V2 3/3] s390/mm: "

[PATCH] mm: Fix spelling mistake in Kconfig "whats" -> "what's"
 2020-12-17 17:27 UTC 

[PATCH V3 05/10] x86/entry: Pass irqentry_state_t by reference
 2020-12-17 16:58 UTC  (7+ messages)
` [PATCH V3.1] entry: "

[PATCH] kfence: fix typo in test
 2020-12-17 15:57 UTC  (3+ messages)

[linux-next:pending-fixes] BUILD SUCCESS 31c318f75dc40b05022f1eba1494878a408c100d
 2020-12-17 15:56 UTC 

[PATCH RFC 0/8] dcache: increase poison resistance
 2020-12-17 15:47 UTC  (8+ messages)

[PATCH 0/5] Allocate memmap from hotadded memory (per device)
 2020-12-17 13:07 UTC  (3+ messages)
` [PATCH 4/5] powerpc/memhotplug: Enable MHP_MEMMAP_ON_MEMORY when supported
` [PATCH 5/5] mm,memory_hotplug: Add kernel boot option to enable memmap_on_memory


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).