linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: Pavel Tatashin <pasha.tatashin@soleen.com>
To: Michal Hocko <mhocko@suse.com>
Cc: LKML <linux-kernel@vger.kernel.org>,
	linux-mm <linux-mm@kvack.org>,
	 Andrew Morton <akpm@linux-foundation.org>,
	Vlastimil Babka <vbabka@suse.cz>,
	 David Hildenbrand <david@redhat.com>,
	Oscar Salvador <osalvador@suse.de>,
	 Dan Williams <dan.j.williams@intel.com>,
	Sasha Levin <sashal@kernel.org>,
	 Tyler Hicks <tyhicks@linux.microsoft.com>,
	Joonsoo Kim <iamjoonsoo.kim@lge.com>,
	 mike.kravetz@oracle.com, Steven Rostedt <rostedt@goodmis.org>,
	 Ingo Molnar <mingo@redhat.com>, Jason Gunthorpe <jgg@ziepe.ca>,
	Peter Zijlstra <peterz@infradead.org>,
	 Mel Gorman <mgorman@suse.de>,
	Matthew Wilcox <willy@infradead.org>,
	 David Rientjes <rientjes@google.com>,
	John Hubbard <jhubbard@nvidia.com>,
	 Linux Doc Mailing List <linux-doc@vger.kernel.org>
Subject: Re: [PATCH v3 4/6] mm: honor PF_MEMALLOC_PIN for all movable pages
Date: Tue, 15 Dec 2020 00:24:30 -0500	[thread overview]
Message-ID: <CA+CK2bCWkPDw-Aif6iXHq15Dpa+50hmrcAk_LpMCMk30zY5aFw@mail.gmail.com> (raw)
In-Reply-To: <20201214141715.GF32193@dhcp22.suse.cz>

On Mon, Dec 14, 2020 at 9:17 AM Michal Hocko <mhocko@suse.com> wrote:
>
> On Fri 11-12-20 15:21:38, Pavel Tatashin wrote:
> [...]
> > diff --git a/mm/page_alloc.c b/mm/page_alloc.c
> > index c2dea9ad0e98..4d8e7f801c66 100644
> > --- a/mm/page_alloc.c
> > +++ b/mm/page_alloc.c
> > @@ -3802,16 +3802,12 @@ alloc_flags_nofragment(struct zone *zone, gfp_t gfp_mask)
> >       return alloc_flags;
> >  }
> >
> > -static inline unsigned int current_alloc_flags(gfp_t gfp_mask,
> > -                                     unsigned int alloc_flags)
> > +static inline unsigned int cma_alloc_flags(gfp_t gfp_mask,
> > +                                        unsigned int alloc_flags)
>
> Do you have any strong reason to rename? Even though the current

Yes :)

> implementation only does something for cma I do not think this is all
> that important. The naming nicely fits with current_gfp_context so I
> would stick with it.

I am renaming because current->flags is removed from this function,
therefore keeping the name
becomes misleading. This function only addresses cma flag check
without looking at the thread local state now.

>
> Other than that the patch looks reasonable. I would just add a comment
> explaining that current_alloc_flags should be called _after_
> current_gfp_context because that one might change the gfp_mask.

Thanks, I will add it.

>
> With that addressed, feel free to add
> Acked-by: Michal Hocko <mhocko@suse.com>

Thank you,
Pasha


  reply	other threads:[~2020-12-15  5:25 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-12-11 20:21 [PATCH v3 0/6] prohibit pinning pages in ZONE_MOVABLE Pavel Tatashin
2020-12-11 20:21 ` [PATCH v3 1/6] mm/gup: don't pin migrated cma pages in movable zone Pavel Tatashin
2020-12-11 20:21 ` [PATCH v3 2/6] mm cma: rename PF_MEMALLOC_NOCMA to PF_MEMALLOC_PIN Pavel Tatashin
2020-12-14 14:03   ` Michal Hocko
2020-12-15  4:37     ` Pavel Tatashin
2020-12-11 20:21 ` [PATCH v3 3/6] mm: apply per-task gfp constraints in fast path Pavel Tatashin
2020-12-14 14:09   ` Michal Hocko
2020-12-15  5:20     ` Pavel Tatashin
2020-12-15  8:25       ` Michal Hocko
2020-12-15 17:35         ` Pavel Tatashin
2020-12-11 20:21 ` [PATCH v3 4/6] mm: honor PF_MEMALLOC_PIN for all movable pages Pavel Tatashin
2020-12-14 14:17   ` Michal Hocko
2020-12-15  5:24     ` Pavel Tatashin [this message]
2020-12-15  8:27       ` Michal Hocko
2020-12-15 17:28         ` Pavel Tatashin
2020-12-11 20:21 ` [PATCH v3 5/6] mm/gup: migrate pinned pages out of movable zone Pavel Tatashin
2020-12-11 20:23   ` Jason Gunthorpe
2020-12-11 20:40     ` Pavel Tatashin
2020-12-11 20:46       ` Jason Gunthorpe
2020-12-11 21:09         ` Pavel Tatashin
2020-12-11 21:29           ` David Hildenbrand
2020-12-11 21:35             ` Pavel Tatashin
2020-12-11 21:53               ` David Hildenbrand
2020-12-11 23:00                 ` Pavel Tatashin
2020-12-12  0:07                   ` John Hubbard
2020-12-11 23:50                 ` Jason Gunthorpe
2020-12-12  7:29                   ` David Hildenbrand
2020-12-14 13:36                     ` Jason Gunthorpe
2020-12-14 14:21                       ` David Hildenbrand
2020-12-14 14:30                         ` Michal Hocko
2020-12-14 14:19   ` Michal Hocko
2020-12-11 20:21 ` [PATCH v3 6/6] memory-hotplug.rst: add a note about ZONE_MOVABLE and page pinning Pavel Tatashin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CA+CK2bCWkPDw-Aif6iXHq15Dpa+50hmrcAk_LpMCMk30zY5aFw@mail.gmail.com \
    --to=pasha.tatashin@soleen.com \
    --cc=akpm@linux-foundation.org \
    --cc=dan.j.williams@intel.com \
    --cc=david@redhat.com \
    --cc=iamjoonsoo.kim@lge.com \
    --cc=jgg@ziepe.ca \
    --cc=jhubbard@nvidia.com \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mgorman@suse.de \
    --cc=mhocko@suse.com \
    --cc=mike.kravetz@oracle.com \
    --cc=mingo@redhat.com \
    --cc=osalvador@suse.de \
    --cc=peterz@infradead.org \
    --cc=rientjes@google.com \
    --cc=rostedt@goodmis.org \
    --cc=sashal@kernel.org \
    --cc=tyhicks@linux.microsoft.com \
    --cc=vbabka@suse.cz \
    --cc=willy@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).