linux-mmc.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Ludovic BARRE <ludovic.barre@st.com>
To: Ulf Hansson <ulf.hansson@linaro.org>
Cc: Rob Herring <robh+dt@kernel.org>,
	Srinivas Kandagatla <srinivas.kandagatla@linaro.org>,
	Maxime Coquelin <mcoquelin.stm32@gmail.com>,
	Alexandre Torgue <alexandre.torgue@st.com>,
	Linux ARM <linux-arm-kernel@lists.infradead.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	DTML <devicetree@vger.kernel.org>,
	"linux-mmc@vger.kernel.org" <linux-mmc@vger.kernel.org>,
	<linux-stm32@st-md-mailman.stormreply.com>
Subject: Re: [PATCH V2 0/9] mmc: mmci: sdmmc: add sdr104 support
Date: Mon, 24 Feb 2020 17:20:22 +0100	[thread overview]
Message-ID: <86464a0a-d830-465e-b35b-8dd2e766db70@st.com> (raw)
In-Reply-To: <CAPDyKFr+7SvRasPPjFDA2kwG0ERS-Qp3FGbVbRGLrscz5N=L2g@mail.gmail.com>

hi Ulf

Le 2/19/20 à 11:28 AM, Ulf Hansson a écrit :
> On Tue, 28 Jan 2020 at 10:06, Ludovic Barre <ludovic.barre@st.com> wrote:
>>
>> To support the sdr104 mode, sdmmc variant needs:
>> -Hardware delay block support for sdmmc variant
>>   with tuning procedure
>> -Voltage switch callbacks
>> -sdmmc revision 2.0
>>
>> V2:
>> -regroup host->mmc_ops & mmc->ops assignment
>> -add timeout define
>> -rename prep_volt_switch to pre_sig_volt_switch
>> -rename volt_switch to post_sig_volt_switch
>> -add 'why' comment for "mmc: mmci: add volt_switch callbacks"
>>
>> Ludovic Barre (9):
>>    mmc: mmci: sdmmc: replace sg_dma_xxx macros
>>    mmc: mmci: sdmmc: rename sdmmc_priv struct to sdmmc_idma
>>    mmc: mmci: add a reference at mmc_host_ops in mmci struct
>>    mmc: mmci: add private pointer for variant
>>    dt-bindings: mmc: mmci: add delay block base register for sdmmc
>>    mmc: mmci: sdmmc: add execute tuning with delay block
>>    mmc: mmci: add volt_switch callbacks
>>    mmc: mmci: sdmmc: add voltage switch functions
>>    mmc: mmci: add sdmmc variant revision 2.0
>>
>>   .../devicetree/bindings/mmc/mmci.txt          |   2 +
>>   drivers/mmc/host/mmci.c                       |  42 +++-
>>   drivers/mmc/host/mmci.h                       |   8 +
>>   drivers/mmc/host/mmci_stm32_sdmmc.c           | 204 +++++++++++++++++-
>>   4 files changed, 248 insertions(+), 8 deletions(-)
>>
>> --
>> 2.17.1
>>
> 
> Applied for next, thanks!

thanks Ulf.

> 
> I took the liberty to do minor amendments to some of the changelogs,
> but in particular I have change some of prefixes for the commit
> message headers into "mmc: mmci_sdmmc:".

Ok, I use this prefixe for next commit.

> 
> Please tell, if there is anything that you want me to update.

I tested your next branch, and it's ok for me.
sdmmc upstream is almost finished, I just some recent fixes to send.

> 
> Kind regards
> Uffe
> 

      reply	other threads:[~2020-02-24 16:20 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-28  9:06 [PATCH V2 0/9] mmc: mmci: sdmmc: add sdr104 support Ludovic Barre
2020-01-28  9:06 ` [PATCH V2 1/9] mmc: mmci: sdmmc: replace sg_dma_xxx macros Ludovic Barre
2020-01-28  9:06 ` [PATCH V2 2/9] mmc: mmci: sdmmc: rename sdmmc_priv struct to sdmmc_idma Ludovic Barre
2020-01-28  9:06 ` [PATCH V2 3/9] mmc: mmci: add a reference at mmc_host_ops in mmci struct Ludovic Barre
2020-01-28  9:06 ` [PATCH V2 4/9] mmc: mmci: add private pointer for variant Ludovic Barre
2020-01-28  9:06 ` [PATCH V2 5/9] dt-bindings: mmc: mmci: add delay block base register for sdmmc Ludovic Barre
2020-02-05 17:49   ` Rob Herring
2020-01-28  9:06 ` [PATCH V2 6/9] mmc: mmci: sdmmc: add execute tuning with delay block Ludovic Barre
2020-01-28  9:06 ` [PATCH V2 7/9] mmc: mmci: add volt_switch callbacks Ludovic Barre
2020-01-28  9:06 ` [PATCH V2 8/9] mmc: mmci: sdmmc: add voltage switch functions Ludovic Barre
2020-01-28  9:06 ` [PATCH V2 9/9] mmc: mmci: add sdmmc variant revision 2.0 Ludovic Barre
2020-02-11 14:44   ` Ludovic BARRE
2020-02-19 10:28     ` Ulf Hansson
2020-02-11 14:47 ` [PATCH V2 0/9] mmc: mmci: sdmmc: add sdr104 support Ludovic BARRE
2020-02-11 15:16   ` Ulf Hansson
2020-02-19 10:28 ` Ulf Hansson
2020-02-24 16:20   ` Ludovic BARRE [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=86464a0a-d830-465e-b35b-8dd2e766db70@st.com \
    --to=ludovic.barre@st.com \
    --cc=alexandre.torgue@st.com \
    --cc=devicetree@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mmc@vger.kernel.org \
    --cc=linux-stm32@st-md-mailman.stormreply.com \
    --cc=mcoquelin.stm32@gmail.com \
    --cc=robh+dt@kernel.org \
    --cc=srinivas.kandagatla@linaro.org \
    --cc=ulf.hansson@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).