linux-mtd.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 00/11] mtd: rawnand: denali: exec_op(), controller/chip separation, and cleanups
@ 2019-02-08  8:08 Masahiro Yamada
  2019-02-08  8:08 ` [PATCH 01/11] mtd: rawnand: denali: use nand_chip pointer more for internal functions Masahiro Yamada
                   ` (11 more replies)
  0 siblings, 12 replies; 21+ messages in thread
From: Masahiro Yamada @ 2019-02-08  8:08 UTC (permalink / raw)
  To: linux-mtd, Miquel Raynal
  Cc: Mark Rutland, devicetree, Masahiro Yamada, Richard Weinberger,
	Boris Brezillon, linux-kernel, Marek Vasut, Rob Herring,
	Brian Norris, David Woodhouse

I took time for the Denali driver to catch up with the latest framework.

 - switch over to exec_op() and remove legacy hooks

 - separate controller/chips

 - various cleanups



Masahiro Yamada (11):
  mtd: rawnand: denali: use nand_chip pointer more for internal
    functions
  mtd: rawnand: denali: refactor syndrome layout handling for raw access
  mtd: rawnand: denali: remove unneeded casts in denali_{read,write}_pio
  mtd: rawnand: denali: switch over to ->exec_op() from legacy hooks
  mtd: rawnand: denali: rename irq_status to irq_stat
  mtd: rawnand: denali: use more precise timeout for
    NAND_OP_WAITRDT_INSTR
  mtd: rawnand: denali: use bool type instead of int where appropriate
  mtd: rawnand: denali_pci: rename goto labels
  mtd: rawnand: denali: decouple controller and NAND chips
  mtd: rawnand: denali: remove DENALI_NR_BANKS macro
  mtd: rawnand: denali: clean up coding style

 .../devicetree/bindings/mtd/denali-nand.txt        |   39 +-
 drivers/mtd/nand/raw/denali.c                      | 1182 ++++++++++----------
 drivers/mtd/nand/raw/denali.h                      |  119 +-
 drivers/mtd/nand/raw/denali_dt.c                   |   98 +-
 drivers/mtd/nand/raw/denali_pci.c                  |   38 +-
 5 files changed, 867 insertions(+), 609 deletions(-)

-- 
2.7.4


______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/

^ permalink raw reply	[flat|nested] 21+ messages in thread

end of thread, other threads:[~2019-02-11  1:27 UTC | newest]

Thread overview: 21+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-02-08  8:08 [PATCH 00/11] mtd: rawnand: denali: exec_op(), controller/chip separation, and cleanups Masahiro Yamada
2019-02-08  8:08 ` [PATCH 01/11] mtd: rawnand: denali: use nand_chip pointer more for internal functions Masahiro Yamada
2019-02-08  8:08 ` [PATCH 02/11] mtd: rawnand: denali: refactor syndrome layout handling for raw access Masahiro Yamada
2019-02-08  8:08 ` [PATCH 03/11] mtd: rawnand: denali: remove unneeded casts in denali_{read, write}_pio Masahiro Yamada
2019-02-08  8:08 ` [PATCH 04/11] mtd: rawnand: denali: switch over to ->exec_op() from legacy hooks Masahiro Yamada
2019-02-08  9:49   ` Masahiro Yamada
2019-02-08  8:08 ` [PATCH 05/11] mtd: rawnand: denali: rename irq_status to irq_stat Masahiro Yamada
2019-02-08 21:57   ` Miquel Raynal
2019-02-11  1:15     ` Masahiro Yamada
2019-02-08  8:08 ` [PATCH 06/11] mtd: rawnand: denali: use more precise timeout for NAND_OP_WAITRDT_INSTR Masahiro Yamada
2019-02-08 22:05   ` Miquel Raynal
2019-02-11  1:26     ` Masahiro Yamada
2019-02-08  8:08 ` [PATCH 07/11] mtd: rawnand: denali: use bool type instead of int where appropriate Masahiro Yamada
2019-02-08  9:23   ` Joe Perches
2019-02-08  9:33     ` Masahiro Yamada
2019-02-08 22:11     ` Miquel Raynal
2019-02-08  8:08 ` [PATCH 08/11] mtd: rawnand: denali_pci: rename goto labels Masahiro Yamada
2019-02-08  8:08 ` [PATCH 09/11] mtd: rawnand: denali: decouple controller and NAND chips Masahiro Yamada
2019-02-08  8:08 ` [PATCH 10/11] mtd: rawnand: denali: remove DENALI_NR_BANKS macro Masahiro Yamada
2019-02-08  8:08 ` [PATCH 11/11] mtd: rawnand: denali: clean up coding style Masahiro Yamada
2019-02-08 21:55 ` [PATCH 00/11] mtd: rawnand: denali: exec_op(), controller/chip separation, and cleanups Miquel Raynal

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).