From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mail.bootlin.com ([62.4.15.54]) by bombadil.infradead.org with esmtp (Exim 4.90_1 #2 (Red Hat Linux)) id 1gDPXV-0003St-Fb for linux-mtd@lists.infradead.org; Fri, 19 Oct 2018 07:50:15 +0000 From: Boris Brezillon To: David Woodhouse , Brian Norris , Boris Brezillon , Marek Vasut , Richard Weinberger , linux-mtd@lists.infradead.org Cc: Rob Herring , Pawel Moll , Mark Rutland , Ian Campbell , Kumar Gala , devicetree@vger.kernel.org, Ricardo Ribalda Delgado , Linus Walleij Subject: [PATCH v2 10/15] mtd: maps: Prepare merging of physmap and physmap_of Date: Fri, 19 Oct 2018 09:49:03 +0200 Message-Id: <20181019074908.13226-11-boris.brezillon@bootlin.com> In-Reply-To: <20181019074908.13226-1-boris.brezillon@bootlin.com> References: <20181019074908.13226-1-boris.brezillon@bootlin.com> List-Id: Linux MTD discussion mailing list List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , We want to merge the physmap and physmap_of driver, but before we can do that we must prepare things to create physmap.o out of several .c files. Rename physmap.c into physmap-core.c and add a new Makefile rule to create physmap.o (right now it only contains physmap-core.o). Signed-off-by: Boris Brezillon Reviewed-by: Ricardo Ribalda Delgado --- Changes in v2: - Add Ricardo's R-b --- drivers/mtd/maps/Makefile | 2 ++ drivers/mtd/maps/{physmap.c => physmap-core.c} | 0 2 files changed, 2 insertions(+) rename drivers/mtd/maps/{physmap.c => physmap-core.c} (100%) diff --git a/drivers/mtd/maps/Makefile b/drivers/mtd/maps/Makefile index 51acf1fec19b..2574909edffd 100644 --- a/drivers/mtd/maps/Makefile +++ b/drivers/mtd/maps/Makefile @@ -17,6 +17,8 @@ obj-$(CONFIG_MTD_ICHXROM) += ichxrom.o obj-$(CONFIG_MTD_CK804XROM) += ck804xrom.o obj-$(CONFIG_MTD_TSUNAMI) += tsunami_flash.o obj-$(CONFIG_MTD_PXA2XX) += pxa2xx-flash.o +physmap-objs-y += physmap-core.o +physmap-objs := $(physmap-objs-y) obj-$(CONFIG_MTD_PHYSMAP) += physmap.o physmap_of-objs-y += physmap_of_core.o physmap_of-objs-$(CONFIG_MTD_PHYSMAP_OF_VERSATILE) += physmap_of_versatile.o diff --git a/drivers/mtd/maps/physmap.c b/drivers/mtd/maps/physmap-core.c similarity index 100% rename from drivers/mtd/maps/physmap.c rename to drivers/mtd/maps/physmap-core.c -- 2.14.1