linux-mtd.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 1/2] mtd: onenand: Use a better name for samsung driver
@ 2019-12-30 17:31 Miquel Raynal
  2019-12-30 17:31 ` [PATCH 2/2] mtd: onenand: Rename omap2 driver to avoid a build warning Miquel Raynal
  2020-01-14 17:04 ` [PATCH 1/2] mtd: onenand: Use a better name for samsung driver Miquel Raynal
  0 siblings, 2 replies; 4+ messages in thread
From: Miquel Raynal @ 2019-12-30 17:31 UTC (permalink / raw)
  To: Richard Weinberger, Vignesh Raghavendra, Tudor Ambarus, linux-mtd
  Cc: Boris Brezillon, Thomas Petazzoni, Miquel Raynal

Commit 55ed51fff224 ("{tty: serial, nand: onenand}: samsung: rename to
fix build warning") has changed the samsung.c driver to be
samsung_mtd.c in order to avoid a conflict in module names with the
tty driver.

Since the *_mtd suffix is very undescriptive, rename it to
onenand_samsung.c, following the folder's convention. Same will be
applied to the omap2 onenand driver.

Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com>
---
 drivers/mtd/nand/onenand/Makefile                             | 2 +-
 drivers/mtd/nand/onenand/{samsung_mtd.c => onenand_samsung.c} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename drivers/mtd/nand/onenand/{samsung_mtd.c => onenand_samsung.c} (100%)

diff --git a/drivers/mtd/nand/onenand/Makefile b/drivers/mtd/nand/onenand/Makefile
index a27b635eb23a..0f2f460adbe4 100644
--- a/drivers/mtd/nand/onenand/Makefile
+++ b/drivers/mtd/nand/onenand/Makefile
@@ -9,6 +9,6 @@ obj-$(CONFIG_MTD_ONENAND)		+= onenand.o
 # Board specific.
 obj-$(CONFIG_MTD_ONENAND_GENERIC)	+= generic.o
 obj-$(CONFIG_MTD_ONENAND_OMAP2)		+= omap2.o
-obj-$(CONFIG_MTD_ONENAND_SAMSUNG)       += samsung_mtd.o
+obj-$(CONFIG_MTD_ONENAND_SAMSUNG)       += onenand_samsung.o
 
 onenand-objs = onenand_base.o onenand_bbt.o
diff --git a/drivers/mtd/nand/onenand/samsung_mtd.c b/drivers/mtd/nand/onenand/onenand_samsung.c
similarity index 100%
rename from drivers/mtd/nand/onenand/samsung_mtd.c
rename to drivers/mtd/nand/onenand/onenand_samsung.c
-- 
2.20.1


______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH 2/2] mtd: onenand: Rename omap2 driver to avoid a build warning
  2019-12-30 17:31 [PATCH 1/2] mtd: onenand: Use a better name for samsung driver Miquel Raynal
@ 2019-12-30 17:31 ` Miquel Raynal
  2020-01-14 17:04   ` Miquel Raynal
  2020-01-14 17:04 ` [PATCH 1/2] mtd: onenand: Use a better name for samsung driver Miquel Raynal
  1 sibling, 1 reply; 4+ messages in thread
From: Miquel Raynal @ 2019-12-30 17:31 UTC (permalink / raw)
  To: Richard Weinberger, Vignesh Raghavendra, Tudor Ambarus, linux-mtd
  Cc: Boris Brezillon, Thomas Petazzoni, Miquel Raynal

As previously reported by Sudip Mukherjee for the Samsung driver, the
omap2 onenand driver is called omap2.c in our directory and omap2.c in
the tty/serial/ directory. If both drivers are compiled as modules, it
would produce the following warning:

        warning: same module names found:
            drivers/tty/serial/omap2.ko
            drivers/mtd/nand/onenand/omap2.ko

Rename the onenand omap2 driver so that it fits the folder's
convention: onenand_omap2.c.

Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com>
---
 drivers/mtd/nand/onenand/Makefile                     | 2 +-
 drivers/mtd/nand/onenand/{omap2.c => onenand_omap2.c} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename drivers/mtd/nand/onenand/{omap2.c => onenand_omap2.c} (100%)

diff --git a/drivers/mtd/nand/onenand/Makefile b/drivers/mtd/nand/onenand/Makefile
index 0f2f460adbe4..a0761c7e0288 100644
--- a/drivers/mtd/nand/onenand/Makefile
+++ b/drivers/mtd/nand/onenand/Makefile
@@ -8,7 +8,7 @@ obj-$(CONFIG_MTD_ONENAND)		+= onenand.o
 
 # Board specific.
 obj-$(CONFIG_MTD_ONENAND_GENERIC)	+= generic.o
-obj-$(CONFIG_MTD_ONENAND_OMAP2)		+= omap2.o
+obj-$(CONFIG_MTD_ONENAND_OMAP2)		+= onenand_omap2.o
 obj-$(CONFIG_MTD_ONENAND_SAMSUNG)       += onenand_samsung.o
 
 onenand-objs = onenand_base.o onenand_bbt.o
diff --git a/drivers/mtd/nand/onenand/omap2.c b/drivers/mtd/nand/onenand/onenand_omap2.c
similarity index 100%
rename from drivers/mtd/nand/onenand/omap2.c
rename to drivers/mtd/nand/onenand/onenand_omap2.c
-- 
2.20.1


______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH 2/2] mtd: onenand: Rename omap2 driver to avoid a build warning
  2019-12-30 17:31 ` [PATCH 2/2] mtd: onenand: Rename omap2 driver to avoid a build warning Miquel Raynal
@ 2020-01-14 17:04   ` Miquel Raynal
  0 siblings, 0 replies; 4+ messages in thread
From: Miquel Raynal @ 2020-01-14 17:04 UTC (permalink / raw)
  To: Miquel Raynal, Richard Weinberger, Vignesh Raghavendra,
	Tudor Ambarus, linux-mtd
  Cc: Boris Brezillon, Thomas Petazzoni

On Mon, 2019-12-30 at 17:31:03 UTC, Miquel Raynal wrote:
> As previously reported by Sudip Mukherjee for the Samsung driver, the
> omap2 onenand driver is called omap2.c in our directory and omap2.c in
> the tty/serial/ directory. If both drivers are compiled as modules, it
> would produce the following warning:
> 
>         warning: same module names found:
>             drivers/tty/serial/omap2.ko
>             drivers/mtd/nand/onenand/omap2.ko
> 
> Rename the onenand omap2 driver so that it fits the folder's
> convention: onenand_omap2.c.
> 
> Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com>

Applied to https://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git nand/next.

Miquel

______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/2] mtd: onenand: Use a better name for samsung driver
  2019-12-30 17:31 [PATCH 1/2] mtd: onenand: Use a better name for samsung driver Miquel Raynal
  2019-12-30 17:31 ` [PATCH 2/2] mtd: onenand: Rename omap2 driver to avoid a build warning Miquel Raynal
@ 2020-01-14 17:04 ` Miquel Raynal
  1 sibling, 0 replies; 4+ messages in thread
From: Miquel Raynal @ 2020-01-14 17:04 UTC (permalink / raw)
  To: Miquel Raynal, Richard Weinberger, Vignesh Raghavendra,
	Tudor Ambarus, linux-mtd
  Cc: Boris Brezillon, Thomas Petazzoni

On Mon, 2019-12-30 at 17:31:02 UTC, Miquel Raynal wrote:
> Commit 55ed51fff224 ("{tty: serial, nand: onenand}: samsung: rename to
> fix build warning") has changed the samsung.c driver to be
> samsung_mtd.c in order to avoid a conflict in module names with the
> tty driver.
> 
> Since the *_mtd suffix is very undescriptive, rename it to
> onenand_samsung.c, following the folder's convention. Same will be
> applied to the omap2 onenand driver.
> 
> Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com>

Applied to https://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git nand/next.

Miquel

______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2020-01-14 17:05 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-12-30 17:31 [PATCH 1/2] mtd: onenand: Use a better name for samsung driver Miquel Raynal
2019-12-30 17:31 ` [PATCH 2/2] mtd: onenand: Rename omap2 driver to avoid a build warning Miquel Raynal
2020-01-14 17:04   ` Miquel Raynal
2020-01-14 17:04 ` [PATCH 1/2] mtd: onenand: Use a better name for samsung driver Miquel Raynal

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).