linux-mtd.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
* [GIT PULL] mtd: nand: Changes for 5.6
@ 2020-01-21 19:08 Miquel Raynal
  2020-01-30 19:51 ` Miquel Raynal
  0 siblings, 1 reply; 2+ messages in thread
From: Miquel Raynal @ 2020-01-21 19:08 UTC (permalink / raw)
  To: miquel.raynal
  Cc: Richard Weinberger, linux-mtd, Vignesh Raghavendra,
	Frieder Schrempf, Tudor Ambarus

Hello,

This is the NAND PR for 5.6.

Thanks,
Miquèl

The following changes since commit b3a987b0264d3ddbb24293ebff10eddfc472f653:

  Linux 5.5-rc6 (2020-01-12 16:55:08 -0800)

are available in the Git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git tags/nand/for-5.6

for you to fetch changes up to d85339d9ea2660b550f12aca8bd040be4395c963:

  mtd: onenand: Rename omap2 driver to avoid a build warning (2020-01-21 20:00:35 +0100)

----------------------------------------------------------------
Raw NAND
* Macronix: Use match_string() helper
* Atmel: switch to using devm_fwnode_gpiod_get()
* Denali: rework the SKIP_BYTES feature and add reset controlling
* Brcmnand: set appropriate DMA mask
* Various cleanup.

Onenand drivers
* Rename Samsung and Omap2 drivers to avoid possible build warnings
* Enable compile testing
* Various build issues
* Kconfig cleanup

SPI-NAND
* Support for Toshiba TC58CVG2S0HRAIJ

----------------------------------------------------------------
Chen Wandun (1):
      mtd: onenand: samsung: remove set but not used variable

Dmitry Torokhov (1):
      mtd: rawnand: atmel: switch to using devm_fwnode_gpiod_get()

Florian Fainelli (1):
      mtd: rawnand: brcmnand: Set appropriate DMA mask

Krzysztof Kozlowski (4):
      mtd: onenand: Fix Kconfig indentation
      mtd: onenand: samsung: Fix pointer cast -Wpointer-to-int-cast warnings on 64 bit
      mtd: onenand: samsung: Fix printing format for size_t on 64-bit
      mtd: onenand: Enable compile testing of OMAP and Samsung drivers

Marek Vasut (1):
      mtd: rawnand: denali_dt: Add support for configuring SPARE_AREA_SKIP_BYTES

Masahiro Yamada (4):
      mtd: rawnand: denali_dt: error out if platform has no associated data
      dt-bindings: mtd: denali_dt: document reset property
      mtd: rawnand: denali_dt: add reset controlling
      mtd: rawnand: denali: remove hard-coded DENALI_DEFAULT_OOB_SKIP_BYTES

Miquel Raynal (2):
      mtd: onenand: Use a better name for samsung driver
      mtd: onenand: Rename omap2 driver to avoid a build warning

Nathan Chancellor (1):
      mtd: onenand_base: Adjust indentation in onenand_read_ops_nolock

Robert Marko (1):
      mtd: spinand: add support for Toshiba TC58CVG2S0HRAIJ

YueHaibing (2):
      mtd: sharpslpart: Fix unsigned comparison to zero
      mtd: rawnand: macronix: Use match_string() helper to simplify the code

zhengbin (1):
      mtd: rawnand: mpc5121: Remove unneeded semicolon

 Documentation/devicetree/bindings/mtd/denali-nand.txt   |  7 ++
 drivers/mtd/nand/onenand/Kconfig                        | 14 ++--
 drivers/mtd/nand/onenand/Makefile                       |  4 +-
 drivers/mtd/nand/onenand/onenand_base.c                 | 82 ++++++++++++------------
 drivers/mtd/nand/onenand/{omap2.c => onenand_omap2.c}   |  0
 .../nand/onenand/{samsung_mtd.c => onenand_samsung.c}   |  9 ++-
 drivers/mtd/nand/raw/atmel/nand-controller.c            | 20 +++---
 drivers/mtd/nand/raw/brcmnand/brcmnand.c                | 10 +++
 drivers/mtd/nand/raw/denali.c                           | 14 ++--
 drivers/mtd/nand/raw/denali_dt.c                        | 56 ++++++++++++++--
 drivers/mtd/nand/raw/mpc5121_nfc.c                      |  2 +-
 drivers/mtd/nand/raw/nand_macronix.c                    | 11 ++--
 drivers/mtd/nand/spi/toshiba.c                          | 10 +++
 drivers/mtd/parsers/sharpslpart.c                       |  4 +-
 14 files changed, 155 insertions(+), 88 deletions(-)
 rename drivers/mtd/nand/onenand/{omap2.c => onenand_omap2.c} (100%)
 rename drivers/mtd/nand/onenand/{samsung_mtd.c => onenand_samsung.c} (99%)

______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [GIT PULL] mtd: nand: Changes for 5.6
  2020-01-21 19:08 [GIT PULL] mtd: nand: Changes for 5.6 Miquel Raynal
@ 2020-01-30 19:51 ` Miquel Raynal
  0 siblings, 0 replies; 2+ messages in thread
From: Miquel Raynal @ 2020-01-30 19:51 UTC (permalink / raw)
  To: miquel.raynal
  Cc: Richard Weinberger, linux-mtd, Vignesh Raghavendra,
	Frieder Schrempf, Tudor Ambarus

Hello,

Miquel Raynal <miquel.raynal@bootlin.com> wrote on Tue, 21 Jan 2020
20:08:29 +0100:

> Hello,
> 
> This is the NAND PR for 5.6.
> 
> Thanks,
> Miquèl
> 
> The following changes since commit b3a987b0264d3ddbb24293ebff10eddfc472f653:
> 
>   Linux 5.5-rc6 (2020-01-12 16:55:08 -0800)
> 
> are available in the Git repository at:
> 
>   git://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git tags/nand/for-5.6
> 
> for you to fetch changes up to d85339d9ea2660b550f12aca8bd040be4395c963:
> 
>   mtd: onenand: Rename omap2 driver to avoid a build warning (2020-01-21 20:00:35 +0100)

Pulled.

______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2020-01-30 19:51 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-01-21 19:08 [GIT PULL] mtd: nand: Changes for 5.6 Miquel Raynal
2020-01-30 19:51 ` Miquel Raynal

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).