linux-mtd.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-05-24 19:28:10 to 2020-05-26 21:52:43 UTC [more...]

[PATCH v5 00/28] Allow vendor drivers to propose their own timings
 2020-05-26 21:52 UTC  (39+ messages)
` [PATCH v5 01/28] mtd: rawnand: Use unsigned types for nand_chip unsigned values
` [PATCH v5 02/28] mtd: rawnand: Only use u8 instead of uint8_t in nand_chip structure
` [PATCH v5 03/28] mtd: rawnand: Create a nand_chip operations structure
` [PATCH v5 04/28] mtd: rawnand: Rename the manufacturer structure
` [PATCH v5 05/28] mtd: rawnand: Declare the nand_manufacturer structure out of nand_chip
` [PATCH v5 06/28] mtd: rawnand: Reorganize the nand_chip structure
` [PATCH v5 07/28] mtd: rawnand: Compare the actual timing values
` [PATCH v5 08/28] mtd: rawnand: Use the data interface mode entry when relevant
` [PATCH v5 09/28] mtd: rawnand: Rename nand_has_setup_data_interface()
` [PATCH v5 10/28] mtd: rawnand: Fix nand_setup_data_interface() description
` [PATCH v5 11/28] mtd: rawnand: Rename nand_init_data_interface()
` [PATCH v5 12/28] mtd: rawnand: timings: Update onfi_fill_data_interface() kernel doc
` [PATCH v5 13/28] mtd: rawnand: timings: Provide onfi_fill_data_interface() with a data interface
` [PATCH v5 14/28] mtd: rawnand: timings: Add a helper to find the closest ONFI mode
` [PATCH v5 15/28] mtd: rawnand: timings: Avoid redefining tR_max and tCCS_min
` [PATCH v5 16/28] mtd: rawnand: timings: Use default values for tPROG_max and tBERS_max
` [PATCH v5 17/28] mtd: rawnand: Define a unique reset data interface
` [PATCH v5 18/28] mtd: rawnand: marvell: Use a helper to access the timings
` [PATCH v5 19/28] mtd: rawnand: legacy: "
` [PATCH v5 20/28] mtd: rawnand: Hide the chip->data_interface indirection
` [PATCH v5 21/28] mtd: rawnand: Introduce nand_choose_best_sdr_timings()
` [PATCH v5 22/28] mtd: rawnand: Add the ->choose_data_interface() hook
` [PATCH v5 23/28] mtd: rawnand: toshiba: Implement ->choose_data_interface() for TC58TEG5DCLTA00
` [PATCH v5 24/28] mtd: rawnand: toshiba: Implement ->choose_data_interface() for TC58NVG0S3E
` [PATCH v5 25/28] mtd: rawnand: hynix: Implement ->choose_data_interface() for H27UCG8T2ATR-BC
` [PATCH v5 26/28] mtd: rawnand: toshiba: Choose the data interface for TH58NVG2S3HBAI4
` [PATCH v5 27/28] mtd: rawnand: Get rid of the default ONFI timing mode
` [PATCH v5 28/28] mtd: rawnand: Allocate the best data interface structure dynamically

[RESENDPATCH v8 0/2] mtd: rawnand: Add NAND controller support on Intel LGM SoC
 2020-05-26 20:43 UTC  (3+ messages)
` [RESENDPATCH v8 1/2] dt-bindings: mtd: Add Nand Flash Controller support for "

[RESEND v5 00/21] Introduce the generic ECC engine abstraction
 2020-05-26 19:56 UTC  (22+ messages)
` [RESEND v5 01/21] mtd: Fix typo in mtd_ooblayout_set_databytes() description
` [RESEND v5 02/21] mtd: rawnand: Avoid a typedef
` [RESEND v5 03/21] mtd: rawnand: Drop OOB_FIRST placement scheme
` [RESEND v5 04/21] dt-bindings: mtd: Deprecate OOB_FIRST mode
` [RESEND v5 05/21] mtd: rawnand: Return an enum from of_get_nand_ecc_algo()
` [RESEND v5 06/21] mtd: rawnand: Add an invalid ECC mode to discriminate with valid ones
` [RESEND v5 07/21] mtd: rawnand: Create a new enumeration to describe OOB placement
` [RESEND v5 08/21] mtd: rawnand: Separate the ECC engine type and the "
` [RESEND v5 09/21] mtd: rawnand: Create a new enumeration to describe properly ECC types
` [RESEND v5 10/21] mtd: rawnand: Create a helper to retrieve the ECC placement
` [RESEND v5 11/21] mtd: rawnand: Use the new ECC engine type enumeration
` [RESEND v5 12/21] mtd: rawnand: Deprecate nand-ecc-mode in favor of nand-ecc-provider
` [RESEND v5 13/21] mtd: rawnand: Drop the legacy ECC type enumeration
` [RESEND v5 14/21] dt-bindings: mtd: Add the nand-ecc-placement property
` [RESEND v5 15/21] dt-bindings: mtd: Deprecate hw_syndrome from the ECC modes
` [RESEND v5 16/21] dt-bindings: mtd: Deprecate the nand-ecc-mode property
` [RESEND v5 17/21] mtd: nand: Move nand_device forward declaration to the top
` [RESEND v5 18/21] mtd: nand: Add an extra level in the Kconfig hierarchy
` [RESEND v5 19/21] mtd: nand: Drop useless 'depends on' in Kconfig
` [RESEND v5 20/21] mtd: nand: Add a NAND page I/O request type
` [RESEND v5 21/21] mtd: nand: Rename a core structure

Missing 2 blocks on my UBI partition
 2020-05-26 17:21 UTC  (3+ messages)

[PATCH v4 00/19] Allow vendor drivers to propose their own timings
 2020-05-26 11:42 UTC  (44+ messages)
` [PATCH v4 01/19] mtd: rawnand: Use unsigned types for nand_chip unsigned values
` [PATCH v4 02/19] mtd: rawnand: Only use u8 instead of uint8_t in nand_chip structure
` [PATCH v4 03/19] mtd: rawnand: Create a nand_chip operations structure
` [PATCH v4 04/19] mtd: rawnand: Rename the manufacturer structure
` [PATCH v4 05/19] mtd: rawnand: Declare the nand_manufacturer structure out of nand_chip
` [PATCH v4 06/19] mtd: rawnand: Reorganize the nand_chip structure
` [PATCH v4 07/19] mtd: rawnand: Compare the actual timing values
` [PATCH v4 08/19] mtd: rawnand: Rename onfi_timing_mode_default
` [PATCH v4 09/19] mtd: rawnand: Use the data interface mode entry when relevant
` [PATCH v4 10/19] mtd: rawnand: Rename nand_has_setup_data_interface()
` [PATCH v4 11/19] mtd: rawnand: Fix nand_setup_data_interface() description
` [PATCH v4 12/19] mtd: rawnand: Rename nand_init_data_interface()
` [PATCH v4 13/19] mtd: rawnand: timings: Update onfi_fill_data_interface() kernel doc
` [PATCH v4 14/19] mtd: rawnand: timings: Provide onfi_fill_data_interface() with a data interface
` [PATCH v4 15/19] mtd: rawnand: timings: Add a helper to find the closest ONFI mode
` [PATCH v4 16/19] mtd: rawnand: Introduce nand_choose_best_sdr_iface()
` [PATCH v4 17/19] mtd: rawnand: Introduce nand_choose_best_vendor_sdr_iface()
    ` SV: "
` [PATCH v4 18/19] mtd: rawnand: Add the ->choose_data_interface() hook
` [PATCH v4 19/19] mtd: rawnand: Add timings for Kioxia TH58NVG2S3HBAI4

[RFC PATCH 0/3] Add prepare/unprepare method in spi_controller_mem_ops
 2020-05-26  9:43 UTC  (6+ messages)
` [RFC PATCH 3/3] spi: hisi-sfc-v3xx: Add prepare/unprepare methods to avoid race condition

[PATCH v2 0/6] mtd: spi-nor: Move cadence-qaudspi to spi-mem framework
 2020-05-26  9:36 UTC  (7+ messages)
` [PATCH v2 1/6] mtd: spi-nor: cadence-quadspi: Make driver independent of flash geometry
` [PATCH v2 2/6] mtd: spi-nor: cadence-quadspi: Provide a way to disable DAC mode
` [PATCH v2 3/6] mtd: spi-nor: cadence-quadspi: Don't initialize rx_dma_complete on failure
` [PATCH v2 4/6] mtd: spi-nor: cadence-quadspi: Fix error path on failure to acquire reset lines
` [PATCH v2 5/6] mtd: spi-nor: Convert cadence-quadspi to use spi-mem framework
` [PATCH v2 6/6] spi: Move cadence-quadspi driver to drivers/spi/

[PATCH 0/6] mtd: spi-nor: Move cadence-qaudspi to spi-mem framework
 2020-05-26  9:31 UTC  (3+ messages)
` [PATCH 1/6] mtd: spi-nor: cadence-quadspi: Drop cdns, is-decoded-cs property
  ` [PATCH 1/6] mtd: spi-nor: cadence-quadspi: Drop cdns,is-decoded-cs property

[PATCH] ubifs: code cleanup by removing ifdef macro surrounding
 2020-05-26  9:07 UTC 

[GIT PULL] CFI and HyperFlash changes for v5.8-rc1
 2020-05-26  9:06 UTC 

[PATCH] mtd: Replace zero-length array with flexible-array
 2020-05-26  8:46 UTC  (2+ messages)

[PATCH v3 1/2] mtd: rawnand: Add and use helper for testing data interface
 2020-05-26  7:34 UTC  (4+ messages)
` [PATCH v3 2/2] mtd: rawnand: Add timings for Kioxia TH58NVG2S3HBAI4
  ` SV: [PATCH v3 1/2] mtd: rawnand: Add and use helper for testing data interface

[PATCH] jffs2: GC deadlock reading a page that is used in jffs2_write_begin()
 2020-05-25 19:45 UTC  (4+ messages)

[PATCH v6 0/5] Micron SLC NAND filling block
 2020-05-25 12:18 UTC  (6+ messages)
` [PATCH v6 1/5] mtd: rawnand: group all NAND specific ops into new nand_chip_ops
` [PATCH v6 2/5] mtd: rawnand: Add {pre, post}_erase hooks in nand_chip_ops
` [PATCH v6 3/5] mtd: rawnand: Add write_oob hook "
` [PATCH v6 4/5] mtd: rawnand: Introduce a new function nand_check_is_erased_page()
` [PATCH v6 5/5] mtd: rawnand: micron: Micron SLC NAND filling block

[PATCH v9 00/19] mtd: spi-nor: add xSPI Octal DTR support
 2020-05-25  9:15 UTC  (20+ messages)
` [PATCH v9 01/19] spi: spi-mem: allow specifying whether an op is DTR or not
` [PATCH v9 02/19] spi: spi-mem: allow specifying a command's extension
` [PATCH v9 03/19] spi: atmel-quadspi: reject DTR ops
` [PATCH v9 04/19] spi: spi-mtk-nor: "
` [PATCH v9 05/19] mtd: spi-nor: add support for DTR protocol
` [PATCH v9 06/19] mtd: spi-nor: sfdp: default to addr_width of 3 for configurable widths
` [PATCH v9 07/19] mtd: spi-nor: sfdp: prepare BFPT parsing for JESD216 rev D
` [PATCH v9 08/19] mtd: spi-nor: sfdp: get command opcode extension type from BFPT
` [PATCH v9 09/19] mtd: spi-nor: sfdp: parse xSPI Profile 1.0 table
` [PATCH v9 10/19] mtd: spi-nor: core: use dummy cycle and address width info from SFDP
` [PATCH v9 11/19] mtd: spi-nor: core: do 2 byte reads for SR and FSR in DTR mode
` [PATCH v9 12/19] mtd: spi-nor: core: enable octal DTR mode when possible
` [PATCH v9 13/19] mtd: spi-nor: sfdp: do not make invalid quad enable fatal
` [PATCH v9 14/19] mtd: spi-nor: sfdp: detect Soft Reset sequence support from BFPT
` [PATCH v9 15/19] mtd: spi-nor: core: perform a Soft Reset on shutdown
` [PATCH v9 16/19] mtd: spi-nor: core: disable Octal DTR mode on suspend
` [PATCH v9 17/19] mtd: spi-nor: core: expose spi_nor_default_setup() in core.h
` [PATCH v9 18/19] mtd: spi-nor: spansion: add support for Cypress Semper flash
` [PATCH v9 19/19] mtd: spi-nor: micron-st: allow using MT35XU512ABA in Octal DTR mode

[PATCH v2 00/17] Clean nandsim error path
 2020-05-25  8:58 UTC  (18+ messages)
` [PATCH v2 01/17] mtd: rawnand: nandsim: Consistent use of 'ns' instead of 'dev'
` [PATCH v2 02/17] mtd: rawnand: nandsim: Use octal permissions
` [PATCH v2 03/17] mtd: rawnand: nandsim: Use a consistent ns_ prefix for all functions
` [PATCH v2 04/17] mtd: rawnand: nandsim: Clean error handling
` [PATCH v2 05/17] mtd: rawnand: nandsim: Keep track of the created debugfs entries
` [PATCH v2 06/17] mtd: rawnand: nandsim: Remove debugfs entries at unload time
` [PATCH v2 07/17] mtd: rawnand: nandsim: Fix the two ns_alloc_device() error paths
` [PATCH v2 08/17] mtd: rawnand: nandsim: Free partition names on error in ns_init()
` [PATCH v2 09/17] mtd: rawnand: nandsim: Free the allocated device "
` [PATCH v2 10/17] mtd: rawnand: nandsim: Free the partition names in ns_free()
` [PATCH v2 11/17] mtd: rawnand: nandsim: Stop using nand_release()
` [PATCH v2 12/17] mtd: rawnand: nandsim: Use an additional label when freeing the nandsim object
` [PATCH v2 13/17] mtd: rawnand: nandsim: Free erase_block_wear on error
` [PATCH v2 14/17] mtd: rawnand: nandsim: Fix the label pointing on nand_cleanup()
` [PATCH v2 15/17] mtd: rawnand: nandsim: Manage lists on error in ns_init_module()
` [PATCH v2 16/17] mtd: rawnand: nandsim: Rename a label "
` [PATCH v2 17/17] mtd: rawnand: nandsim: Reorganize ns_cleanup_module()

[PATCH v2 00/17] Clean nandsim error path
 2020-05-25  8:55 UTC  (4+ messages)
` [PATCH v2 01/62] mtd: rawnand: ams-delta: Stop using nand_release()
` [PATCH v2 01/17] mtd: rawnand: nandsim: Consistent use of 'ns' instead of 'dev'

[PATCH 00/17] Clean nandsim error path
 2020-05-25  8:35 UTC  (17+ messages)
` [PATCH 06/17] mtd: rawnand: nandsim: Remove debugfs entries at unload time
` [PATCH 15/17] mtd: rawnand: nandsim: Manage lists on error in ns_init_module()
` [PATCH 17/17] mtd: rawnand: nandsim: Reorganize ns_cleanup_module()

[PATCH v2 0/2] enable spi flash and update is25wp256d page write capabilities
 2020-05-25  5:45 UTC  (2+ messages)

[PATCH v4 4/5] dt: bindings: brcmnand: add v2.1 and v2.2 support
 2020-05-24 22:06 UTC  (4+ messages)

[PATCH v4 5/5] mtd: rawnand: brcmnand: support v2.1-v2.2 controllers
 2020-05-24 22:06 UTC  (2+ messages)

[PATCH v8 00/19] mtd: spi-nor: add xSPI Octal DTR support
 2020-05-24 20:17 UTC  (3+ messages)
` [PATCH v8 02/19] spi: spi-mem: allow specifying a command's extension

[PATCH v4 1/5] mtd: rawnand: brcmnand: rename v4 registers
 2020-05-24 19:26 UTC  (2+ messages)

[PATCH v4 2/5] mtd: rawnand: brcmnand: fix CS0 layout
 2020-05-24 19:26 UTC  (2+ messages)

[PATCH v4 3/5] mtd: rawnand: brcmnand: rename page sizes
 2020-05-24 19:26 UTC  (2+ messages)

[PATCH v5 1/2] mtd: rawnand: stm32_fmc2: cosmetic change to use nfc instead of fmc2 where relevant
 2020-05-24 19:17 UTC  (2+ messages)

[PATCH v5 2/2] mtd: rawnand: stm32_fmc2: use FIELD_PREP/FIELD_GET macros
 2020-05-24 19:17 UTC  (2+ messages)

[PATCH v2 01/19] mtd: rawnand: Propage CS selection to sub operations
 2020-05-24 19:17 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).