linux-mtd.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-05-28 15:36:22 to 2020-06-01 08:59:46 UTC [more...]

[PATCH v9 00/19] mtd: spi-nor: add xSPI Octal DTR support
 2020-06-01  8:58 UTC  (8+ messages)
` [PATCH v9 06/19] mtd: spi-nor: sfdp: default to addr_width of 3 for configurable widths
` [PATCH v9 07/19] mtd: spi-nor: sfdp: prepare BFPT parsing for JESD216 rev D
` [PATCH v9 13/19] mtd: spi-nor: sfdp: do not make invalid quad enable fatal

[PATCH] block: Flag elevators suitable for single queue
 2020-06-01  7:49 UTC  (2+ messages)

[PATCH v3 0/8] mtd: spi-nor: Move cadence-qaudspi to spi-mem framework
 2020-06-01  7:07 UTC  (14+ messages)
` [PATCH v3 1/8] mtd: spi-nor: cadence-quadspi: Make driver independent of flash geometry
` [PATCH v3 2/8] mtd: spi-nor: cadence-quadspi: Provide a way to disable DAC mode
` [PATCH v3 3/8] mtd: spi-nor: cadence-quadspi: Don't initialize rx_dma_complete on failure
` [PATCH v3 4/8] mtd: spi-nor: cadence-quadspi: Fix error path on failure to acquire reset lines
` [PATCH v3 5/8] mtd: spi-nor: cadence-quadspi: Handle probe deferral while requesting DMA channel
` [PATCH v3 6/8] mtd: spi-nor: cadence-quadspi: Drop redundant WREN in erase path
` [PATCH v3 7/8] mtd: spi-nor: Convert cadence-quadspi to use spi-mem framework
` [PATCH v3 8/8] spi: Move cadence-quadspi driver to drivers/spi/

[RESEND PATCH v3 0/8] mtd: spi-nor: Move cadence-qaudspi to spi-mem framework
 2020-06-01  7:04 UTC  (9+ messages)
` [RESEND PATCH v3 1/8] mtd: spi-nor: cadence-quadspi: Make driver independent of flash geometry
` [RESEND PATCH v3 2/8] mtd: spi-nor: cadence-quadspi: Provide a way to disable DAC mode
` [RESEND PATCH v3 3/8] mtd: spi-nor: cadence-quadspi: Don't initialize rx_dma_complete on failure
` [RESEND PATCH v3 4/8] mtd: spi-nor: cadence-quadspi: Fix error path on failure to acquire reset lines
` [RESEND PATCH v3 5/8] mtd: spi-nor: cadence-quadspi: Handle probe deferral while requesting DMA channel
` [RESEND PATCH v3 6/8] mtd: spi-nor: cadence-quadspi: Drop redundant WREN in erase path
` [RESEND PATCH v3 7/8] mtd: spi-nor: Convert cadence-quadspi to use spi-mem framework
` [RESEND PATCH v3 8/8] spi: Move cadence-quadspi driver to drivers/spi/

[GIT PULL] fscrypt updates for 5.8
 2020-06-01  6:28 UTC 

[PATCH v2 0/6] mtd: spi-nor: Move cadence-qaudspi to spi-mem framework
 2020-06-01  4:56 UTC  (12+ messages)
` [PATCH v2 2/6] mtd: spi-nor: cadence-quadspi: Provide a way to disable DAC mode
` [PATCH v2 3/6] mtd: spi-nor: cadence-quadspi: Don't initialize rx_dma_complete on failure
` [PATCH v2 4/6] mtd: spi-nor: cadence-quadspi: Fix error path on failure to acquire reset lines
` [PATCH v2 5/6] mtd: spi-nor: Convert cadence-quadspi to use spi-mem framework
` [PATCH v2 6/6] spi: Move cadence-quadspi driver to drivers/spi/

[GIT PULL] mtd: nand: Changes for 5.8
 2020-05-31  9:18 UTC 

[PATCH] mtd: spi-nor: sfdp: add/use local variable in spi_nor_parse_bfpt()
 2020-05-31  6:05 UTC  (2+ messages)

[PATCH] mtd: spi-nor: fix 4-byte opcode support for w25q256
 2020-05-31  6:05 UTC  (2+ messages)

[PATCH v2 1/3] dt-bindings: pinctrl: Convert ingenic, pinctrl.txt to YAML
 2020-05-30 11:04 UTC  (7+ messages)
` [PATCH v2 2/3] dt-bindings: memory: Convert ingenic, jz4780-nemc.txt "
  ` [PATCH v2 2/3] dt-bindings: memory: Convert ingenic,jz4780-nemc.txt "
` [PATCH v2 3/3] dt-bindings: mtd: Convert ingenic, jz4780-nand.txt "

[PATCH v11 0/2] mtd: rawnand: Add NAND controller support on Intel LGM SoC
 2020-05-30  0:51 UTC  (3+ messages)
` [PATCH v11 1/2] dt-bindings: mtd: Add Nand Flash Controller support for "
` [PATCH v11 2/2] mtd: rawnand: Add NAND controller support on "

[PATCH v10 0/2] mtd: rawnand: Add NAND controller support on Intel LGM SoC
 2020-05-30  0:18 UTC  (5+ messages)
` [PATCH v10 1/2] dt-bindings: mtd: Add Nand Flash Controller support for "
` [PATCH v10 2/2] mtd: rawnand: Add NAND controller support on "

[PATCH v7 00/20] Introduce the generic ECC engine abstraction
 2020-05-29 22:21 UTC  (28+ messages)
` [PATCH v7 01/20] dt-bindings: mtd: Document nand-ecc-placement
` [PATCH v7 02/20] mtd: rawnand: Create a new enumeration to describe ECC bytes placement
` [PATCH v7 03/20] mtd: rawnand: Separate the ECC engine type and the ECC byte placement
` [PATCH v7 04/20] mtd: rawnand: Create a helper to retrieve the ECC placement
` [PATCH v7 05/20] mtd: rawnand: Add a kernel doc to the ECC algorithm enumeration
` [PATCH v7 06/20] mtd: rawnand: Rename the ECC algorithm enumeration items
` [PATCH v7 07/20] mtd: rawnand: Create a new enumeration to describe properly ECC types
` [PATCH v7 08/20] mtd: rawnand: Use the new ECC engine type enumeration
` [PATCH v7 09/20] mtd: nand: Move nand_device forward declaration to the top
` [PATCH v7 10/20] mtd: nand: Add an extra level in the Kconfig hierarchy
` [PATCH v7 11/20] mtd: nand: Drop useless 'depends on' in Kconfig
` [PATCH v7 12/20] mtd: nand: Add a NAND page I/O request type
` [PATCH v7 13/20] mtd: nand: Rename a core structure
` [PATCH v7 14/20] mtd: nand: Add more parameters to the nand_ecc_props structure
` [PATCH v7 15/20] mtd: nand: Introduce the ECC engine abstraction
` [PATCH v7 16/20] mtd: nand: Convert generic NAND bits to use the ECC framework
` [PATCH v7 17/20] mtd: rawnand: Hide the generic OOB layout objects behind helpers
` [PATCH v7 18/20] mtd: rawnand: Write a compatibility layer
` [PATCH v7 19/20] mtd: rawnand: Move generic OOB layouts to the ECC framework
` [PATCH v7 20/20] mtd: rawnand: Move the user input parsing bits "

[PATCH v8 0/5] Preparation to the generic ECC engine abstraction
 2020-05-29 13:16 UTC  (6+ messages)
` [PATCH v8 1/5] mtd: nand: Convert generic NAND bits to use the ECC framework
` [PATCH v8 2/5] mtd: rawnand: Hide the generic OOB layout objects behind helpers
` [PATCH v8 3/5] mtd: rawnand: Write a compatibility layer
` [PATCH v8 4/5] mtd: rawnand: Move generic OOB layouts to the ECC framework
` [PATCH v8 5/5] mtd: rawnand: Move the user input parsing bits "

[PATCH v7 00/28] Allow vendor drivers to propose their own timings
 2020-05-29 11:52 UTC  (42+ messages)
` [PATCH v7 01/28] mtd: rawnand: Use unsigned types for nand_chip unsigned values
` [PATCH v7 02/28] mtd: rawnand: Only use u8 instead of uint8_t in nand_chip structure
` [PATCH v7 03/28] mtd: rawnand: Create a nand_chip operations structure
` [PATCH v7 04/28] mtd: rawnand: Rename the manufacturer structure
` [PATCH v7 05/28] mtd: rawnand: Declare the nand_manufacturer structure out of nand_chip
` [PATCH v7 06/28] mtd: rawnand: Reorganize the nand_chip structure
` [PATCH v7 07/28] mtd: rawnand: Compare the actual timing values
` [PATCH v7 08/28] mtd: rawnand: Use the data interface mode entry when relevant
` [PATCH v7 09/28] mtd: rawnand: Rename nand_has_setup_data_iface()
` [PATCH v7 10/28] mtd: rawnand: Fix nand_setup_data_interface() description
` [PATCH v7 11/28] mtd: rawnand: Rename nand_init_data_interface()
` [PATCH v7 12/28] mtd: rawnand: timings: Update onfi_fill_data_interface() kernel doc
` [PATCH v7 13/28] mtd: rawnand: timings: Provide onfi_fill_data_interface() with a data interface
` [PATCH v7 14/28] mtd: rawnand: timings: onfi_fill_data_interface timing mode is unsigned
` [PATCH v7 15/28] mtd: rawnand: timings: Add a helper to find the closest ONFI mode
` [PATCH v7 16/28] mtd: rawnand: timings: Avoid redefining tR_max and tCCS_min
` [PATCH v7 17/28] mtd: rawnand: timings: Use default values for tPROG_max and tBERS_max
` [PATCH v7 18/28] mtd: rawnand: Hide the chip->data_interface indirection
` [PATCH v7 19/28] mtd: rawnand: s/data_interface/interface_config/
` [PATCH v7 20/28] mtd: rawnand: timings: Make onfi_fill_interface_config() a void helper
` [PATCH v7 21/28] mtd: rawnand: Introduce nand_choose_best_sdr_timings()
` [PATCH v7 22/28] mtd: rawnand: Add the ->choose_interface_config() hook
` [PATCH v7 23/28] mtd: rawnand: toshiba: Implement ->choose_interface_config() for TC58TEG5DCLTA00
` [PATCH v7 24/28] mtd: rawnand: toshiba: Implement ->choose_interface_config() for TC58NVG0S3E
` [PATCH v7 25/28] mtd: rawnand: hynix: Implement ->choose_interface_config() for H27UCG8T2ATR-BC
` [PATCH v7 26/28] mtd: rawnand: toshiba: Choose the interface configuration for TH58NVG2S3HBAI4
` [PATCH v7 27/28] mtd: rawnand: Get rid of the default ONFI timing mode
` [PATCH v7 28/28] mtd: rawnand: Allocate the interface configurations dynamically

[PATCH v4 0/7] mtd: spi-nor: add xSPI Octal DTR support
 2020-05-29  9:42 UTC  (12+ messages)
` [PATCH v4 1/7] mtd: spi-nor: sfdp: get octal mode maximum speed from BFPT
` [PATCH v4 2/7] mtd: spi-nor: sfdp: parse xSPI Profile 1.0 table
` [PATCH v4 3/7] mtd: spi-nor: sfdp: parse command sequences to change octal DTR mode
` [PATCH v4 4/7] mtd: spi-nor: core: add configuration register 2 read & write support
` [PATCH v4 5/7] mtd: spi-nor: core: execute command sequences to change octal DTR mode
` [PATCH v4 6/7] spi: mxic: patch for octal DTR mode support
` [PATCH v4 7/7] mtd: spi-nor: macronix: Add Octal 8D-8D-8D supports for Macronix mx25uw51245g

[PATCH v6 00/30] Allow vendor drivers to propose their own timings
 2020-05-29  9:27 UTC  (44+ messages)
` [PATCH v6 01/30] mtd: rawnand: Use unsigned types for nand_chip unsigned values
` [PATCH v6 02/30] mtd: rawnand: Only use u8 instead of uint8_t in nand_chip structure
` [PATCH v6 03/30] mtd: rawnand: Create a nand_chip operations structure
` [PATCH v6 04/30] mtd: rawnand: Rename the manufacturer structure
` [PATCH v6 05/30] mtd: rawnand: Declare the nand_manufacturer structure out of nand_chip
` [PATCH v6 06/30] mtd: rawnand: Reorganize the nand_chip structure
` [PATCH v6 07/30] mtd: rawnand: Compare the actual timing values
` [PATCH v6 08/30] mtd: rawnand: Use the data interface mode entry when relevant
` [PATCH v6 09/30] mtd: rawnand: Rename nand_has_setup_data_iface()
` [PATCH v6 10/30] mtd: rawnand: Fix nand_setup_data_interface() description
` [PATCH v6 11/30] mtd: rawnand: Rename nand_init_data_interface()
` [PATCH v6 12/30] mtd: rawnand: timings: Update onfi_fill_data_interface() kernel doc
` [PATCH v6 13/30] mtd: rawnand: timings: Provide onfi_fill_data_interface() with a data interface
` [PATCH v6 14/30] mtd: rawnand: timings: Add a helper to find the closest ONFI mode
` [PATCH v6 15/30] mtd: rawnand: timings: Avoid redefining tR_max and tCCS_min
` [PATCH v6 16/30] mtd: rawnand: timings: Use default values for tPROG_max and tBERS_max
` [PATCH v6 17/30] mtd: rawnand: s/data_interface/interface_config/
` [PATCH v6 18/30] mtd: rawnand: timings: Make onfi_fill_interface_config() a void helper
` [PATCH v6 19/30] mtd: rawnand: Define a unique reset interface configuration
` [PATCH v6 20/30] mtd: rawnand: marvell: Use a helper to access the timings
` [PATCH v6 21/30] mtd: rawnand: legacy: "
` [PATCH v6 22/30] mtd: rawnand: Hide the chip->interface_config indirection
` [PATCH v6 23/30] mtd: rawnand: Introduce nand_choose_best_sdr_timings()
` [PATCH v6 24/30] mtd: rawnand: Add the ->choose_interface() hook
` [PATCH v6 25/30] mtd: rawnand: toshiba: Implement ->choose_interface() for TC58TEG5DCLTA00
` [PATCH v6 26/30] mtd: rawnand: toshiba: Implement ->choose_interface() for TC58NVG0S3E
` [PATCH v6 27/30] mtd: rawnand: hynix: Implement ->choose_interface() for H27UCG8T2ATR-BC
` [PATCH v6 28/30] mtd: rawnand: toshiba: Choose the data interface for TH58NVG2S3HBAI4
` [PATCH v6 29/30] mtd: rawnand: Get rid of the default ONFI timing mode
` [PATCH v6 30/30] mtd: rawnand: Allocate the best interface configuration dynamically

[PATCH v2 1/1] drivers: mtd: spi-nor: update read capabilities for w25q64 and s25fl064k
 2020-05-29  7:16 UTC 

[PATCH 1/2] mtd: spi-nor: create/Export parameter softwareseq for intel-spi driver to user
 2020-05-29  5:36 UTC  (3+ messages)

[PATCH v3 00/14] mtd: spi-nor: add xSPI Octal DTR support
 2020-05-29  5:27 UTC  (3+ messages)

[PATCH] jffs2: fix nothing output for "ls" command
 2020-05-29  3:38 UTC 

[PATCH] jffs2: fix GC exit abnormally
 2020-05-29  3:37 UTC 

[PATCH v6 00/18] Introduce the generic ECC engine abstraction
 2020-05-28 23:55 UTC  (11+ messages)
` [PATCH v6 15/18] mtd: nand: Introduce the "
` [PATCH v6 16/18] mtd: nand: Convert generic NAND bits to use the ECC framework
` [PATCH v6 18/18] mtd: rawnand: Move generic bits to "

[PATCH v3 12/14] spi: mxic: patch for octal DTR mode support
 2020-05-28 21:44 UTC  (2+ messages)

[PATCH v2 1/4] dt-bindings: mtd: rawnand: ingenic: Clarify the active state of the RB pin
 2020-05-28 21:22 UTC  (3+ messages)
` [PATCH v2 2/4] dt-bindings: mtd: nand: Document the generic rb-gpios property

[PATCH 0/6] mtd: spi-nor: Move cadence-qaudspi to spi-mem framework
 2020-05-28 18:37 UTC  (3+ messages)
` [PATCH 2/6] mtd: spi-nor: cadence-quadspi: Provide a way to disable DAC mode

[PATCH 2/2] mtd: spi-nor: intel-spi: fix forced writable option
 2020-05-28 15:55 UTC  (3+ messages)

[PATCH v9 0/2] mtd: rawnand: Add NAND controller support on Intel LGM SoC
 2020-05-28 15:34 UTC  (3+ messages)
` [PATCH v9 1/2] dt-bindings: mtd: Add Nand Flash Controller support for "
` [PATCH v9 2/2] mtd: rawnand: Add NAND controller support on "


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).