Hi all, Today's linux-next merge of the drm-intel tree got a conflict in: drivers/gpu/drm/i915/i915_drv.h between commit: 3bb6a44251b4 ("drm/i915: Rename ggtt_view as gtt_view") from the drm tree and commit: 5fd5cc73e449 ("drm/i915: split out i915_gem.c declarations to i915_gem.h") from the drm-intel tree. I fixed it up (I used the latter version of this file and applied the merge fix below) and can carry the fix as necessary. This is now fixed as far as linux-next is concerned, but any non trivial conflicts should be mentioned to your upstream maintainer when your tree is submitted for merging. You may also want to consider cooperating with the maintainer of the conflicting tree to minimise any particularly complex conflicts. From: Stephen Rothwell Date: Tue, 13 Sep 2022 12:06:57 +1000 Subject: [PATCH] drm/i915: fix up for "drm/i915: Rename ggtt_view as gtt_view" Signed-off-by: Stephen Rothwell --- drivers/gpu/drm/i915/i915_gem.h | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/gpu/drm/i915/i915_gem.h b/drivers/gpu/drm/i915/i915_gem.h index 2fccb19ed9f7..a5cdf6662d01 100644 --- a/drivers/gpu/drm/i915/i915_gem.h +++ b/drivers/gpu/drm/i915/i915_gem.h @@ -36,7 +36,7 @@ struct drm_file; struct drm_i915_gem_object; struct drm_i915_private; struct i915_gem_ww_ctx; -struct i915_ggtt_view; +struct i915_gtt_view; struct i915_vma; void i915_gem_init_early(struct drm_i915_private *i915); @@ -48,12 +48,12 @@ void i915_gem_drain_workqueue(struct drm_i915_private *i915); struct i915_vma * __must_check i915_gem_object_ggtt_pin_ww(struct drm_i915_gem_object *obj, struct i915_gem_ww_ctx *ww, - const struct i915_ggtt_view *view, + const struct i915_gtt_view *view, u64 size, u64 alignment, u64 flags); struct i915_vma * __must_check i915_gem_object_ggtt_pin(struct drm_i915_gem_object *obj, - const struct i915_ggtt_view *view, + const struct i915_gtt_view *view, u64 size, u64 alignment, u64 flags); int i915_gem_object_unbind(struct drm_i915_gem_object *obj, -- 2.35.1 -- Cheers, Stephen Rothwell