linux-nfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-11-10 21:48:00 to 2020-11-14 18:49:45 UTC [more...]

[PATCH v1 00/61] Update NFSD XDR functions
 2020-11-14 18:49 UTC  (70+ messages)
` [PATCH v1 01/61] NFSD: Fix returned READDIR offset cookie
` [PATCH v1 02/61] SUNRPC: Add xdr_set_scratch_page() and xdr_reset_scratch_buffer()
` [PATCH v1 03/61] SUNRPC: Prepare for xdr_stream-style decoding on the server-side
` [PATCH v1 04/61] NFSD: Add common helpers to decode void args and encode void results
` [PATCH v1 05/61] NFSD: Replace the internals of the READ_BUF() macro
` [PATCH v1 06/61] NFSD: Replace READ* macros in nfsd4_decode_access()
` [PATCH v1 07/61] NFSD: Replace READ* macros in nfsd4_decode_close()
` [PATCH v1 08/61] NFSD: Replace READ* macros in nfsd4_decode_commit()
` [PATCH v1 09/61] NFSD: Replace READ* macros in nfsd4_decode_create()
` [PATCH v1 10/61] NFSD: Replace READ* macros in nfsd4_decode_bitmap()
` [PATCH v1 11/61] NFSD: Replace READ* macros in nfsd4_decode_link()
` [PATCH v1 12/61] NFSD: Relocate nfsd4_decode_opaque()
` [PATCH v1 13/61] NFSD: Replace READ* macros in nfsd4_decode_lock()
` [PATCH v1 14/61] NFSD: Replace READ* macros in nfsd4_decode_lockt()
` [PATCH v1 15/61] NFSD: Replace READ* macros in nfsd4_decode_locku()
` [PATCH v1 16/61] NFSD: Replace READ* macros in nfsd4_decode_lookup()
` [PATCH v1 17/61] NFSD: Replace READ* macros in nfsd4_decode_time()
` [PATCH v1 18/61] NFSD: Replace READ* macros in nfsd4_decode_fattr()
` [PATCH v1 19/61] NFSD: Replace READ* macros in nfsd4_decode_open()
` [PATCH v1 20/61] NFSD: Replace READ* macros in nfsd4_decode_open_confirm()
` [PATCH v1 21/61] NFSD: Replace READ* macros in nfsd4_decode_open_downgrade()
` [PATCH v1 22/61] NFSD: Replace READ* macros in nfsd4_decode_putfh()
` [PATCH v1 23/61] NFSD: Replace READ* macros in nfsd4_decode_read()
` [PATCH v1 24/61] NFSD: Replace READ* macros in nfsd4_decode_readdir()
` [PATCH v1 25/61] NFSD: Replace READ* macros in nfsd4_decode_remove()
` [PATCH v1 26/61] NFSD: Replace READ* macros in nfsd4_decode_rename()
` [PATCH v1 27/61] NFSD: Replace READ* macros in nfsd4_decode_renew()
` [PATCH v1 28/61] NFSD: Replace READ* macros in nfsd4_decode_secinfo()
` [PATCH v1 29/61] NFSD: Replace READ* macros in nfsd4_decode_setclientid()
` [PATCH v1 30/61] NFSD: Replace READ* macros in nfsd4_decode_setclientid_confirm()
` [PATCH v1 31/61] NFSD: Replace READ* macros in nfsd4_decode_verify()
` [PATCH v1 32/61] NFSD: Replace READ* macros in nfsd4_decode_write()
` [PATCH v1 33/61] NFSD: Replace READ* macros in nfsd4_decode_release_lockowner()
` [PATCH v1 34/61] NFSD: Replace READ* macros in nfsd4_decode_cb_sec()
` [PATCH v1 35/61] NFSD: Replace READ* macros in nfsd4_decode_backchannel_ctl()
` [PATCH v1 36/61] NFSD: Replace READ* macros in nfsd4_decode_bind_conn_to_session()
` [PATCH v1 37/61] NFSD: Add a separate decoder to handle state_protect_ops
` [PATCH v1 38/61] NFSD: Add a separate decoder for ssv_sp_parms
` [PATCH v1 39/61] NFSD: Add a helper to decode state_protect4_a
` [PATCH v1 40/61] NFSD: Replace READ* macros in nfsd4_decode_exchange_id()
` [PATCH v1 41/61] NFSD: Replace READ* macros in nfsd4_decode_create_session()
` [PATCH v1 42/61] NFSD: Replace READ* macros in nfsd4_decode_destroy_session()
` [PATCH v1 43/61] NFSD: Replace READ* macros in nfsd4_decode_free_stateid()
` [PATCH v1 44/61] NFSD: Replace READ* macros in nfsd4_decode_getdeviceinfo()
` [PATCH v1 45/61] NFSD: Replace READ* macros in nfsd4_decode_layoutcommit()
` [PATCH v1 46/61] NFSD: Replace READ* macros in nfsd4_decode_layoutget()
` [PATCH v1 47/61] NFSD: Replace READ* macros in nfsd4_decode_layoutreturn()
` [PATCH v1 48/61] NFSD: Replace READ* macros in nfsd4_decode_secinfo_no_name()
` [PATCH v1 49/61] NFSD: Replace READ* macros in nfsd4_decode_sequence()
` [PATCH v1 50/61] NFSD: Replace READ* macros in nfsd4_decode_test_stateid()
` [PATCH v1 51/61] NFSD: Replace READ* macros in nfsd4_decode_destroy_clientid()
` [PATCH v1 52/61] NFSD: Replace READ* macros in nfsd4_decode_reclaim_complete()
` [PATCH v1 53/61] NFSD: Replace READ* macros in nfsd4_decode_fallocate()
` [PATCH v1 54/61] NFSD: Replace READ* macros in nfsd4_decode_clone()
` [PATCH v1 55/61] NFSD: Replace READ* macros in nfsd4_decode_copy()
` [PATCH v1 56/61] NFSD: Replace READ* macros in nfsd4_decode_seek()
` [PATCH v1 57/61] NFSD: Replace READ* macros in nfsd4_decode_xattr_name()
` [PATCH v1 58/61] NFSD: Replace READ* macros in nfsd4_decode_setxattr()
` [PATCH v1 59/61] NFSD: Replace READ* macros in nfsd4_decode_listxattrs()
` [PATCH v1 60/61] NFSD: Replace READ* macros in nfsd4_decode_compound()
` [PATCH v1 61/61] NFSD: Remove macros that are no longer used

[PATCH v3 00/11] Add RDMA support to the pNFS file+flexfiles data channels
 2020-11-14 14:29 UTC  (18+ messages)
` [PATCH v3 01/11] SUNRPC: xprt_load_transport() needs to support the netid "rdma6"
  ` [PATCH v3 02/11] SUNRPC: Close a race with transport setup and module put
    ` [PATCH v3 03/11] SUNRPC: Add a helper to return the transport identifier given a netid
      ` [PATCH v3 04/11] NFS: Switch mount code to use xprt_find_transport_ident()
        ` [PATCH v3 05/11] SUNRPC: Remove unused function xprt_load_transport()
          ` [PATCH v3 06/11] NFSv4/pNFS: Use connections to a DS that are all of the same protocol family
            ` [PATCH v3 07/11] pNFS: Add helpers for allocation/free of struct nfs4_pnfs_ds_addr
              ` [PATCH v3 08/11] NFSv4/pNFS: Store the transport type in "
                ` [PATCH v3 09/11] pNFS/flexfiles: Fix up layoutstats reporting for non-TCP transports
                  ` [PATCH v3 10/11] SUNRPC: Fix up open coded kmemdup_nul()
                    ` [PATCH v3 11/11] pNFS: Clean up open coded xdr string decoding

[PATCH v5 00/22] Readdir enhancements
 2020-11-14 13:32 UTC  (36+ messages)
` [PATCH v5 01/22] NFS: Remove unnecessary inode locking in nfs_llseek_dir()
  ` [PATCH v5 02/22] NFS: Remove unnecessary inode lock in nfs_fsync_dir()
    ` [PATCH v5 03/22] NFSv4.2: condition READDIR's mask for security label based on LSM state
      ` [PATCH v5 04/22] NFS: Ensure contents of struct nfs_open_dir_context are consistent
        ` [PATCH v5 05/22] NFS: Clean up readdir struct nfs_cache_array
          ` [PATCH v5 06/22] NFS: Clean up nfs_readdir_page_filler()
            ` [PATCH v5 07/22] NFS: Clean up directory array handling
              ` [PATCH v5 08/22] NFS: Don't discard readdir results
                ` [PATCH v5 09/22] NFS: Remove unnecessary kmap in nfs_readdir_xdr_to_array()
                  ` [PATCH v5 10/22] NFS: Replace kmap() with kmap_atomic() in nfs_readdir_search_array()
                    ` [PATCH v5 11/22] NFS: Simplify struct nfs_cache_array_entry
                      ` [PATCH v5 12/22] NFS: Support larger readdir buffers
                        ` [PATCH v5 13/22] NFS: More readdir cleanups
                          ` [PATCH v5 14/22] NFS: nfs_do_filldir() does not return a value
                            ` [PATCH v5 15/22] NFS: Reduce readdir stack usage
                              ` [PATCH v5 16/22] NFS: Cleanup to remove nfs_readdir_descriptor_t typedef
                                ` [PATCH v5 17/22] NFS: Allow the NFS generic code to pass in a verifier to readdir
                                  ` [PATCH v5 18/22] NFS: Handle NFS4ERR_NOT_SAME and NFSERR_BADCOOKIE from readdir calls
                                    ` [PATCH v5 19/22] NFS: Improve handling of directory verifiers
                                      ` [PATCH v5 20/22] NFS: Optimisations for monotonically increasing readdir cookies
                                        ` [PATCH v5 21/22] NFS: Reduce number of RPC calls when doing uncached readdir
                                          ` [PATCH v5 22/22] NFS: Do uncached readdir when we're seeking a cookie in an empty page cache

Adventures in NFS re-exporting
 2020-11-14 12:57 UTC  (15+ messages)

[PATCH 1/1] NFSv4.2: fix LISTXATTR buffer receive size
 2020-11-13 20:34 UTC  (2+ messages)

kernel oops in generic/013 on an rdma mount (over either soft roce or iwarp)
 2020-11-13 19:12 UTC  (16+ messages)

[PATCH v5 0/2] NFS: Fix interaction between fs_context and user namespaces
 2020-11-13 18:46 UTC  (4+ messages)
` [PATCH v5 1/2] NFS: NFSv2/NFSv3: Use cred from fs_context during mount
` [PATCH v5 2/2] NFSv4: Refactor to use user namespaces for nfs4idmap

[GIT PULL] Please pull NFS Client Bugfixes for Linux 5.10-rc4
 2020-11-12 22:11 UTC  (2+ messages)

[PATCH v1] svcrdma: Catch another Reply chunk overflow case
 2020-11-12 21:55 UTC 

[RFC][PATCH 00/18] crypto: Add generic Kerberos library
 2020-11-12 21:09 UTC  (28+ messages)
` [PATCH 01/18] crypto/krb5: Implement Kerberos crypto core
` [PATCH 02/18] crypto/krb5: Add some constants out of sunrpc headers
` [PATCH 03/18] crypto/krb5: Provide infrastructure and key derivation
` [PATCH 04/18] crypto/krb5: Implement the Kerberos5 rfc3961 "
` [PATCH 05/18] crypto/krb5: Implement the Kerberos5 rfc3961 encrypt and decrypt functions
` [PATCH 06/18] crypto/krb5: Implement the Kerberos5 rfc3961 get_mic and verify_mic
` [PATCH 07/18] crypto/krb5: Implement the AES enctypes from rfc3962
` [PATCH 08/18] crypto/krb5: Implement crypto self-testing
` [PATCH 09/18] crypto/krb5: Implement the AES enctypes from rfc8009
` [PATCH 10/18] crypto/krb5: Implement the AES encrypt/decrypt "
` [PATCH 11/18] crypto/krb5: Add the AES self-testing data "
` [PATCH 12/18] crypto/krb5: Implement the Camellia enctypes from rfc6803
` [PATCH 13/18] rxrpc: Add the security index for yfs-rxgk
` [PATCH 14/18] rxrpc: Add YFS RxGK (GSSAPI) security class
` [PATCH 15/18] rxrpc: rxgk: Provide infrastructure and key derivation
` [PATCH 16/18] rxrpc: rxgk: Implement the yfs-rxgk security class (GSSAPI)
` [PATCH 17/18] rxrpc: rxgk: Implement connection rekeying
` [PATCH 18/18] rxgk: Support OpenAFS's rxgk implementation

[PATCH] lockd: don't use interval-based rebinding over TCP
 2020-11-12 21:04 UTC  (2+ messages)

[PATCH] SUNRPC: Fix oops in the rpc_xdr_buf event class
 2020-11-12 21:03 UTC  (4+ messages)

[PATCH v1 0/4] NFSD tracepoint clean-ups for v5.11
 2020-11-12 19:46 UTC  (7+ messages)
` [PATCH v1 1/4] SUNRPC: Move the svc_xdr_recvfrom() tracepoint
` [PATCH v1 2/4] NFSD: Clean up the show_nf_may macro
` [PATCH v1 3/4] NFSD: Remove extra "0x" in tracepoint format specifier
` [PATCH v1 4/4] NFSD: Add SPDX header for fs/nfsd/trace.c

Bug 209399 - Can't unmount bind-mounted NFS mounts with "Stale file handle"
 2020-11-12 17:01 UTC 

[PATCH] NFSv4.2: fix failure to unregister shrinker
 2020-11-12 14:07 UTC  (3+ messages)

[PATCH v4 1/1] NFSv4.2: Fix NFS4ERR_STALE error when doing inter server copy
 2020-11-11 23:02 UTC  (15+ messages)

[PATCH v4 0/2] NFS: Fix interaction between fs_context and user namespaces
 2020-11-12  0:42 UTC  (9+ messages)

[PATCH v4 00/21] Readdir enhancements
 2020-11-11 20:11 UTC  (28+ messages)
` [PATCH v4 01/21] NFS: Remove unnecessary inode locking in nfs_llseek_dir()
  ` [PATCH v4 02/21] NFS: Remove unnecessary inode lock in nfs_fsync_dir()
    ` [PATCH v4 03/21] NFS: Ensure contents of struct nfs_open_dir_context are consistent
      ` [PATCH v4 04/21] NFS: Clean up readdir struct nfs_cache_array
        ` [PATCH v4 05/21] NFS: Clean up nfs_readdir_page_filler()
          ` [PATCH v4 06/21] NFS: Clean up directory array handling
            ` [PATCH v4 07/21] NFS: Don't discard readdir results
              ` [PATCH v4 08/21] NFS: Remove unnecessary kmap in nfs_readdir_xdr_to_array()
                ` [PATCH v4 09/21] NFS: Replace kmap() with kmap_atomic() in nfs_readdir_search_array()
                  ` [PATCH v4 10/21] NFS: Simplify struct nfs_cache_array_entry
                    ` [PATCH v4 11/21] NFS: Support larger readdir buffers
                      ` [PATCH v4 12/21] NFS: More readdir cleanups
                        ` [PATCH v4 13/21] NFS: nfs_do_filldir() does not return a value
                          ` [PATCH v4 14/21] NFS: Reduce readdir stack usage
                            ` [PATCH v4 15/21] NFS: Cleanup to remove nfs_readdir_descriptor_t typedef
                              ` [PATCH v4 16/21] NFS: Allow the NFS generic code to pass in a verifier to readdir
                                ` [PATCH v4 17/21] NFS: Handle NFS4ERR_NOT_SAME and NFSERR_BADCOOKIE from readdir calls
                                  ` [PATCH v4 18/21] NFS: Improve handling of directory verifiers
                                    ` [PATCH v4 19/21] NFS: Optimisations for monotonically increasing readdir cookies
                                      ` [PATCH v4 20/21] NFS: Reduce number of RPC calls when doing uncached readdir
                                        ` [PATCH v4 21/21] NFS: Do uncached readdir when we're seeking a cookie in an empty page cache

Corporate and Personal Loan *
 2020-11-11  8:31 UTC 

[PATCH] fs/nfsd: remove unused NFSDDBG_FACILITY to tame gcc
 2020-11-11  5:52 UTC  (4+ messages)
    ` [kbuild-all] "

[PATCH] NFSD: Fix 5 seconds delay when doing inter server copy
 2020-11-11  0:40 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).