linux-nvdimm.lists.01.org archive mirror
 help / color / mirror / Atom feed
From: Dan Williams <dan.j.williams@intel.com>
To: alexander.h.duyck@linux.intel.com
Cc: "Brown, Len" <len.brown@intel.com>,
	bvanassche@acm.org, linux-nvdimm <linux-nvdimm@lists.01.org>,
	Greg KH <gregkh@linuxfoundation.org>,
	Linux-pm mailing list <linux-pm@vger.kernel.org>,
	jiangshanlai@gmail.com,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	"Luis R. Rodriguez" <mcgrof@kernel.org>,
	Pavel Machek <pavel@ucw.cz>,
	zwisler@kernel.org, Tejun Heo <tj@kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	"Rafael J. Wysocki" <rafael@kernel.org>
Subject: Re: [driver-core PATCH v7 2/9] driver core: Establish clear order of operations for deferred probe and remove
Date: Thu, 29 Nov 2018 10:55:08 -0800	[thread overview]
Message-ID: <CAPcyv4j2w6ygzuP-vEKPk6NGLCEB6FcKTVFQkUqr3HC471xJsg@mail.gmail.com> (raw)
In-Reply-To: <a5b33ae899fc4131abf0f26af33a6c6b7f462431.camel@linux.intel.com>

On Thu, Nov 29, 2018 at 10:07 AM Alexander Duyck
<alexander.h.duyck@linux.intel.com> wrote:
>
> On Wed, 2018-11-28 at 17:57 -0800, Dan Williams wrote:
[..]
> > I think the flag should be named "cancel" and set it in the
> > device_del() path. Otherwise this is encoding code flow state in the
> > struct rather than device-state that the code needs to comprehend.
>
> Instead of "cancel" what would you think of "dead"? In my mind once we
> call device_del we are essentially working with a dead device object so
> that might make more sense in terms of a state rather than "cancel"
> which doesn't really tell us what should be canceled.

That sounds good to me.

> Looking over the code I could probably set it before we start calling
> the notifiers for BUS_NOTIFY_DEL_DEVICE. The only thing I am not sure
> about is if we would need to add any sort of synchronization primitives
> around it.
>

I think it needs to be something like a barrier:

    dev->dead;
    device_lock();
    device_unlock();

...where you can be sure that anyone after that device_unlock() has
acted on dev->dead, or will see dev->dead.
_______________________________________________
Linux-nvdimm mailing list
Linux-nvdimm@lists.01.org
https://lists.01.org/mailman/listinfo/linux-nvdimm

  reply	other threads:[~2018-11-29 18:55 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-11-29  0:32 [driver-core PATCH v7 0/9] Add NUMA aware async_schedule calls Alexander Duyck
2018-11-29  0:32 ` [driver-core PATCH v7 1/9] driver core: Move async_synchronize_full call Alexander Duyck
2018-11-30 23:21   ` Luis Chamberlain
2018-11-29  0:32 ` [driver-core PATCH v7 2/9] driver core: Establish clear order of operations for deferred probe and remove Alexander Duyck
2018-11-29  1:57   ` Dan Williams
2018-11-29 18:07     ` Alexander Duyck
2018-11-29 18:55       ` Dan Williams [this message]
2018-11-29 21:53         ` Alexander Duyck
2018-11-29 22:00           ` Dan Williams
2018-11-30 23:40   ` Luis Chamberlain
2018-11-29  0:32 ` [driver-core PATCH v7 3/9] device core: Consolidate locking and unlocking of parent and device Alexander Duyck
2018-12-01  0:01   ` Luis Chamberlain
2018-11-29  0:32 ` [driver-core PATCH v7 4/9] driver core: Probe devices asynchronously instead of the driver Alexander Duyck
2018-12-01  2:48   ` Luis Chamberlain
2018-12-03 16:44     ` Alexander Duyck
2018-11-29  0:32 ` [driver-core PATCH v7 5/9] workqueue: Provide queue_work_node to queue work near a given NUMA node Alexander Duyck
2018-11-29  0:32 ` [driver-core PATCH v7 6/9] async: Add support for queueing on specific " Alexander Duyck
2018-11-29  0:32 ` [driver-core PATCH v7 7/9] driver core: Attach devices on CPU local to device node Alexander Duyck
2018-11-29  0:32 ` [driver-core PATCH v7 8/9] PM core: Use new async_schedule_dev command Alexander Duyck
2018-11-29  0:32 ` [driver-core PATCH v7 9/9] libnvdimm: Schedule device registration on node local to the device Alexander Duyck

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAPcyv4j2w6ygzuP-vEKPk6NGLCEB6FcKTVFQkUqr3HC471xJsg@mail.gmail.com \
    --to=dan.j.williams@intel.com \
    --cc=akpm@linux-foundation.org \
    --cc=alexander.h.duyck@linux.intel.com \
    --cc=bvanassche@acm.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=jiangshanlai@gmail.com \
    --cc=len.brown@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-nvdimm@lists.01.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=mcgrof@kernel.org \
    --cc=pavel@ucw.cz \
    --cc=rafael@kernel.org \
    --cc=tj@kernel.org \
    --cc=zwisler@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).