linux-nvme.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Jens Axboe <axboe@kernel.dk>
Cc: linux-bcache@vger.kernel.org, linux-xtensa@linux-xtensa.org,
	linux-nvdimm@lists.01.org, linux-s390@vger.kernel.org,
	dm-devel@redhat.com, linux-nvme@lists.infradead.org,
	linux-kernel@vger.kernel.org, linux-raid@vger.kernel.org,
	linux-m68k@lists.linux-m68k.org, linuxppc-dev@lists.ozlabs.org,
	drbd-dev@lists.linbit.com
Subject: [PATCH 02/20] simdisk: stop using ->queuedata
Date: Wed,  1 Jul 2020 10:59:29 +0200	[thread overview]
Message-ID: <20200701085947.3354405-3-hch@lst.de> (raw)
In-Reply-To: <20200701085947.3354405-1-hch@lst.de>

Instead of setting up the queuedata as well just use one private data
field.

Signed-off-by: Christoph Hellwig <hch@lst.de>
---
 arch/xtensa/platforms/iss/simdisk.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/arch/xtensa/platforms/iss/simdisk.c b/arch/xtensa/platforms/iss/simdisk.c
index 49322b66cda931..31b5020077a059 100644
--- a/arch/xtensa/platforms/iss/simdisk.c
+++ b/arch/xtensa/platforms/iss/simdisk.c
@@ -103,7 +103,7 @@ static void simdisk_transfer(struct simdisk *dev, unsigned long sector,
 
 static blk_qc_t simdisk_make_request(struct request_queue *q, struct bio *bio)
 {
-	struct simdisk *dev = q->queuedata;
+	struct simdisk *dev = bio->bi_disk->private_data;
 	struct bio_vec bvec;
 	struct bvec_iter iter;
 	sector_t sector = bio->bi_iter.bi_sector;
@@ -273,8 +273,6 @@ static int __init simdisk_setup(struct simdisk *dev, int which,
 		goto out_alloc_queue;
 	}
 
-	dev->queue->queuedata = dev;
-
 	dev->gd = alloc_disk(SIMDISK_MINORS);
 	if (dev->gd == NULL) {
 		pr_err("alloc_disk failed\n");
-- 
2.26.2


_______________________________________________
Linux-nvme mailing list
Linux-nvme@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-nvme

  parent reply	other threads:[~2020-07-01  8:59 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-01  8:59 rename ->make_request_fn and move it to the block_device_operations v2 Christoph Hellwig
2020-07-01  8:59 ` [PATCH 01/20] nfblock: stop using ->queuedata Christoph Hellwig
2020-07-01  8:59 ` Christoph Hellwig [this message]
2020-07-01  8:59 ` [PATCH 03/20] drbd: " Christoph Hellwig
2020-07-01  8:59 ` [PATCH 04/20] null_blk: stop using ->queuedata for bio mode Christoph Hellwig
2020-07-01  8:59 ` [PATCH 05/20] ps3vram: stop using ->queuedata Christoph Hellwig
2020-07-01  8:59 ` [PATCH 06/20] rsxx: " Christoph Hellwig
2020-07-01  8:59 ` [PATCH 07/20] umem: " Christoph Hellwig
2020-07-01  8:59 ` [PATCH 08/20] zram: " Christoph Hellwig
2020-07-01  8:59 ` [PATCH 09/20] bcache: stop setting ->queuedata Christoph Hellwig
2020-07-02 14:47   ` Coly Li
2020-07-01  8:59 ` [PATCH 10/20] dm: stop using ->queuedata Christoph Hellwig
2020-07-01 17:24   ` Mike Snitzer
2020-07-01  8:59 ` [PATCH 11/20] fs: remove a weird comment in submit_bh_wbc Christoph Hellwig
2020-07-01  8:59 ` [PATCH 12/20] block: remove the request_queue argument from blk_queue_split Christoph Hellwig
2020-07-02  6:14   ` Song Liu
2020-07-01  8:59 ` [PATCH 13/20] block: tidy up a warning in bio_check_ro Christoph Hellwig
2020-07-01  8:59 ` [PATCH 14/20] block: remove the NULL queue check in generic_make_request_checks Christoph Hellwig
2020-07-01  8:59 ` [PATCH 15/20] block: remove the nr_sectors variable " Christoph Hellwig
2020-07-01  8:59 ` [PATCH 16/20] block: move ->make_request_fn to struct block_device_operations Christoph Hellwig
2020-07-01 16:08   ` Dan Williams
2020-07-02 14:48   ` Coly Li
2020-07-01  8:59 ` [PATCH 17/20] block: rename generic_make_request to submit_bio_noacct Christoph Hellwig
2020-07-02 14:51   ` Coly Li
2020-07-02 18:22   ` Song Liu
2020-07-01  8:59 ` [PATCH 18/20] block: refator submit_bio_noacct Christoph Hellwig
2020-07-01  8:59 ` [PATCH 19/20] block: shortcut __submit_bio_noacct for blk-mq drivers Christoph Hellwig
2020-07-01  8:59 ` [PATCH 20/20] block: remove direct_make_request Christoph Hellwig
2020-07-01 13:43 ` rename ->make_request_fn and move it to the block_device_operations v2 Jens Axboe
  -- strict thread matches above, loose matches on Subject: below --
2020-06-29 19:39 rename ->make_request_fn and move it to the block_device_operations Christoph Hellwig
2020-06-29 19:39 ` [PATCH 02/20] simdisk: stop using ->queuedata Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200701085947.3354405-3-hch@lst.de \
    --to=hch@lst.de \
    --cc=axboe@kernel.dk \
    --cc=dm-devel@redhat.com \
    --cc=drbd-dev@lists.linbit.com \
    --cc=linux-bcache@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-m68k@lists.linux-m68k.org \
    --cc=linux-nvdimm@lists.01.org \
    --cc=linux-nvme@lists.infradead.org \
    --cc=linux-raid@vger.kernel.org \
    --cc=linux-s390@vger.kernel.org \
    --cc=linux-xtensa@linux-xtensa.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).