From: Max Gurtovoy <maxg@mellanox.com>
To: Keith Busch <kbusch@kernel.org>
Cc: axboe@kernel.dk, sagi@grimberg.me,
"Martin K. Petersen" <martin.petersen@oracle.com>,
shlomin@mellanox.com, israelr@mellanox.com,
vladimirk@mellanox.com, linux-nvme@lists.infradead.org,
idanb@mellanox.com, oren@mellanox.com, hch@lst.de
Subject: Re: [PATCH 01/15] nvme: Introduce namespace features flag
Date: Tue, 14 Jan 2020 18:04:20 +0200 [thread overview]
Message-ID: <2a237612-2114-ec1a-9cc8-91c0464591ad@mellanox.com> (raw)
In-Reply-To: <20200113203135.GB23750@redsun51.ssa.fujisawa.hgst.com>
On 1/13/2020 10:31 PM, Keith Busch wrote:
> On Sun, Jan 12, 2020 at 11:40:31AM +0200, Max Gurtovoy wrote:
>> On 1/9/2020 6:26 PM, Keith Busch wrote:
>>> On Thu, Jan 09, 2020 at 12:38:05PM +0200, Max Gurtovoy wrote:
>>>> On 1/9/2020 5:11 AM, Martin K. Petersen wrote:
>>>>> Max,
>>>>>
>>>>>> +#define NVME_NS_DIX_SUPPORTED (1 << 1)
>>>>>> +#define NVME_NS_DIF_SUPPORTED (1 << 2)
>>>>> Not so keen on the DIF/DIX terminology in this context.
>>>> Martin,
>>>>
>>>> how about:
>>>>
>>>> +#define NVME_NS_PI_HOST_SUPPORTED (1 << 1)
>>>> +#define NVME_NS_PI_CTRL_SUPPORTED (1 << 2)
>>> Well, I was trying to say earlier that nvme supports formats with metadata
>>> that's not used for protection information. The metadata, whether separate
>>> or interleaved, can be used for some proprietary non-pi related feature.
>> so how about:
>>
>> +#define NVME_NS_MD_HOST_SUPPORTED (1 << 1)
>> +#define NVME_NS_MD_CTRL_SUPPORTED (1 << 2)
> You're using these to report the in-memory format of the meta-data,
> right? These are either Extended or Separate from the block data, so
> I think the names should convey that. Something like the following
> maybe:
>
> #define NVME_NS_MD_SEP_SUPPORTED (1 << 1)
> #define NVME_NS_MD_EXT_SUPPORTED (1 << 2)
No, we're setting it to know if we have host MD (aka DIX, memory-domain)
and if we have ctrl MD (aka DIF, ctrl-domain).
for the MD format we use:
#define NVME_NS_EXT_LBAS (1 << 0)
>
>> We didn't change any logic for metadata support for non-PI format.
>>
>>> The nvme driver only leverages "blk-integrity" to facilitate allocating
>>> and managing the metdata payloads even when not used for integrity. It
>>> might make sense to give that block component a more generic name than
>>> "integrity".
>> Yup that True, But this patchset is already big enough by itself.
>>
>> We can do block layer refactoring in different series..
> Absolutely, didn't mean to imply you take that on. :)
>
> I was just trying to emphasize the current name doesn't always describe how
> that component is used.
_______________________________________________
linux-nvme mailing list
linux-nvme@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-nvme
next prev parent reply other threads:[~2020-01-14 16:04 UTC|newest]
Thread overview: 44+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-01-06 13:37 [PATCH 00/15 V3] nvme-rdma/nvmet-rdma: Add metadata/T10-PI support Max Gurtovoy
2020-01-06 13:37 ` [PATCH] nvme-cli/fabrics: Add pi_enable param to connect cmd Max Gurtovoy
2020-01-06 13:37 ` [PATCH 01/15] nvme: Introduce namespace features flag Max Gurtovoy
2020-01-07 18:07 ` Keith Busch
2020-01-08 12:00 ` Max Gurtovoy
2020-01-09 3:11 ` Martin K. Petersen
2020-01-09 10:38 ` Max Gurtovoy
2020-01-09 16:26 ` Keith Busch
2020-01-12 9:40 ` Max Gurtovoy
2020-01-13 20:31 ` Keith Busch
2020-01-14 16:04 ` Max Gurtovoy [this message]
2020-01-12 9:40 ` Max Gurtovoy
2020-01-06 13:37 ` [PATCH 02/15] nvme: Enforce extended LBA format for fabrics metadata Max Gurtovoy
2020-01-16 23:53 ` James Smart
2020-01-19 11:20 ` Max Gurtovoy
2020-01-21 17:40 ` James Smart
2020-01-06 13:37 ` [PATCH 03/15] nvme: Introduce max_integrity_segments ctrl attribute Max Gurtovoy
2020-01-09 3:12 ` Martin K. Petersen
2020-01-06 13:37 ` [PATCH 04/15] nvme-fabrics: Allow user enabling metadata/T10-PI support Max Gurtovoy
2020-01-06 13:37 ` [PATCH 05/15] nvme: Introduce NVME_INLINE_PROT_SG_CNT Max Gurtovoy
2020-01-09 3:13 ` Martin K. Petersen
2020-01-06 13:37 ` [PATCH 06/15] nvme-rdma: Introduce nvme_rdma_sgl structure Max Gurtovoy
2020-01-06 13:37 ` [PATCH 07/15] nvme-rdma: Add metadata/T10-PI support Max Gurtovoy
2020-01-06 13:37 ` [PATCH 08/15] nvmet: Prepare metadata request Max Gurtovoy
2020-01-06 13:37 ` [PATCH 09/15] nvmet: Add metadata characteristics for a namespace Max Gurtovoy
2020-01-09 3:16 ` Martin K. Petersen
2020-01-06 13:37 ` [PATCH 10/15] nvmet: Rename nvmet_rw_len to nvmet_rw_data_len Max Gurtovoy
2020-01-09 3:17 ` Martin K. Petersen
2020-01-06 13:37 ` [PATCH 11/15] nvmet: Rename nvmet_check_data_len to nvmet_check_transfer_len Max Gurtovoy
2020-01-09 3:19 ` Martin K. Petersen
2020-01-06 13:37 ` [PATCH 12/15] nvme: Add Metadata Capabilities enumerations Max Gurtovoy
2020-01-06 13:37 ` [PATCH 13/15] nvmet: Add metadata/T10-PI support Max Gurtovoy
2020-01-09 3:24 ` Martin K. Petersen
2020-01-27 17:17 ` Max Gurtovoy
2020-01-29 2:32 ` Martin K. Petersen
2020-01-17 16:46 ` James Smart
2020-01-19 13:47 ` Max Gurtovoy
2020-01-06 13:37 ` [PATCH 14/15] nvmet: Add metadata support for block devices Max Gurtovoy
2020-01-06 13:37 ` [PATCH 15/15] nvmet-rdma: Add metadata/T10-PI support Max Gurtovoy
2020-01-09 3:29 ` Martin K. Petersen
2020-04-28 13:11 [PATCH 00/15 V6] nvme-rdma/nvmet-rdma: " Max Gurtovoy
2020-04-28 13:11 ` [PATCH 01/15] nvme: introduce namespace features flag Max Gurtovoy
2020-05-01 13:20 ` Christoph Hellwig
2020-05-01 14:24 ` Christoph Hellwig
2020-05-01 14:33 ` Max Gurtovoy
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2a237612-2114-ec1a-9cc8-91c0464591ad@mellanox.com \
--to=maxg@mellanox.com \
--cc=axboe@kernel.dk \
--cc=hch@lst.de \
--cc=idanb@mellanox.com \
--cc=israelr@mellanox.com \
--cc=kbusch@kernel.org \
--cc=linux-nvme@lists.infradead.org \
--cc=martin.petersen@oracle.com \
--cc=oren@mellanox.com \
--cc=sagi@grimberg.me \
--cc=shlomin@mellanox.com \
--cc=vladimirk@mellanox.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).