From: Bob Liu <bob.liu@oracle.com>
To: "Singh, Balbir" <sblbir@amazon.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linux-block@vger.kernel.org" <linux-block@vger.kernel.org>,
"linux-nvme@lists.infradead.org" <linux-nvme@lists.infradead.org>
Cc: "axboe@kernel.dk" <axboe@kernel.dk>,
"Chaitanya.Kulkarni@wdc.com" <Chaitanya.Kulkarni@wdc.com>,
"mst@redhat.com" <mst@redhat.com>,
"jejb@linux.ibm.com" <jejb@linux.ibm.com>,
"Sangaraju, Someswarudu" <ssomesh@amazon.com>,
"hch@lst.de" <hch@lst.de>
Subject: Re: [resend v1 0/5] Add support for block disk resize notification
Date: Mon, 6 Jan 2020 17:08:49 +0800 [thread overview]
Message-ID: <77a665c6-1409-3dd0-2fde-221a00e04b3c@oracle.com> (raw)
In-Reply-To: <f260159c7c56a08711240cc6c7f69d2d5327a449.camel@amazon.com>
On 1/6/20 4:47 PM, Singh, Balbir wrote:
> On Mon, 2020-01-06 at 13:59 +0800, Bob Liu wrote:
>> On 1/2/20 3:53 PM, Balbir Singh wrote:
>>> Allow block/genhd to notify user space about disk size changes
>>> using a new helper disk_set_capacity(), which is a wrapper on top
>>> of set_capacity(). disk_set_capacity() will only notify if
>>> the current capacity or the target capacity is not zero.
>>>
>>
>> set_capacity_and_notify() may be a more straightforward name.
>>
>
> Yes, agreed.
>
>>> Background:
>>>
>>> As a part of a patch to allow sending the RESIZE event on disk capacity
>>> change, Christoph (hch@lst.de) requested that the patch be made generic
>>> and the hacks for virtio block and xen block devices be removed and
>>> merged via a generic helper.
>>>
>>> This series consists of 5 changes. The first one adds the basic
>>> support for changing the size and notifying. The follow up patches
>>> are per block subsystem changes. Other block drivers can add their
>>> changes as necessary on top of this series.
>>>
>>> Testing:
>>> 1. I did some basic testing with an NVME device, by resizing it in
>>> the backend and ensured that udevd received the event.
>>>
>>> NOTE: After these changes, the notification might happen before
>>> revalidate disk, where as it occured later before.
>>>
>>
>> It's better not to change original behavior.
>> How about something like:
>>
>> +void set_capacity_and_notify(struct gendisk *disk, sector_t size, bool
>> revalidate)
>> {
>> sector_t capacity = get_capacity(disk);
>>
>> set_capacity(disk, size);
>>
>> + if (revalidate)
>> + revalidate_disk(disk);
>
> Do you see a concern with the notification going out before revalidate_disk?
Not aware any, but keep the original behavior is safer especial when not must change..
> I could keep the behaviour and come up with a suitable name
>
> revalidate_disk_and_notify() (set_capacity is a part of the revalidation
> process), or feel free to suggest a better name
>
Feel free to add my reviewed-by next version in this series.
Reviewed-by: Bob Liu <bob.liu@oracle.com>
> Thanks,
> Balbir Singh
>
_______________________________________________
linux-nvme mailing list
linux-nvme@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-nvme
prev parent reply other threads:[~2020-01-06 9:10 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-01-02 7:53 [resend v1 0/5] Add support for block disk resize notification Balbir Singh
2020-01-02 7:53 ` [resend v1 1/5] block/genhd: Notify udev about capacity change Balbir Singh
2020-01-03 6:16 ` Chaitanya Kulkarni
2020-01-04 4:44 ` Singh, Balbir
2020-01-04 22:32 ` Chaitanya Kulkarni
2020-01-08 15:02 ` hch
2020-01-07 3:32 ` Martin K. Petersen
2020-01-07 22:30 ` Singh, Balbir
2020-01-08 3:15 ` Martin K. Petersen
2020-01-08 15:04 ` hch
2020-01-21 19:57 ` Singh, Balbir
2020-01-02 7:53 ` [resend v1 2/5] drivers/block/virtio_blk.c: Convert to use disk_set_capacity Balbir Singh
2020-01-02 7:53 ` [resend v1 3/5] drivers/block/xen-blkfront.c: " Balbir Singh
2020-01-02 7:53 ` [resend v1 4/5] drivers/nvme/host/core.c: " Balbir Singh
2020-01-04 22:27 ` Chaitanya Kulkarni
2020-01-06 0:46 ` Singh, Balbir
2020-01-08 15:04 ` hch
2020-01-09 3:33 ` Martin K. Petersen
2020-01-09 13:12 ` Ewan D. Milne
2020-01-21 19:52 ` Singh, Balbir
2020-01-02 7:53 ` [resend v1 5/5] drivers/scsi/sd.c: " Balbir Singh
2020-01-02 22:21 ` Chaitanya Kulkarni
2020-01-03 0:23 ` Singh, Balbir
2020-01-07 3:48 ` Martin K. Petersen
2020-01-07 3:57 ` James Bottomley
2020-01-07 4:39 ` Martin K. Petersen
2020-01-07 21:37 ` Ewan D. Milne
2020-01-08 2:59 ` Martin K. Petersen
2020-01-08 21:27 ` Ewan D. Milne
2020-01-07 22:28 ` Singh, Balbir
2020-01-08 3:15 ` Martin K. Petersen
2020-01-08 4:20 ` Singh, Balbir
2020-01-08 21:32 ` Ewan D. Milne
2020-01-08 15:06 ` Christoph Hellwig
2020-01-09 2:53 ` Martin K. Petersen
2020-01-06 5:59 ` [resend v1 0/5] Add support for block disk resize notification Bob Liu
2020-01-06 8:47 ` Singh, Balbir
2020-01-06 9:08 ` Bob Liu [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=77a665c6-1409-3dd0-2fde-221a00e04b3c@oracle.com \
--to=bob.liu@oracle.com \
--cc=Chaitanya.Kulkarni@wdc.com \
--cc=axboe@kernel.dk \
--cc=hch@lst.de \
--cc=jejb@linux.ibm.com \
--cc=linux-block@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-nvme@lists.infradead.org \
--cc=mst@redhat.com \
--cc=sblbir@amazon.com \
--cc=ssomesh@amazon.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).