linux-nvme.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-06-30 01:49:58 to 2020-07-08 22:26:59 UTC [more...]

[PATCH 0/4] nvme: fix iod size calculation in nvme_probe()
 2020-07-08 22:26 UTC  (7+ messages)
` [PATCH 1/4] nvme-core: use macro for ctrl page size default value
` [PATCH 2/4] nvme-pci: don't use ctrl page size value in probe
` [PATCH 3/4] nvme-pci: use max of PRP or SGL for iod size
` [PATCH 4/4] nvme-core: fix checkpatch warnings

[PATCH] nvme: remove ns->disk checks
 2020-07-08 17:12 UTC  (3+ messages)

[PATCH v2 rfc 0/3] resolve controller delete hang due to ongoing mpath I/O
 2020-07-08 15:17 UTC  (5+ messages)
` [PATCH v2 rfc 1/3] nvme: split nvme_remove_namespaces
` [PATCH v2 rfc 2/3] nvme: document nvme controller states
` [PATCH v2 rfc 3/3] nvme-core: fix deadlock in disconnect during scan_work and/or ana_work

[PATCH v7] nvme-fabrics: reject I/O to offline device
 2020-07-08 15:07 UTC 

[PATCH v2 for-5.8-rc 0/6] address deadlocks in high stress ns scanning and ana updates
 2020-07-08 14:42 UTC  (6+ messages)
` [PATCH v2 for-5.8-rc 1/6] nvme: fix possible deadlock when I/O is blocked

[PATCH] nvme-pci: use standard block status symbolic names to check return value
 2020-07-08  6:17 UTC  (3+ messages)

[PATCH 0/5] Some cleanups for NVMe-pci driver
 2020-07-08  6:05 UTC  (19+ messages)
` [PATCH 1/5] nvme-pci: Fix some comments issues
` [PATCH 2/5] nvme-pci: Add a blank line after declarations
` [PATCH 3/5] nvme-pci: Remove redundant segment validation
` [PATCH 4/5] nvme-pci: Use the consistent return type of nvme_pci_iod_alloc_size()
` [PATCH 5/5] nvme-pci: Use standard block status macro

[PATCH V2 0/2] nvme: Add support for ACPI StorageD3Enable property
 2020-07-07 21:24 UTC  (5+ messages)
` [PATCH v4] drivers/nvme: "

[RFC PATCH 0/5] nvme: reduce repetitive calls in fast path
 2020-07-07 18:10 UTC  (8+ messages)
` [RFC PATCH 1/5] nvme-pci: reduce blk_rq_nr_phys_segments calls
` [RFC PATCH 2/5 COMPILE TESTED] nvme-rdma: "
` [RFC PATCH 3/5 COMPILE TESTED] nvme-tcp: "
` [RFC PATCH 4/5 COMPILE TESTED] nvme-fc: "
` [RFC PATCH 5/5] nvme-loop: "

[PATCH 0/2] Zone Descriptor Extension for Zoned Block Devices
 2020-07-07 16:03 UTC  (9+ messages)
` [PATCH 2/2] block: add BLKSETDESCZONE ioctl "

[PATCH RFC] nvme-pci: remove the unsed code in alloc_size
 2020-07-07 15:53 UTC  (3+ messages)

[linux-nvme:nvme-5.9 34/40] drivers/nvme/host/core.c:3567:1: sparse: sparse: symbol 'dev_attr_ctrl_loss_tmo' was not declared. Should it be
 2020-07-07 10:55 UTC  (3+ messages)
` [RFC PATCH linux-nvme] nvme: dev_attr_ctrl_loss_tmo can be static

[PATCH] nvme: expose reconnect_delay and ctrl_loss_tmo via sysfs
 2020-07-07  8:51 UTC  (2+ messages)

[PATCH] nvme: document quirked Intel models
 2020-07-07  8:48 UTC  (2+ messages)

[PATCH] nvme-tcp: remove dead code in map data
 2020-07-06 19:46 UTC 

[PATCH] nvme: associate stripe size quirk with D4512
 2020-07-03 20:16 UTC  (8+ messages)

[PATCH v2 0/2] Export max open zones and max active zones to sysfs
 2020-07-03 14:15 UTC  (10+ messages)
` [PATCH v2 1/2] block: add max_open_zones to blk-sysfs
` [PATCH v2 2/2] block: add max_active_zones "

[V2 PATCH 0/4] ZNS: Extra features for current patche
 2020-07-03  8:35 UTC  (19+ messages)
` [PATCH 1/4] block: Add zone flags to queue zone prop
` [PATCH 2/4] block: add support for zone offline transition
` [PATCH 3/4] nvme: Add consistency check for zone count
` [PATCH 4/4] block: add attributes to zone report

[PATCH 0/2] Export max open zones and max active zones to sysfs
 2020-07-03  4:56 UTC  (11+ messages)
` [PATCH 1/2] block: add max_open_zones to blk-sysfs
` [PATCH 2/2] block: add max_active_zones "

rename ->make_request_fn and move it to the block_device_operations v2
 2020-07-02 18:22 UTC  (29+ messages)
` [PATCH 01/20] nfblock: stop using ->queuedata
` [PATCH 02/20] simdisk: "
` [PATCH 03/20] drbd: "
` [PATCH 04/20] null_blk: stop using ->queuedata for bio mode
` [PATCH 05/20] ps3vram: stop using ->queuedata
` [PATCH 06/20] rsxx: "
` [PATCH 07/20] umem: "
` [PATCH 08/20] zram: "
` [PATCH 09/20] bcache: stop setting ->queuedata
` [PATCH 10/20] dm: stop using ->queuedata
` [PATCH 11/20] fs: remove a weird comment in submit_bh_wbc
` [PATCH 12/20] block: remove the request_queue argument from blk_queue_split
` [PATCH 13/20] block: tidy up a warning in bio_check_ro
` [PATCH 14/20] block: remove the NULL queue check in generic_make_request_checks
` [PATCH 15/20] block: remove the nr_sectors variable "
` [PATCH 16/20] block: move ->make_request_fn to struct block_device_operations
` [PATCH 17/20] block: rename generic_make_request to submit_bio_noacct
` [PATCH 18/20] block: refator submit_bio_noacct
` [PATCH 19/20] block: shortcut __submit_bio_noacct for blk-mq drivers
` [PATCH 20/20] block: remove direct_make_request

[GIT PULL] nvme fixes for 5.8
 2020-07-02 18:11 UTC  (2+ messages)

rename ->make_request_fn and move it to the block_device_operations
 2020-07-02 15:52 UTC  (13+ messages)
` [PATCH 11/20] fs: remove a weird comment in submit_bh_wbc
` [PATCH 18/20] block: refator submit_bio_noacct

[PATCH v6] nvme-fabrics: reject I/O to offline device
 2020-07-02 14:48 UTC  (2+ messages)

[PATCH V4] nvme-fabrics: reject I/O to offline device
 2020-07-02 14:35 UTC  (6+ messages)

[PATCH v3 0/4] ZNS: Extra features for current patches
 2020-07-02 10:18 UTC  (9+ messages)
` [PATCH v3 1/4] block: Add zone flags to queue zone prop
` [PATCH v3 2/4] block: add support for zone offline transition
` [PATCH v3 3/4] nvme: Add consistency check for zone count
` [PATCH v3 4/4] block: add attributes to zone report

[PATCH v5] nvme-fabrics: reject I/O to offline device
 2020-07-02  4:45 UTC  (5+ messages)

[PATCH AUTOSEL 4.14 15/17] nvme-rdma: assign completion vector correctly
 2020-07-02  1:26 UTC 

[PATCH AUTOSEL 4.19 25/27] nvme-rdma: assign completion vector correctly
 2020-07-02  1:26 UTC 

[PATCH AUTOSEL 5.4 37/40] nvme-rdma: assign completion vector correctly
 2020-07-02  1:23 UTC 

[PATCH AUTOSEL 5.7 47/53] nvme-rdma: assign completion vector correctly
 2020-07-02  1:21 UTC 

[PATCH V2 0/2] nvme: replace linked list with xarray for ns tracking
 2020-07-01 18:43 UTC  (16+ messages)
` [PATCH V2 1/2] nvme-core: use xarray for ctrl "
` [PATCH V2 2/2] nvmet: use xarray for ctrl ns storing

NVMe regression, NVMe no longer uses blk_path_error()
 2020-07-01 16:39 UTC 

[PATCHv4 0/5] nvme support for zoned namespace command set
 2020-07-01  6:37 UTC  (13+ messages)
` [PATCHv4 1/5] block: add capacity field to zone descriptors
` [PATCHv4 2/5] null_blk: introduce zone capacity for zoned device
` [PATCHv4 3/5] nvme: implement I/O Command Sets Command Set support
` [PATCHv4 4/5] nvme: support for multi-command set effects
` [PATCHv4 5/5] nvme: support for zoned namespaces

[PATCH] nvme: validate cntlid's only for nvme >= 1.1.0
 2020-06-30 14:08 UTC  (5+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).