Linux-OMAP Archive on lore.kernel.org
 help / color / Atom feed
From: Tony Lindgren <tony@atomide.com>
To: Tomi Valkeinen <tomi.valkeinen@ti.com>
Cc: Faiz Abbas <faiz_abbas@ti.com>, Keerthy <j-keerthy@ti.com>,
	linux-kernel@vger.kernel.org, linux-omap@vger.kernel.org,
	bcousson@baylibre.com
Subject: Re: [PATCH v2] arm: dts: Move am33xx and am43xx mmc nodes to sdhci-omap driver
Date: Fri, 29 May 2020 14:53:14 -0700
Message-ID: <20200529215314.GZ37466@atomide.com> (raw)
In-Reply-To: <20200527160543.GI37466@atomide.com>

* Tony Lindgren <tony@atomide.com> [200527 16:06]:
> * Tony Lindgren <tony@atomide.com> [200519 09:05]:
> > * Tomi Valkeinen <tomi.valkeinen@ti.com> [200519 15:55]:
> > > (Dropping DT from cc)
> > > 
> > > On 19/05/2020 18:48, Tony Lindgren wrote:
> > > 
> > > > > > Suspend/resume on am43xx-gpevm is broken right now in mainline and the regression looks
> > > > > > like it is caused by the display subsystem. I have reported this to Tomi and
> > > > > > its being investigated.
> > > > > > 
> > > > > > Meanwhile I have tested this patch with display configs disabled and Keerthy's
> > > > > > suspend/resume tests pass on both am3 and am4.
> > > > 
> > > > OK great thanks for checking it. Do you have the display subsystem
> > > > related commit that broke PM? I'm wondering if my recent DSS platform
> > > > data removal changes might have caused the regression.
> > > 
> > > I spent a bit time looking at this, but unfortunately I wasn't even able to
> > > resume my AM4 evm from suspend. I tried with rtcwake and with plain console
> > > (with no_console_suspend). I did not have DSS loaded.
> > 
> > My test-bbb-suspend script seems to have:
> > 
> > sudo modprobe wkup_m3_ipc
> > sudo modprobe pm33xx
> > sudo modprobe rtc-omap
> > rtcwake -m mem -s 5
> > 
> > I think the same should work for am437x. But some boards do not support
> > deep sleep like am437x-idk.
> > 
> > > Anyone have quick hints on how to debug why resume doesn't seem to happen?
> > 
> > You might get some info with no_console_suspend, but that might also
> > cause other issues.
> 
> To me it seems we may have some dss clock missing with the ti-sysc dts
> changes that makes resume fail. Or else there is some ordering issue
> between the dss components now on resume, I'll try to debug more.

Looks like we now set the CLOCKATIVITY bit while earlier we did not
set it except for HWMOD_SET_DEFAULT_CLOCKACT cases. I've also found
few other minor issues, but I'm still seeing resume fail for DSS.
The clock and sysconfig registers look just fine, so getting closer.

Regards,

Tony

      reply index

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-12 20:38 Faiz Abbas
2020-05-13 16:23 ` Tony Lindgren
2020-05-15  9:34   ` Faiz Abbas
2020-05-19  8:22     ` Faiz Abbas
2020-05-19 15:48       ` Tony Lindgren
2020-05-19 15:54         ` Tomi Valkeinen
2020-05-19 16:04           ` Tony Lindgren
2020-05-27 16:05             ` Tony Lindgren
2020-05-29 21:53               ` Tony Lindgren [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200529215314.GZ37466@atomide.com \
    --to=tony@atomide.com \
    --cc=bcousson@baylibre.com \
    --cc=faiz_abbas@ti.com \
    --cc=j-keerthy@ti.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-omap@vger.kernel.org \
    --cc=tomi.valkeinen@ti.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Linux-OMAP Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/linux-omap/0 linux-omap/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 linux-omap linux-omap/ https://lore.kernel.org/linux-omap \
		linux-omap@vger.kernel.org
	public-inbox-index linux-omap

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.kernel.vger.linux-omap


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git