linux-parisc.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* clean up and streamline probe_kernel_* and friends v3
@ 2020-05-19 13:44 Christoph Hellwig
  2020-05-19 13:44 ` [PATCH 01/20] maccess: unexport probe_kernel_write and probe_user_write Christoph Hellwig
                   ` (20 more replies)
  0 siblings, 21 replies; 33+ messages in thread
From: Christoph Hellwig @ 2020-05-19 13:44 UTC (permalink / raw)
  To: x86, Alexei Starovoitov, Daniel Borkmann, Masami Hiramatsu,
	Linus Torvalds, Andrew Morton
  Cc: linux-parisc, linux-um, netdev, bpf, linux-mm, linux-kernel

Hi all,

this series start cleaning up the safe kernel and user memory probing
helpers in mm/maccess.c, and then allows architectures to implement
the kernel probing without overriding the address space limit and
temporarily allowing access to user memory.  It then switches x86
over to this new mechanism by reusing the unsafe_* uaccess logic.

This version also switches to the saner copy_{from,to}_kernel_nofault
naming suggested by Linus.

I kept the x86 helprs as-is without calling unsage_{get,put}_user as
that avoids a number of hard to trace casts, and it will still work
with the asm-goto based version easily.

Changes since v2:
 - rebased on 5.7-rc6 with the bpf trace format string changes
 - rename arch_kernel_read to __get_kernel_nofault and arch_kernel_write
   to __put_kernel_nofault
 - clean up the tracers to only allowd "mixed" reads when the kernel
   has non-overlapping address spaces

^ permalink raw reply	[flat|nested] 33+ messages in thread

end of thread, other threads:[~2020-05-20 16:16 UTC | newest]

Thread overview: 33+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-19 13:44 clean up and streamline probe_kernel_* and friends v3 Christoph Hellwig
2020-05-19 13:44 ` [PATCH 01/20] maccess: unexport probe_kernel_write and probe_user_write Christoph Hellwig
2020-05-19 13:44 ` [PATCH 02/20] maccess: remove various unused weak aliases Christoph Hellwig
2020-05-19 13:44 ` [PATCH 03/20] maccess: remove duplicate kerneldoc comments Christoph Hellwig
2020-05-19 13:44 ` [PATCH 04/20] maccess: clarify " Christoph Hellwig
2020-05-19 13:44 ` [PATCH 05/20] maccess: update the top of file comment Christoph Hellwig
2020-05-19 13:44 ` [PATCH 06/20] maccess: rename strncpy_from_unsafe_user to strncpy_from_user_nofault Christoph Hellwig
2020-05-19 13:44 ` [PATCH 07/20] maccess: rename strncpy_from_unsafe_strict to strncpy_from_kernel_nofault Christoph Hellwig
2020-05-19 13:44 ` [PATCH 08/20] maccess: rename strnlen_unsafe_user to strnlen_user_nofault Christoph Hellwig
2020-05-19 13:44 ` [PATCH 09/20] maccess: remove probe_read_common and probe_write_common Christoph Hellwig
2020-05-19 13:44 ` [PATCH 10/20] maccess: unify the probe kernel arch hooks Christoph Hellwig
2020-05-19 13:44 ` [PATCH 11/20] bpf: factor out a bpf_trace_copy_string helper Christoph Hellwig
2020-05-19 16:07   ` Linus Torvalds
2020-05-19 16:14     ` Christoph Hellwig
2020-05-19 16:36       ` Linus Torvalds
2020-05-19 13:44 ` [PATCH 12/20] maccess: remove strncpy_from_unsafe Christoph Hellwig
2020-05-19 16:25   ` Linus Torvalds
2020-05-19 16:41     ` Christoph Hellwig
2020-05-19 16:46       ` Linus Torvalds
2020-05-19 13:44 ` [PATCH 13/20] maccess: always use strict semantics for probe_kernel_read Christoph Hellwig
2020-05-19 16:33   ` Linus Torvalds
2020-05-20 11:11   ` Masami Hiramatsu
2020-05-20 11:13     ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 14/20] maccess: move user access routines together Christoph Hellwig
2020-05-19 13:44 ` [PATCH 15/20] maccess: allow architectures to provide kernel probing directly Christoph Hellwig
2020-05-19 13:44 ` [PATCH 16/20] x86: use non-set_fs based maccess routines Christoph Hellwig
2020-05-19 13:44 ` [PATCH 17/20] maccess: rename probe_kernel_{read,write} to copy_{from,to}_kernel_nofault Christoph Hellwig
2020-05-19 13:44 ` [PATCH 18/20] maccess: rename probe_user_{read,write} to copy_{from,to}_user_nofault Christoph Hellwig
2020-05-19 13:44 ` [PATCH 19/20] maccess: rename probe_kernel_address to get_kernel_nofault Christoph Hellwig
2020-05-19 13:44 ` [PATCH 20/20] maccess: return -ERANGE when copy_from_kernel_nofault_allowed fails Christoph Hellwig
2020-05-20 11:02   ` Masami Hiramatsu
2020-05-20 16:16     ` Christoph Hellwig
2020-05-19 16:34 ` clean up and streamline probe_kernel_* and friends v3 Linus Torvalds

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).