linux-parisc.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Linus Torvalds <torvalds@linux-foundation.org>
Cc: Christoph Hellwig <hch@lst.de>,
	the arch/x86 maintainers <x86@kernel.org>,
	Alexei Starovoitov <ast@kernel.org>,
	Daniel Borkmann <daniel@iogearbox.net>,
	Masami Hiramatsu <mhiramat@kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	linux-parisc@vger.kernel.org,
	linux-um <linux-um@lists.infradead.org>,
	Netdev <netdev@vger.kernel.org>,
	bpf@vger.kernel.org, Linux-MM <linux-mm@kvack.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 12/20] maccess: remove strncpy_from_unsafe
Date: Tue, 19 May 2020 18:41:46 +0200	[thread overview]
Message-ID: <20200519164146.GA28313@lst.de> (raw)
In-Reply-To: <CAHk-=whE_C2JF0ywF09iMBWtquEfMM3aSxCeLrb5S75EdHr1JA@mail.gmail.com>

On Tue, May 19, 2020 at 09:25:57AM -0700, Linus Torvalds wrote:
> On Tue, May 19, 2020 at 6:45 AM Christoph Hellwig <hch@lst.de> wrote:
> >
> > +       if (IS_ENABLED(CONFIG_ARCH_HAS_NON_OVERLAPPING_ADDRESS_SPACE) &&
> > +           compat && (unsigned long)unsafe_ptr < TASK_SIZE)
> > +               ret = strncpy_from_user_nofault(dst, user_ptr, size);
> > +       else
> > +               ret = strncpy_from_kernel_nofault(dst, unsafe_ptr, size);
> 
> These conditionals are completely illegible.

I had a lot of folks complaining about things like:

#ifdef CONFIG_FOO
	if (foo)
		do_stuff();
	else
#endif
		do_something_else();

which I personally don't mind at all, so I switched to this style.

>   static long bpf_strncpy_from_legacy(void *dest, const void
> *unsafe_ptr, long size, bool legacy)
>   {
>   #ifdef CONFIG_ARCH_HAS_NON_OVERLAPPING_ADDRESS_SPACE
>         if (legacy && addr < TASK_SIZE)
>             return strncpy_from_user_nofault(dst, (const void __user
> *) unsafe_ptr, size);
>   #endif
> 
>         return strncpy_from_kernel_nofault(dst, unsafe_ptr, size);
>   }
> 
> and then you'd just use
> 
>         if (bpf_strncpy_from_unsafe(dst, unsafe_ptr, size, compat) < 0)
>                 memset(dst, 0, size);
> 
> and avoid any complicated conditionals, goto's, and make the code much
> easier to understand thanks to having a big comment about the legacy
> case.

Sure.

> In fact, separately I'd probably want that "compat" naming to be
> scrapped entirely in that file.

Not my choice..  Maybe Daniel has a recommendation of what to change
there, but I'd love to not have to deal with that renaming as well
in this series.

  reply	other threads:[~2020-05-19 16:41 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-19 13:44 clean up and streamline probe_kernel_* and friends v3 Christoph Hellwig
2020-05-19 13:44 ` [PATCH 01/20] maccess: unexport probe_kernel_write and probe_user_write Christoph Hellwig
2020-05-19 13:44 ` [PATCH 02/20] maccess: remove various unused weak aliases Christoph Hellwig
2020-05-19 13:44 ` [PATCH 03/20] maccess: remove duplicate kerneldoc comments Christoph Hellwig
2020-05-19 13:44 ` [PATCH 04/20] maccess: clarify " Christoph Hellwig
2020-05-19 13:44 ` [PATCH 05/20] maccess: update the top of file comment Christoph Hellwig
2020-05-19 13:44 ` [PATCH 06/20] maccess: rename strncpy_from_unsafe_user to strncpy_from_user_nofault Christoph Hellwig
2020-05-19 13:44 ` [PATCH 07/20] maccess: rename strncpy_from_unsafe_strict to strncpy_from_kernel_nofault Christoph Hellwig
2020-05-19 13:44 ` [PATCH 08/20] maccess: rename strnlen_unsafe_user to strnlen_user_nofault Christoph Hellwig
2020-05-19 13:44 ` [PATCH 09/20] maccess: remove probe_read_common and probe_write_common Christoph Hellwig
2020-05-19 13:44 ` [PATCH 10/20] maccess: unify the probe kernel arch hooks Christoph Hellwig
2020-05-19 13:44 ` [PATCH 11/20] bpf: factor out a bpf_trace_copy_string helper Christoph Hellwig
2020-05-19 16:07   ` Linus Torvalds
2020-05-19 16:14     ` Christoph Hellwig
2020-05-19 16:36       ` Linus Torvalds
2020-05-19 13:44 ` [PATCH 12/20] maccess: remove strncpy_from_unsafe Christoph Hellwig
2020-05-19 16:25   ` Linus Torvalds
2020-05-19 16:41     ` Christoph Hellwig [this message]
2020-05-19 16:46       ` Linus Torvalds
2020-05-19 13:44 ` [PATCH 13/20] maccess: always use strict semantics for probe_kernel_read Christoph Hellwig
2020-05-19 16:33   ` Linus Torvalds
2020-05-20 11:11   ` Masami Hiramatsu
2020-05-20 11:13     ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 14/20] maccess: move user access routines together Christoph Hellwig
2020-05-19 13:44 ` [PATCH 15/20] maccess: allow architectures to provide kernel probing directly Christoph Hellwig
2020-05-19 13:44 ` [PATCH 16/20] x86: use non-set_fs based maccess routines Christoph Hellwig
2020-05-19 13:44 ` [PATCH 17/20] maccess: rename probe_kernel_{read,write} to copy_{from,to}_kernel_nofault Christoph Hellwig
2020-05-19 13:44 ` [PATCH 18/20] maccess: rename probe_user_{read,write} to copy_{from,to}_user_nofault Christoph Hellwig
2020-05-19 13:44 ` [PATCH 19/20] maccess: rename probe_kernel_address to get_kernel_nofault Christoph Hellwig
2020-05-19 13:44 ` [PATCH 20/20] maccess: return -ERANGE when copy_from_kernel_nofault_allowed fails Christoph Hellwig
2020-05-20 11:02   ` Masami Hiramatsu
2020-05-20 16:16     ` Christoph Hellwig
2020-05-19 16:34 ` clean up and streamline probe_kernel_* and friends v3 Linus Torvalds

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200519164146.GA28313@lst.de \
    --to=hch@lst.de \
    --cc=akpm@linux-foundation.org \
    --cc=ast@kernel.org \
    --cc=bpf@vger.kernel.org \
    --cc=daniel@iogearbox.net \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-parisc@vger.kernel.org \
    --cc=linux-um@lists.infradead.org \
    --cc=mhiramat@kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=torvalds@linux-foundation.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).