patches.lists.linux.dev archive mirror
 help / color / mirror / Atom feed
From: Peter Newman <peternewman@google.com>
To: "Yu, Fenghua" <fenghua.yu@intel.com>
Cc: "Luck, Tony" <tony.luck@intel.com>,
	"Chatre, Reinette" <reinette.chatre@intel.com>,
	 Jonathan Corbet <corbet@lwn.net>,
	"x86@kernel.org" <x86@kernel.org>,
	Shaopeng Tan <tan.shaopeng@fujitsu.com>,
	 James Morse <james.morse@arm.com>,
	Jamie Iles <quic_jiles@quicinc.com>,
	 Babu Moger <babu.moger@amd.com>,
	 "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	 "linux-doc@vger.kernel.org" <linux-doc@vger.kernel.org>,
	 "patches@lists.linux.dev" <patches@lists.linux.dev>
Subject: Re: [PATCH 3/7] x86/resctrl: Add a new node-scoped resource to rdt_resources_all[]
Date: Fri, 27 Jan 2023 17:02:15 +0100	[thread overview]
Message-ID: <CALPaoCiFotg80LJZ3d+QeO=bNUh85AuP2VgmLaWXX7JaAMYfLQ@mail.gmail.com> (raw)
In-Reply-To: <IA1PR11MB6097400A3056553FCC8E193C9BCC9@IA1PR11MB6097.namprd11.prod.outlook.com>

Hi Tony,

On Fri, Jan 27, 2023 at 6:25 AM Yu, Fenghua <fenghua.yu@intel.com> wrote:
>
> On 1/26/23 10:41, Tony Luck wrote:
> > diff --git a/arch/x86/kernel/cpu/resctrl/core.c b/arch/x86/kernel/cpu/resctrl/core.c
> > index 6914232acf84..19be6fe42ef3 100644
> > --- a/arch/x86/kernel/cpu/resctrl/core.c
> > +++ b/arch/x86/kernel/cpu/resctrl/core.c
> > @@ -100,6 +100,16 @@ struct rdt_hw_resource rdt_resources_all[] = {
> >                       .fflags                 = RFTYPE_RES_MB,
> >               },
> >       },
> > +     [RDT_RESOURCE_NODE] =
> > +     {
> > +             .r_resctrl = {
> > +                     .rid                    = RDT_RESOURCE_NODE,
> > +                     .name                   = "L3",
> "L3" was named as RDT_RESOURCE_L3 already. The duplicate name here may
> cause duplicate file names in info dir. Maybe rename it as "L3_NODE"?

I'm trying to get some feedback from our own users on whether changing
the directory names would bother them. At least from my own testing, I
did learn to appreciate the interface change a bit more: I needed an
SNC and non-SNC case to correctly predict which mon_data subdirectory
the data would appear in.

I was able to confirm that this change allows bandwidth to be counted
on RMID/CPU combos where it didn't work before on an SNC2
configuration.

If I'm understanding this correctly, it might be helpful to highlight
that the extra resource is needed to allow a different number of L3
domains in L3 monitoring vs allocation.

Thanks!
-Peter

Tested-By: Peter Newman <peternewman@google.com>
Reviewed-By: Peter Newman <peternewman@google.com>

  reply	other threads:[~2023-01-27 16:02 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-01-26 18:41 [PATCH 0/7] x86/resctrl: Add support for Sub-NUMA cluster (SNC) systems Tony Luck
2023-01-26 18:41 ` [PATCH 1/7] x86/resctrl: Refactor in preparation for node-scoped resources Tony Luck
2023-01-26 18:41 ` [PATCH 2/7] x86/resctrl: Remove hard code of RDT_RESOURCE_L3 in monitor.c Tony Luck
2023-01-27  4:51   ` Yu, Fenghua
2023-01-26 18:41 ` [PATCH 3/7] x86/resctrl: Add a new node-scoped resource to rdt_resources_all[] Tony Luck
2023-01-27  5:24   ` Yu, Fenghua
2023-01-27 16:02     ` Peter Newman [this message]
2023-01-27 18:23     ` Luck, Tony
2023-01-28  2:25       ` Yu, Fenghua
2023-01-28  2:22   ` Yu, Fenghua
2023-01-28  2:36   ` Yu, Fenghua
2023-01-30 19:04     ` Luck, Tony
2023-02-28 14:27   ` Moger, Babu
2023-02-28 17:05     ` Luck, Tony
2023-01-26 18:41 ` [PATCH 4/7] x86/resctrl: Add code to setup monitoring at L3 or NODE scope Tony Luck
2023-02-28 17:13   ` James Morse
2023-02-28 17:28     ` Luck, Tony
2023-01-26 18:41 ` [PATCH 5/7] x86/resctrl: Add a new "snc_ways" file to the monitoring info directory Tony Luck
2023-02-28 17:13   ` James Morse
2023-02-28 17:44     ` Luck, Tony
2023-03-03 18:32       ` James Morse
2023-01-26 18:41 ` [PATCH 6/7] x86/resctrl: Update documentation with Sub-NUMA cluster changes Tony Luck
2023-02-28 17:14   ` James Morse
2023-01-26 18:41 ` [PATCH 7/7] x86/resctrl: Determine if Sub-NUMA Cluster is enabled and initialize Tony Luck
2023-02-27 13:30   ` Peter Newman
2023-03-10 17:30     ` Tony Luck
2023-03-13  9:19       ` Peter Newman
2023-03-13 16:38         ` Luck, Tony
2023-02-28 19:51   ` Moger, Babu
2023-03-14 20:23     ` Tony Luck
     [not found]   ` <85d7e70a-b9c8-6551-b1ac-229b51ee18d7@amd.com>
2023-02-28 20:39     ` Luck, Tony
2023-02-28 22:31       ` Moger, Babu
2023-02-28 17:12 ` [PATCH 0/7] x86/resctrl: Add support for Sub-NUMA cluster (SNC) systems James Morse
2023-02-28 18:04   ` Luck, Tony

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CALPaoCiFotg80LJZ3d+QeO=bNUh85AuP2VgmLaWXX7JaAMYfLQ@mail.gmail.com' \
    --to=peternewman@google.com \
    --cc=babu.moger@amd.com \
    --cc=corbet@lwn.net \
    --cc=fenghua.yu@intel.com \
    --cc=james.morse@arm.com \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=patches@lists.linux.dev \
    --cc=quic_jiles@quicinc.com \
    --cc=reinette.chatre@intel.com \
    --cc=tan.shaopeng@fujitsu.com \
    --cc=tony.luck@intel.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).