linux-pci.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Yijing Wang <wangyijing@huawei.com>
To: Bjorn Helgaas <bhelgaas@google.com>
Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	<linuxppc-dev@lists.ozlabs.org>, <linux-pci@vger.kernel.org>,
	Tony Luck <tony.luck@intel.com>, <linux-ia64@vger.kernel.org>,
	"David S. Miller" <davem@davemloft.net>,
	<sparclinux@vger.kernel.org>,
	Thomas Gleixner <tglx@linutronix.de>, <x86@kernel.org>,
	Yijing Wang <wangyijing@huawei.com>
Subject: [PATCH v2 00/13] Refactor pci_is_brdige() to simplify code
Date: Sun, 4 May 2014 12:23:35 +0800	[thread overview]
Message-ID: <1399177428-3784-1-git-send-email-wangyijing@huawei.com> (raw)

v1->v2: Add comments for new pci_is_bridge().

This patchset rename the current pci_is_bridge() to pci_has_subordinate(), 
and introduce a new pci_is_bridge() which determine pci bridge by check
dev->hdr_type. The new one is more accurate. PCI Spec define the pci
device is a bridge by the dev->hdr_type = 0x01 || 0x02.

There is no guarantee that a PCI bridge must attached a subordinate bus.
When PCI bridge is created but before the scan child bus, it has no 
subordinate bus. Also users can remove the pci bus using
interface pci_remove_bus() in remove.c. 

So use new pci_is_bridge() check if the PCI device is bridge is better
choice. If user want check PCI bridge whether has a subordinate bus,
pci_has_subordinate() is a candidate.


Yijing Wang (13):
  PCI: rename pci_is_bridge() to pci_has_subordinate()
  PCI: Introduce new pci_is_bridge() helper function
  PCI: Use new pci_is_bridge() to simplify code
  x86/PCI: Use new pci_is_bridge() to simplify code
  IA64/PCI: Use new pci_is_bridge() to simplify code
  powerpc/PCI: Use new pci_is_bridge() to simplify code
  sparc/PCI: Use new pci_is_bridge() to simplify code
  PCI, rpaphp: Use new pci_is_bridge() to simplify code
  PCI, shpchp: Use new pci_is_bridge() to simplify code
  PCI, cpcihp: Use new pci_is_bridge() to simplify code
  PCI, acpiphp: Use new pci_is_bridge() to simplify code
  PCI, pcmcia: Use new pci_is_bridge() to simplify code
  PCI, pciehp: Use new pci_is_bridge() to simplify code

 arch/ia64/pci/fixup.c                  |    4 +---
 arch/powerpc/kernel/pci-hotplug.c      |    3 +--
 arch/powerpc/kernel/pci_of_scan.c      |    3 +--
 arch/sparc/kernel/pci.c                |    3 +--
 arch/x86/pci/fixup.c                   |    4 +---
 drivers/pci/hotplug/acpiphp_glue.c     |    3 +--
 drivers/pci/hotplug/cpci_hotplug_pci.c |    3 +--
 drivers/pci/hotplug/pciehp_pci.c       |    3 +--
 drivers/pci/hotplug/rpadlpar_core.c    |    3 +--
 drivers/pci/hotplug/shpchp_pci.c       |    3 +--
 drivers/pci/pci-acpi.c                 |    8 +-------
 drivers/pci/pci-driver.c               |    8 ++++----
 drivers/pci/pci.h                      |    2 +-
 drivers/pci/probe.c                    |    3 +--
 drivers/pci/setup-bus.c                |    4 +---
 drivers/pcmcia/cardbus.c               |    3 +--
 include/linux/pci.h                    |   13 +++++++++++++
 17 files changed, 32 insertions(+), 41 deletions(-)



             reply	other threads:[~2014-05-04  4:26 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-05-04  4:23 Yijing Wang [this message]
2014-05-04  4:23 ` [PATCH v2 01/13] PCI: rename pci_is_bridge() to pci_has_subordinate() Yijing Wang
2014-05-04  4:23 ` [PATCH v2 02/13] PCI: Introduce new pci_is_bridge() helper function Yijing Wang
2014-05-04  4:23 ` [PATCH v2 03/13] PCI: Use new pci_is_bridge() to simplify code Yijing Wang
2014-05-04  4:23 ` [PATCH v2 04/13] x86/PCI: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 05/13] IA64/PCI: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 06/13] powerpc/PCI: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 07/13] sparc/PCI: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 08/13] PCI, rpaphp: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 09/13] PCI, shpchp: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 10/13] PCI, cpcihp: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 11/13] PCI, acpiphp: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 12/13] PCI, pcmcia: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 13/13] PCI, pciehp: " Yijing Wang
2014-05-27 21:05 ` [PATCH v2 00/13] Refactor pci_is_brdige() " Bjorn Helgaas

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1399177428-3784-1-git-send-email-wangyijing@huawei.com \
    --to=wangyijing@huawei.com \
    --cc=benh@kernel.crashing.org \
    --cc=bhelgaas@google.com \
    --cc=davem@davemloft.net \
    --cc=linux-ia64@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=sparclinux@vger.kernel.org \
    --cc=tglx@linutronix.de \
    --cc=tony.luck@intel.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).